source: projects/specs/trunk/d/directfb/directfb-vl.spec @ 8835

Revision 8835, 5.2 KB checked in by Takemikaduchi, 10 years ago (diff)

rebuild or new upstream release

Line 
1%define oname DirectFB
2%define libver 1.7-4
3
4Summary:        Hardware graphics acceleration library
5Name:           directfb
6Version:        1.7.4
7Release:        1%{?_dist_release}
8License:        GPL
9Group:          System Environment/Libraries
10Source0:        http://www.directfb.org/downloads/Core/%{name}-1.7/%{oname}-%{version}.tar.gz
11URL:            http://www.directfb.org/
12BuildRequires:  libpng-devel >= 1.2.0
13BuildRequires:  zlib-devel >= 1.1.3
14BuildRequires:  libjpeg-turbo-devel
15BuildRequires:  libtiff-devel
16BuildRequires:  libwebp-devel
17BuildRequires:  jasper-devel
18BuildRequires:  freetype2-devel >= 2.0.2
19BuildRequires:  libX11-devel
20BuildRequires:  libdrm-devel
21BuildRequires:  mesa-libEGL-devel
22BuildRequires:  mesa-libGLES-devel
23BuildRequires:  mesa-libgbm-devel
24BuildRequires:  eudev-libudev-devel
25BuildRequires:  libvdpau-devel
26BuildRequires:  libvncserver-devel
27BuildRequires:  sysfsutils-devel
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30Vendor:       Project Vine
31Distribution: Vine Linux
32
33%description
34DirectFB hardware graphics acceleration - libraries.
35
36
37%package -n lib%{name}
38Summary:        Shared library part of %oname
39Group:          System Environment/Libraries
40
41%description -n lib%{name}
42DirectFB hardware graphics acceleration - libraries.
43
44This package contains the %oname shared library and interface modules.
45It's required for running apps based on %oname.
46
47#'
48%package -n lib%{name}-devel
49Group:          Development/Libraries
50Summary:        Header files for compiling DirectFB applications
51Requires:       lib%{name} = %{version}-%{release}
52Provides:       %{oname}-devel = %{version}-%{release}
53
54%description -n lib%{name}-devel
55DirectFB header files for building applications based on %oname.
56
57%package doc
58Summary:        DirectFB - documentation
59Group:          Applications/Documentation
60
61%description doc
62DirectFB documentation and examples.
63
64%prep
65%setup  -q -n %{oname}-%{version}
66
67%build
68%configure \
69        --enable-fbdev \
70        --disable-maintainer-mode \
71        --enable-shared \
72        --with-gfxdrivers=all
73
74make
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install DESTDIR=$RPM_BUILD_ROOT
79
80find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
81
82# we don't ship dfbg ATM
83rm -f $RPM_BUILD_ROOT%{_bindir}/dfbg
84rm -f $RPM_BUILD_ROOT%{_mandir}/man1/dfbg.1
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -n lib%{name} -p /sbin/ldconfig
90
91%postun -n lib%{name} -p /sbin/ldconfig
92
93
94%files -n lib%{name}
95%defattr(-,root,root,-)
96%doc README* AUTHORS ChangeLog NEWS TODO
97%{_bindir}/dfbdump
98%{_bindir}/dfbdumpinput
99%{_bindir}/dfbfx
100%{_bindir}/dfbinfo
101%{_bindir}/dfbinput
102%{_bindir}/dfbinspector
103%{_bindir}/dfbmaster
104%{_bindir}/dfblayer
105%{_bindir}/dfbplay
106%{_bindir}/dfbscreen
107%{_bindir}/dfbshow
108%{_bindir}/dfbswitch
109%{_bindir}/dfbpenmount
110%{_bindir}/mkdfiff
111%{_bindir}/mkdgiff
112%{_bindir}/mkdgifft
113%{_bindir}/pxa3xx_dump
114%{_libdir}/lib*.so.*
115%dir %{_libdir}/directfb-%{libver}
116%dir %{_libdir}/directfb-%{libver}/gfxdrivers
117%dir %{_libdir}/directfb-%{libver}/inputdrivers
118%dir %{_libdir}/directfb-%{libver}/interfaces
119%dir %{_libdir}/directfb-%{libver}/systems
120%dir %{_libdir}/directfb-%{libver}/wm
121%{_libdir}/directfb-%{libver}/gfxdrivers/*.so
122%{_libdir}/directfb-%{libver}/inputdrivers/*.so
123%{_libdir}/directfb-%{libver}/interfaces/*/*.so
124%{_libdir}/directfb-%{libver}/systems/*.so
125%{_libdir}/directfb-%{libver}/wm/*.so
126%{_datadir}/directfb-%{version}
127%{_mandir}/man5/directfbrc.5*
128
129%files -n lib%{name}-devel
130%defattr(-,root,root,-)
131%{_bindir}/directfb-config
132%{_bindir}/directfb-csource
133%{_includedir}/*
134%{_libdir}/pkgconfig/*.pc
135%{_libdir}/*.so
136%{_mandir}/man1/directfb-csource.1*
137
138%files doc
139%defattr(-,root,root,-)
140%doc docs/html/*
141
142%changelog
143* Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
144- update to 1.7.4
145- remove Patch0 (DirectFB-1.1.1_ppc.patch)
146- add BuildRequires: libwebp-devel, jasper-devel, libdrm-devel, mesa-libEGL-devel, mesa-libGLES-devel, mesa-libgbm-devel, eudev-libudev-devel, libvdpau-devel
147
148* Sun May 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.11-2
149- fix permission
150
151* Tue Dec 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.11-1
152- new upstream release
153- change Source URL
154- add BuildRequires: libX11-devel, libvncserver-devel, sysfsutils-devel
155- change BuildRequires: libjpeg-turbo-devel instead libjpeg-devel >= 6g
156- fix %%files
157
158* Mon Oct 11 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1
159- updated DirectFB to 1.2.5
160- rebuilt with rpm-4.8.1 for pkg-config
161
162* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.1-2
163- add Patch0 to fix ppc build problem (with newer kernels)
164
165* Fri May  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.1-1
166- new upstream release
167
168* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.16-2vl2
169- changed doc Group to Applications/Documentation
170
171* Fri Nov 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.16-2vl1
172- changed packages Group:
173- cleaned spec file (a little bit!)
174
175* Fri Feb 28 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.9.16-2vl0
176- new upstream version
177- convert to Vine Linux
178
179* Fri Dec 27 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.15-2mdk
180- rebuild
181
182* Wed Nov 13 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.15-1mdk
183- new version
184
185* Tue Oct 29 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.14-1mdk
186- fix group of doc package
187- new version
188
189* Fri Aug 23 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.13-1mdk
190- add directfb-csource and man page
191- 0.9.13
192
193* Thu Jul 11 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.12-1mdk
194- initial package based on PLD effort
195
Note: See TracBrowser for help on using the repository browser.