source: projects/specs/trunk/d/dietlibc/dietlibc-vl.spec @ 521

Revision 521, 3.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A small libc implementation
2Summary(ja): 小さな libc の実装
3Name: dietlibc
4Version: 0.31
5Release: 1%{?_dist_release}
6Group: Development/Libraries
7License: GPL
8Url: http://www.fefe.de/dietlibc/
9ExclusiveArch: i386 x86_64 alpha ppc
10Source0: %{name}-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12Patch1:         dietlibc-0.28-setpriority.patch
13Patch3:         dietlibc-0.24-gnuokay.patch
14Patch10:        dietlibc-0.29-scall.patch
15Patch30:        dietlibc-0.30-longdouble.patch
16Patch31:        dietlibc-0.31-defpath.patch
17Patch32:        dietlibc-0.31-stacksmash.patch
18Patch33:        dietlibc-0.31-stacksmash-dyn.patch
19
20
21%description
22A small libc implementation
23
24%description -l ja
25小さな libc の実装
26
27
28%prep
29%setup -q
30%patch1  -p1 -b .nice
31%patch3  -p1 -b .gnuokay
32%patch10 -p1 -b .scall
33%patch30 -p1 -b .longdouble
34%patch31 -p1 -b .defpath
35%patch32 -p1 -b .stacksmash
36%patch33 -p1 -b .stacksmash-dyn
37
38sed -i -e 's!strip !: !g' Makefile
39
40%global fixcflags       -fomit-frame-pointer -fno-exceptions -fno-asynchronous-unwind-tables -Os
41%global basemakeflags   prefix=%_libdir/dietlibc BINDIR=%_bindir MAN1DIR=%_mandir/man1 COMMENT=: CFLAGS="$RPM_OPT_FLAGS %fixcflags" PDIET=%_libdir/dietlibc
42%global makeflags       %basemakeflags
43
44%build
45make %makeflags all %{?_smp_mglags}
46
47
48%install
49rm -rf $RPM_BUILD_ROOT
50make %makeflags DESTDIR=$RPM_BUILD_ROOT install
51
52ln -s lib-%_arch ${RPM_BUILD_ROOT}%_libdir/dietlibc/lib-%_arch-%_vendor
53
54chmod a-x $RPM_BUILD_ROOT%_libdir/dietlibc/lib-*/*.o
55rm -f $RPM_BUILD_ROOT%_bindir/dnsd
56
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61
62%files
63%defattr(-,root,root)
64%doc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO
65%{_bindir}/diet
66%{_libdir}/dietlibc
67%{_mandir}/man*/*
68
69
70%changelog
71* Sun Jul 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.31-1
72- applied new versioning policy
73- spec in UTF-8
74
75* Sat Sep 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.31-0vl1
76- new upstream release
77
78* Fri Jun 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.25-0vl1
79- new upstream release
80
81* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.21-2vl1
82- based on 0.21-2 from Rawhide and built for Vine Linux
83
84* Tue Nov 19 2002 Bill Nottingham <notting@redhat.com>
85- use the right elf definition for hammer
86
87* Fri Nov  1 2002 Jeremy Katz <katzj@redhat.com>
88- update to 0.21
89- stop applying patches already upstream
90- i386 optimized getenv should work now
91
92* Tue Oct 22 2002 Jeremy Katz <katzj@redhat.com>
93- also build on alpha, x86_64, and ppc
94- add a patch so that the ppc64 kernel still builds for ppc
95
96* Tue Aug 13 2002 Jeremy Katz <katzj@redhat.com>
97- apply patch to fix fwrite with empty strings from upstream cvs
98
99* Fri Aug  9 2002 Jeremy Katz <katzj@redhat.com>
100- apply patch to fix calloc from upstream cvs
101
102* Fri Aug  9 2002 Jeremy Katz <katzj@redhat.com>
103- update to 0.19
104- __thread patch is present, so don't apply anymore
105
106* Wed Jul 10 2002 Erik Troan <ewt@redhat.com>
107- upgraded to 0.18
108- added patch to work around __thread being a gcc 3.1 keyword
109
110* Thu May 23 2002 Tim Powers <timp@redhat.com>
111- automated rebuild
112
113* Thu Mar 14 2002 Jeremy Katz <katzj@redhat.com>
114- remove the i386 optimized getenv since it seems to break when you have
115  two variables that start out the same (eg LANG and LANGKEY)
116
117* Tue Feb 26 2002 Erik Troan <ewt@redhat.com>
118- updated to 0.15 -- no more RH specific patches required
119
120* Wed Feb 20 2002 Jeremy Katz <katzj@redhat.com>
121- update to 0.14 which includes a lot of Erik's patches
122- include the man page
123- munge a few patches
124- we want to allow linking against glibc objects
125
126* Mon Feb  4 2002 Bill Nottingham <notting@redhat.com>
127- add fdatasync
128
129* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
130- automated rebuild
131
132* Sat Dec 15 2001 Erik Troan <ewt@redhat.com>
133- fixed putenv to remove environment variables
134
135* Fri Dec 07 2001 Erik Troan <ewt@redhat.com>
136- added fnmatch() fix
137
138* Fri Nov 09 2001 Erik Troan <ewt@redhat.com>
139- initial packaging
Note: See TracBrowser for help on using the repository browser.