source: projects/specs/trunk/d/diald/diald-vl.spec @ 521

Revision 521, 3.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _initdir %{_sysconfdir}/rc.d/init.d
2
3Summary: Daemon that provides on demand IP links via SLIP or PPP.
4Name: diald
5Version: 1.0
6Release: 0vl4
7License: distributable
8Group: System Environment/Daemons
9URL: http://diald.sourceforge.net/
10Source0: http://download.sourceforge.net/diald/diald-%{version}.tar.gz
11Source1: diald.init
12Source2: diald.conf.sample
13Source3: phone.filter
14Source4: connect.diald
15Patch0: diald-1.0-Makefile.patch
16Patch1: diald-route-0.99.4.patch
17Patch2: diald-1.0-glibc22.patch
18Requires: ppp
19PreReq: chkconfig
20BuildRoot: %{_tmppath}/%{name}-root
21
22%description
23Diald is a daemon that provides on demand IP links via SLIP or PPP. The
24purpose of diald is to make it transparently appear that you have a
25permanent connection to a remote site. Diald sets up a "proxy" device which
26stands in for the physical connection to a remote site. It then monitors the
27proxy, waiting for packets to arrive. When interesting packets arrive it
28will attempt to establish the physical link to the remote site using either
29SLIP or PPP, and if it succeeds it will forward traffic from the proxy to
30the physical link. As well, diald will monitor traffic once the physical
31link is up, and when it has determined that the link is idle, the remote
32connection is terminated. The criteria for bringing the link up and taking
33it down are configurable at run time, and are based upon the type of traffic
34passing over the link.
35
36%prep
37%setup -q
38%patch0 -p1 -b .orig
39%patch1 -p0 -b .route
40%patch2 -p1 -b .glibc22
41
42%build
43%configure --localstatedir=/var
44make
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall
49
50cp -p config/dynamic.filter $RPM_BUILD_ROOT%{_libdir}/diald/
51mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/diald
52mknod -m 0660 $RPM_BUILD_ROOT%{_sysconfdir}/diald/diald.ctl p
53mkdir -p $RPM_BUILD_ROOT%{_initdir}
54install -p -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_initdir}/diald
55
56# Source 2,3,4
57cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/diald.conf
58cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/diald
59cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/diald/connect
60
61# eliminate excessive executable bit
62find contrib/ -type f -perm +111 | xargs chmod -x
63find %{buildroot}%{_libdir}/diald -type f -perm +111 | xargs chmod -x
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%post
69/sbin/chkconfig --add diald
70
71%preun
72if [ $1 = 0 ]; then
73   /sbin/chkconfig --del diald
74fi
75
76%files
77%defattr(-,root,root)
78%doc BUGS CHANGES LICENSE NOTES README* THANKS TODO TODO.budget
79%doc doc/diald-faq.txt contrib
80%config %{_initdir}/diald
81%config(noreplace) %{_sysconfdir}/diald.conf
82%config(noreplace) %{_sysconfdir}/diald/connect
83%config(noreplace) %{_sysconfdir}/diald/phone.filter
84%{_sysconfdir}/diald/diald.ctl
85%{_bindir}/dctrl
86%{_sbindir}/diald
87%{_libdir}/diald
88%{_mandir}/man1/dctrl.1*
89%{_mandir}/man5/diald-control.5*
90%{_mandir}/man5/diald-examples.5*
91%{_mandir}/man5/diald-monitor.5*
92%{_mandir}/man8/diald.8*
93
94%changelog
95* Wed Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 1.0-0vl4
96- added adhoc patch to build on glibc22 system
97
98* Wed Aug 08 2001 <sagami@vinelinux.org>
99- 1.0-0vl3: fix again to handle pid file correctly
100
101* Fri Aug 03 2001 <sagami@vinelinux.org>
102- 1.0-0vl2: fix initscript to handle pid file correctly
103
104* Sun Jun 17 2001 <sagami@vinelinux.org>
105- 1.0-0vl0
106
107* Fri Jun 15 2001 <sagami@vinelinux.org>
108- 0.99.4-0vl2: %%{_mandir}
109
110* Wed Mar 01 2000 Toru Sagami <czs14350@nifty.ne.jp>
111- 0.99.4
112- add contrib to docdir
113- fix diald.init
114
115* Fri Feb 18 2000 Toru Sagami <czs14350@nifty.ne.jp>
116- handle RPM_OPT_FLAGS
117- add noreplace to configutation files
118
119* Fri Feb 11 2000 Toru Sagami <czs14350@nifty.ne.jp>
120- added diald-twoway.diff(it fixes diald_won't_redial problem?)
121- changed Group from Networking/Daemons to System Environment/Daemons
122- enabled %post and %preun
123
124* Fri Jan 28 2000 Toru Sagami <czs14350@nifty.ne.jp>
125- freshen URL Source tags
126
127* Fri Jan 14 2000 Toru Sagami <czs14350@nifty.ne.jp>
128- 0.99.3
129
130* Wed Dec 01 1999 Toru Sagami <czs14350@nifty.ne.jp>
131- build 0.99.2
132- include diald.conf.sample
Note: See TracBrowser for help on using the repository browser.