source: projects/specs/trunk/d/dia/dia-vl.spec @ 623

Revision 623, 7.2 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1# %%define extraver 1
2
3%define _gtk_ver 2.10.0
4%define _glib_ver 2.12.0
5%define _pango_ver 1.16.0
6%define _freetype_ver 2.3.0
7%define _libxml_ver 2.6.27
8%define _cairo_ver 1.4.6
9
10Summary: A gtk+ based diagram creation program.
11Summary(ja): Gtk+ ベースのダイアグラム作成プログラム
12Name: dia
13Version: 0.97.1
14Release: 1%{?_dist_release}
15License: GPL
16Group: Applications/Graphics
17
18Source: http://ftp.gnome.org/pub/GNOME/sources/dia/%{version}/dia-%{version}%{?extraver:-%extraver}.tar.bz2
19
20URL: http://www.gnome.org/projects/dia/
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Requires(post): desktop-file-utils, scrollkeeper
23Requires(postun): desktop-file-utils, scrollkeeper
24BuildRequires: gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
25BuildRequires: pango-devel >= %{_pango_ver}
26BuildRequires: libgnome-devel, libgnomeui-devel
27BuildRequires: libxml2-devel >= %{_libxml_ver}, libxslt-devel
28BuildRequires: libpng-devel, libart_lgpl-devel
29BuildRequires: freetype2-devel >= %{_freetype_ver}
30BuildRequires: cairo-devel >= %{_cairo_ver}
31BuildRequires: libSM-devel
32BuildRequires: perl
33BuildConflicts: glitz-devel
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39Dia is a program designed to be much like the Windows
40program 'Visio'. It can be used to draw different kind of diagrams. In
41this first version there is support for UML static structure diagrams
42(class diagrams) and Network diagrams. It can currently load and save
43diagrams to a custom fileformat and export to postscript.
44
45%description -l ja
46Dia は Windows にある 'Visio' に似せて設計されたプログラムです。
47種々のダイアグラムを描写、編集することが可能です。
48この最初のバージョンでは、UML の静的構造ダイアグラム (クラス・ダイア
49グラム) とネットワーク・ダイアグラムがサポートされています。
50現在では, カスタムのファイル形式でダイアグラムを読み込みや保存した
51り、PostScript へ保存することができます。
52
53%prep
54%setup -q -n %{name}-%{version}%{?extraver:-%extraver}
55
56%build
57%configure --enable-gnome --enable-db2html --with-cairo
58%__make
59
60%install
61%__rm -rf %{buildroot}
62%makeinstall
63
64# remove unneeded files
65%__rm -rf %{buildroot}%{_localstatedir}/scrollkeeper
66%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
67%__rm -rf %{buildroot}%{_datadir}/doc/dia
68
69%find_lang %{name}
70
71%clean
72%__rm -rf %{buildroot}
73
74%post
75%{_bindir}/update-desktop-database ||:
76%{_bindir}/scrollkeeper-update > /dev/null 2>&1 ||:
77touch --no-create %{_datadir}/icons/hicolor
78if [ -x /usr/bin/gtk-update-icon-cache ]; then
79  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
80fi
81
82%postun
83%{_bindir}/update-desktop-database ||:
84%{_bindir}/scrollkeeper-update > /dev/null 2>&1 ||:
85touch --no-create %{_datadir}/icons/hicolor
86if [ -x /usr/bin/gtk-update-icon-cache ]; then
87  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
88fi
89
90%files -f %{name}.lang
91%defattr(-,root,root)
92%doc README TODO NEWS INSTALL COPYING ChangeLog AUTHORS doc
93%{_bindir}/dia
94%{_libdir}/dia
95%{_mandir}/man1/dia.1*
96%{_datadir}/dia
97%{_datadir}/applications/*
98%{_datadir}/mime-info/*
99%{_datadir}/icons/hicolor/*
100%dir %{_datadir}/omf/dia
101%{_datadir}/omf/dia/*
102%{_datadir}/gnome/help/dia
103
104%changelog
105* Thu Mar 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.97.1-1
106- new upstream release
107
108* Sun Nov 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-2
109- add BR: libSM-devel (<BTS:828>)
110
111* Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-1
112- new upstream release
113
114* Tue Jul 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.96.1-1
115- applied new versioning policy
116- spec in UTF-8
117
118* Thu May 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96.1-0vl1
119- new upstream release
120
121* Sat Oct 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl4
122- [SECURITY] update to 0.95-1
123
124* Tue Sep 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl3
125- add BuildConflicts: glitz-devel not to depend on glitz
126
127* Sun Sep 10 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.95-0vl2
128- change Group to Applications/Graphics. <BTS:VineLinux:163>
129
130* Thu Apr 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl1
131- upstream release
132- update source-URL
133- drop BuildRequires: automake17
134
135* Sat Apr 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl0.0pre9
136- 0.95-pre9
137
138* Thu Apr 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl0.0pre8
139- 0.95-pre8
140- enable cairo plugin
141- add BuildRequires: cairo-devel, Requires: cairo
142
143* Thu Mar 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl0.0pre7
144- 0.95-pre7
145
146* Sat Mar 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl0.0pre6
147- 0.95-pre6
148
149* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl0.0pre5
150- 0.95-pre5
151
152* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.95-0vl0.0pre1
153- 0.95-pre1
154- drop obsolete patch1
155- run scrollkeeper-update at %%post,postun
156- add PreReq: scrollkeeper
157
158* Sat Jul 16 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.94-0vl1
159- upstream release
160- drop BuildPrereq: desktop-file-utils (not used)
161- run update-desktop-database at %%post,postun
162- add PreReq: desktop-file-utils
163- drop obsolete patch0
164
165* Thu Aug 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.93-0vl3
166- use defalut ja.po file
167- fixed encoding of sheet/Cybernetics.in (patch1)
168
169* Sat Jul 31 2004 Tomoya TAKA <taka@vinelinux.org> 0.93-0vl2
170- use GtkType rather than guint (patch0)
171- update URL:
172
173* Wed Jul 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.93-0vl1
174- new upstream release
175
176* Mon Nov  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.92.2-0vl1
177- new upstream release
178- updated ja.po
179
180* Sun Jun 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.91-0vl2
181- applyed dia-0.91-help.patch and dia-0.91-css.patch from Redhat Rawhide
182- fixed Requires, BuildRequires and BuildPreReq
183- fixed gnome-dia.desktop
184- merged newly ja.po
185
186* Sun Jun 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.91-0vl1
187- rebuild with new toolchains and Gnome2
188- modified specfile based on Redhat Rawhide 0.90-11
189
190* Tue Sep 25 2001 Satoshi MACHINO <machino@vinelinux.org> dia-0.88.1-0vl1
191- updated 0.88.1
192- added Requires: gtk+ imlib
193- updated patch1
194
195* Fri Apr 20 2001 Daisuke SUZUKI <daisuke@linux.or.jp> dia-0.86-0vl3
196- brush up this spec files
197
198* Fri Apr 20 2001 Daisuke SUZUKI <daisuke@linux.or.jp> dia-0.86-0vl2
199- changed to use TrueType Fonts for screen.
200
201* Tue Aug 29 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
202- updated dia-0.86 and ja patch's
203- removed vfont.patch
204- fixed %files section to handle compressed man page
205
206* Fri Aug 11 2000  Yasuyuki Furukawa <furukawa@vinelinux.org>
207- updated ja patch to rel 8.
208- added vfont patch
209
210* Fri Mar 31 2000  Yasuyuki Furukawa <furukawa@vinelinux.org>
211- updated to 0.84
212
213* Fri Feb 21 2000  Yasuyuki Furukawa <furukawa@vinelinux.org>
214- updated Japanese patch
215
216* Fri Feb 18 2000  Yasuyuki Furukawa <furukawa@vinelinux.org>
217- added Japanese patch and some bug fix patches from http://www.u-aizu.ac.jp/%7Em5031201/dia/
218
219* Sun Sep 5 1999  James Henstridge <james@daa.com.au>
220- added $(prefix)/share/dia to files list.
221
222* Thu Apr 29 1999  Enrico Scholz <enrico.scholz@wirtschaft.tu-chemnitz.de>
223- Made %setup quiet
224- Enabled build from cvs
225- Removed superfluous mkdir's
226- using DESTDIR and install-strip
227
228* Fri Aug 28 1998  Francis J. Lacoste <francis@Contre.COM>
229- First RPM release.
Note: See TracBrowser for help on using the repository browser.