source: projects/specs/trunk/d/device-mapper-multipath/device-mapper-multipath-vl.spec @ 9463

Revision 9463, 8.9 KB checked in by inagaki, 9 years ago (diff)

2015-03-22 Ryoichi INAGAKI <ryo1@…>

  • device-mapper-multipath, lvm2, libqalculate, ntp, perl-Term-ReadLine?-Gnu, physfs, postgresql: rebuilt


Line 
1Summary: Tools to manage multipath devices using device-mapper
2Summary(ja): Device-mapper を使用してマルチパスデバイスを管理するためのツール集
3Name: device-mapper-multipath
4Version: 0.4.9
5Release: 5%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Base
8URL: http://christophe.varoqui.free.fr/
9Source0: multipath-tools-%{version}.tar.bz2
10Source1: multipath.conf
11
12# patch that should go upstream
13Patch1: 0001-for-upstream-add-tpg_pref-prioritizer.patch
14
15# RH patches
16Patch1007: 0007-RH-do-not-remove.patch
17Patch1008: 0008-RH-Make-build-system-RH-Fedora-friendly.patch
18Patch1009: 0009-RH-multipathd-blacklist-all-by-default.patch
19Patch1010: 0010-RH-multipath-rules-udev-changes.patch
20Patch1014: 0014-RH-add-hp_tur-checker.patch
21Patch1017: 0017-RHBZ-554592-man-page-note.patch
22Patch1018: 0018-RHBZ-554596-SUN-6540-config.patch
23Patch1019: 0019-RHBZ-554598-fix-multipath-locking.patch
24Patch1020: 0020-RHBZ-554605-fix-manual-failover.patch
25Patch1021: 0021-RHBZ-548874-add-find-multipaths-2.patch
26Patch1022: 0022-RHBZ-557845-RHEL5-style-partitions-2.patch
27Patch1023: 0023-RHBZ-557810-emc-invista-config.patch
28Patch1024: 0024-RHBZ-565933-checker-timeout-2.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
31Requires(post): chkconfig
32Requires(preun): chkconfig
33Requires: kpartx = %{version}-%{release}
34Requires: device-mapper >= 1.02.39
35BuildRequires: libsysfs-devel
36BuildRequires: device-mapper-devel
37#BuildRequires: libselinux-devel, libsepol-devel
38BuildRequires: readline-devel, ncurses-devel
39BuildRequires: libaio-devel
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke
44
45%description
46%{name} provides tools to manage multipath devices by instructing the
47device-mapper multipath kernel module what to do.
48The tools are :
49* multipath :   Scan the system for multipath devices and assemble them.
50* multipathd :  Detects when paths fail and execs multipath to update things.
51
52
53%package -n kpartx
54Summary: Partition device manager for device-mapper devices
55Summary(ja): Device-mapper デバイス用のパーティションデバイスマネージャー
56Group: System Environment/Base
57Provides: kpartx = %{version}-%{release}
58
59%description -n kpartx
60kpartx manages partition creation and removal for device-mapper devices.
61
62
63%prep
64%setup -q -c
65%patch1 -p1
66%patch1007 -p1
67%patch1008 -p1
68%patch1009 -p1
69%patch1010 -p1
70%patch1014 -p1
71%patch1017 -p1
72%patch1018 -p1
73%patch1019 -p1
74%patch1020 -p1
75%patch1021 -p1
76%patch1022 -p1
77%patch1023 -p1
78%patch1024 -p1
79
80
81%build
82make LIB=%{_lib}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make install \
87  DESTDIR=$RPM_BUILD_ROOT \
88  bindir=%{_syssbindir} \
89  syslibdir=/%{_lib} \
90  libdir=/%{_lib}/multipath \
91  rcdir=%{_initrddir}
92
93install -d %{buildroot}/etc/multipath
94install -m644 %{SOURCE1} %{buildroot}/etc/multipath.conf
95
96install -m755 multipathd/multipathd.init.redhat %{buildroot}%{_initrddir}/multipathd
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101
102%post
103/sbin/ldconfig
104/sbin/chkconfig --add multipathd
105if [ "$1" -gt "1" -a ! -e /etc/multipath/bindings -a \
106    -f /var/lib/multipath/bindings ]; then
107       mv /var/lib/multipath/bindings /etc/multipath/bindings
108       ln -s /etc/multipath/bindings /var/lib/multipath/bindings
109fi
110
111%preun
112if [ "$1" = 0 ]; then
113        /sbin/service multipathd stop /dev/null 2>&1
114        /sbin/chkconfig --del multipathd
115fi
116
117
118%postun
119/sbin/ldconfig
120if [ "$1" -ge "1" ]; then
121        /sbin/service multipathd condrestart >/dev/null 2>&1 || :
122fi
123
124
125%files
126%defattr(-,root,root,-)
127%doc AUTHOR COPYING README* FAQ
128%doc multipath.conf.annotated multipath.conf.defaults
129%doc multipath.conf.synthetic
130%{_syssbindir}/multipath
131%{_syssbindir}/multipathd
132%{_syssbindir}/mpathconf
133%config /lib/udev/rules.d/40-multipath.rules
134%{_mandir}/man8/multipath.8.gz
135%{_mandir}/man8/multipathd.8.gz
136%{_mandir}/man5/multipath.conf.5.gz
137%config /etc/rc.d/init.d/multipathd
138%config(noreplace) /etc/multipath.conf
139%dir /etc/multipath
140/%{_lib}/libmultipath.so*
141%dir /%{_lib}/multipath
142/%{_lib}/multipath/*
143
144%files -n kpartx
145%defattr(-,root,root,-)
146%{_syssbindir}/kpartx
147%{_mandir}/man8/kpartx.8.gz
148
149
150%changelog
151* Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.9-5
152- rebuilt with readline 6.3
153- changed BuildRequires: libsysfs-devel instead of sysfsutils-devel
154- added Japanese summary
155
156* Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.9-4
157- rebuild with VineSeed environment
158
159* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-3
160- import patches from RH package
161
162* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-2
163- install multipath libraries to %%{_lib}/multipath
164
165* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-1
166- update to 0.4.9
167- drop static version
168- add BR: libaio-devel
169
170* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.7-12vl5
171- applied new versioning policy
172
173* Thu Feb 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.7-11vl1
174- initial build for VineSeed
175- add Patch100 to disable linking to libselinux and libsepol
176
177* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 0.4.7-11.fc7
178- Add build dependency on new device-mapper-devel package.
179- Add dependency on device-mapper.
180
181* Wed Jan 31 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-10.fc7
182- Update BuildRoot and PreReq lines.
183
184* Mon Jan 15 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-9.fc7
185- Fixed spec file.
186
187* Mon Jan 15 2007 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-8.fc7
188- Update to latest code (t0_4_7_head2)
189
190* Wed Dec 13 2006 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-7.fc7
191- Update to latest code (t0_4_7_head1)
192
193* Thu Sep  7 2006 Peter Jones <pjones@redhat.com> - 0.4.7-5
194- Fix kpartx to handle with drives >2TB correctly.
195
196* Thu Aug 31 2006 Peter Jones <pjones@redhat.com> - 0.4.7-4.1
197- Split kpartx out into its own package so dmraid can use it without
198  installing multipathd
199- Fix a segfault in kpartx
200
201* Mon Jul 17 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-4.0
202- Updated to latest source. Fixes bug in default multipath.conf
203
204* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.1
205- Added ncurses-devel to BuildRequires
206
207* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.0
208- Updated to latest source. deals with change in libsysfs API
209
210* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.4.7-2.2.1
211- rebuild
212
213* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.2
214- fix tagging issue.
215
216* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.1
217- changed BuildRequires from sysfsutils-devel to libsysfs-devel
218
219* Wed Jun 28 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.0
220- Updated to latest upstream source, fixes kpartx udev rule issue
221
222* Tue Jun 06 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-1.0
223- Updated to Christophe's latest source
224
225* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-16.0
226- Newer upstream source (t0_4_5_post59).
227
228* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-12.3
229- BuildRequires: libsepol-devel, readline-devel
230
231* Mon Feb 27 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.5-12.2
232- Prereq: chkconfig
233
234* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 0.4.5-12.1
235- BuildRequires: libselinux-devel
236
237* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-12.0.1
238- bump again for double-long bug on ppc(64)
239
240* Tue Feb 07 2006 Benjamin Marzinski <bmarzins@redhat.com> -0.4.5-12.0
241- Updated to latest upstream source (t0_4_5_post56)
242
243* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-9.1.1
244- rebuilt for new gcc4.1 snapshot and glibc changes
245
246* Mon Dec 19 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.1
247- added patch for fedora changes
248
249* Fri Dec 16 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.0
250- Updated to latest upstream source (t)_4_5_post52)
251
252* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
253- rebuilt
254
255* Sun Dec  4 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.6
256- rebuild for newer libs
257
258* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.5
259- unsplit kpartx.  parted knows how to do this now, so we don't
260  need this in a separate package.
261
262* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.4
263- split kpartx out into its own package
264
265* Fri May 06 2005 Bill Nottingham <notting@redhat.com> - 0.4.4-2.3
266- Fix last fix.
267
268* Thu May 05 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.2
269- Fix last fix.
270
271* Wed May 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.1
272- By default, disable the multipathd service.
273
274* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.0
275- Fix core dump from last build.
276
277* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-1.0
278- Move cache file into /var/cache/multipath.
279
280* Fri Apr 08 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.1
281- Remove pp_balance_units.
282
283* Mon Apr 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.0
284- Incorporate numerous upstream fixes.
285- Update init script to distribution standards.
286
287* Tue Mar 01 2005 Alasdair Kergon <agk@redhat.com> - 0.4.2-1.0
288- Initial import based on Christophe Varoqui's spec file.
Note: See TracBrowser for help on using the repository browser.