source: projects/specs/trunk/d/devhelp/devhelp-vl.spec @ 7119

Revision 7119, 6.7 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.2

Line 
1Version:        3.6.1
2Release:        1%{?_dist_release}
3
4%define gtk_required            3.6.0
5
6Summary:        API document browser
7Summary(ja):    API ドキュメントブラウザ
8Name:           devhelp
9License:        GPL
10Group:          Applications/Development
11Url:            http://live.gnome.org/devhelp
12Source:         http://ftp.gnome.org/pub/GNOME/sources/devhelp/3.6/%{name}-%{version}.tar.xz
13#Patch10:       %{name}-0.19.1-xulrunner19.patch
14#Patch11:       %{name}-webkit.patch
15#Patch:         %{name}-r1265.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: yasumichi
22
23Requires(pre,preun,post): GConf2
24Requires(post,postun): gtk3     >= %{gtk_required}
25
26BuildRequires:  gtk3-devel      >= %{gtk_required}
27BuildRequires:  GConf2-devel    >= 2.6.0
28BuildRequires:  WebKit3-gtk-devel
29
30%description
31An API document browser for GNOME 3.
32
33%description -l ja
34GNOME3 用の API ブラウザです。
35
36%package devel
37Summary:        Library to embed Devhelp in other applications.
38Group:          Development/Libraries
39Requires:       %{name} = %{version}
40Requires:       gtk3-devel      >= %{gtk_required}
41Requires:       GConf2-devel    >= 2.6.0
42Requires:       WebKit3-gtk-devel
43
44%description devel
45Library of Devhelp for embedding into other applications.
46
47%prep
48%setup -q
49#patch10 -p1 -b .xulrunner19
50#%patch -p1
51
52%build
53%configure --disable-static --disable-schemas-install
54
55make
56
57%install
58[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
59
60export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
61%makeinstall PREFIX=$RPM_BUILD_ROOT%{_prefix} install
62unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
63
64# remove, not shipped
65rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
66rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
67
68%find_lang %{name}
69
70%clean
71[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
72
73%post
74/sbin/ldconfig
75export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
76gconftool-2 --makefile-install-rule \
77    %{_sysconfdir}/gconf/schemas/devhelp.schemas > /dev/null || :
78touch --no-create %{_datadir}/icons/hicolor
79if [ -x /usr/bin/gtk-update-icon-cache ]; then
80  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
81fi
82
83%pre
84if [ "$1" -gt 1 ]; then
85    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86    gconftool-2 --makefile-uninstall-rule \
87        %{_sysconfdir}/gconf/schemas/devhelp.schemas >/dev/null || :
88fi
89
90%preun
91if [ "$1" -eq 0 ]; then
92    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93    gconftool-2 --makefile-uninstall-rule \
94        %{_sysconfdir}/gconf/schemas/devhelp.schemas >/dev/null || :
95fi
96 
97%postun
98/sbin/ldconfig
99touch --no-create %{_datadir}/icons/hicolor
100if [ -x /usr/bin/gtk-update-icon-cache ]; then
101  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
102fi
103
104 
105%files -f %{name}.lang
106%defattr(-, root, root)
107%doc AUTHORS COPYING ChangeLog NEWS README INSTALL
108%config %{_sysconfdir}/gconf/schemas/*.schemas
109%{_bindir}/devhelp
110%{_libdir}/lib*.so.*
111%{_datadir}/applications/devhelp.desktop
112%{_datadir}/devhelp
113%{_datadir}/icons/hicolor/*/apps/devhelp.png
114%{_libdir}/gedit/plugins/devhelp*
115
116%files devel
117%defattr(-,root,root)
118%{_includedir}/*
119%{_libdir}/libdevhelp*.so
120%{_libdir}/pkgconfig/*
121
122%changelog
123* Wed Nov 14 2012 TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
124- new upstream release
125
126* Sat Sep 29 2012 TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
127- new upstream release
128
129* Sun Apr 22 2012 TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
130- new upstream release
131
132* Thu Sep 29 2011 TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
133- new upstream release
134
135* Mon Aug 15 2011 TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
136- new upstream release
137
138* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
139- new upstream release
140- remove %pre, %preun
141- fix %post, %postun
142- add %posttrans
143
144* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-2
145- rebuilt with rpm-4.8.1 for pkg-config
146
147* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
148- new upstream release
149
150* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
151- new upstream release
152
153* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-2
154- add unique-devel to BR
155
156* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-1
157- New upstream release.
158- remove Patch
159- build with WebKit-1.1.15.3
160- add Vendor, Distribution and Packager.
161
162* Mon Aug 10 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-4
163- update Patch(See follow url)
164- http://git.gnome.org/cgit/devhelp/commit/?id=af67fbedccab5044808a489a9f3a5540d42adcf2
165
166* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-3
167- update Url.
168- add Patch11(http://bugzilla.gnome.org/show_bug.cgi?id=586559)
169
170* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-2
171- remove unneeded Requires:
172- remove Requires/BuildRequires to gecko.
173
174* Tue Apr 28 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-1
175- new upstream release
176- added Requires: Webkit-gtk,libsoup BuildRequires: Webkit-gtk-devel,libsoup-devel
177
178* Tue Sep 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21-1
179- new upstream release (dropped Patch10)
180- updated BuildRequires: gecko-devel-unstable instead of gecko-devel
181- added Requires: gecko-libs instead of firefox
182
183* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.19.1-2
184- add Patch10 to build with xulrunner-1.9
185- add %%pre %%preun scripts to remove old gconf schemas
186- add %%postun to update icon cache
187- add unpackaged icons to %%files
188
189* Fri May 30 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.19.1
190- new upstream version.
191
192* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.16.1-2
193- use macro for Release
194
195* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org>
196- apply new virsioning policy.
197- remove *.la
198
199* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.1-0vl2
200- rebuilt with libwnck 2.20.2
201
202* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-0vl1
203- new upstream version
204- removed icon-theme.cache in %%install section
205
206* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
207- new upstream release
208
209* Tue Apr 03 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl2
210- icon-theme.cache is not included.
211
212* Sun Apr 01 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl1
213- update to 0.13
214
215* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.12-0vl2
216- build devel package
217
218* Sun Oct 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12-0vl1
219- updated to 0.12
220- using firefox(gecko) instead of gtkhtml2
221- disabled intltoolize before configure
222
223* Thu Aug 25 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.3-0vl2
224- add "--force" to intltoolize
225
226* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.3-0vl1
227- build for Vine Linux
228- do not build devel package
229
230* Sun Jun 29 2003 Mikael Hallendal <micke@imendio.com>
231- Released 0.7
Note: See TracBrowser for help on using the repository browser.