source: projects/specs/trunk/d/devhelp/devhelp-vl.spec @ 6078

Revision 6078, 6.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Version:        3.4.1
2Release:        1%{?_dist_release}
3
4%define gtk_required            3.4.1
5
6Summary:        API document browser
7Summary(ja):    API ドキュメントブラウザ
8Name:           devhelp
9License:        GPL
10Group:          Applications/Development
11Url:            http://live.gnome.org/devhelp
12Source:         http://ftp.gnome.org/pub/GNOME/sources/devhelp/3.4/%{name}-%{version}.tar.xz
13#Patch10:       %{name}-0.19.1-xulrunner19.patch
14#Patch11:       %{name}-webkit.patch
15#Patch:         %{name}-r1265.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: yasumichi
22
23Requires(pre,preun,post): GConf2
24Requires(post,postun): gtk3     >= %{gtk_required}
25
26BuildRequires:  gtk3-devel      >= %{gtk_required}
27BuildRequires:  GConf2-devel    >= 2.6.0
28BuildRequires:  WebKit3-gtk-devel
29
30%description
31An API document browser for GNOME 3.
32
33%description -l ja
34GNOME3 用の API ブラウザです。
35
36%package devel
37Summary:        Library to embed Devhelp in other applications.
38Group:          Development/Libraries
39Requires:       %{name} = %{version}
40Requires:       gtk3-devel      >= %{gtk_required}
41Requires:       GConf2-devel    >= 2.6.0
42Requires:       WebKit3-gtk-devel
43
44%description devel
45Library of Devhelp for embedding into other applications.
46
47%prep
48%setup -q
49#patch10 -p1 -b .xulrunner19
50#%patch -p1
51
52%build
53%configure --disable-static --disable-schemas-install
54
55make
56
57%install
58[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
59
60export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
61%makeinstall PREFIX=$RPM_BUILD_ROOT%{_prefix} install
62unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
63
64# remove, not shipped
65rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
66rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
67
68%find_lang %{name}
69
70%clean
71[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
72
73%post
74/sbin/ldconfig
75touch --no-create %{_datadir}/icons/hicolor
76if [ -x /usr/bin/gtk-update-icon-cache ]; then
77  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
78fi
79 
80%postun
81/sbin/ldconfig
82glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
83touch --no-create %{_datadir}/icons/hicolor
84if [ -x /usr/bin/gtk-update-icon-cache ]; then
85  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
86fi
87
88%posttrans
89glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
90
91 
92%files -f %{name}.lang
93%defattr(-, root, root)
94%doc AUTHORS COPYING ChangeLog NEWS README INSTALL
95%config %{_sysconfdir}/gconf/schemas/*.schemas
96%{_bindir}/devhelp
97%{_libdir}/lib*.so.*
98%{_datadir}/applications/devhelp.desktop
99%{_datadir}/devhelp
100%{_datadir}/icons/hicolor/*/apps/devhelp.png
101%{_libdir}/gedit/plugins/devhelp*
102
103%files devel
104%defattr(-,root,root)
105%{_includedir}/*
106%{_libdir}/libdevhelp*.so
107%{_libdir}/pkgconfig/*
108
109%changelog
110* Sun Apr 22 2012 TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
111- new upstream release
112
113* Thu Sep 29 2011 TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
114- new upstream release
115
116* Mon Aug 15 2011 TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
117- new upstream release
118
119* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
120- new upstream release
121- remove %pre, %preun
122- fix %post, %postun
123- add %posttrans
124
125* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-2
126- rebuilt with rpm-4.8.1 for pkg-config
127
128* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
129- new upstream release
130
131* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
132- new upstream release
133
134* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-2
135- add unique-devel to BR
136
137* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-1
138- New upstream release.
139- remove Patch
140- build with WebKit-1.1.15.3
141- add Vendor, Distribution and Packager.
142
143* Mon Aug 10 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-4
144- update Patch(See follow url)
145- http://git.gnome.org/cgit/devhelp/commit/?id=af67fbedccab5044808a489a9f3a5540d42adcf2
146
147* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-3
148- update Url.
149- add Patch11(http://bugzilla.gnome.org/show_bug.cgi?id=586559)
150
151* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-2
152- remove unneeded Requires:
153- remove Requires/BuildRequires to gecko.
154
155* Tue Apr 28 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-1
156- new upstream release
157- added Requires: Webkit-gtk,libsoup BuildRequires: Webkit-gtk-devel,libsoup-devel
158
159* Tue Sep 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21-1
160- new upstream release (dropped Patch10)
161- updated BuildRequires: gecko-devel-unstable instead of gecko-devel
162- added Requires: gecko-libs instead of firefox
163
164* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.19.1-2
165- add Patch10 to build with xulrunner-1.9
166- add %%pre %%preun scripts to remove old gconf schemas
167- add %%postun to update icon cache
168- add unpackaged icons to %%files
169
170* Fri May 30 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.19.1
171- new upstream version.
172
173* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.16.1-2
174- use macro for Release
175
176* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org>
177- apply new virsioning policy.
178- remove *.la
179
180* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.1-0vl2
181- rebuilt with libwnck 2.20.2
182
183* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-0vl1
184- new upstream version
185- removed icon-theme.cache in %%install section
186
187* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
188- new upstream release
189
190* Tue Apr 03 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl2
191- icon-theme.cache is not included.
192
193* Sun Apr 01 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl1
194- update to 0.13
195
196* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.12-0vl2
197- build devel package
198
199* Sun Oct 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12-0vl1
200- updated to 0.12
201- using firefox(gecko) instead of gtkhtml2
202- disabled intltoolize before configure
203
204* Thu Aug 25 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.3-0vl2
205- add "--force" to intltoolize
206
207* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.3-0vl1
208- build for Vine Linux
209- do not build devel package
210
211* Sun Jun 29 2003 Mikael Hallendal <micke@imendio.com>
212- Released 0.7
Note: See TracBrowser for help on using the repository browser.