source: projects/specs/trunk/d/devhelp/devhelp-vl.spec @ 521

Revision 521, 6.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Version:        2.28.1
2Release:        2%{?_dist_release}
3
4%define gtk_required            2.10.0
5%define libwnck_required        2.10.0
6
7Summary:        API document browser
8Summary(ja):    API ドキュメントブラウザ
9Name:           devhelp
10License:        GPL
11Group:          Applications/Development
12Url:            http://live.gnome.org/devhelp
13Source:         http://ftp.gnome.org/pub/GNOME/sources/devhelp/0.21/%{name}-%{version}.tar.bz2
14#Patch10:       %{name}-0.19.1-xulrunner19.patch
15#Patch11:       %{name}-webkit.patch
16#Patch:         %{name}-r1265.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: yasumichi
23
24Requires(pre,preun,post): GConf2
25Requires(post,postun): gtk2     >= %{gtk_required}
26
27BuildRequires:  gtk2-devel      >= %{gtk_required}
28BuildRequires:  GConf2-devel    >= 2.6.0
29BuildRequires:  libglade2-devel >= 2.4.0
30BuildRequires:  libwnck-devel   >= %{libwnck_required}
31BuildRequires:  zlib-devel
32BuildRequires:  WebKit-gtk-devel >= 1.1.13
33BuildRequires:  libsoup-devel
34BuildRequires:  unique-devel
35
36%description
37An API document browser for GNOME 2.
38
39%description -l ja
40GNOME2 用の API ブラウザです。
41
42%package devel
43Summary:        Library to embed Devhelp in other applications.
44Group:          Development/Libraries
45Requires:       %{name} = %{version}
46Requires:       gtk2-devel      >= %{gtk_required}
47Requires:       GConf2-devel    >= 2.6.0
48Requires:       libglade2-devel >= 2.4.0
49Requires:       libwnck-devel   >= %{libwnck_required}
50Requires:       WebKit-gtk-devel
51Requires:       libsoup-devel
52Requires:       unique-devel
53
54%description devel
55Library of Devhelp for embedding into other applications.
56
57%prep
58%setup -q
59#patch10 -p1 -b .xulrunner19
60#%patch -p1
61
62%build
63%configure --disable-static --disable-schemas-install
64
65make
66
67%install
68[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
69
70export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
71%makeinstall PREFIX=$RPM_BUILD_ROOT%{_prefix} install
72unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
73
74# remove, not shipped
75rm -f $RPM_BUILD_ROOT%{_libdir}/libdevhelp-1.la
76#rm -f $RPM_BUILD_ROOT%{_libdir}/libdevhelp-1.so
77#rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
78#rm -rf $RPM_BUILD_ROOT%{_includedir}
79rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
80
81%find_lang %{name}
82
83%clean
84[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
85
86%pre
87if [ "$1" -gt 1 ]; then
88  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
89  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/devhelp.schemas > /dev/null || :
90fi
91
92%preun
93if [ "$1" -eq 0 ]; then
94  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/devhelp.schemas > /dev/null || :
96fi
97
98%post
99/sbin/ldconfig
100export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
101gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/devhelp.schemas > /dev/null ||:
102touch --no-create %{_datadir}/icons/hicolor
103if [ -x /usr/bin/gtk-update-icon-cache ]; then
104  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
105fi
106 
107%postun
108/sbin/ldconfig
109touch --no-create %{_datadir}/icons/hicolor
110if [ -x /usr/bin/gtk-update-icon-cache ]; then
111  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
112fi
113 
114%files -f %{name}.lang
115%defattr(-, root, root)
116%doc AUTHORS COPYING ChangeLog NEWS README INSTALL
117%config %{_sysconfdir}/gconf/schemas/*.schemas
118%{_bindir}/devhelp
119%{_libdir}/lib*.so.*
120%{_datadir}/applications/devhelp.desktop
121%{_datadir}/devhelp
122%{_datadir}/icons/hicolor/scalable/apps/devhelp.svg
123%{_datadir}/icons/hicolor/*/apps/devhelp.png
124%{_libdir}/gedit-2/plugins/*
125
126%files devel
127%defattr(-,root,root)
128%{_includedir}/*
129#%{_libdir}/libdevhelp*.la
130%{_libdir}/libdevhelp*.so
131%{_libdir}/pkgconfig/*
132
133%changelog
134* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-2
135- add unique-devel to BR
136
137* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-1
138- New upstream release.
139- remove Patch
140- build with WebKit-1.1.15.3
141- add Vendor, Distribution and Packager.
142
143* Mon Aug 10 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-4
144- update Patch(See follow url)
145- http://git.gnome.org/cgit/devhelp/commit/?id=af67fbedccab5044808a489a9f3a5540d42adcf2
146
147* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-3
148- update Url.
149- add Patch11(http://bugzilla.gnome.org/show_bug.cgi?id=586559)
150
151* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-2
152- remove unneeded Requires:
153- remove Requires/BuildRequires to gecko.
154
155* Tue Apr 28 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-1
156- new upstream release
157- added Requires: Webkit-gtk,libsoup BuildRequires: Webkit-gtk-devel,libsoup-devel
158
159* Tue Sep 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21-1
160- new upstream release (dropped Patch10)
161- updated BuildRequires: gecko-devel-unstable instead of gecko-devel
162- added Requires: gecko-libs instead of firefox
163
164* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.19.1-2
165- add Patch10 to build with xulrunner-1.9
166- add %%pre %%preun scripts to remove old gconf schemas
167- add %%postun to update icon cache
168- add unpackaged icons to %%files
169
170* Fri May 30 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.19.1
171- new upstream version.
172
173* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.16.1-2
174- use macro for Release
175
176* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org>
177- apply new virsioning policy.
178- remove *.la
179
180* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.1-0vl2
181- rebuilt with libwnck 2.20.2
182
183* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-0vl1
184- new upstream version
185- removed icon-theme.cache in %%install section
186
187* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
188- new upstream release
189
190* Tue Apr 03 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl2
191- icon-theme.cache is not included.
192
193* Sun Apr 01 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl1
194- update to 0.13
195
196* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.12-0vl2
197- build devel package
198
199* Sun Oct 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12-0vl1
200- updated to 0.12
201- using firefox(gecko) instead of gtkhtml2
202- disabled intltoolize before configure
203
204* Thu Aug 25 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.3-0vl2
205- add "--force" to intltoolize
206
207* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.3-0vl1
208- build for Vine Linux
209- do not build devel package
210
211* Sun Jun 29 2003 Mikael Hallendal <micke@imendio.com>
212- Released 0.7
Note: See TracBrowser for help on using the repository browser.