source: projects/specs/trunk/d/devhelp/devhelp-vl.spec @ 4616

Revision 4616, 6.0 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Version:        3.0.0
2Release:        1%{?_dist_release}
3
4%define gtk_required            3.0.11
5
6Summary:        API document browser
7Summary(ja):    API ドキュメントブラウザ
8Name:           devhelp
9License:        GPL
10Group:          Applications/Development
11Url:            http://live.gnome.org/devhelp
12Source:         http://ftp.gnome.org/pub/GNOME/sources/devhelp/3.0/%{name}-%{version}.tar.bz2
13#Patch10:       %{name}-0.19.1-xulrunner19.patch
14#Patch11:       %{name}-webkit.patch
15#Patch:         %{name}-r1265.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: yasumichi
22
23Requires(pre,preun,post): GConf2
24Requires(post,postun): gtk3     >= %{gtk_required}
25
26BuildRequires:  gtk3-devel      >= %{gtk_required}
27BuildRequires:  GConf2-devel    >= 2.6.0
28BuildRequires:  WebKit3-gtk-devel
29
30%description
31An API document browser for GNOME 2.
32
33%description -l ja
34GNOME2 用の API ブラウザです。
35
36%package devel
37Summary:        Library to embed Devhelp in other applications.
38Group:          Development/Libraries
39Requires:       %{name} = %{version}
40Requires:       gtk3-devel      >= %{gtk_required}
41Requires:       GConf2-devel    >= 2.6.0
42Requires:       WebKit3-gtk-devel
43
44%description devel
45Library of Devhelp for embedding into other applications.
46
47%prep
48%setup -q
49#patch10 -p1 -b .xulrunner19
50#%patch -p1
51
52%build
53%configure --disable-static --disable-schemas-install
54
55make
56
57%install
58[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
59
60export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
61%makeinstall PREFIX=$RPM_BUILD_ROOT%{_prefix} install
62unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
63
64# remove, not shipped
65rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
66#rm -f $RPM_BUILD_ROOT%{_libdir}/libdevhelp-1.so
67#rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
68#rm -rf $RPM_BUILD_ROOT%{_includedir}
69rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
70
71%find_lang %{name}
72
73%clean
74[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
75
76%post
77/sbin/ldconfig
78touch --no-create %{_datadir}/icons/hicolor
79if [ -x /usr/bin/gtk-update-icon-cache ]; then
80  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
81fi
82 
83%postun
84/sbin/ldconfig
85glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x /usr/bin/gtk-update-icon-cache ]; then
88  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
89fi
90
91%posttrans
92glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
93
94 
95%files -f %{name}.lang
96%defattr(-, root, root)
97%doc AUTHORS COPYING ChangeLog NEWS README INSTALL
98%config %{_sysconfdir}/gconf/schemas/*.schemas
99%{_bindir}/devhelp
100%{_libdir}/lib*.so.*
101%{_datadir}/applications/devhelp.desktop
102%{_datadir}/devhelp
103%{_datadir}/icons/hicolor/*/apps/devhelp.png
104%{_libdir}/gedit/plugins/devhelp*
105
106%files devel
107%defattr(-,root,root)
108%{_includedir}/*
109#%{_libdir}/libdevhelp*.la
110%{_libdir}/libdevhelp*.so
111%{_libdir}/pkgconfig/*
112
113%changelog
114* Mon Aug 15 2011 TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
115- new upstream release
116
117* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
118- new upstream release
119- remove %pre, %preun
120- fix %post, %postun
121- add %posttrans
122
123* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-2
124- rebuilt with rpm-4.8.1 for pkg-config
125
126* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
127- new upstream release
128
129* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
130- new upstream release
131
132* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-2
133- add unique-devel to BR
134
135* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-1
136- New upstream release.
137- remove Patch
138- build with WebKit-1.1.15.3
139- add Vendor, Distribution and Packager.
140
141* Mon Aug 10 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-4
142- update Patch(See follow url)
143- http://git.gnome.org/cgit/devhelp/commit/?id=af67fbedccab5044808a489a9f3a5540d42adcf2
144
145* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-3
146- update Url.
147- add Patch11(http://bugzilla.gnome.org/show_bug.cgi?id=586559)
148
149* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-2
150- remove unneeded Requires:
151- remove Requires/BuildRequires to gecko.
152
153* Tue Apr 28 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-1
154- new upstream release
155- added Requires: Webkit-gtk,libsoup BuildRequires: Webkit-gtk-devel,libsoup-devel
156
157* Tue Sep 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21-1
158- new upstream release (dropped Patch10)
159- updated BuildRequires: gecko-devel-unstable instead of gecko-devel
160- added Requires: gecko-libs instead of firefox
161
162* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.19.1-2
163- add Patch10 to build with xulrunner-1.9
164- add %%pre %%preun scripts to remove old gconf schemas
165- add %%postun to update icon cache
166- add unpackaged icons to %%files
167
168* Fri May 30 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.19.1
169- new upstream version.
170
171* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.16.1-2
172- use macro for Release
173
174* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org>
175- apply new virsioning policy.
176- remove *.la
177
178* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.1-0vl2
179- rebuilt with libwnck 2.20.2
180
181* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-0vl1
182- new upstream version
183- removed icon-theme.cache in %%install section
184
185* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
186- new upstream release
187
188* Tue Apr 03 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl2
189- icon-theme.cache is not included.
190
191* Sun Apr 01 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl1
192- update to 0.13
193
194* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.12-0vl2
195- build devel package
196
197* Sun Oct 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12-0vl1
198- updated to 0.12
199- using firefox(gecko) instead of gtkhtml2
200- disabled intltoolize before configure
201
202* Thu Aug 25 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.3-0vl2
203- add "--force" to intltoolize
204
205* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.3-0vl1
206- build for Vine Linux
207- do not build devel package
208
209* Sun Jun 29 2003 Mikael Hallendal <micke@imendio.com>
210- Released 0.7
Note: See TracBrowser for help on using the repository browser.