source: projects/specs/trunk/d/dev86/dev86-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A real mode 80x86 assembler and linker
2Summary(ja): リアルモード 80x86 アセンブラとリンカ
3Name: dev86
4Version: 0.16.17
5Release: 2%{?_dist_release}
6License: GPL
7Group: Development/Languages
8URL: http://homepage.ntlworld.com/robert.debath/
9Source: http://homepage.ntlworld.com/robert.debath/dev86/Dev86src-%{version}.tar.gz
10Patch0: dev86-noelks.patch
11Patch1: dev86-x86_64.patch
12Patch2: dev86-nostrip.patch
13Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
14Obsoletes: bin86
15BuildRequires: gawk
16
17%define __os_install_post    /usr/lib/rpm/brp-compress /usr/lib/rpm/brp-strip %{__strip} /usr/lib/rpm/brp-strip-comment-note %{__strip} %{__objdump} %{nil}
18
19%description
20The dev86 package provides an assembler and linker for real mode 80x86
21instructions. You'll need to have this package installed in order to
22build programs that run in real mode, including LILO and the kernel's
23bootstrapping code, from their sources.
24
25You should install dev86 if you intend to build programs that run in real
26mode from their source code.
27
28%description -l ja
29dev86 パッケージは リアルモード 80x86 命令のアセンブラとリンカを提供
30します。LILO や kernel のブートストラップコードを含むリアルモードで
31走るプログラムをソースから作成するときにはこのパッケージがインストー
32ルされている必要があります。
33
34リアルモードで走るプログラムをソースから作成するつもりなら dev86 を
35インストールしてください。
36
37%prep
38%setup -q
39%patch0 -p1 -b .noelks
40%ifarch x86_64
41%patch1 -p1 -b .x86_64
42%endif
43%patch2 -p1 -b .nostrip
44
45%build
46make <<EOF
475
48quit
49EOF
50
51%install
52rm -rf ${RPM_BUILD_ROOT}
53
54make    DIST=${RPM_BUILD_ROOT} \
55        MANDIR=%{_mandir} \
56        LIBDIR=%{_libdir}/bcc \
57        INCLDIR=%{_libdir}/bcc \
58        LOCALPREFIX=%{_prefix} \
59        install install-man
60
61# preserve READMEs
62for i in bootblocks copt dis88 unproto bin86 ; do cp $i/README README.$i ; done
63cp bin86/README-0.4 README-0.4.bin86
64cp bin86/ChangeLog ChangeLog.bin86
65
66pushd ${RPM_BUILD_ROOT}%{_bindir}
67rm -f nm86 size86
68ln -s objdump86 nm86
69ln -s objdump86 size86
70popd
71
72%clean
73rm -rf ${RPM_BUILD_ROOT}
74
75%files
76%defattr(-,root,root,-)
77%doc README MAGIC Contributors README.bootblocks README.copt README.dis88
78%doc README.unproto README-0.4.bin86 README.bin86 ChangeLog.bin86
79%dir %{_libdir}/bcc
80%{_bindir}/bcc
81%{_bindir}/ar86
82%{_bindir}/as86
83%{_bindir}/ld86
84%{_bindir}/objdump86
85%{_bindir}/nm86
86%{_bindir}/size86
87%{_libdir}/bcc/*
88%{_mandir}/man1/*
89
90%changelog
91* Tue Jan  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.16.17-2
92- remove ExclusiveArch to allow to run dev86 on different arches
93
94* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.17-1vl5
95- applied new versioning policy, spec in utf-8
96
97* Tue Nov 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.17-0vl1
98- new upstream release
99
100* Sat Sep 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.3-9vl1
101- based on Rawhide 0.16.3-9
102  * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 0.16.3-9
103  - preserve README files with separate names
104  * Fri Jan 31 2003 Florian La Roche <Florian.LaRoche@redhat.de>
105  - do not strip static archive to get rebuild working again
106  * Sat Aug 10 2002 Florian La Roche <Florian.LaRoche@redhat.de>
107  - add ar86 to filelist
108  * Wed Jun 19 2002 Florian La Roche <Florian.LaRoche@redhat.de>
109  - do not strip apps
110
111- rebuild with new toolchains
112- s/Copyright/License/
113
114* Sat Jul 14 2001 <sagami@vinelinux.org>
115- 0.15.5-1vl2: use %%{ix86} for ExclusiveArch instead of i386
116- enabled %%clean (why was it disabled?)
117
118* Sun May 27 2001 <sagami@vinelinux.org>
119- 0.15.5-1vl1: added Japanese summary and description
120
121* Mon May  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.15.5-1
122- Update to 0.15.5, lots of fixes
123
124* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
125- automatic rebuild
126
127* Mon Jun 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
128- add defattr
129
130* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
131- use %%{_mandir}
132
133* Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
134- change default header directory to match libs and fix bug #9121
135
136* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
137- version 0.15.0
138- man pages are compressed
139
140* Mon Sep 20 1999 Donnie Barnes <djb@redhat.com>
141- removed "Distribution:" line (was RHCN)
142- changed description and summary to the ones from bin86 with s/bin/dev/
143  done throughout
144- added patch to keep from installing in /usr/bcc and simply in /usr
145- moved include files to /usr/lib/bcc/include
146
147* Tue Sep 07 1999 Erik Troan <ewt@redhat.com>
148- updated to Dev86src
149- included in Red Hat 6.1
150
151* Sat Nov 14 1998 Simon Weijgers <simon@mbit.doa.org>
152
153- First release of this package to be shipped to rhcn.
154
155- To be fixed: Bug in Makefile which installs headerfiles
156  double. E.g. /usr/bcc/include/arch is also installed under
157  /usr/bcc/include/arch/arch. This doesn't hinder operation,
158  just eats a tiny bit of diskspace.
159
Note: See TracBrowser for help on using the repository browser.