source: projects/specs/trunk/d/deluge/deluge-vl.spec @ 7496

Revision 7496, 27.2 KB checked in by kudoh, 11 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           deluge
4Version:        1.3.6
5Release:        1%{?_dist_release}
6Summary:        A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
7Summary(ja):    DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
8Group:          Applications/Internet
9License:        GPLv3 with exceptions
10URL:            http://deluge-torrent.org/
11
12Source0:        http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.lzma
13Source1:       deluge-daemon-init
14
15## The scalable icon needs to be installed to the proper place.
16Patch0:         %{name}-scalable-icon-dir.diff
17Patch1:         010_new_release_check.patch
18Patch10:       workaround_build.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildArch:      noarch
22
23BuildRequires:  desktop-file-utils
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26## The build script checks for the libtorrent module and skips compiling the
27## in-tarball one if this is found.
28BuildRequires:  libtorrent-rasterbar-python >= 0.14.9
29BuildRequires:  intltool
30
31## add Requires to make into Meta package
32Requires: %{name}-common = %{version}-%{release}
33Requires: %{name}-gtk = %{version}-%{release}
34Requires: %{name}-images = %{version}-%{release}
35Requires: %{name}-console = %{version}-%{release}
36Requires: %{name}-web = %{version}-%{release}
37Requires: %{name}-daemon = %{version}-%{release}
38
39# removal of flags
40Provides:         deluge-flags = %{version}-%{release}
41Obsoletes:        deluge-flags < 1.3.1-3
42
43%description
44Deluge is a new BitTorrent client, created using Python and GTK+. It is
45intended to bring a native, full-featured client to Linux GTK+ desktop
46environments such as GNOME and Xfce.
47
48%description -l ja
49Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
50GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
51クライアントを提供することを意図しています。
52
53
54%package common
55Summary:    Files common to Deluge sub packages
56Summary(ja): Deluge サブパッケージに共通するファイル
57Group:      Applications/Internet
58License:    GPLv3 with exceptions
59Requires:   python-setuptools
60Requires:   pyOpenSSL
61Requires:   python-chardet
62Requires:   python-simplejson
63Requires:   pyxdg
64Requires:   libtorrent-rasterbar-python >= 0.14.9
65Requires:   python-twisted
66
67%description common
68Common files needed by the Deluge bittorrent client sub packages
69
70%package gtk
71Summary:    The gtk UI to Deluge
72Summary(ja): Deluge の gtk ユーザーインターフェイス
73Group:      Applications/Internet
74License:    GPLv3 with exceptions
75Requires:   %{name}-common = %{version}-%{release}
76Requires:   %{name}-images = %{version}-%{release}
77Requires:   %{name}-daemon = %{version}-%{release}
78Requires:   gnome-python
79## Required for the proper ownership of icon dirs.
80Requires:   hicolor-icon-theme
81Requires:   notify-python
82Requires:   pygtk2-libglade
83
84%description gtk
85Deluge bittorent client GTK graphical user interface
86
87%package images
88Summary:    Image files for Deluge
89Summary(ja): Deluge の画像ファイル
90Group:      Applications/Internet
91License:    GPLv3 with exceptions
92
93%description images
94Data files used by the GTK and web user interface for Deluge bittorent client
95
96%package console
97Summary:    CLI to Deluge
98Summary(ja): Deluge のコマンドラインインターフェイス
99Group:      Applications/Internet
100License:    GPLv3 with exceptions
101Requires:   %{name}-common = %{version}-%{release}
102Requires:   %{name}-daemon = %{version}-%{release}
103
104%description console
105Deluge bittorent client command line interface
106
107%package web
108Summary:    Web interface to Deluge
109Summary(ja): Deluge の Web インターフェイス
110Group:      Applications/Internet
111License:    GPLv3 with exceptions
112Requires:   python-mako
113Requires:   %{name}-common = %{version}-%{release}
114Requires:   %{name}-images = %{version}-%{release}
115Requires:   %{name}-daemon = %{version}-%{release}
116
117%description web
118Deluge bittorent client web interface
119
120%package daemon
121Summary:    The Deluge daemon
122Summary(ja): Deluge デーモン
123Group:      Applications/Internet
124License:    GPLv3 with exceptions
125Requires:   %{name}-common = %{version}-%{release}
126Requires(pre): shadow-utils
127Requires(post): chkconfig
128Requires(preun): chkconfig
129Requires(preun): initscripts
130Requires(postun): initscripts
131
132%description daemon
133Files for the Deluge daemon
134
135
136%prep
137%setup -qn "%{name}-%{version}"
138%patch0 -p0 -b .fix-scalable-icon-dir
139%patch1 -p1
140#%patch10 -p1
141
142
143%build
144CFLAGS="%{optflags}" %{__python} setup.py build
145
146%install
147rm -rf %{buildroot}
148mkdir -p %{buildroot}%{_initddir}
149install -m755 %{SOURCE1} %{buildroot}%{_initddir}/%{name}-daemon
150mkdir -p %{buildroot}/var/lib/%{name}
151
152%{__python} setup.py install -O1 --skip-build --root %{buildroot}
153
154desktop-file-install --vendor vine                      \
155        --dir %{buildroot}%{_datadir}/applications      \
156        --copy-name-to-generic-name                     \
157        --add-mime-type=application/x-bittorrent        \
158        --delete-original                               \
159        --remove-category=Application                   \
160        %{buildroot}%{_datadir}/applications/%{name}.desktop
161
162## NOTE: The lang files should REEEAALLLY be in a standard place such as
163##       /usr/share/locale or similar. It'd make things so much nicer for
164##       the packaging. :O
165## A bit of sed magic to mark the translation files with %%lang, taken from
166## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
167## cannot (unfortunately) call find-lang directly since it's not on a
168## "$PREFIX/share/locale/"-ish directory tree.
169pushd %{buildroot}
170    find -type f -o -type l \
171        | sed '
172            s:%{buildroot}%{python_sitelib}::
173            s:^\.::
174            s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
175            s:^\([^%].*\)::
176            s:%lang(C) ::
177            /^$/d' \
178    > %{name}.lang
179
180## Now we move that list back to our sources, so that '%%files -f' can find it
181## properly.
182popd && mv %{buildroot}/%{name}.lang .
183
184#fix non exec script errors in two files
185for lib in "%{buildroot}%{python_sitelib}/%{name}/ui/web/gen_gettext.py" "%{buildroot}%{python_sitelib}/%{name}/ui/Win32IconImagePlugin.py" ; do
186 sed '/\/usr\/bin/d' $lib > $lib.new &&
187 touch -r $lib $lib.new &&
188 mv $lib.new $lib
189done
190
191#Removing unneeded .order files.
192rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/.order
193rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/add/.order
194rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/data/.order
195rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/.build
196rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/.build_data
197
198%clean
199rm -rf %{buildroot}
200
201
202%files
203
204%files common -f %{name}.lang
205%doc ChangeLog LICENSE README
206%{python_sitelib}/%{name}-%{version}-py?.?.egg-info/
207
208%dir %{python_sitelib}/%{name}
209%{python_sitelib}/%{name}/*.py*
210%{python_sitelib}/%{name}/plugins
211%{python_sitelib}/%{name}/core
212
213%dir %{python_sitelib}/%{name}/ui
214%{python_sitelib}/%{name}/ui/*.py*
215
216# includes %%name.pot too
217%dir %{python_sitelib}/%{name}/i18n
218%dir %{python_sitelib}/%{name}/i18n/*
219%dir %{python_sitelib}/%{name}/i18n/*/LC_MESSAGES
220
221%files images
222# only pixmaps dir is in data so I own it all
223%{python_sitelib}/%{name}/data
224# if someone decides to only install images
225%dir %{python_sitelib}/%{name}
226%{_datadir}/icons/hicolor/*/apps/%{name}.*
227%{_datadir}/pixmaps/%{name}.*
228
229%files gtk
230%{_bindir}/%{name}
231%{_bindir}/%{name}-gtk
232%{_datadir}/applications/vine-%{name}.desktop
233%{python_sitelib}/%{name}/ui/gtkui
234%{_mandir}/man?/%{name}-gtk*
235%{_mandir}/man?/%{name}.1*
236
237%files console
238%{_bindir}/%{name}-console
239%{python_sitelib}/%{name}/ui/console
240%{_mandir}/man?/%{name}-console*
241
242%files web
243%{_bindir}/%{name}-web
244%{python_sitelib}/%{name}/ui/web
245%{_mandir}/man?/%{name}-web*
246
247%files daemon
248%{_bindir}/%{name}d
249%{_initddir}/%{name}-daemon
250%attr(-,%{name}, %{name})/var/lib/%{name}/
251%{_mandir}/man?/%{name}d*
252
253%pre daemon
254getent group %{name} >/dev/null || groupadd -r %{name}
255getent passwd %{name} >/dev/null || \
256useradd -r -g %{name} -d /var/lib/%{name} -s /sbin/nologin \
257        -c "deluge daemon account" %{name}
258exit 0
259
260
261%post daemon
262/sbin/chkconfig --add %{name}-daemon
263
264%post gtk
265update-desktop-database &> /dev/null || :
266
267%post images
268touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
269
270%preun daemon
271if [ $1 = 0 ] ; then
272    /sbin/service %{name}-daemon stop >/dev/null 2>&1
273    /sbin/chkconfig --del %{name}-daemon
274fi
275
276%postun daemon
277if [ "$1" -ge "1" ] ; then
278    /sbin/service %{name}-daemon condrestart >/dev/null 2>&1 || :
279fi
280
281%postun gtk
282update-desktop-database &> /dev/null || :
283
284%postun images
285if [ $1 -eq 0 ] ; then
286    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
287    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
288fi
289
290%posttrans images
291gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
292
293
294%changelog
295* Wed Feb 27 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.6-1
296- new upstream release
297
298* Wed May 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.5-1
299- new upstream release
300
301* Tue Mar 06 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.4-1
302- new upstream release
303
304* Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.3-2
305- rebuilt with python-2.7
306
307* Wed Sep 21 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.3-1
308- new upstream release
309- splitted -common, -gtk, -images, -console, -web, -daemon packages
310  - imported source1 from Fedora develoment
311- changed source archive
312- added BuildRequires: intltool
313
314* Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.1-1
315- new upstream release
316- added patch10 to work around building problem
317  - disabled svn access
318
319* Sun Sep 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
320- new upstream release
321
322* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.3-1
323- new upstream release
324
325* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
326- new upstream release
327- added Requires: python-mako, notify-python, gnome-python
328- removed Requires: /bin/sh, dbus-python, dbus-x11
329- changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
330- applied new naming policy to spec
331
332* Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
333- rebuilt with python-2.6.4
334
335* Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
336- new upstream release
337- added Patch1 from Debian to disable update
338- added Requires: python-twisted, python-simplejson
339
340* Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
341- initial build for VineSeed
342
343* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
344- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
345
346* Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
347- Fixed rb_libtorrent-python dependency, so as not to use the
348  %%min_rblibtorrent_ver macro any more (#510264).
349
350* Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
351- Update to new upstream bug-fix release (1.1.9).
352- Do not hard-code minimum rb_libtorrent version. (We're only building against
353  the system rb_libtorrent for Fedora 11+, which already has the necessary
354  version.)
355
356* Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
357- Update to new upstream release (1.1.8) for bug-fixes and some translation
358  updates. Adds dependency on chardet for fixing lots of bugs with torrents
359  which are not encoded as UTF-8.
360- Add back the flags, in an optional -flags subpackage as per the new Flags
361  policy (Package_Maintainers_Flags_Policy on the wiki).
362- Add LICENSE and README to installed documentation.
363
364* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
365- Rebuild for the Boost 1.39.0 update.
366
367* Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
368- Update to new upstream bug-fix release (1.1.7).
369
370* Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
371- Update to new upstream bug-fix release (1.1.6)
372- Fix GPL version, add OpenSSL exception to License.
373- Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
374  necessary when building the in-tarball libtorrent copy).
375
376* Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
377- Update to new upstream bug-fix release (1.1.5)
378- Remove FIXME comment about parallel-compilation. We're not building the
379  in-tarball libtorrent copy anymore, so no compilation (other than the python
380  bytecode) happens and we no longer need to worry about this.
381
382* Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
383- Fix the installed location of the scalable (SVG) icon (#483443).
384  + scalable-icon-dir.diff
385
386* Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
387- Update to new upstream bug-fix release (1.1.4)
388
389* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
390- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
391
392* Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
393- Update to new upstream bug-fix release (1.1.3)
394
395* Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
396- Fix scalable icon directory ownership (#483443).
397
398* Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
399- Update to new upstream bug-fix release (1.1.2)
400
401* Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
402- Update to new upstream bug-fix release (1.1.1)
403
404* Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
405- Update to new upstream release (1.1.0 Final - yay!)
406- Drop the get_tracker_host patch (fixed upstream):
407  - fix-get_tracker-host-if-no-tracker.patch
408 
409* Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
410- Do not package the country flags data.
411- Resolves: #479265 (country flags should not be used in Deluge)
412
413* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
414- Add patch from upstream SVN to fix an error where torrents are not shown (or
415  possibly shown in "Error" states) due to a bad inet_aton call:
416  + fix-get_tracker-host-if-no-tracker.patch
417- Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
418  the bug report.
419- Fix day of previous %%changelog entry.
420
421* Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
422- Update to new upstream release candidate (1.1.0 RC3)
423- Build against the system rb_libtorrent instead of using the in-tarball copy
424  (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
425  the hacked setup.py script formerly used to enable this (fixed upstream):
426  - fixed-setup.py
427- Make it a noarch package now that it's just python scripts and related
428  data files (translations, images, etc.)
429
430* Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
431- Update to new upstream release candidate (1.1.0 RC2)
432
433* Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
434- Rebuild for new boost.
435
436* Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
437- Update to new upstream bug-fix release (1.0.7)
438- Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
439
440* Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
441- Update to new upstream release (1.0.6)
442- Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
443- Properly mark translation files with %%lang.
444
445* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
446- Fix locations for Python 2.6
447
448* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
449- Rebuild for Python 2.6
450
451* Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
452- Update to new upstream release (1.0.5)
453
454* Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
455- Update to new upstream release (1.0.4).
456
457* Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
458- Update to new upstream release (1.0.3)
459
460* Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
461- Update to new upstream release (1.0.2)
462- Drop multithreaded boost compilation patch (fixed upstream, again).
463  - mt-boost-fix.patch
464 
465* Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
466- Update to new upstream release (1.0.0 Final)
467- Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
468  libraries once more:
469  + mt-boost-fix.patch
470- Resolves: #464151 (About 1.0.0 build failure)
471
472* Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
473- Update to new upstream release candidate (1.0.0 RC9)
474- Drop mt-boost patch (fixed upstream):
475  - use-mt-boost.patch
476
477* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
478- Update to new upstream release candidate (1.0.0 RC8)
479- Drop state_upgrade script from the documentation. (This is now handled
480  automatically.)
481- Fix version in previous %%changelog entry.
482
483* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
484- Update to new upstream release candidate (1.0.0 RC7)
485- Drop desktop file icon name hack (fixed upstream).
486
487* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
488- Update to new upstream release candidate (1.0.0 RC6)
489- Drop desktop file icon name hack (fixed upstream).
490
491* Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
492- Update to new upstream release candidate (1.0.0 RC4)
493
494* Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
495- Add setuptools runtime dependency, to fix "No module named pkg_resources"
496  error messages.
497
498* Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
499- Update to new upstream release candidate (1.0.0 RC3)
500- Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
501  complete.)
502
503* Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
504- Update to new upstream release candidate (1.0.0 RC2)
505- Force building against the multithreaded Boost libs.
506  + use-mt-boost.patch
507- Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
508  is just clutter.)
509- Remove the blocklist plugin, at upstream's recommendation.
510
511* Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
512- Update to new upstream release (0.5.9.3)
513
514* Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
515- Update to new upstream release (0.5.9.1)
516
517* Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
518- Update to new upstream release (0.5.9.0)
519- Drop upstreamed default-preferences patch for disabling new version
520  notifications:
521  - default-prefs-no-release-notifications.patch
522
523* Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
524- Update to new upstream release (0.5.8.9)
525
526* Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
527- Update to new upstream release (0.5.8.7)
528
529* Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
530- Update to new upstream release (0.5.8.6)
531
532* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
533- Update to new upstream release (0.5.8.5)
534
535* Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
536- Update to new upstream release (0.5.8.4)
537- Rebuild for GCC 4.3
538
539* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
540- Update to new upstream security fix release (0.5.8.3), which includes a fix
541  for a potential remotely-exploitable stack overflow with a malformed
542  bencoded message.
543
544* Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
545- Update to new upstream bugfix release (0.5.8.1)
546
547* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
548- Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
549  428106 (Missing BR dbus-x11).
550- Bump release to 3 to maintain a proper F8->F9+ upgrade path.
551
552* Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
553- Update to new upstream release (0.5.8)
554- Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
555  patch.
556 
557* Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
558- Update to new upstream release candidate (0.5.8 RC2)
559
560* Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
561- Update to new upstream release candidate (0.5.8 RC1)
562- Completely suppress updates notification (bug 299601, 426642)
563
564* Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
565- Add missing icon cache %%post and %%postun scriptlets.
566- Add missing egg-info to the %%files list.
567
568* Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
569- Update to new upstream bug-fix release (0.5.7.1).
570- Sort %%files list (aesthetic-only change).
571
572* Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
573- Fix previous %%changelog Version.
574- Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
575  in rawhide  bad .desktop file.)
576
577* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
578- Rebuild for deps
579
580* Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
581- Update to new upstream release (0.5.7)
582
583* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
584- Update to new upstream release candidate (0.5.7 RC2)
585- Drop plugin error patch (fixed upstream):
586  - plugin-not-found-OK.patch
587
588* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
589- Update to new upstream release candidate (0.5.7 RC)
590- Update Source0 url
591- Add upstream patch to prevent dying if plugin in prefs.state is not found on
592  the filesystem:
593  + plugin-not-found-OK.patch
594
595* Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
596- Update to new upstream bug-fix release (0.5.6.2)
597
598* Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
599- Update to new upstream bug-fix release (0.5.6.1)
600- Drop use-mt-boost build script patch (fixed upstream):
601  - use-mt-boost.patch
602
603* Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
604- Update to new upstream release (0.5.6)
605
606* Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
607- Update to new upstream release candidate (0.5.6 RC1)
608
609* Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
610- Fix release on previous %%changelog entry.
611- Disable the version update notifications by default:
612  + default-prefs-no-release-notifications.patch
613  (Resolves bug 299601: Deluge alerts of new versions)
614
615* Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
616- Update to new upstream release (0.5.5)
617
618* Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
619- Update to new upstream release candidate (0.5.5 RC1)
620
621* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
622- Update to new upstream release (0.5.4.1)
623- Build with new binutils to gain BuildID debugging goodness.
624
625* Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
626- Update to new upstream release (0.5.4)
627
628* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
629- Update License tag (GPLv2+).
630- Rebuild against new Boost libraries, adding a patch to build against the
631  multi-threaded ("*-mt") libraries:
632  + use-mt-boost.patch
633
634* Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
635- Update to new upstream release candidate (0.5.3)
636- Drop %%ifarch invocations for 64-bit builds. The internal setup script now
637  properly determines this and adds the AMD64 compiler definition if necessary.
638
639* Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
640- Update to new upstream release candidate (0.5.3 RC1)
641- Drop stale persistence fix patch (applied upstream):
642  - fix-persistence-upgrade-rhbz_247927.patch
643
644* Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
645- Add patch to fix the existence of stale persistence files by automatically
646  updating the deluge.deluge module name to deluge.core, or removing them if
647  empty (bug 247927):
648  + fix-persistence-upgrade-rhbz_247927.patch
649
650* Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
651- Update to new upstream release (0.5.2)
652- Update Summary and %%description to reflect new µTorrent-compatible Peer
653  Exchange ("PEX") functionality.
654
655* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
656- Update to new upstream release (0.5.1 Beta 2)
657
658* Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
659- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
660 
661* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
662- Update to new upstream release (0.5.0).
663
664* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
665- Update to new upstream release (0.5 RC2).
666- Drop IndexError exception-handling fix (applied upstream):
667  - delugegtk.py-fix-IndexError-exception-handling.patch
668- Use the system libtool instead of the one from the sources to ensure
669  that no unnecessary RPATH hacks are added to the final build.
670
671* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
672- Add a patch (submitted upstream) to properly catch a thrown IndexError in
673  state message updates. This should resolve the bug wherein the UI stops
674  updating its details and torrent listing.
675  + delugegtk.py-fix-IndexError-exception-handling.patch
676 
677* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
678- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
679  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
680  - 64bit-python_long patch
681  (This should fix the bug where, even though torrents are active, they are not
682  shown in the GtkTreeView listing.)
683
684* Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
685- Update to new upstream release (0.5 RC1).
686- Use rewritten setup.py instead of patching it so much, since it's easier to
687  maintain across version upgrades and whatnot:
688  + fixed-setup.py
689- Remove the setup.py patches (no longer needed, since I'm packaging my own):
690  - setup.py-dont-store-the-install-dir.patch
691  - setup.py-build-against-system-libtorrent.patch
692
693* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
694- Update to new upstream release (0.5 Beta 3).
695- Add patch to fix storing of installation directory:
696  + setup.py-dont-store-the-install-dir.patch
697    (to be applied after setup.py-build-against-system-libtorrent.patch)
698
699* Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
700- Add patch to fix 64-bit python_long type.
701  +  64bit-python_long.patch
702
703* Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
704- Update to new upstream release (0.5 Beta 2)
705- Add patch to force building against system copy of rb_libtorrent:
706  + setup.py-build-against-system-libtorrent.patch
707- Remove python-libtorrent and a few other dependencies that are no longer
708  used.
709
710* Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
711- Fix Source0 URL.
712
713* Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
714- Make notify-python dependency conditional (FC6+ only)
715- Strip the unneeded shebang lines from the plugin scripts, since they are not
716  meant to be directly executed.
717
718* Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
719- Update .desktop file: Icon should not have the "-256" size suffix.
720- Add Requires: notify-python
721- Remove strict dependency on python 2.3+, since we're targetting FC5+
722  only, which has 2.4+.
723
724* Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
725- Use install instead of the cp/find/chmod fiasco of earlier releases for
726  clarity and proper permissions setting.
727- Be more consistent about use of %%{name} and other macros in file naming as
728  well as whitespace between sections.
729
730* Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
731- Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
732  64-bit systems.
733
734* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
735- Initial packaging for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.