source: projects/specs/trunk/d/deluge/deluge-vl.spec @ 5784

Revision 5784, 26.9 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           deluge
4Version:        1.3.3
5Release:        2%{?_dist_release}
6Summary:        A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
7Summary(ja):    DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
8Group:          Applications/Internet
9License:        GPLv3 with exceptions
10URL:            http://deluge-torrent.org/
11
12Source0:        http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.lzma
13Source1:       deluge-daemon-init
14
15## The scalable icon needs to be installed to the proper place.
16Patch0:         %{name}-scalable-icon-dir.diff
17Patch1:         010_new_release_check.patch
18Patch10:       workaround_build.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildArch:      noarch
22
23BuildRequires:  desktop-file-utils
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26## The build script checks for the libtorrent module and skips compiling the
27## in-tarball one if this is found.
28BuildRequires:  libtorrent-rasterbar-python >= 0.14.9
29BuildRequires:  intltool
30
31## add Requires to make into Meta package
32Requires: %{name}-common = %{version}-%{release}
33Requires: %{name}-gtk = %{version}-%{release}
34Requires: %{name}-images = %{version}-%{release}
35Requires: %{name}-console = %{version}-%{release}
36Requires: %{name}-web = %{version}-%{release}
37Requires: %{name}-daemon = %{version}-%{release}
38
39# removal of flags
40Provides:         deluge-flags = %{version}-%{release}
41Obsoletes:        deluge-flags < 1.3.1-3
42
43%description
44Deluge is a new BitTorrent client, created using Python and GTK+. It is
45intended to bring a native, full-featured client to Linux GTK+ desktop
46environments such as GNOME and Xfce.
47
48%description -l ja
49Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
50GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
51クライアントを提供することを意図しています。
52
53
54%package common
55Summary:    Files common to Deluge sub packages
56Summary(ja): Deluge サブパッケージに共通するファイル
57Group:      Applications/Internet
58License:    GPLv3 with exceptions
59Requires:   python-setuptools
60Requires:   pyOpenSSL
61Requires:   python-chardet
62Requires:   python-simplejson
63Requires:   pyxdg
64Requires:   libtorrent-rasterbar-python >= 0.14.9
65Requires:   python-twisted
66
67%description common
68Common files needed by the Deluge bittorrent client sub packages
69
70%package gtk
71Summary:    The gtk UI to Deluge
72Summary(ja): Deluge の gtk ユーザーインターフェイス
73Group:      Applications/Internet
74License:    GPLv3 with exceptions
75Requires:   %{name}-common = %{version}-%{release}
76Requires:   %{name}-images = %{version}-%{release}
77Requires:   %{name}-daemon = %{version}-%{release}
78Requires:   gnome-python
79## Required for the proper ownership of icon dirs.
80Requires:   hicolor-icon-theme
81Requires:   notify-python
82Requires:   pygtk2-libglade
83
84%description gtk
85Deluge bittorent client GTK graphical user interface
86
87%package images
88Summary:    Image files for Deluge
89Summary(ja): Deluge の画像ファイル
90Group:      Applications/Internet
91License:    GPLv3 with exceptions
92
93%description images
94Data files used by the GTK and web user interface for Deluge bittorent client
95
96%package console
97Summary:    CLI to Deluge
98Summary(ja): Deluge のコマンドラインインターフェイス
99Group:      Applications/Internet
100License:    GPLv3 with exceptions
101Requires:   %{name}-common = %{version}-%{release}
102Requires:   %{name}-daemon = %{version}-%{release}
103
104%description console
105Deluge bittorent client command line interface
106
107%package web
108Summary:    Web interface to Deluge
109Summary(ja): Deluge の Web インターフェイス
110Group:      Applications/Internet
111License:    GPLv3 with exceptions
112Requires:   python-mako
113Requires:   %{name}-common = %{version}-%{release}
114Requires:   %{name}-images = %{version}-%{release}
115Requires:   %{name}-daemon = %{version}-%{release}
116
117%description web
118Deluge bittorent client web interface
119
120%package daemon
121Summary:    The Deluge daemon
122Summary(ja): Deluge デーモン
123Group:      Applications/Internet
124License:    GPLv3 with exceptions
125Requires:   %{name}-common = %{version}-%{release}
126Requires(pre): shadow-utils
127Requires(post): chkconfig
128Requires(preun): chkconfig
129Requires(preun): initscripts
130Requires(postun): initscripts
131
132%description daemon
133Files for the Deluge daemon
134
135
136%prep
137%setup -qn "%{name}-%{version}"
138%patch0 -p0 -b .fix-scalable-icon-dir
139%patch1 -p1
140#%patch10 -p1
141
142
143%build
144CFLAGS="%{optflags}" %{__python} setup.py build
145
146%install
147rm -rf %{buildroot}
148mkdir -p %{buildroot}%{_initddir}
149install -m755 %{SOURCE1} %{buildroot}%{_initddir}/%{name}-daemon
150mkdir -p %{buildroot}/var/lib/%{name}
151
152%{__python} setup.py install -O1 --skip-build --root %{buildroot}
153
154desktop-file-install --vendor vine                      \
155        --dir %{buildroot}%{_datadir}/applications      \
156        --copy-name-to-generic-name                     \
157        --add-mime-type=application/x-bittorrent        \
158        --delete-original                               \
159        --remove-category=Application                   \
160        %{buildroot}%{_datadir}/applications/%{name}.desktop
161
162## NOTE: The lang files should REEEAALLLY be in a standard place such as
163##       /usr/share/locale or similar. It'd make things so much nicer for
164##       the packaging. :O
165## A bit of sed magic to mark the translation files with %%lang, taken from
166## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
167## cannot (unfortunately) call find-lang directly since it's not on a
168## "$PREFIX/share/locale/"-ish directory tree.
169pushd %{buildroot}
170    find -type f -o -type l \
171        | sed '
172            s:%{buildroot}%{python_sitelib}::
173            s:^\.::
174            s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
175            s:^\([^%].*\)::
176            s:%lang(C) ::
177            /^$/d' \
178    > %{name}.lang
179
180## Now we move that list back to our sources, so that '%%files -f' can find it
181## properly.
182popd && mv %{buildroot}/%{name}.lang .
183
184#fix non exec script errors in two files
185for lib in "%{buildroot}%{python_sitelib}/%{name}/ui/web/gen_gettext.py" "%{buildroot}%{python_sitelib}/%{name}/ui/Win32IconImagePlugin.py" ; do
186 sed '/\/usr\/bin/d' $lib > $lib.new &&
187 touch -r $lib $lib.new &&
188 mv $lib.new $lib
189done
190
191#Removing unneeded .order files.
192rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/.order
193rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/add/.order
194rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/data/.order
195rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/.build
196rm -f %{buildroot}%{python_sitelib}/%{name}/ui/web/js/deluge-all/.build_data
197
198%clean
199rm -rf %{buildroot}
200
201
202%files
203
204%files common -f %{name}.lang
205%doc ChangeLog LICENSE README
206%{python_sitelib}/%{name}-%{version}-py?.?.egg-info/
207
208%dir %{python_sitelib}/%{name}
209%{python_sitelib}/%{name}/*.py*
210%{python_sitelib}/%{name}/plugins
211%{python_sitelib}/%{name}/core
212
213%dir %{python_sitelib}/%{name}/ui
214%{python_sitelib}/%{name}/ui/*.py*
215
216# includes %%name.pot too
217%dir %{python_sitelib}/%{name}/i18n
218%dir %{python_sitelib}/%{name}/i18n/*
219%dir %{python_sitelib}/%{name}/i18n/*/LC_MESSAGES
220
221%files images
222# only pixmaps dir is in data so I own it all
223%{python_sitelib}/%{name}/data
224# if someone decides to only install images
225%dir %{python_sitelib}/%{name}
226%{_datadir}/icons/hicolor/*/apps/%{name}.*
227%{_datadir}/pixmaps/%{name}.*
228
229%files gtk
230%{_bindir}/%{name}
231%{_bindir}/%{name}-gtk
232%{_datadir}/applications/vine-%{name}.desktop
233%{python_sitelib}/%{name}/ui/gtkui
234%{_mandir}/man?/%{name}-gtk*
235%{_mandir}/man?/%{name}.1*
236
237%files console
238%{_bindir}/%{name}-console
239%{python_sitelib}/%{name}/ui/console
240%{_mandir}/man?/%{name}-console*
241
242%files web
243%{_bindir}/%{name}-web
244%{python_sitelib}/%{name}/ui/web
245%{_mandir}/man?/%{name}-web*
246
247%files daemon
248%{_bindir}/%{name}d
249%{_initddir}/%{name}-daemon
250%attr(-,%{name}, %{name})/var/lib/%{name}/
251%{_mandir}/man?/%{name}d*
252
253%pre daemon
254getent group %{name} >/dev/null || groupadd -r %{name}
255getent passwd %{name} >/dev/null || \
256useradd -r -g %{name} -d /var/lib/%{name} -s /sbin/nologin \
257        -c "deluge daemon account" %{name}
258exit 0
259
260
261%post daemon
262/sbin/chkconfig --add %{name}-daemon
263
264%post gtk
265update-desktop-database &> /dev/null || :
266
267%post images
268touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
269
270%preun daemon
271if [ $1 = 0 ] ; then
272    /sbin/service %{name}-daemon stop >/dev/null 2>&1
273    /sbin/chkconfig --del %{name}-daemon
274fi
275
276%postun daemon
277if [ "$1" -ge "1" ] ; then
278    /sbin/service %{name}-daemon condrestart >/dev/null 2>&1 || :
279fi
280
281%postun gtk
282update-desktop-database &> /dev/null || :
283
284%postun images
285if [ $1 -eq 0 ] ; then
286    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
287    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
288fi
289
290%posttrans images
291gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
292
293
294%changelog
295* Tue Feb 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.3-2
296- rebuilt with python-2.7
297
298* Wed Sep 21 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.3-1
299- new upstream release
300- splitted -common, -gtk, -images, -console, -web, -daemon packages
301  - imported source1 from Fedora develoment
302- changed source archive
303- added BuildRequires: intltool
304
305* Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.1-1
306- new upstream release
307- added patch10 to work around building problem
308  - disabled svn access
309
310* Sun Sep 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
311- new upstream release
312
313* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.3-1
314- new upstream release
315
316* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
317- new upstream release
318- added Requires: python-mako, notify-python, gnome-python
319- removed Requires: /bin/sh, dbus-python, dbus-x11
320- changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
321- applied new naming policy to spec
322
323* Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
324- rebuilt with python-2.6.4
325
326* Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
327- new upstream release
328- added Patch1 from Debian to disable update
329- added Requires: python-twisted, python-simplejson
330
331* Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
332- initial build for VineSeed
333
334* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
335- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
336
337* Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
338- Fixed rb_libtorrent-python dependency, so as not to use the
339  %%min_rblibtorrent_ver macro any more (#510264).
340
341* Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
342- Update to new upstream bug-fix release (1.1.9).
343- Do not hard-code minimum rb_libtorrent version. (We're only building against
344  the system rb_libtorrent for Fedora 11+, which already has the necessary
345  version.)
346
347* Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
348- Update to new upstream release (1.1.8) for bug-fixes and some translation
349  updates. Adds dependency on chardet for fixing lots of bugs with torrents
350  which are not encoded as UTF-8.
351- Add back the flags, in an optional -flags subpackage as per the new Flags
352  policy (Package_Maintainers_Flags_Policy on the wiki).
353- Add LICENSE and README to installed documentation.
354
355* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
356- Rebuild for the Boost 1.39.0 update.
357
358* Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
359- Update to new upstream bug-fix release (1.1.7).
360
361* Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
362- Update to new upstream bug-fix release (1.1.6)
363- Fix GPL version, add OpenSSL exception to License.
364- Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
365  necessary when building the in-tarball libtorrent copy).
366
367* Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
368- Update to new upstream bug-fix release (1.1.5)
369- Remove FIXME comment about parallel-compilation. We're not building the
370  in-tarball libtorrent copy anymore, so no compilation (other than the python
371  bytecode) happens and we no longer need to worry about this.
372
373* Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
374- Fix the installed location of the scalable (SVG) icon (#483443).
375  + scalable-icon-dir.diff
376
377* Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
378- Update to new upstream bug-fix release (1.1.4)
379
380* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
381- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
382
383* Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
384- Update to new upstream bug-fix release (1.1.3)
385
386* Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
387- Fix scalable icon directory ownership (#483443).
388
389* Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
390- Update to new upstream bug-fix release (1.1.2)
391
392* Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
393- Update to new upstream bug-fix release (1.1.1)
394
395* Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
396- Update to new upstream release (1.1.0 Final - yay!)
397- Drop the get_tracker_host patch (fixed upstream):
398  - fix-get_tracker-host-if-no-tracker.patch
399 
400* Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
401- Do not package the country flags data.
402- Resolves: #479265 (country flags should not be used in Deluge)
403
404* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
405- Add patch from upstream SVN to fix an error where torrents are not shown (or
406  possibly shown in "Error" states) due to a bad inet_aton call:
407  + fix-get_tracker-host-if-no-tracker.patch
408- Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
409  the bug report.
410- Fix day of previous %%changelog entry.
411
412* Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
413- Update to new upstream release candidate (1.1.0 RC3)
414- Build against the system rb_libtorrent instead of using the in-tarball copy
415  (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
416  the hacked setup.py script formerly used to enable this (fixed upstream):
417  - fixed-setup.py
418- Make it a noarch package now that it's just python scripts and related
419  data files (translations, images, etc.)
420
421* Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
422- Update to new upstream release candidate (1.1.0 RC2)
423
424* Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
425- Rebuild for new boost.
426
427* Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
428- Update to new upstream bug-fix release (1.0.7)
429- Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
430
431* Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
432- Update to new upstream release (1.0.6)
433- Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
434- Properly mark translation files with %%lang.
435
436* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
437- Fix locations for Python 2.6
438
439* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
440- Rebuild for Python 2.6
441
442* Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
443- Update to new upstream release (1.0.5)
444
445* Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
446- Update to new upstream release (1.0.4).
447
448* Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
449- Update to new upstream release (1.0.3)
450
451* Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
452- Update to new upstream release (1.0.2)
453- Drop multithreaded boost compilation patch (fixed upstream, again).
454  - mt-boost-fix.patch
455 
456* Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
457- Update to new upstream release (1.0.0 Final)
458- Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
459  libraries once more:
460  + mt-boost-fix.patch
461- Resolves: #464151 (About 1.0.0 build failure)
462
463* Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
464- Update to new upstream release candidate (1.0.0 RC9)
465- Drop mt-boost patch (fixed upstream):
466  - use-mt-boost.patch
467
468* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
469- Update to new upstream release candidate (1.0.0 RC8)
470- Drop state_upgrade script from the documentation. (This is now handled
471  automatically.)
472- Fix version in previous %%changelog entry.
473
474* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
475- Update to new upstream release candidate (1.0.0 RC7)
476- Drop desktop file icon name hack (fixed upstream).
477
478* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
479- Update to new upstream release candidate (1.0.0 RC6)
480- Drop desktop file icon name hack (fixed upstream).
481
482* Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
483- Update to new upstream release candidate (1.0.0 RC4)
484
485* Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
486- Add setuptools runtime dependency, to fix "No module named pkg_resources"
487  error messages.
488
489* Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
490- Update to new upstream release candidate (1.0.0 RC3)
491- Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
492  complete.)
493
494* Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
495- Update to new upstream release candidate (1.0.0 RC2)
496- Force building against the multithreaded Boost libs.
497  + use-mt-boost.patch
498- Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
499  is just clutter.)
500- Remove the blocklist plugin, at upstream's recommendation.
501
502* Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
503- Update to new upstream release (0.5.9.3)
504
505* Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
506- Update to new upstream release (0.5.9.1)
507
508* Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
509- Update to new upstream release (0.5.9.0)
510- Drop upstreamed default-preferences patch for disabling new version
511  notifications:
512  - default-prefs-no-release-notifications.patch
513
514* Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
515- Update to new upstream release (0.5.8.9)
516
517* Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
518- Update to new upstream release (0.5.8.7)
519
520* Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
521- Update to new upstream release (0.5.8.6)
522
523* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
524- Update to new upstream release (0.5.8.5)
525
526* Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
527- Update to new upstream release (0.5.8.4)
528- Rebuild for GCC 4.3
529
530* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
531- Update to new upstream security fix release (0.5.8.3), which includes a fix
532  for a potential remotely-exploitable stack overflow with a malformed
533  bencoded message.
534
535* Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
536- Update to new upstream bugfix release (0.5.8.1)
537
538* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
539- Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
540  428106 (Missing BR dbus-x11).
541- Bump release to 3 to maintain a proper F8->F9+ upgrade path.
542
543* Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
544- Update to new upstream release (0.5.8)
545- Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
546  patch.
547 
548* Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
549- Update to new upstream release candidate (0.5.8 RC2)
550
551* Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
552- Update to new upstream release candidate (0.5.8 RC1)
553- Completely suppress updates notification (bug 299601, 426642)
554
555* Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
556- Add missing icon cache %%post and %%postun scriptlets.
557- Add missing egg-info to the %%files list.
558
559* Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
560- Update to new upstream bug-fix release (0.5.7.1).
561- Sort %%files list (aesthetic-only change).
562
563* Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
564- Fix previous %%changelog Version.
565- Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
566  in rawhide  bad .desktop file.)
567
568* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
569- Rebuild for deps
570
571* Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
572- Update to new upstream release (0.5.7)
573
574* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
575- Update to new upstream release candidate (0.5.7 RC2)
576- Drop plugin error patch (fixed upstream):
577  - plugin-not-found-OK.patch
578
579* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
580- Update to new upstream release candidate (0.5.7 RC)
581- Update Source0 url
582- Add upstream patch to prevent dying if plugin in prefs.state is not found on
583  the filesystem:
584  + plugin-not-found-OK.patch
585
586* Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
587- Update to new upstream bug-fix release (0.5.6.2)
588
589* Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
590- Update to new upstream bug-fix release (0.5.6.1)
591- Drop use-mt-boost build script patch (fixed upstream):
592  - use-mt-boost.patch
593
594* Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
595- Update to new upstream release (0.5.6)
596
597* Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
598- Update to new upstream release candidate (0.5.6 RC1)
599
600* Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
601- Fix release on previous %%changelog entry.
602- Disable the version update notifications by default:
603  + default-prefs-no-release-notifications.patch
604  (Resolves bug 299601: Deluge alerts of new versions)
605
606* Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
607- Update to new upstream release (0.5.5)
608
609* Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
610- Update to new upstream release candidate (0.5.5 RC1)
611
612* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
613- Update to new upstream release (0.5.4.1)
614- Build with new binutils to gain BuildID debugging goodness.
615
616* Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
617- Update to new upstream release (0.5.4)
618
619* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
620- Update License tag (GPLv2+).
621- Rebuild against new Boost libraries, adding a patch to build against the
622  multi-threaded ("*-mt") libraries:
623  + use-mt-boost.patch
624
625* Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
626- Update to new upstream release candidate (0.5.3)
627- Drop %%ifarch invocations for 64-bit builds. The internal setup script now
628  properly determines this and adds the AMD64 compiler definition if necessary.
629
630* Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
631- Update to new upstream release candidate (0.5.3 RC1)
632- Drop stale persistence fix patch (applied upstream):
633  - fix-persistence-upgrade-rhbz_247927.patch
634
635* Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
636- Add patch to fix the existence of stale persistence files by automatically
637  updating the deluge.deluge module name to deluge.core, or removing them if
638  empty (bug 247927):
639  + fix-persistence-upgrade-rhbz_247927.patch
640
641* Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
642- Update to new upstream release (0.5.2)
643- Update Summary and %%description to reflect new µTorrent-compatible Peer
644  Exchange ("PEX") functionality.
645
646* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
647- Update to new upstream release (0.5.1 Beta 2)
648
649* Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
650- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
651 
652* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
653- Update to new upstream release (0.5.0).
654
655* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
656- Update to new upstream release (0.5 RC2).
657- Drop IndexError exception-handling fix (applied upstream):
658  - delugegtk.py-fix-IndexError-exception-handling.patch
659- Use the system libtool instead of the one from the sources to ensure
660  that no unnecessary RPATH hacks are added to the final build.
661
662* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
663- Add a patch (submitted upstream) to properly catch a thrown IndexError in
664  state message updates. This should resolve the bug wherein the UI stops
665  updating its details and torrent listing.
666  + delugegtk.py-fix-IndexError-exception-handling.patch
667 
668* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
669- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
670  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
671  - 64bit-python_long patch
672  (This should fix the bug where, even though torrents are active, they are not
673  shown in the GtkTreeView listing.)
674
675* Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
676- Update to new upstream release (0.5 RC1).
677- Use rewritten setup.py instead of patching it so much, since it's easier to
678  maintain across version upgrades and whatnot:
679  + fixed-setup.py
680- Remove the setup.py patches (no longer needed, since I'm packaging my own):
681  - setup.py-dont-store-the-install-dir.patch
682  - setup.py-build-against-system-libtorrent.patch
683
684* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
685- Update to new upstream release (0.5 Beta 3).
686- Add patch to fix storing of installation directory:
687  + setup.py-dont-store-the-install-dir.patch
688    (to be applied after setup.py-build-against-system-libtorrent.patch)
689
690* Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
691- Add patch to fix 64-bit python_long type.
692  +  64bit-python_long.patch
693
694* Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
695- Update to new upstream release (0.5 Beta 2)
696- Add patch to force building against system copy of rb_libtorrent:
697  + setup.py-build-against-system-libtorrent.patch
698- Remove python-libtorrent and a few other dependencies that are no longer
699  used.
700
701* Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
702- Fix Source0 URL.
703
704* Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
705- Make notify-python dependency conditional (FC6+ only)
706- Strip the unneeded shebang lines from the plugin scripts, since they are not
707  meant to be directly executed.
708
709* Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
710- Update .desktop file: Icon should not have the "-256" size suffix.
711- Add Requires: notify-python
712- Remove strict dependency on python 2.3+, since we're targetting FC5+
713  only, which has 2.4+.
714
715* Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
716- Use install instead of the cp/find/chmod fiasco of earlier releases for
717  clarity and proper permissions setting.
718- Be more consistent about use of %%{name} and other macros in file naming as
719  well as whitespace between sections.
720
721* Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
722- Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
723  64-bit systems.
724
725* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
726- Initial packaging for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.