source: projects/specs/trunk/d/deluge/deluge-vl.spec @ 521

Revision 521, 22.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           deluge
5Version:        1.2.0
6Release:        2%{?_dist_release}
7Summary:        A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
8Summary(ja):    DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
9Group:          Applications/Internet
10License:        GPLv3 with exceptions
11URL:            http://deluge-torrent.org/           
12
13Source0:        http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.bz2
14
15## The scalable icon needs to be installed to the proper place.
16Patch0:         %{name}-scalable-icon-dir.diff
17Patch1:         010_new_release_check.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildArch:      noarch
21
22BuildRequires:  desktop-file-utils
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25## The build script checks for the libtorrent module and skips compiling the
26## in-tarball one if this is found.
27BuildRequires:  libtorrent-rasterbar-python
28
29Requires:       /bin/sh
30Requires:       dbus-python
31Requires:       dbus-x11
32## Required for the proper ownership of icon dirs.
33Requires:       hicolor-icon-theme
34Requires:       pygtk2-libglade
35Requires:       pyOpenSSL
36Requires:       python-chardet
37Requires:       python-setuptools
38Requires:       python-twisted
39Requires:       python-simplejson
40Requires:       pyxdg
41Requires:       libtorrent-rasterbar-python
42
43%description
44Deluge is a new BitTorrent client, created using Python and GTK+. It is
45intended to bring a native, full-featured client to Linux GTK+ desktop
46environments such as GNOME and Xfce.
47
48%description -l ja
49Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
50GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
51クライアントを提供することを意図しています。
52
53
54%package        flags
55Summary:        Country flags for peer location display in Deluge
56Group:          Applications/Internet
57License:        GPLv3
58Requires:       %{name} = %{version}-%{release}
59
60%description    flags
61The %{name}-flags package contains optional country flags which are used to
62display the location of peers in the "Peers" information tab.
63
64
65%prep
66%setup -qn "%{name}-%{version}"
67%patch0 -p0 -b .fix-scalable-icon-dir
68%patch1 -p1
69
70
71%build
72CFLAGS="%{optflags}" %{__python} setup.py build
73
74
75%install
76rm -rf %{buildroot}
77%{__python} setup.py install -O1 --skip-build --root %{buildroot}
78desktop-file-install --vendor vine                      \
79        --dir %{buildroot}%{_datadir}/applications      \
80        --copy-name-to-generic-name                     \
81        --add-mime-type=application/x-bittorrent        \
82        --delete-original                               \
83        --remove-category=Application                   \
84        %{buildroot}%{_datadir}/applications/%{name}.desktop
85
86## NOTE: The lang files should REEEAALLLY be in a standard place such as
87##       /usr/share/locale or similar. It'd make things so much nicer for
88##       the packaging. :O
89## A bit of sed magic to mark the translation files with %%lang, taken from
90## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
91## cannot (unfortunately) call find-lang directly since it's not on a
92## "$PREFIX/share/locale/"-ish directory tree.
93pushd %{buildroot}
94        find -type f -o -type l \
95                | sed '
96                        s:%{buildroot}%{python_sitelib}::
97                        s:^\.::
98                        s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
99                        s:^\([^%].*\)::
100                        s:%lang(C) ::
101                        /^$/d' \
102        > %{name}.filelist
103
104## We've got the .mo files now; but we need the rest of the files in those
105## dirs. We can't just glob in the %%files, as that would add duplicate
106## entries for the .mo files which we've already marked with appropriate
107## %%lang-fu.
108        find ./%{python_sitelib}/%{name} -not -iname '%{name}.mo' -type f \
109                | grep -v 'pixmaps/flags' | sed 's:^\./::' >> %{name}.filelist
110        find ./%{python_sitelib}/%{name} -type d  | grep -v 'pixmaps/flags' \
111                | sed 's:^\./:%%dir :' >> %{name}.filelist
112
113## Now we move that list back to our sources, so that '%%files -f' can find it
114## properly.
115popd && mv %{buildroot}/%{name}.filelist .
116
117
118%clean
119rm -rf %{buildroot}
120
121
122%files -f %{name}.filelist
123%defattr(-,root,root,-)
124%doc ChangeLog LICENSE README
125%{python_sitelib}/%{name}-%{version}-py?.?.egg-info/
126%{_bindir}/%{name}
127%{_bindir}/%{name}-*
128%{_bindir}/%{name}d
129%{_datadir}/applications/vine-%{name}.desktop
130%{_datadir}/pixmaps/%{name}.*
131%{_datadir}/icons/hicolor/*/apps/%{name}.*
132%{_mandir}/man?/%{name}*
133
134%files  flags
135%defattr(-,root,root,-)
136%doc LICENSE
137%{python_sitelib}/%{name}/data/pixmaps/flags/
138
139
140%post
141update-desktop-database &>/dev/null ||:
142touch --no-create %{_datadir}/icons/hicolor
143if [ -x %{_bindir}/gtk-update-icon-cache ]; then
144        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
145fi
146
147
148%postun
149update-desktop-database &> /dev/null ||:
150touch --no-create %{_datadir}/icons/hicolor
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
153fi
154
155
156%changelog
157* Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
158- rebuilt with python-2.6.4
159
160* Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
161- new upstream release
162- added Patch1 from Debian to disable update
163- added Requires: python-twisted, python-simplejson
164
165* Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
166- initial build for VineSeed
167
168* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
170
171* Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
172- Fixed rb_libtorrent-python dependency, so as not to use the
173  %%min_rblibtorrent_ver macro any more (#510264).
174
175* Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
176- Update to new upstream bug-fix release (1.1.9).
177- Do not hard-code minimum rb_libtorrent version. (We're only building against
178  the system rb_libtorrent for Fedora 11+, which already has the necessary
179  version.)
180
181* Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
182- Update to new upstream release (1.1.8) for bug-fixes and some translation
183  updates. Adds dependency on chardet for fixing lots of bugs with torrents
184  which are not encoded as UTF-8.
185- Add back the flags, in an optional -flags subpackage as per the new Flags
186  policy (Package_Maintainers_Flags_Policy on the wiki).
187- Add LICENSE and README to installed documentation.
188
189* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
190- Rebuild for the Boost 1.39.0 update.
191
192* Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
193- Update to new upstream bug-fix release (1.1.7).
194
195* Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
196- Update to new upstream bug-fix release (1.1.6)
197- Fix GPL version, add OpenSSL exception to License.
198- Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
199  necessary when building the in-tarball libtorrent copy).
200
201* Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
202- Update to new upstream bug-fix release (1.1.5)
203- Remove FIXME comment about parallel-compilation. We're not building the
204  in-tarball libtorrent copy anymore, so no compilation (other than the python
205  bytecode) happens and we no longer need to worry about this.
206
207* Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
208- Fix the installed location of the scalable (SVG) icon (#483443).
209  + scalable-icon-dir.diff
210
211* Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
212- Update to new upstream bug-fix release (1.1.4)
213
214* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
216
217* Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
218- Update to new upstream bug-fix release (1.1.3)
219
220* Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
221- Fix scalable icon directory ownership (#483443).
222
223* Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
224- Update to new upstream bug-fix release (1.1.2)
225
226* Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
227- Update to new upstream bug-fix release (1.1.1)
228
229* Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
230- Update to new upstream release (1.1.0 Final - yay!)
231- Drop the get_tracker_host patch (fixed upstream):
232  - fix-get_tracker-host-if-no-tracker.patch
233 
234* Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
235- Do not package the country flags data.
236- Resolves: #479265 (country flags should not be used in Deluge)
237
238* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
239- Add patch from upstream SVN to fix an error where torrents are not shown (or
240  possibly shown in "Error" states) due to a bad inet_aton call:
241  + fix-get_tracker-host-if-no-tracker.patch
242- Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
243  the bug report.
244- Fix day of previous %%changelog entry.
245
246* Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
247- Update to new upstream release candidate (1.1.0 RC3)
248- Build against the system rb_libtorrent instead of using the in-tarball copy
249  (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
250  the hacked setup.py script formerly used to enable this (fixed upstream):
251  - fixed-setup.py
252- Make it a noarch package now that it's just python scripts and related
253  data files (translations, images, etc.)
254
255* Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
256- Update to new upstream release candidate (1.1.0 RC2)
257
258* Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
259- Rebuild for new boost.
260
261* Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
262- Update to new upstream bug-fix release (1.0.7)
263- Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
264
265* Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
266- Update to new upstream release (1.0.6)
267- Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
268- Properly mark translation files with %%lang.
269
270* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
271- Fix locations for Python 2.6
272
273* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
274- Rebuild for Python 2.6
275
276* Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
277- Update to new upstream release (1.0.5)
278
279* Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
280- Update to new upstream release (1.0.4).
281
282* Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
283- Update to new upstream release (1.0.3)
284
285* Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
286- Update to new upstream release (1.0.2)
287- Drop multithreaded boost compilation patch (fixed upstream, again).
288  - mt-boost-fix.patch
289 
290* Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
291- Update to new upstream release (1.0.0 Final)
292- Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
293  libraries once more:
294  + mt-boost-fix.patch
295- Resolves: #464151 (About 1.0.0 build failure)
296
297* Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
298- Update to new upstream release candidate (1.0.0 RC9)
299- Drop mt-boost patch (fixed upstream):
300  - use-mt-boost.patch
301
302* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
303- Update to new upstream release candidate (1.0.0 RC8)
304- Drop state_upgrade script from the documentation. (This is now handled
305  automatically.)
306- Fix version in previous %%changelog entry.
307
308* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
309- Update to new upstream release candidate (1.0.0 RC7)
310- Drop desktop file icon name hack (fixed upstream).
311
312* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
313- Update to new upstream release candidate (1.0.0 RC6)
314- Drop desktop file icon name hack (fixed upstream).
315
316* Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
317- Update to new upstream release candidate (1.0.0 RC4)
318
319* Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
320- Add setuptools runtime dependency, to fix "No module named pkg_resources"
321  error messages.
322
323* Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
324- Update to new upstream release candidate (1.0.0 RC3)
325- Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
326  complete.)
327
328* Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
329- Update to new upstream release candidate (1.0.0 RC2)
330- Force building against the multithreaded Boost libs.
331  + use-mt-boost.patch
332- Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
333  is just clutter.)
334- Remove the blocklist plugin, at upstream's recommendation.
335
336* Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
337- Update to new upstream release (0.5.9.3)
338
339* Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
340- Update to new upstream release (0.5.9.1)
341
342* Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
343- Update to new upstream release (0.5.9.0)
344- Drop upstreamed default-preferences patch for disabling new version
345  notifications:
346  - default-prefs-no-release-notifications.patch
347
348* Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
349- Update to new upstream release (0.5.8.9)
350
351* Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
352- Update to new upstream release (0.5.8.7)
353
354* Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
355- Update to new upstream release (0.5.8.6)
356
357* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
358- Update to new upstream release (0.5.8.5)
359
360* Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
361- Update to new upstream release (0.5.8.4)
362- Rebuild for GCC 4.3
363
364* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
365- Update to new upstream security fix release (0.5.8.3), which includes a fix
366  for a potential remotely-exploitable stack overflow with a malformed
367  bencoded message.
368
369* Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
370- Update to new upstream bugfix release (0.5.8.1)
371
372* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
373- Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
374  428106 (Missing BR dbus-x11).
375- Bump release to 3 to maintain a proper F8->F9+ upgrade path.
376
377* Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
378- Update to new upstream release (0.5.8)
379- Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
380  patch.
381 
382* Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
383- Update to new upstream release candidate (0.5.8 RC2)
384
385* Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
386- Update to new upstream release candidate (0.5.8 RC1)
387- Completely suppress updates notification (bug 299601, 426642)
388
389* Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
390- Add missing icon cache %%post and %%postun scriptlets.
391- Add missing egg-info to the %%files list.
392
393* Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
394- Update to new upstream bug-fix release (0.5.7.1).
395- Sort %%files list (aesthetic-only change).
396
397* Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
398- Fix previous %%changelog Version.
399- Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
400  in rawhide  bad .desktop file.)
401
402* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
403- Rebuild for deps
404
405* Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
406- Update to new upstream release (0.5.7)
407
408* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
409- Update to new upstream release candidate (0.5.7 RC2)
410- Drop plugin error patch (fixed upstream):
411  - plugin-not-found-OK.patch
412
413* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
414- Update to new upstream release candidate (0.5.7 RC)
415- Update Source0 url
416- Add upstream patch to prevent dying if plugin in prefs.state is not found on
417  the filesystem:
418  + plugin-not-found-OK.patch
419
420* Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
421- Update to new upstream bug-fix release (0.5.6.2)
422
423* Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
424- Update to new upstream bug-fix release (0.5.6.1)
425- Drop use-mt-boost build script patch (fixed upstream):
426  - use-mt-boost.patch
427
428* Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
429- Update to new upstream release (0.5.6)
430
431* Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
432- Update to new upstream release candidate (0.5.6 RC1)
433
434* Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
435- Fix release on previous %%changelog entry.
436- Disable the version update notifications by default:
437  + default-prefs-no-release-notifications.patch
438  (Resolves bug 299601: Deluge alerts of new versions)
439
440* Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
441- Update to new upstream release (0.5.5)
442
443* Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
444- Update to new upstream release candidate (0.5.5 RC1)
445
446* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
447- Update to new upstream release (0.5.4.1)
448- Build with new binutils to gain BuildID debugging goodness.
449
450* Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
451- Update to new upstream release (0.5.4)
452
453* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
454- Update License tag (GPLv2+).
455- Rebuild against new Boost libraries, adding a patch to build against the
456  multi-threaded ("*-mt") libraries:
457  + use-mt-boost.patch
458
459* Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
460- Update to new upstream release candidate (0.5.3)
461- Drop %%ifarch invocations for 64-bit builds. The internal setup script now
462  properly determines this and adds the AMD64 compiler definition if necessary.
463
464* Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
465- Update to new upstream release candidate (0.5.3 RC1)
466- Drop stale persistence fix patch (applied upstream):
467  - fix-persistence-upgrade-rhbz_247927.patch
468
469* Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
470- Add patch to fix the existence of stale persistence files by automatically
471  updating the deluge.deluge module name to deluge.core, or removing them if
472  empty (bug 247927):
473  + fix-persistence-upgrade-rhbz_247927.patch
474
475* Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
476- Update to new upstream release (0.5.2)
477- Update Summary and %%description to reflect new µTorrent-compatible Peer
478  Exchange ("PEX") functionality.
479
480* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
481- Update to new upstream release (0.5.1 Beta 2)
482
483* Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
484- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
485 
486* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
487- Update to new upstream release (0.5.0).
488
489* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
490- Update to new upstream release (0.5 RC2).
491- Drop IndexError exception-handling fix (applied upstream):
492  - delugegtk.py-fix-IndexError-exception-handling.patch
493- Use the system libtool instead of the one from the sources to ensure
494  that no unnecessary RPATH hacks are added to the final build.
495
496* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
497- Add a patch (submitted upstream) to properly catch a thrown IndexError in
498  state message updates. This should resolve the bug wherein the UI stops
499  updating its details and torrent listing.
500  + delugegtk.py-fix-IndexError-exception-handling.patch
501 
502* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
503- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
504  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
505  - 64bit-python_long patch
506  (This should fix the bug where, even though torrents are active, they are not
507  shown in the GtkTreeView listing.)
508
509* Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
510- Update to new upstream release (0.5 RC1).
511- Use rewritten setup.py instead of patching it so much, since it's easier to
512  maintain across version upgrades and whatnot:
513  + fixed-setup.py
514- Remove the setup.py patches (no longer needed, since I'm packaging my own):
515  - setup.py-dont-store-the-install-dir.patch
516  - setup.py-build-against-system-libtorrent.patch
517
518* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
519- Update to new upstream release (0.5 Beta 3).
520- Add patch to fix storing of installation directory:
521  + setup.py-dont-store-the-install-dir.patch
522    (to be applied after setup.py-build-against-system-libtorrent.patch)
523
524* Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
525- Add patch to fix 64-bit python_long type.
526  +  64bit-python_long.patch
527
528* Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
529- Update to new upstream release (0.5 Beta 2)
530- Add patch to force building against system copy of rb_libtorrent:
531  + setup.py-build-against-system-libtorrent.patch
532- Remove python-libtorrent and a few other dependencies that are no longer
533  used.
534
535* Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
536- Fix Source0 URL.
537
538* Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
539- Make notify-python dependency conditional (FC6+ only)
540- Strip the unneeded shebang lines from the plugin scripts, since they are not
541  meant to be directly executed.
542
543* Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
544- Update .desktop file: Icon should not have the "-256" size suffix.
545- Add Requires: notify-python
546- Remove strict dependency on python 2.3+, since we're targetting FC5+
547  only, which has 2.4+.
548
549* Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
550- Use install instead of the cp/find/chmod fiasco of earlier releases for
551  clarity and proper permissions setting.
552- Be more consistent about use of %%{name} and other macros in file naming as
553  well as whitespace between sections.
554
555* Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
556- Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
557  64-bit systems.
558
559* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
560- Initial packaging for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.