source: projects/specs/trunk/d/deluge/deluge-vl.spec @ 607

Revision 607, 22.4 KB checked in by kudoh, 14 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           deluge
5Version:        1.2.1
6Release:        1%{?_dist_release}
7Summary:        A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
8Summary(ja):    DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
9Group:          Applications/Internet
10License:        GPLv3 with exceptions
11URL:            http://deluge-torrent.org/           
12
13Source0:        http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.bz2
14
15## The scalable icon needs to be installed to the proper place.
16Patch0:         %{name}-scalable-icon-dir.diff
17Patch1:         010_new_release_check.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildArch:      noarch
21
22BuildRequires:  desktop-file-utils
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25## The build script checks for the libtorrent module and skips compiling the
26## in-tarball one if this is found.
27BuildRequires:  libtorrent-rasterbar-python >= 0.14.9
28
29Requires:       gnome-python
30## Required for the proper ownership of icon dirs.
31Requires:       hicolor-icon-theme
32Requires:       notify-python
33Requires:       pygtk2-libglade
34Requires:       pyOpenSSL
35Requires:       python-chardet
36Requires:       python-mako
37Requires:       python-setuptools
38Requires:       python-simplejson
39Requires:       python-twisted
40Requires:       pyxdg
41Requires:       libtorrent-rasterbar-python >= 0.14.9
42
43%description
44Deluge is a new BitTorrent client, created using Python and GTK+. It is
45intended to bring a native, full-featured client to Linux GTK+ desktop
46environments such as GNOME and Xfce.
47
48%description -l ja
49Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
50GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
51クライアントを提供することを意図しています。
52
53
54%package        flags
55Summary:        Country flags for peer location display in Deluge
56Group:          Applications/Internet
57License:        GPLv3
58Requires:       %{name} = %{version}-%{release}
59
60%description    flags
61The %{name}-flags package contains optional country flags which are used to
62display the location of peers in the "Peers" information tab.
63
64
65%prep
66%setup -qn "%{name}-%{version}"
67%patch0 -p0 -b .fix-scalable-icon-dir
68%patch1 -p1
69
70
71%build
72CFLAGS="%{optflags}" %{__python} setup.py build
73
74
75%install
76rm -rf %{buildroot}
77%{__python} setup.py install -O1 --skip-build --root %{buildroot}
78desktop-file-install --vendor vine                      \
79        --dir %{buildroot}%{_datadir}/applications      \
80        --copy-name-to-generic-name                     \
81        --add-mime-type=application/x-bittorrent        \
82        --delete-original                               \
83        --remove-category=Application                   \
84        %{buildroot}%{_datadir}/applications/%{name}.desktop
85
86## NOTE: The lang files should REEEAALLLY be in a standard place such as
87##       /usr/share/locale or similar. It'd make things so much nicer for
88##       the packaging. :O
89## A bit of sed magic to mark the translation files with %%lang, taken from
90## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
91## cannot (unfortunately) call find-lang directly since it's not on a
92## "$PREFIX/share/locale/"-ish directory tree.
93pushd %{buildroot}
94        find -type f -o -type l \
95                | sed '
96                        s:%{buildroot}%{python_sitelib}::
97                        s:^\.::
98                        s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
99                        s:^\([^%].*\)::
100                        s:%lang(C) ::
101                        /^$/d' \
102        > %{name}.filelist
103
104## We've got the .mo files now; but we need the rest of the files in those
105## dirs. We can't just glob in the %%files, as that would add duplicate
106## entries for the .mo files which we've already marked with appropriate
107## %%lang-fu.
108        find ./%{python_sitelib}/%{name} -not -iname '%{name}.mo' -type f \
109                | grep -v 'pixmaps/flags' | sed 's:^\./::' >> %{name}.filelist
110        find ./%{python_sitelib}/%{name} -type d  | grep -v 'pixmaps/flags' \
111                | sed 's:^\./:%%dir :' >> %{name}.filelist
112
113## Now we move that list back to our sources, so that '%%files -f' can find it
114## properly.
115popd && mv %{buildroot}/%{name}.filelist .
116
117
118%clean
119rm -rf %{buildroot}
120
121
122%files -f %{name}.filelist
123%defattr(-,root,root,-)
124%doc ChangeLog LICENSE README
125%{python_sitelib}/%{name}-%{version}-py?.?.egg-info/
126%{_bindir}/%{name}
127%{_bindir}/%{name}-*
128%{_bindir}/%{name}d
129%{_datadir}/applications/vine-%{name}.desktop
130%{_datadir}/pixmaps/%{name}.*
131%{_datadir}/icons/hicolor/*/apps/%{name}.*
132%{_mandir}/man?/%{name}*
133
134%files  flags
135%defattr(-,root,root,-)
136%doc LICENSE
137%{python_sitelib}/%{name}/data/pixmaps/flags/
138
139
140%post
141update-desktop-database &>/dev/null ||:
142touch --no-create %{_datadir}/icons/hicolor
143if [ -x %{_bindir}/gtk-update-icon-cache ]; then
144        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
145fi
146
147
148%postun
149update-desktop-database &> /dev/null ||:
150touch --no-create %{_datadir}/icons/hicolor
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
153fi
154
155
156%changelog
157* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
158- new upstream release
159- added Requires: python-mako, notify-python, gnome-python
160- removed Requires: /bin/sh, dbus-python, dbus-x11
161- changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
162- applied new naming policy to spec
163
164* Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
165- rebuilt with python-2.6.4
166
167* Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
168- new upstream release
169- added Patch1 from Debian to disable update
170- added Requires: python-twisted, python-simplejson
171
172* Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
173- initial build for VineSeed
174
175* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
177
178* Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
179- Fixed rb_libtorrent-python dependency, so as not to use the
180  %%min_rblibtorrent_ver macro any more (#510264).
181
182* Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
183- Update to new upstream bug-fix release (1.1.9).
184- Do not hard-code minimum rb_libtorrent version. (We're only building against
185  the system rb_libtorrent for Fedora 11+, which already has the necessary
186  version.)
187
188* Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
189- Update to new upstream release (1.1.8) for bug-fixes and some translation
190  updates. Adds dependency on chardet for fixing lots of bugs with torrents
191  which are not encoded as UTF-8.
192- Add back the flags, in an optional -flags subpackage as per the new Flags
193  policy (Package_Maintainers_Flags_Policy on the wiki).
194- Add LICENSE and README to installed documentation.
195
196* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
197- Rebuild for the Boost 1.39.0 update.
198
199* Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
200- Update to new upstream bug-fix release (1.1.7).
201
202* Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
203- Update to new upstream bug-fix release (1.1.6)
204- Fix GPL version, add OpenSSL exception to License.
205- Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
206  necessary when building the in-tarball libtorrent copy).
207
208* Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
209- Update to new upstream bug-fix release (1.1.5)
210- Remove FIXME comment about parallel-compilation. We're not building the
211  in-tarball libtorrent copy anymore, so no compilation (other than the python
212  bytecode) happens and we no longer need to worry about this.
213
214* Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
215- Fix the installed location of the scalable (SVG) icon (#483443).
216  + scalable-icon-dir.diff
217
218* Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
219- Update to new upstream bug-fix release (1.1.4)
220
221* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
223
224* Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
225- Update to new upstream bug-fix release (1.1.3)
226
227* Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
228- Fix scalable icon directory ownership (#483443).
229
230* Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
231- Update to new upstream bug-fix release (1.1.2)
232
233* Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
234- Update to new upstream bug-fix release (1.1.1)
235
236* Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
237- Update to new upstream release (1.1.0 Final - yay!)
238- Drop the get_tracker_host patch (fixed upstream):
239  - fix-get_tracker-host-if-no-tracker.patch
240 
241* Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
242- Do not package the country flags data.
243- Resolves: #479265 (country flags should not be used in Deluge)
244
245* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
246- Add patch from upstream SVN to fix an error where torrents are not shown (or
247  possibly shown in "Error" states) due to a bad inet_aton call:
248  + fix-get_tracker-host-if-no-tracker.patch
249- Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
250  the bug report.
251- Fix day of previous %%changelog entry.
252
253* Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
254- Update to new upstream release candidate (1.1.0 RC3)
255- Build against the system rb_libtorrent instead of using the in-tarball copy
256  (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
257  the hacked setup.py script formerly used to enable this (fixed upstream):
258  - fixed-setup.py
259- Make it a noarch package now that it's just python scripts and related
260  data files (translations, images, etc.)
261
262* Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
263- Update to new upstream release candidate (1.1.0 RC2)
264
265* Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
266- Rebuild for new boost.
267
268* Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
269- Update to new upstream bug-fix release (1.0.7)
270- Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
271
272* Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
273- Update to new upstream release (1.0.6)
274- Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
275- Properly mark translation files with %%lang.
276
277* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
278- Fix locations for Python 2.6
279
280* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
281- Rebuild for Python 2.6
282
283* Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
284- Update to new upstream release (1.0.5)
285
286* Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
287- Update to new upstream release (1.0.4).
288
289* Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
290- Update to new upstream release (1.0.3)
291
292* Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
293- Update to new upstream release (1.0.2)
294- Drop multithreaded boost compilation patch (fixed upstream, again).
295  - mt-boost-fix.patch
296 
297* Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
298- Update to new upstream release (1.0.0 Final)
299- Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
300  libraries once more:
301  + mt-boost-fix.patch
302- Resolves: #464151 (About 1.0.0 build failure)
303
304* Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
305- Update to new upstream release candidate (1.0.0 RC9)
306- Drop mt-boost patch (fixed upstream):
307  - use-mt-boost.patch
308
309* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
310- Update to new upstream release candidate (1.0.0 RC8)
311- Drop state_upgrade script from the documentation. (This is now handled
312  automatically.)
313- Fix version in previous %%changelog entry.
314
315* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
316- Update to new upstream release candidate (1.0.0 RC7)
317- Drop desktop file icon name hack (fixed upstream).
318
319* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
320- Update to new upstream release candidate (1.0.0 RC6)
321- Drop desktop file icon name hack (fixed upstream).
322
323* Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
324- Update to new upstream release candidate (1.0.0 RC4)
325
326* Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
327- Add setuptools runtime dependency, to fix "No module named pkg_resources"
328  error messages.
329
330* Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
331- Update to new upstream release candidate (1.0.0 RC3)
332- Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
333  complete.)
334
335* Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
336- Update to new upstream release candidate (1.0.0 RC2)
337- Force building against the multithreaded Boost libs.
338  + use-mt-boost.patch
339- Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
340  is just clutter.)
341- Remove the blocklist plugin, at upstream's recommendation.
342
343* Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
344- Update to new upstream release (0.5.9.3)
345
346* Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
347- Update to new upstream release (0.5.9.1)
348
349* Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
350- Update to new upstream release (0.5.9.0)
351- Drop upstreamed default-preferences patch for disabling new version
352  notifications:
353  - default-prefs-no-release-notifications.patch
354
355* Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
356- Update to new upstream release (0.5.8.9)
357
358* Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
359- Update to new upstream release (0.5.8.7)
360
361* Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
362- Update to new upstream release (0.5.8.6)
363
364* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
365- Update to new upstream release (0.5.8.5)
366
367* Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
368- Update to new upstream release (0.5.8.4)
369- Rebuild for GCC 4.3
370
371* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
372- Update to new upstream security fix release (0.5.8.3), which includes a fix
373  for a potential remotely-exploitable stack overflow with a malformed
374  bencoded message.
375
376* Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
377- Update to new upstream bugfix release (0.5.8.1)
378
379* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
380- Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
381  428106 (Missing BR dbus-x11).
382- Bump release to 3 to maintain a proper F8->F9+ upgrade path.
383
384* Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
385- Update to new upstream release (0.5.8)
386- Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
387  patch.
388 
389* Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
390- Update to new upstream release candidate (0.5.8 RC2)
391
392* Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
393- Update to new upstream release candidate (0.5.8 RC1)
394- Completely suppress updates notification (bug 299601, 426642)
395
396* Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
397- Add missing icon cache %%post and %%postun scriptlets.
398- Add missing egg-info to the %%files list.
399
400* Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
401- Update to new upstream bug-fix release (0.5.7.1).
402- Sort %%files list (aesthetic-only change).
403
404* Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
405- Fix previous %%changelog Version.
406- Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
407  in rawhide  bad .desktop file.)
408
409* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
410- Rebuild for deps
411
412* Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
413- Update to new upstream release (0.5.7)
414
415* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
416- Update to new upstream release candidate (0.5.7 RC2)
417- Drop plugin error patch (fixed upstream):
418  - plugin-not-found-OK.patch
419
420* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
421- Update to new upstream release candidate (0.5.7 RC)
422- Update Source0 url
423- Add upstream patch to prevent dying if plugin in prefs.state is not found on
424  the filesystem:
425  + plugin-not-found-OK.patch
426
427* Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
428- Update to new upstream bug-fix release (0.5.6.2)
429
430* Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
431- Update to new upstream bug-fix release (0.5.6.1)
432- Drop use-mt-boost build script patch (fixed upstream):
433  - use-mt-boost.patch
434
435* Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
436- Update to new upstream release (0.5.6)
437
438* Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
439- Update to new upstream release candidate (0.5.6 RC1)
440
441* Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
442- Fix release on previous %%changelog entry.
443- Disable the version update notifications by default:
444  + default-prefs-no-release-notifications.patch
445  (Resolves bug 299601: Deluge alerts of new versions)
446
447* Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
448- Update to new upstream release (0.5.5)
449
450* Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
451- Update to new upstream release candidate (0.5.5 RC1)
452
453* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
454- Update to new upstream release (0.5.4.1)
455- Build with new binutils to gain BuildID debugging goodness.
456
457* Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
458- Update to new upstream release (0.5.4)
459
460* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
461- Update License tag (GPLv2+).
462- Rebuild against new Boost libraries, adding a patch to build against the
463  multi-threaded ("*-mt") libraries:
464  + use-mt-boost.patch
465
466* Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
467- Update to new upstream release candidate (0.5.3)
468- Drop %%ifarch invocations for 64-bit builds. The internal setup script now
469  properly determines this and adds the AMD64 compiler definition if necessary.
470
471* Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
472- Update to new upstream release candidate (0.5.3 RC1)
473- Drop stale persistence fix patch (applied upstream):
474  - fix-persistence-upgrade-rhbz_247927.patch
475
476* Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
477- Add patch to fix the existence of stale persistence files by automatically
478  updating the deluge.deluge module name to deluge.core, or removing them if
479  empty (bug 247927):
480  + fix-persistence-upgrade-rhbz_247927.patch
481
482* Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
483- Update to new upstream release (0.5.2)
484- Update Summary and %%description to reflect new µTorrent-compatible Peer
485  Exchange ("PEX") functionality.
486
487* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
488- Update to new upstream release (0.5.1 Beta 2)
489
490* Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
491- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
492 
493* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
494- Update to new upstream release (0.5.0).
495
496* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
497- Update to new upstream release (0.5 RC2).
498- Drop IndexError exception-handling fix (applied upstream):
499  - delugegtk.py-fix-IndexError-exception-handling.patch
500- Use the system libtool instead of the one from the sources to ensure
501  that no unnecessary RPATH hacks are added to the final build.
502
503* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
504- Add a patch (submitted upstream) to properly catch a thrown IndexError in
505  state message updates. This should resolve the bug wherein the UI stops
506  updating its details and torrent listing.
507  + delugegtk.py-fix-IndexError-exception-handling.patch
508 
509* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
510- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
511  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
512  - 64bit-python_long patch
513  (This should fix the bug where, even though torrents are active, they are not
514  shown in the GtkTreeView listing.)
515
516* Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
517- Update to new upstream release (0.5 RC1).
518- Use rewritten setup.py instead of patching it so much, since it's easier to
519  maintain across version upgrades and whatnot:
520  + fixed-setup.py
521- Remove the setup.py patches (no longer needed, since I'm packaging my own):
522  - setup.py-dont-store-the-install-dir.patch
523  - setup.py-build-against-system-libtorrent.patch
524
525* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
526- Update to new upstream release (0.5 Beta 3).
527- Add patch to fix storing of installation directory:
528  + setup.py-dont-store-the-install-dir.patch
529    (to be applied after setup.py-build-against-system-libtorrent.patch)
530
531* Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
532- Add patch to fix 64-bit python_long type.
533  +  64bit-python_long.patch
534
535* Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
536- Update to new upstream release (0.5 Beta 2)
537- Add patch to force building against system copy of rb_libtorrent:
538  + setup.py-build-against-system-libtorrent.patch
539- Remove python-libtorrent and a few other dependencies that are no longer
540  used.
541
542* Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
543- Fix Source0 URL.
544
545* Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
546- Make notify-python dependency conditional (FC6+ only)
547- Strip the unneeded shebang lines from the plugin scripts, since they are not
548  meant to be directly executed.
549
550* Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
551- Update .desktop file: Icon should not have the "-256" size suffix.
552- Add Requires: notify-python
553- Remove strict dependency on python 2.3+, since we're targetting FC5+
554  only, which has 2.4+.
555
556* Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
557- Use install instead of the cp/find/chmod fiasco of earlier releases for
558  clarity and proper permissions setting.
559- Be more consistent about use of %%{name} and other macros in file naming as
560  well as whitespace between sections.
561
562* Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
563- Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
564  64-bit systems.
565
566* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
567- Initial packaging for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.