source: projects/specs/trunk/d/dconf/dconf-vl.spec @ 8584

Revision 8584, 5.4 KB checked in by daisuke, 10 years ago (diff)

dconf:

  • move some post/postun scripts to dconf-editor:
    • glib-compile-schemas, gtk-update-icon-cache, update-desktop-database
Line 
1# Basic Information
2Name:           dconf
3Version:        0.20.0
4Release:        3%{?_dist_release}
5License:        LGPL
6Group:          System Environment/Base
7Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.20/%{name}-%{version}.tar.xz
8BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9
10Vendor:         Project Vine
11Distribution:   Vine Linux
12Packager:       yasumichi, Takemiakduchi
13
14Summary:        dconf is a low-level configuration system.
15Summary(ja):    dconfは、低レベル設定システムです。
16
17# Dependency
18Requires:       dbus
19
20BuildRequires:  glib2-devel
21BuildRequires:  gtk3-devel
22BuildRequires:  libxml2-devel
23BuildRequires:  dbus-devel
24BuildRequires:  libxslt-devel
25BuildRequires:  vala-devel
26BuildRequires:  docbook-style-xsl
27
28%description
29dconf is a low-level configuration system. Its main purpose is to provide
30a backend to GSettings on platforms that don't already have configuration
31storage systems.
32
33%description -l ja
34dconfは、低レベル設定システムです。その主要な目的は、まだ設定保存システムを
35有していないプラットフォーム上にGSettingsのバックエンドを提供することです。
36
37%package devel
38Summary:        Headers for developing programs that will use %{name}
39Summary(ja):    %{name} の開発用ファイル
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42Requires:       glib2-devel
43Requires:       libxml2-devel
44Requires:       dbus-devel
45
46%description devel
47This package contains the headers that programmers will need to develop
48applications which will use %{name}.
49
50%package editor
51Summary:        Editor/admin tool for dconf
52Summary(ja):    dconf の編集/管理ツール
53Group:          Applications/System
54Requires:       %{name} = %{version}-%{release}
55
56%description editor
57dconf-editor allows you to browse and modify dconf configuration.
58
59%description -l ja editor
60dconf-editor により dconf の設定を参照したり変更したりすることができます。
61
62%prep
63%setup -q
64
65%build
66%configure
67#%{__make} %{?_smp_mflags} INTROSPECTION_SCANNER='/usr/bin/g-ir-scanner --identifier-prefix=DConf'
68%{__make} %{?_smp_mflags}
69
70%install
71%{__rm} -rf ${RPM_BUILD_ROOT}
72%{__make} install DESTDIR=${RPM_BUILD_ROOT}
73
74%find_lang %{name}
75
76%clean
77%{__rm} -rf ${RPM_BUILD_ROOT}
78
79
80%post
81gio-querymodules %{_libdir}/gio/modules
82
83%post editor
84touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
85gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
86update-desktop-database -q &> /dev/null || :
87
88%postun
89if [ $1 -eq 0 ] ; then
90    gio-querymodules %{_libdir}/gio/modules
91fi
92
93%postun editor
94if [ $1 -eq 0 ] ; then
95    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
96    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
97    update-desktop-database -q &> /dev/null || :
98    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
99fi
100
101%posttrans  editor
102glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
103
104
105%files -f %{name}.lang
106%defattr(-,root,root)
107%doc COPYING NEWS
108%{_bindir}/dconf
109%{_libdir}/gio/modules/libdconfsettings.so
110%{_libdir}/libdconf*.so.*
111%{_libexecdir}/dconf-service
112%{_datadir}/bash-completion/completions/dconf
113%{_datadir}/dbus-1/services/ca.desrt.dconf.service
114%{_mandir}/man1/dconf.1.gz
115%{_mandir}/man1/dconf-service.1.gz
116%{_mandir}/man7/dconf.7.gz
117
118%files devel
119%defattr(-, root, root, -)
120%{_includedir}/dconf/
121%{_includedir}/dconf-dbus-1/
122%{_libdir}/libdconf*.so
123%{_libdir}/pkgconfig/*.pc
124%{_datadir}/gtk-doc/html/dconf/
125%{_datadir}/vala/vapi/dconf.deps
126%{_datadir}/vala/vapi/dconf.vapi
127
128%files editor
129%defattr(-, root, root, -)
130%{_bindir}/dconf-editor
131%{_datadir}/appdata/dconf-editor.appdata.xml
132%{_datadir}/applications/dconf-editor.desktop
133%{_datadir}/glib-2.0/schemas/*.xml
134%{_datadir}/icons/hicolor/*/apps/*
135%{_datadir}/icons/HighContrast/*/apps/*
136%{_mandir}/man1/dconf-editor.1.gz
137
138
139%changelog
140* Wed Jun 18 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.20.0-3
141- move some post/postun scripts to dconf-editor:
142  - glib-compile-schemas, gtk-update-icon-cache, update-desktop-database
143
144* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.20.0-2
145- split dconf-editor to subpackage.
146- drop libgee dependency(R,BR)
147- remove unneeded dependency(Requires)
148
149* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.0-1
150- new upstream release
151
152* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-2
153- rebuild with VineSeed environment
154
155* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
156- new upstream release
157
158* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
159- new upstream release
160
161* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
162- new upstream release
163- add BuildRequires: vala
164
165* Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
166- new upstream release
167
168* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
169- new upstream release
170- add BuildRequires: libxslt-devel, docbook-style-xsl
171
172* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
173- new upstream release
174
175* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
176- new upstream release
177
178* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
179- new upstream release
180
181* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-1
182- new upstream release
183
184* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
185- new upstream release
186- add BuildRequires: dbus-devel
187- change BuildRequires: gtk3-devel instead of gtk2-devel
188
189* Sun Oct 17 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.5.1-1
190- new package.
191
Note: See TracBrowser for help on using the repository browser.