source: projects/specs/trunk/d/dbus-python3/dbus-python3-vl.spec @ 10405

Revision 10405, 2.0 KB checked in by Takemikaduchi, 8 years ago (diff)

gcc-5.4.0 & python3-3.5.2

Line 
1%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
3
4%define dbus_glib_version       0.70
5%define dbus_version            1.6
6%define pkg_release             3%{?_dist_release}
7
8Name:           dbus-python3
9Summary:        D-Bus Python3 Bindings
10Summary(ja):    D-Bus Python3 バインディング
11Version:        1.2.0
12Release:        %{pkg_release}
13
14Group:          System Environment/Libraries
15License:        MIT
16URL:            http://www.freedesktop.org/software/dbus/
17
18Source0:        http://dbus.freedesktop.org/releases/dbus-python/dbus-python-%{version}.tar.gz
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  dbus-devel >= %{dbus_version}
22BuildRequires:  dbus-glib-devel >= %{dbus_glib_version}
23BuildRequires:  python3-devel
24Requires:       python3
25
26%description
27D-Bus python3 bindings for use with python programs.   
28
29%description -l ja
30D-Bus を python3 プログラムから使う為のバインディングです。   
31
32
33%prep
34%setup -q -n dbus-python-%{version}
35
36%build
37%configure PYTHON=/usr/bin/python3
38%{__make} %{?_smp_mflags}
39
40
41%install
42%{__rm} -rf ${RPM_BUILD_ROOT}
43%{__make} install DESTDIR=${RPM_BUILD_ROOT}
44
45# remove unnecessary *.la files
46find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
47
48# remove conflict files with dbus-python
49rm -f ${RPM_BUILD_ROOT}%{_includedir}/dbus-1.0/dbus/dbus-python.h
50rm -f ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/dbus-python.pc
51rm -f ${RPM_BUILD_ROOT}%{_docdir}/dbus-python/*
52
53
54%clean
55rm -rf ${RPM_BUILD_ROOT}
56
57%files
58%defattr(-,root,root)
59%doc COPYING ChangeLog README NEWS
60%{python3_sitearch}/*.so
61%{python3_sitelib}/dbus/*.py*
62%{python3_sitelib}/dbus/mainloop/*.py*
63
64%changelog
65* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-3
66- rebuild with python3-3.5.2
67
68* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
69- rebuild with python3-3.4.3
70
71* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
72- initial build
73
Note: See TracBrowser for help on using the repository browser.