source: projects/specs/trunk/d/dbus-python3/dbus-python3-vl.spec @ 9585

Revision 9585, 1.9 KB checked in by Takemikaduchi, 9 years ago (diff)

gnome-shell: add patch
gnome-music: add R: python3-pycairo
dbus-python3: rebuild

Line 
1%{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
3
4%define dbus_glib_version       0.70
5%define dbus_version            1.6
6%define pkg_release             2%{?_dist_release}
7
8Name:           dbus-python3
9Summary:        D-Bus Python3 Bindings
10Summary(ja):    D-Bus Python3 バインディング
11Version:        1.2.0
12Release:        %{pkg_release}
13
14Group:          System Environment/Libraries
15License:        MIT
16URL:            http://www.freedesktop.org/software/dbus/
17
18Source0:        http://dbus.freedesktop.org/releases/dbus-python/dbus-python-%{version}.tar.gz
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  dbus-devel >= %{dbus_version}
22BuildRequires:  dbus-glib-devel >= %{dbus_glib_version}
23BuildRequires:  python3-devel
24
25%description
26D-Bus python3 bindings for use with python programs.   
27
28%description -l ja
29D-Bus を python3 プログラムから使う為のバインディングです。   
30
31
32%prep
33%setup -q -n dbus-python-%{version}
34
35%build
36%configure PYTHON=/usr/bin/python3
37%{__make} %{?_smp_mflags}
38
39
40%install
41%{__rm} -rf ${RPM_BUILD_ROOT}
42%{__make} install DESTDIR=${RPM_BUILD_ROOT}
43
44# remove unnecessary *.la files
45find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
46
47# remove conflict files with dbus-python
48rm -f ${RPM_BUILD_ROOT}%{_includedir}/dbus-1.0/dbus/dbus-python.h
49rm -f ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/dbus-python.pc
50rm -f ${RPM_BUILD_ROOT}%{_docdir}/dbus-python/*
51
52
53%clean
54rm -rf ${RPM_BUILD_ROOT}
55
56%files
57%defattr(-,root,root)
58%doc COPYING ChangeLog README NEWS
59%{python3_sitearch}/*.so
60%{python3_sitelib}/dbus/*.py*
61%{python3_sitelib}/dbus/mainloop/*.py*
62
63%changelog
64* Sun May 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-2
65- rebuild with python3-3.4.3
66
67* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
68- initial build
69
Note: See TracBrowser for help on using the repository browser.