source: projects/specs/trunk/d/dbus-python/dbus-python-vl.spec @ 521

Revision 521, 5.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch:    %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_sitelib:     %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3
4%define dbus_glib_version       0.70
5%define dbus_version            0.90
6%define pkg_release             4%{?_dist_release}
7
8Summary:        D-Bus Python Bindings
9Summary(ja):    D-Bus Python バインディング
10Name:           dbus-python
11Version:        0.83.0
12Release:        %{pkg_release}
13Source0:        http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
14Patch0:         dbus-python-0.83.0-memleak.patch
15License:        MIT
16Group:          System Environment/Libraries
17URL:            http://www.freedesktop.org/software/dbus/
18
19BuildRequires:  dbus-devel >= %{dbus_version}
20BuildRequires:  dbus-glib-devel >= %{dbus_glib_version}
21BuildRequires:  python-devel
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24
25%description
26D-Bus python bindings for use with python programs.   
27
28%description -l ja
29D-Bus を python プログラムから使う為のバインディングです。   
30
31
32%package devel
33Summary:        Libraries and headers for dbus-python
34Summary(ja):    dbus-python のライブラリ及びヘッダファイル
35Group:          Development/Libraries
36Requires:       %name = %{version}-%{release}
37
38%description devel
39Headers and static libraries for hooking up custom mainloops to the dbus python
40bindings.
41
42%description devel -l ja
43dbus-python バインディング用のカスタム・メインループをフックする為の
44ヘッダファイルとスタティック・ライブラリです。
45
46
47%prep
48%setup -q
49%patch0 -p0 -b .memleak
50
51
52%build
53%configure
54%{__make} %{?_smp_mflags}
55
56
57%install
58%{__rm} -rf ${RPM_BUILD_ROOT}
59%{__make} install DESTDIR=${RPM_BUILD_ROOT}
60
61# remove unnecessary *.la files
62find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
63
64
65%clean
66rm -rf ${RPM_BUILD_ROOT}
67
68%files
69%defattr(-,root,root)
70%doc COPYING ChangeLog README NEWS TODO
71%doc doc/API_CHANGES.txt doc/HACKING.txt doc/tutorial.txt
72%exclude %{_datadir}/doc/dbus-python
73%dir %{python_sitelib}/dbus
74%dir %{python_sitelib}/dbus/mainloop
75%{python_sitearch}/*.so
76%{python_sitelib}/*.py*
77%{python_sitelib}/dbus/*.py*
78%{python_sitelib}/dbus/mainloop/*.py*
79
80%files devel
81%defattr(-,root,root)
82%{_includedir}/dbus-1.0/dbus/dbus-python.h
83%{_libdir}/pkgconfig/dbus-python.pc
84
85%changelog
86* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-4
87- rebuilt with gcc-4.4.3-3 on ppc
88
89* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-3
90- rebuilt with rpm-4.8.0-3 (on ppc)
91
92* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.83.0-2
93- rebuild with python-2.6
94
95* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.83.0-1
96- initital build for Vine Linux based on fedora package
97
98* Tue Sep 16 2008 Marco Pesenti Gritti - 0.83.0-3
99- Add patch for https://bugs.freedesktop.org/show_bug.cgi?id=17551
100
101* Tue Aug 05 2008  Huang Peng <phuang@redhat.com> - 0.83.0-2
102- Update to 0.83.0.
103
104* Wed Jul 16 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.82.4-3
105- fix license tag
106
107* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.82.4-2
108- Autorebuild for GCC 4.3
109
110* Sun Jan 20 2008 Matthias Clasen <mclasen@redhat.com> - 0.82.4-1
111- Update to 0.82.4
112
113* Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-3
114- Rebuild against new dbus-glib
115
116* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.82.0-2
117- Rebuild for selinux ppc32 issue.
118
119* Fri Jun 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-1
120- Update to 0.82.0
121- Put all docs in the usual place
122
123* Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-3
124- Rebuild
125
126* Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-2
127- Don't examine args for functions declared METH_NOARGS (#235017)
128
129* Tue Feb 13 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.2-1
130- upgrade to 0.80.2 which fixes some memleaks
131
132* Wed Jan 24 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.1-1
133- upgrade to 0.80.1
134- remove dependency on Pyrex and libxml2
135- some API breakage,
136  please see http://dbus.freedesktop.org/doc/dbus-python/NEWS.html
137  for notes on changes
138
139* Wed Jan  3 2007 David Zeuthen <davidz@redhat.com> - 0.70-9%{?dist}
140- rebuild against new Pyrex
141
142* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 0.70-8
143- rebuild against python 2.5
144
145* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 0.70-7
146- Fix a typo in the spec file
147
148* Fri Aug 18 2006 Karsten Hopp <karsten@redhat.com> - 0.70-6
149- require libxml2-python for site-packages/dbus/introspect_parser.py
150
151* Thu Jul 20 2006 Jesse Keating <jkeating@redhat.com> - 0.70-5
152- Remove unnecessary obsoletes
153
154* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-4
155- Try python_sitearch this time
156
157* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-3
158- Add a BR on dbus-devel
159
160* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-2
161- Spec file cleanups
162- Add PKG_CONFIG_PATH
163
164* Mon Jul 17 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-1
165- Initial package import
Note: See TracBrowser for help on using the repository browser.