source: projects/specs/trunk/d/dbus-glib/dbus-glib-vl.spec @ 7633

Revision 7633, 6.1 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define gettext_package dbus
2
3%define expat_version 2.1.0
4%define glib2_version 2.34.0
5%define dbus_version 1.6.4
6
7%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
8
9Summary: GLib bindings for D-Bus
10Summary(ja): D-Bus の GLib バインディング
11Name: dbus-glib
12Version: 0.100.2
13Release: 1%{?_dist_release}
14URL: http://www.freedesktop.org/software/dbus/
15Source0: http://dbus.freedesktop.org/releases/%{name}-%{version}.tar.gz
16Source1: dbus-bus-introspect.xml
17License: AFL/GPL
18Group: System Environment/Libraries
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires: chkconfig
22BuildRequires: libtool
23BuildRequires: dbus-devel >= %{dbus_version}
24BuildRequires: expat-devel >= %{expat_version}
25BuildRequires: libxml2-devel
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: gettext
28BuildRequires: autoconf
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34D-Bus add-on library to integrate the standard D-Bus library with
35the GLib thread abstraction and main loop.
36
37%package devel
38Summary: Libraries and headers for the D-Bus GLib bindings
39Summary(ja): D-Bus GLib バインディング用のライブラリとヘッダファイル
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42Requires: glib2-devel
43Requires: dbus-devel
44Requires: pkgconfig
45Obsoletes: dbus-devel < 0.90
46
47%description devel
48Headers and static libraries for the D-Bus GLib bindings
49
50%if 0
51%package gtk
52Summary: GTK based tools
53Group: Development/Tools
54Requires: %{name} = %{version}-%{release}
55Requires: gtk2 >= 2.10.0
56
57%description gtk
58D-Bus tools written using the gtk+ GUI libaries
59%endif
60
61# compat32
62%package -n compat32-%{name}
63Summary: GLib bindings for D-Bus
64Summary(ja): D-Bus の GLib バインディング
65Group: System Environment/Libraries
66Requires: %{name} = %{version}-%{release}
67
68%description -n compat32-%{name}
69D-Bus add-on library to integrate the standard D-Bus library with
70the GLib thread abstraction and main loop.
71
72%package -n compat32-%{name}-devel
73Summary: Libraries and headers for the D-Bus GLib bindings
74Summary(ja): D-Bus GLib バインディング用のライブラリとヘッダファイル
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77Requires: compat32-%{name} = %{version}-%{release}
78Requires: compat32-glib2-devel
79Requires: compat32-dbus-devel
80
81%description -n compat32-%{name}-devel
82Headers and static libraries for the D-Bus GLib bindings
83
84%prep
85%setup -q
86
87%build
88%configure --disable-tests \
89        --disable-verbose-mode \
90        --disable-asserts \
91        --disable-gtk-doc \
92        --with-introspect-xml=%{SOURCE1}
93%__make
94
95
96%install
97rm -rf %{buildroot}
98
99make install DESTDIR=$RPM_BUILD_ROOT
100
101rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
102rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
103
104%clean
105rm -rf %{buildroot}
106
107%post -p /sbin/ldconfig
108
109%postun -p /sbin/ldconfig
110
111%post -n compat32-%{name} -p /sbin/ldconfig
112
113%postun -n compat32-%{name} -p /sbin/ldconfig
114
115%files
116%defattr(-,root,root)
117%doc COPYING ChangeLog NEWS
118%{_sysconfdir}/bash_completion.d/dbus-bash-completion.sh
119%{_libdir}/*glib*.so.*
120%{_libexecdir}/dbus-bash-completion-helper
121%{_bindir}/dbus-binding-tool
122%{_mandir}/man1/dbus-binding-tool.1.gz
123
124%files devel
125%defattr(-,root,root)
126%{_libdir}/lib*.so
127%{_libdir}/pkgconfig/dbus-glib-1.pc
128%{_includedir}/*
129%{_datadir}/gtk-doc/html/dbus-glib
130
131%if 0
132%files gtk
133%defattr(-,root,root)
134%{_bindir}/dbus-viewer
135%endif
136
137# compat32
138%if %{build_compat32}
139%files -n compat32-%{name}
140%defattr(-,root,root)
141%{_libdir}/*glib*.so.*
142
143%files -n compat32-%{name}-devel
144%defattr(-,root,root)
145%{_libdir}/lib*.so
146%endif
147
148%changelog
149* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.100.2-1
150- new upstream release
151
152* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.100-1
153- new upstream release
154
155* Sat Dec 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.98-1
156- new upstream release
157
158* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.96-1
159- new upstream release
160
161* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.94-1
162- new upstream release
163
164* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92-1
165- new upstream release
166
167* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.88-1
168- new upstream release
169
170* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.86-2
171- build with rpm-4.8.1-1 for pkg-config file
172
173* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.86-1
174- new upstream release
175
176* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.82-1
177- new upstream release
178
179* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.80-2
180- added compat32 package for x86_64 arch support
181
182* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.80-1
183- new upstream release
184- built with dbus-1.2.12, glib-2.20.0
185
186* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.76-1
187- new upstream release
188
189* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.74-1vl5
190- rebuilt with dbus-1.1.20, glib2-2.16.1
191- used %%{?_dist_release}
192
193* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.74-0vl2
194- rebuild with expat-2.0.1
195
196* Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.74-0vl1
197- new upstream release
198
199* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.73-0vl1
200- initial build for Vine Linux
201
202* Wed Apr  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.73-1
203- Update to 0.73 (#233631)
204- Drop upstreamed patches
205
206* Tue Dec 19 2006 John (J5) Palmieri <johnp@redhat.com> - 0.71-4
207- Add dbus-glib-0.70-use-default-threads.patch
208- Partial fix to #219257
209
210* Wed Nov 29 2006 David Zeuthen <davidz@redhat.com> - 0.71-3%{?dist}
211- Add dbus-glib-0.70-fix-info-leak.patch
212- Resolves: #216034
213
214* Sun Nov  5 2006 Matthias Clasen <mclasen@redhat.com> - 0.71-2
215- Fix up Requires for the -devel package
216
217* Mon Oct 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.71-1
218- Update to 0.71
219
220* Thu Jul 20 2006 Jesse Keating <jkeating@redhat.com> - 0.70-4
221- remove improper obsoletes
222
223* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-3
224- Pregenerate the xml introspect file so you don't need dbus running during
225  the build
226
227* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-2
228- Spec file cleanups
229
230* Mon Jul 17 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-1
231- Initial dbus-glib package
Note: See TracBrowser for help on using the repository browser.