source: projects/specs/trunk/d/dbus-glib/dbus-glib-vl.spec @ 2041

Revision 2041, 5.5 KB checked in by Takemikaduchi, 13 years ago (diff)

update to GNOME-2.32.0

Line 
1%define gettext_package dbus
2
3%define expat_version 2.0.1
4%define glib2_version 2.26.0
5%define dbus_version 1.2.24
6
7%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
8
9Summary: GLib bindings for D-Bus
10Summary(ja): D-Bus の GLib バインディング
11Name: dbus-glib
12Version: 0.88
13Release: 1%{?_dist_release}
14URL: http://www.freedesktop.org/software/dbus/
15Source0: http://dbus.freedesktop.org/releases/%{name}-%{version}.tar.gz
16Source1: dbus-bus-introspect.xml
17License: AFL/GPL
18Group: System Environment/Libraries
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires: chkconfig
22BuildRequires: libtool
23BuildRequires: dbus-devel >= %{dbus_version}
24BuildRequires: expat-devel >= %{expat_version}
25BuildRequires: libxml2-devel
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: gettext
28BuildRequires: autoconf
29
30%description
31D-Bus add-on library to integrate the standard D-Bus library with
32the GLib thread abstraction and main loop.
33
34%package devel
35Summary: Libraries and headers for the D-Bus GLib bindings
36Summary(ja): D-Bus GLib バインディング用のライブラリとヘッダファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: glib2-devel
40Requires: dbus-devel
41Requires: pkgconfig
42Obsoletes: dbus-devel < 0.90
43
44%description devel
45Headers and static libraries for the D-Bus GLib bindings
46
47%if 0
48%package gtk
49Summary: GTK based tools
50Group: Development/Tools
51Requires: %{name} = %{version}-%{release}
52Requires: gtk2 >= 2.10.0
53
54%description gtk
55D-Bus tools written using the gtk+ GUI libaries
56%endif
57
58# compat32
59%package -n compat32-%{name}
60Summary: GLib bindings for D-Bus
61Summary(ja): D-Bus の GLib バインディング
62Group: System Environment/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description -n compat32-%{name}
66D-Bus add-on library to integrate the standard D-Bus library with
67the GLib thread abstraction and main loop.
68
69%package -n compat32-%{name}-devel
70Summary: Libraries and headers for the D-Bus GLib bindings
71Summary(ja): D-Bus GLib バインディング用のライブラリとヘッダファイル
72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
74Requires: compat32-%{name} = %{version}-%{release}
75Requires: compat32-glib2-devel
76Requires: compat32-dbus-devel
77
78%description -n compat32-%{name}-devel
79Headers and static libraries for the D-Bus GLib bindings
80
81%prep
82%setup -q
83
84%build
85%configure --disable-tests \
86        --disable-verbose-mode \
87        --disable-asserts \
88        --disable-gtk-doc \
89        --with-introspect-xml=%{SOURCE1}
90%__make
91
92
93%install
94rm -rf %{buildroot}
95
96make install DESTDIR=$RPM_BUILD_ROOT
97
98rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
99rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
100
101%clean
102rm -rf %{buildroot}
103
104%post -p /sbin/ldconfig
105
106%postun -p /sbin/ldconfig
107
108%post -n compat32-%{name} -p /sbin/ldconfig
109
110%postun -n compat32-%{name} -p /sbin/ldconfig
111
112%files
113%defattr(-,root,root)
114%doc COPYING ChangeLog NEWS
115%{_sysconfdir}/bash_completion.d/dbus-bash-completion.sh
116%{_libdir}/*glib*.so.*
117%{_libexecdir}/dbus-bash-completion-helper
118%{_bindir}/dbus-binding-tool
119%{_mandir}/man1/dbus-binding-tool.1.gz
120
121%files devel
122%defattr(-,root,root)
123%{_libdir}/lib*.so
124%{_libdir}/pkgconfig/dbus-glib-1.pc
125%{_includedir}/*
126%{_datadir}/gtk-doc/html/dbus-glib
127
128%if 0
129%files gtk
130%defattr(-,root,root)
131%{_bindir}/dbus-viewer
132%endif
133
134# compat32
135%if %{build_compat32}
136%files -n compat32-%{name}
137%defattr(-,root,root)
138%{_libdir}/*glib*.so.*
139
140%files -n compat32-%{name}-devel
141%defattr(-,root,root)
142%{_libdir}/lib*.so
143%{_libdir}/pkgconfig/dbus-glib-1.pc
144%endif
145
146%changelog
147* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.88-1
148- new upstream release
149
150* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.86-2
151- build with rpm-4.8.1-1 for pkg-config file
152
153* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.86-1
154- new upstream release
155
156* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.82-1
157- new upstream release
158
159* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.80-2
160- added compat32 package for x86_64 arch support
161
162* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.80-1
163- new upstream release
164- built with dbus-1.2.12, glib-2.20.0
165
166* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.76-1
167- new upstream release
168
169* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.74-1vl5
170- rebuilt with dbus-1.1.20, glib2-2.16.1
171- used %%{?_dist_release}
172
173* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.74-0vl2
174- rebuild with expat-2.0.1
175
176* Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.74-0vl1
177- new upstream release
178
179* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.73-0vl1
180- initial build for Vine Linux
181
182* Wed Apr  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.73-1
183- Update to 0.73 (#233631)
184- Drop upstreamed patches
185
186* Tue Dec 19 2006 John (J5) Palmieri <johnp@redhat.com> - 0.71-4
187- Add dbus-glib-0.70-use-default-threads.patch
188- Partial fix to #219257
189
190* Wed Nov 29 2006 David Zeuthen <davidz@redhat.com> - 0.71-3%{?dist}
191- Add dbus-glib-0.70-fix-info-leak.patch
192- Resolves: #216034
193
194* Sun Nov  5 2006 Matthias Clasen <mclasen@redhat.com> - 0.71-2
195- Fix up Requires for the -devel package
196
197* Mon Oct 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.71-1
198- Update to 0.71
199
200* Thu Jul 20 2006 Jesse Keating <jkeating@redhat.com> - 0.70-4
201- remove improper obsoletes
202
203* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-3
204- Pregenerate the xml introspect file so you don't need dbus running during
205  the build
206
207* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-2
208- Spec file cleanups
209
210* Mon Jul 17 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-1
211- Initial dbus-glib package
Note: See TracBrowser for help on using the repository browser.