source: projects/specs/trunk/d/dbskkd-cdb/dbskkd-cdb-vl.spec @ 10141

Revision 10141, 5.0 KB checked in by ara_t, 8 years ago (diff)

update to 2.00, rebuild with skkdic-20160410

Line 
1%define pkg_name dbskkd-cdb
2%define pkg_version 2.00
3%define pkg_release 6%{?_dist_release}
4
5%define cdb_ver 0.78
6
7Summary:     A dictionary server for the SKK Japanese input method system
8Summary(ja): SKK 日本語入力メソッドの辞書サーバ
9Name:        %{pkg_name}
10Version:     %{pkg_version}
11Release:     %{pkg_release}
12
13License: GPL
14Group:   Applications/System
15URL:     http://www.ne.jp/asahi/bdx/info/software/jp-dbskkd.html
16
17Source0: https://github.com/jj1bdx/dbskkd-cdb/archive/%{name}-%{version}_IMPORTED_FROM_SVN.tar.gz
18Source1: http://www.corpit.ru/mjt/tinycdb/tinycdb-%{cdb_ver}.tar.gz
19Source2: dbskkd-cdb.xinetd
20Patch1:  dbskkd-cdb-2.00.c.patch
21Patch2:  dbskkd-cdb-2.00.makefile.patch
22
23BuildRequires: skkdic
24Requires:      xinetd
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
27Provides: skkserv
28
29Vendor:       Project Vine
30Distribution: Vine Linux
31Packager: ara_t
32
33
34%description
35dbskkd-cdb is a dictionary server for the SKK Japanese input method
36system.  dbskkd-cdb is based on the code of skkserv (the original SKK
37server) 3.9.3, using the cdb constant database package of
38D. J. Bernstein (DJB) for faster dictionary access.
39
40#Add an entry for dbskkd-cdb to /etc/hosts.allow when using with tcp_wrappers.
41#ex. dbskkd-cdb: 127.0.0.1
42
43%description -l ja
44dbskkd-cdbは、skkservと同様の機能を提供する
45SKK用の共通辞書サーバーである。
46辞書は D. J. Bernsteinのcdbを使ってデータベース化し、
47検索を高速化している。
48本サーバーは同種のツールpskkservを基にしている。
49
50
51%prep
52%setup -q -n %{name}-%{version}_IMPORTED_FROM_SVN -q -a 1
53%patch1 -p1
54%patch2 -p1
55
56%{__rm} -rf ${RPM_BUILD_ROOT}
57
58%build
59%{__make} -C tinycdb-%{cdb_ver}
60
61for JISYO in %{_datadir}/skk/SKK-JISYO.*
62do
63  LJISYO=`basename $JISYO`
64  ./skktocdbm.sh < ${JISYO} > ${LJISYO}.cdb
65done
66
67%{__make} CDBLIB="-Ltinycdb-%{cdb_ver} -lcdb"
68
69%install
70%{__rm} -rf ${RPM_BUILD_ROOT}
71%{__mkdir_p} ${RPM_BUILD_ROOT}%{_sbindir}
72%{__mkdir_p} ${RPM_BUILD_ROOT}/etc/xinetd.d/
73%{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/skk
74
75%{__install} -m0755 dbskkd-cdb ${RPM_BUILD_ROOT}%{_prefix}/sbin
76%{__install} -m0644 %{SOURCE2} ${RPM_BUILD_ROOT}/etc/xinetd.d/dbskkd-cdb
77%{__install} -m0644 SKK-JISYO.*.cdb ${RPM_BUILD_ROOT}%{_datadir}/skk
78
79%clean
80%{__rm} -rf $RPM_BUILD_ROOT
81
82
83%files
84%defattr(-, root, root)
85%config(noreplace) /etc/xinetd.d/dbskkd-cdb
86%doc CHANGES LICENSE README READMEJP
87%{_sbindir}/
88%{_datadir}/skk
89%config
90
91
92%changelog
93* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 2.00-6
94- rebuild with skkdic-2016410
95- add Packager tag
96
97* Sat Mar 12 2016 Toshiaki Ara <ara_t@384.jp> 2.00-5
98- rebuild with skkdic-20160306
99
100* Mon Dec 28 2015 Toshiaki Ara <ara_t@384.jp> 2.00-4
101- rebuild with skkdic-20151227
102
103* Tue Nov 17 2015 Toshiaki Ara <ara_t@384.jp> 2.00-3
104- rebuild with skkdic-20151115
105- add Requires: xinetd
106
107* Thu Sep 24 2015 Toshiaki Ara <ara_t@384.jp> 2.00-2
108- rebuild with skkdic-20150920
109
110* Thu Jul 09 2015 Toshiaki Ara <ara_t@384.jp> 2.00-1
111- update 2.00
112
113* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.01-20
114- rebuild with Vine6 environment
115
116* Sat Aug 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.01-19
117- spec in utf-8, new versioning policy
118
119* Wed Jan 30 2008 Shu KONNO <owa@bg.wakwak.com> 1.01-18vl2
120- s/Copyright/License/
121
122* Sun May 25 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
123- modified for VineLinux
124
125* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
126- rebuilt
127
128* Mon Nov 25 2002 Jens Petersen <petersen@redhat.com> 1.01-17
129- improve service description in xinetd config file (#77711)
130
131* Mon Jun 24 2002 Jens Petersen <petersen@redhat.com> 1.01-16
132- don't install dbskkd-cdb stripped
133
134* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.01-15
135- automated rebuild
136
137* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.01-14
138- automated rebuild
139
140* Mon Feb 25 2002 Jens Petersen <petersen@redhat.com> 1.01-13
141- rebuild in new environment
142
143* Thu Feb 21 2002 Jens Petersen <petersen@redhat.com> 1.01-12
144- generate and include SKK-JISYO.L.cdb (formerly in skkdic)
145- silence depend files warnings while building freecdb with -include
146- no longer include skktocdbm.sh in docs
147
148* Wed Jan 30 2002 Jens Petersen <petersen@redhat.com> 1.01-11
149- tidy spec
150- freecdb-0.62 included for build, so no longer buildrequires freecdb
151- build it first and link with it
152
153* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.01-10
154- automated rebuild
155
156* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com> 1.01-9
157- Bump release + rebuild.
158
159* Wed Feb 28 2001 SATO Satoru <ssato@redhat.com>
160- add /etc/xinetd.d/dbskkd-cdb
161
162* Wed Feb 28 2001 Bill Nottingham <notting@redhat.com>
163- remove %post, just put it in the default /etc/services (#29759)
164
165* Tue Jan 23 2001 Karsten Hopp <karsten@redhat.de>
166- change Conflicts: skkserv to Obsoletes: skkserv
167
168* Mon Jan 22 2001 SATO Satoru <ssato@redhat.com>
169- fix category
170
171* Mon Jan 21 2001 SATO Satoru <ssato@redhat.com>
172- remove some macros
173- remove the dictionary
174- clean up upstream sources
175- clean up SPEC
176
177* Mon Dec 18 2000 SATO Satoru <ssato@redhat.com>
178- use system macros
179
180* Mon Aug  4 2000 SATO Satoru <ssato@redhat.com>
181- Initial release
Note: See TracBrowser for help on using the repository browser.