source: projects/specs/trunk/d/dblatex/dblatex-vl.spec @ 9468

Revision 9468, 8.6 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           dblatex
4Version:        0.3.5
5Release:        1%{?_dist_release}
6Summary:        DocBook to LaTeX/ConTeXt Publishing
7BuildArch:      noarch
8Group:          Applications/Publishing
9License:        GPLv2+
10URL:            http://dblatex.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12#Source1:        http://docbook.sourceforge.net/release/xsl/current/COPYING
13Source1:        COPYING-docbook-xsl
14Patch0:         dblatex-0.2.7-external-which.patch
15
16##!! ad-hoc patch for no deb
17Patch10:        dblatex-0.3.4-no-deb.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21BuildRequires:  texlive-vtlpkg >= 2013
22BuildRequires:  python-devel
23BuildRequires:  python-which
24BuildRequires:  libxslt docbook-dtds ImageMagick
25## Need epstopdf, fig2dev
26BuildRequires:  texlive-collection-fontutils
27BuildRequires:  transfig
28##BuildRequires:  tex(latex)
29##BuildRequires:  tex(xetex)
30BuildRequires:  texlive-common >= 2013
31## appendix.sty, changebar.sty, footmisc.sty, multirow.sty,
32## overpic.sty, subfigure.sty, titlesec.sty
33BuildRequires:  texlive-collection-latexextra
34## stmaryrd.sty
35BuildRequires:  texlive-collection-mathextra
36BuildRequires:  texlive-collection-htmlxml
37Requires:       libxslt docbook-dtds ImageMagick
38##Requires:       tex(xetex)
39Requires:       texlive-common >= 2009
40Requires:       texlive-collection-latexextra
41Requires:       transfig
42BuildRequires:  texlive-collection-mathextra
43##Requires:     passivetex
44Requires:       texlive-collection-htmlxml
45
46## $ rpm -qf --qf "%{name}\n" $(kpsewhich $(grep "usepackage" $(rpm -ql dblatex | grep sty) | sed -e "s,.*{,," -e "s,}.*$,.sty,")) | sort | uniq
47Requires:       texlive-collection-langcjk texlive-collection-bibtexextra
48
49%description
50dblatex is a program that transforms your SGML/XMLDocBook
51documents to DVI, PostScript or PDF by translating them
52into pure LaTeX as a first process.  MathML 2.0 markups
53are supported, too. It started as a clone of DB2LaTeX.
54
55Authors:
56--------
57   Benoît Guillon <marsgui at users dot sourceforge dot net>
58   Andreas Hoenen <andreas dot hoenen at arcor dot de>
59
60
61%prep
62%setup -q
63%patch0 -p1 -b .external-which
64%patch10 -p1 -b .no-deb
65%__rm -rf lib/contrib
66
67%build
68%{__python} setup.py build
69
70
71%install
72%__rm -rf $RPM_BUILD_ROOT
73#%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
74%{__python} setup.py install --root $RPM_BUILD_ROOT
75# these are already in tetex-latex:
76for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
77  %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
78done
79
80%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex
81for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
82  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
83done
84
85## also move .xetex files
86for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
87  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
88done
89
90%__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
91
92%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/dblatex
93# shipped in %%docs
94%__rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/
95
96%__sed -e 's/\r//' xsl/mathml2/README > README-xsltml
97touch -r xsl/mathml2/README README-xsltml
98%__cp -p %{SOURCE1} COPYING-docbook-xsl
99
100 
101%clean
102%__rm -rf $RPM_BUILD_ROOT
103
104
105%post
106%_tl_touch_run texhash
107exit 0
108
109%postun
110if [ "$1" = 0 ]; then
111   %_tl_touch_run texhash
112fi
113exit 0
114
115%posttrans
116%{_tl_exec_texhash}
117exit 0
118
119
120%files
121%defattr(-,root,root,-)
122%{_mandir}/man1/dblatex.1*
123%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
124%{python_sitelib}/dbtexmf/
125%{python_sitelib}/dblatex-*.egg-info
126%{_bindir}/dblatex
127%{_datadir}/dblatex/
128%{_datadir}/texmf/tex/latex/dblatex/
129%dir %{_sysconfdir}/dblatex
130
131%changelog
132* Wed Mar 25 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.5-1
133- new upstream release
134
135* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.4-2
136- added BuildRequires: texlive-vtlpkg >= 2013
137- added some scriptlets to run mktexlsr
138
139* Fri Nov  8 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.4-1
140- new upstream release
141
142* Fri Dec 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-3
143- added R: texlive-collection-langcjk texlive-collection-bibtexextra [Vine Linux 0002511]
144
145* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-2
146- rebuild with Python 2.7.2
147
148* Fri Jan 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
149- new upstream release
150
151* Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.3-1
152- initial build
153
154* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
156
157* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3-2
158- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
159
160* Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
161- Update to 0.3
162- Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
163
164* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
166
167* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-2
168- remove dblatex-0.2.9-xetex.patch
169
170* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-1
171- Update to 0.2.10
172
173* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
175
176* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.9-3
177- Rebuild for Python 2.6
178
179* Fri Jul  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-2
180- BR: texlive-xetex -> tex(xetex) for F-10 and later
181
182* Thu Jun 12 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-1
183- Update to latest upstream (0.2.9) (#448953)
184- Remove some redundant Requires and BuildRequires (passivetex pulls
185  in the tetex/tex requires, python dep added automatically)
186- For F-9+ BR on tex(latex) and texlive-xetex, fix the installation
187  scripts to install extra new files.
188- Add patch from dblatex mailing list for better handling of a missing
189  xetex.
190- Conditionally add .egg-info file only if F9+ to allow for unified
191  spec file
192
193* Sun Dec 16 2007 Patrice Dumas <pertusus@free.fr> - 0.2.8-2.1
194- don't install in docbook directory, it is a link to a versioned
195  directory and may break upon docbook update (#425251,#389231)
196
197* Sun Nov 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.8-1
198- Update to 0.2.8
199
200* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-16
201- convert spec to utf8
202- change to gplv2+
203
204* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-15
205- Add copyright info
206
207* Mon Nov  5 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-14
208- Req tetex-fonts for texhash
209- Fix post, postun
210
211* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-13
212- Add texhash
213
214* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
215- Fix xsl link
216
217* Sat Nov  3 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
218- Various fixes from pertusus@free.fr:
219- rm iconv stuff
220- simplify docs installation
221
222* Fri Nov  2 2007  <ndbecker2@gmail.com> - 0.2.7-11
223- Various minor fixes
224
225* Thu Nov  1 2007  <ndbecker2@gmail.com> - 0.2.7-10
226- Add some reqs and brs
227- rmdir /usr/share/dblatex/latex/{misc,contrib/example,style}
228
229* Sat Oct 27 2007  <ndbecker2@gmail.com> - 0.2.7-9
230- link /usr/share/dblatex/xsl -> /usr/share/sgml/docbook/xsl-stylesheets/dblatex
231- rmdir /usr/share/dblatex/latex/{misc,specs,style}
232- own /etc/dblatex
233- change $(...) -> `...`
234- Preserve timestamps on iconv
235
236* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-9
237- mv all .sty files to datadir/texmf/tex/latex/dblatex
238- Add Conflicts tetex-tex4ht
239- mv all xsl stuff to datadir/sgml/docbook/xsl-stylesheets/dblatex/
240
241* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
242- rm redundant latex files
243
244* Tue Sep 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
245- Fixed encodings in docs directory
246- Install docs at correct location
247
248* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-7
249- Revert back to GPLv2
250- untabify
251
252* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-6
253- Fix source URL
254- Install all docs
255- Tabify
256
257* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-5
258- Add BR tetex-latex
259
260* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-4
261- Add  BR tetex, ImageMagick
262
263* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-3
264- Add BR libxslt
265
266* Wed Sep 19 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-2
267- Add BR python-devel
268
269* Fri Sep  7 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-1
270- Initial
271
272
273
Note: See TracBrowser for help on using the repository browser.