source: projects/specs/trunk/d/dblatex/dblatex-vl.spec @ 7971

Revision 7971, 8.2 KB checked in by munepi, 11 years ago (diff)

new upstream release

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           dblatex
4Version:        0.3.4
5Release:        1%{?_dist_release}
6Summary:        DocBook to LaTeX/ConTeXt Publishing
7BuildArch:      noarch
8Group:          Applications/Publishing
9License:        GPLv2+
10URL:            http://dblatex.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12#Source1:        http://docbook.sourceforge.net/release/xsl/current/COPYING
13Source1:        COPYING-docbook-xsl
14Patch0:         dblatex-0.2.7-external-which.patch
15
16##!! ad-hoc patch for no deb
17Patch10:        dblatex-0.3.4-no-deb.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21BuildRequires:  python-devel
22BuildRequires:  python-which
23BuildRequires:  libxslt docbook-dtds ImageMagick
24## Need epstopdf, fig2dev
25BuildRequires:  texlive-collection-fontutils
26BuildRequires:  transfig
27##BuildRequires:  tex(latex)
28##BuildRequires:  tex(xetex)
29BuildRequires:  texlive-common >= 2009
30## appendix.sty, changebar.sty, footmisc.sty, multirow.sty,
31## overpic.sty, subfigure.sty, titlesec.sty
32BuildRequires:  texlive-collection-latexextra
33## stmaryrd.sty
34BuildRequires:  texlive-collection-mathextra
35BuildRequires:  texlive-collection-htmlxml
36Requires:       libxslt docbook-dtds ImageMagick
37##Requires:       tex(xetex)
38Requires:       texlive-common >= 2009
39Requires:       texlive-collection-latexextra
40Requires:       transfig
41BuildRequires:  texlive-collection-mathextra
42##Requires:     passivetex
43Requires:       texlive-collection-htmlxml
44
45## $ rpm -qf --qf "%{name}\n" $(kpsewhich $(grep "usepackage" $(rpm -ql dblatex | grep sty) | sed -e "s,.*{,," -e "s,}.*$,.sty,")) | sort | uniq
46Requires:       texlive-collection-langcjk texlive-collection-bibtexextra
47
48%description
49dblatex is a program that transforms your SGML/XMLDocBook
50documents to DVI, PostScript or PDF by translating them
51into pure LaTeX as a first process.  MathML 2.0 markups
52are supported, too. It started as a clone of DB2LaTeX.
53
54Authors:
55--------
56   Benoît Guillon <marsgui at users dot sourceforge dot net>
57   Andreas Hoenen <andreas dot hoenen at arcor dot de>
58
59
60%prep
61%setup -q
62%patch0 -p1 -b .external-which
63%patch10 -p1 -b .no-deb
64%__rm -rf lib/contrib
65
66%build
67%{__python} setup.py build
68
69
70%install
71%__rm -rf $RPM_BUILD_ROOT
72#%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
73%{__python} setup.py install --root $RPM_BUILD_ROOT
74# these are already in tetex-latex:
75for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
76  %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
77done
78
79%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex
80for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
81  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
82done
83
84## also move .xetex files
85for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
86  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
87done
88
89%__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
90
91%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/dblatex
92# shipped in %%docs
93%__rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/
94
95%__sed -e 's/\r//' xsl/mathml2/README > README-xsltml
96touch -r xsl/mathml2/README README-xsltml
97%__cp -p %{SOURCE1} COPYING-docbook-xsl
98
99 
100%clean
101%__rm -rf $RPM_BUILD_ROOT
102
103
104%files
105%defattr(-,root,root,-)
106%{_mandir}/man1/dblatex.1*
107%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
108%{python_sitelib}/dbtexmf/
109%{python_sitelib}/dblatex-*.egg-info
110%{_bindir}/dblatex
111%{_datadir}/dblatex/
112%{_datadir}/texmf/tex/latex/dblatex/
113%dir %{_sysconfdir}/dblatex
114
115%post -p /usr/bin/texhash
116
117%postun -p /usr/bin/texhash
118
119%changelog
120* Fri Nov  8 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.4-1
121- new upstream release
122
123* Fri Dec 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-3
124- added R: texlive-collection-langcjk texlive-collection-bibtexextra [Vine Linux 0002511]
125
126* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-2
127- rebuild with Python 2.7.2
128
129* Fri Jan 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
130- new upstream release
131
132* Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.3-1
133- initial build
134
135* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
137
138* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3-2
139- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
140
141* Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
142- Update to 0.3
143- Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
144
145* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
147
148* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-2
149- remove dblatex-0.2.9-xetex.patch
150
151* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-1
152- Update to 0.2.10
153
154* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
156
157* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.9-3
158- Rebuild for Python 2.6
159
160* Fri Jul  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-2
161- BR: texlive-xetex -> tex(xetex) for F-10 and later
162
163* Thu Jun 12 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-1
164- Update to latest upstream (0.2.9) (#448953)
165- Remove some redundant Requires and BuildRequires (passivetex pulls
166  in the tetex/tex requires, python dep added automatically)
167- For F-9+ BR on tex(latex) and texlive-xetex, fix the installation
168  scripts to install extra new files.
169- Add patch from dblatex mailing list for better handling of a missing
170  xetex.
171- Conditionally add .egg-info file only if F9+ to allow for unified
172  spec file
173
174* Sun Dec 16 2007 Patrice Dumas <pertusus@free.fr> - 0.2.8-2.1
175- don't install in docbook directory, it is a link to a versioned
176  directory and may break upon docbook update (#425251,#389231)
177
178* Sun Nov 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.8-1
179- Update to 0.2.8
180
181* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-16
182- convert spec to utf8
183- change to gplv2+
184
185* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-15
186- Add copyright info
187
188* Mon Nov  5 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-14
189- Req tetex-fonts for texhash
190- Fix post, postun
191
192* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-13
193- Add texhash
194
195* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
196- Fix xsl link
197
198* Sat Nov  3 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
199- Various fixes from pertusus@free.fr:
200- rm iconv stuff
201- simplify docs installation
202
203* Fri Nov  2 2007  <ndbecker2@gmail.com> - 0.2.7-11
204- Various minor fixes
205
206* Thu Nov  1 2007  <ndbecker2@gmail.com> - 0.2.7-10
207- Add some reqs and brs
208- rmdir /usr/share/dblatex/latex/{misc,contrib/example,style}
209
210* Sat Oct 27 2007  <ndbecker2@gmail.com> - 0.2.7-9
211- link /usr/share/dblatex/xsl -> /usr/share/sgml/docbook/xsl-stylesheets/dblatex
212- rmdir /usr/share/dblatex/latex/{misc,specs,style}
213- own /etc/dblatex
214- change $(...) -> `...`
215- Preserve timestamps on iconv
216
217* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-9
218- mv all .sty files to datadir/texmf/tex/latex/dblatex
219- Add Conflicts tetex-tex4ht
220- mv all xsl stuff to datadir/sgml/docbook/xsl-stylesheets/dblatex/
221
222* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
223- rm redundant latex files
224
225* Tue Sep 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
226- Fixed encodings in docs directory
227- Install docs at correct location
228
229* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-7
230- Revert back to GPLv2
231- untabify
232
233* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-6
234- Fix source URL
235- Install all docs
236- Tabify
237
238* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-5
239- Add BR tetex-latex
240
241* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-4
242- Add  BR tetex, ImageMagick
243
244* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-3
245- Add BR libxslt
246
247* Wed Sep 19 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-2
248- Add BR python-devel
249
250* Fri Sep  7 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-1
251- Initial
252
253
254
Note: See TracBrowser for help on using the repository browser.