source: projects/specs/trunk/d/dblatex/dblatex-vl.spec @ 7779

Revision 7779, 8.3 KB checked in by munepi, 11 years ago (diff)

supported TeX Live 2013

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           dblatex
4Version:        0.3.2
5Release:        4%{?_dist_release}
6Summary:        DocBook to LaTeX/ConTeXt Publishing
7BuildArch:      noarch
8Group:          Applications/Publishing
9License:        GPLv2+
10URL:            http://dblatex.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12#Source1:        http://docbook.sourceforge.net/release/xsl/current/COPYING
13Source1:        COPYING-docbook-xsl
14Patch0:         dblatex-0.2.7-external-which.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  python-devel
18BuildRequires:  python-which
19BuildRequires:  libxslt docbook-dtds ImageMagick
20## Need epstopdf, fig2dev
21BuildRequires:  texlive-collection-fontutils
22BuildRequires:  transfig
23BuildRequires:  texlive-vtlpkg >= 2013
24##BuildRequires:  tex(latex)
25##BuildRequires:  tex(xetex)
26BuildRequires:  texlive >= 2013
27## appendix.sty, changebar.sty, footmisc.sty, multirow.sty,
28## overpic.sty, subfigure.sty, titlesec.sty
29BuildRequires:  texlive-collection-latexextra
30## stmaryrd.sty
31BuildRequires:  texlive-collection-mathextra
32BuildRequires:  texlive-collection-htmlxml
33Requires:       libxslt docbook-dtds ImageMagick
34##Requires:       tex(xetex)
35Requires:       texlive >= 2013
36Requires:       texlive-collection-latexextra
37Requires:       transfig
38BuildRequires:  texlive-collection-mathextra
39##Requires:     passivetex
40Requires:       texlive-collection-htmlxml
41
42## $ rpm -qf --qf "%{name}\n" $(kpsewhich $(grep "usepackage" $(rpm -ql dblatex | grep sty) | sed -e "s,.*{,," -e "s,}.*$,.sty,")) | sort | uniq
43Requires:       texlive-collection-langcjk texlive-collection-bibtexextra
44
45%description
46dblatex is a program that transforms your SGML/XMLDocBook
47documents to DVI, PostScript or PDF by translating them
48into pure LaTeX as a first process.  MathML 2.0 markups
49are supported, too. It started as a clone of DB2LaTeX.
50
51Authors:
52--------
53   Benoît Guillon <marsgui at users dot sourceforge dot net>
54   Andreas Hoenen <andreas dot hoenen at arcor dot de>
55
56
57%prep
58%setup -q
59%patch0 -p1 -b .external-which
60%__rm -rf lib/contrib
61
62%build
63%{__python} setup.py build
64
65
66%install
67%__rm -rf $RPM_BUILD_ROOT
68#%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
69%{__python} setup.py install --root $RPM_BUILD_ROOT
70# these are already in tetex-latex:
71for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
72  %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
73done
74
75%__mkdir_p $RPM_BUILD_ROOT%{_tl_texmfvine}/tex/latex/dblatex
76for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
77  %__mv $file $RPM_BUILD_ROOT%{_tl_texmfvine}/tex/latex/dblatex/`basename $file` || exit 1;
78done
79
80## also move .xetex files
81for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
82  %__mv $file $RPM_BUILD_ROOT%{_tl_texmfvine}/tex/latex/dblatex/`basename $file` || exit 1;
83done
84
85%__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
86
87%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/dblatex
88# shipped in %%docs
89%__rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/
90
91%__sed -e 's/\r//' xsl/mathml2/README > README-xsltml
92touch -r xsl/mathml2/README README-xsltml
93%__cp -p %{SOURCE1} COPYING-docbook-xsl
94
95 
96%clean
97%__rm -rf $RPM_BUILD_ROOT
98
99
100%post
101%_tl_touch_run texhash
102exit 0
103
104%postun
105if [ "$1" = 0 ]; then
106   %_tl_touch_run texhash
107fi
108exit 0
109
110%posttrans
111%{_tl_exec_texhash}
112exit 0
113
114
115%files
116%defattr(-,root,root,-)
117%{_mandir}/man1/dblatex.1*
118%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
119%{python_sitelib}/dbtexmf/
120%{python_sitelib}/dblatex-*.egg-info
121%{_bindir}/dblatex
122%{_datadir}/dblatex/
123%{_tl_texmfvine}/tex/latex/dblatex/
124%dir %{_sysconfdir}/dblatex
125
126
127%changelog
128* Thu Aug 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-4
129- added BuildRequires: texlive-vtlpkg
130
131* Fri Dec 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-3
132- added R: texlive-collection-langcjk texlive-collection-bibtexextra [Vine Linux 0002511]
133
134* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-2
135- rebuild with Python 2.7.2
136
137* Fri Jan 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
138- new upstream release
139
140* Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.3-1
141- initial build
142
143* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
145
146* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3-2
147- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
148
149* Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
150- Update to 0.3
151- Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
152
153* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
155
156* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-2
157- remove dblatex-0.2.9-xetex.patch
158
159* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-1
160- Update to 0.2.10
161
162* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
164
165* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.9-3
166- Rebuild for Python 2.6
167
168* Fri Jul  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-2
169- BR: texlive-xetex -> tex(xetex) for F-10 and later
170
171* Thu Jun 12 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-1
172- Update to latest upstream (0.2.9) (#448953)
173- Remove some redundant Requires and BuildRequires (passivetex pulls
174  in the tetex/tex requires, python dep added automatically)
175- For F-9+ BR on tex(latex) and texlive-xetex, fix the installation
176  scripts to install extra new files.
177- Add patch from dblatex mailing list for better handling of a missing
178  xetex.
179- Conditionally add .egg-info file only if F9+ to allow for unified
180  spec file
181
182* Sun Dec 16 2007 Patrice Dumas <pertusus@free.fr> - 0.2.8-2.1
183- don't install in docbook directory, it is a link to a versioned
184  directory and may break upon docbook update (#425251,#389231)
185
186* Sun Nov 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.8-1
187- Update to 0.2.8
188
189* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-16
190- convert spec to utf8
191- change to gplv2+
192
193* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-15
194- Add copyright info
195
196* Mon Nov  5 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-14
197- Req tetex-fonts for texhash
198- Fix post, postun
199
200* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-13
201- Add texhash
202
203* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
204- Fix xsl link
205
206* Sat Nov  3 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
207- Various fixes from pertusus@free.fr:
208- rm iconv stuff
209- simplify docs installation
210
211* Fri Nov  2 2007  <ndbecker2@gmail.com> - 0.2.7-11
212- Various minor fixes
213
214* Thu Nov  1 2007  <ndbecker2@gmail.com> - 0.2.7-10
215- Add some reqs and brs
216- rmdir /usr/share/dblatex/latex/{misc,contrib/example,style}
217
218* Sat Oct 27 2007  <ndbecker2@gmail.com> - 0.2.7-9
219- link /usr/share/dblatex/xsl -> /usr/share/sgml/docbook/xsl-stylesheets/dblatex
220- rmdir /usr/share/dblatex/latex/{misc,specs,style}
221- own /etc/dblatex
222- change $(...) -> `...`
223- Preserve timestamps on iconv
224
225* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-9
226- mv all .sty files to datadir/texmf/tex/latex/dblatex
227- Add Conflicts tetex-tex4ht
228- mv all xsl stuff to datadir/sgml/docbook/xsl-stylesheets/dblatex/
229
230* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
231- rm redundant latex files
232
233* Tue Sep 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
234- Fixed encodings in docs directory
235- Install docs at correct location
236
237* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-7
238- Revert back to GPLv2
239- untabify
240
241* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-6
242- Fix source URL
243- Install all docs
244- Tabify
245
246* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-5
247- Add BR tetex-latex
248
249* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-4
250- Add  BR tetex, ImageMagick
251
252* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-3
253- Add BR libxslt
254
255* Wed Sep 19 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-2
256- Add BR python-devel
257
258* Fri Sep  7 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-1
259- Initial
260
261
262
Note: See TracBrowser for help on using the repository browser.