source: projects/specs/trunk/d/dblatex/dblatex-vl.spec @ 7273

Revision 7273, 8.1 KB checked in by munepi, 11 years ago (diff)

added R: texlive-collection-langcjk texlive-collection-bibtexextra [Vine Linux 0002511]

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           dblatex
4Version:        0.3.2
5Release:        3%{?_dist_release}
6Summary:        DocBook to LaTeX/ConTeXt Publishing
7BuildArch:      noarch
8Group:          Applications/Publishing
9License:        GPLv2+
10URL:            http://dblatex.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12#Source1:        http://docbook.sourceforge.net/release/xsl/current/COPYING
13Source1:        COPYING-docbook-xsl
14Patch0:         dblatex-0.2.7-external-which.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  python-devel
18BuildRequires:  python-which
19BuildRequires:  libxslt docbook-dtds ImageMagick
20## Need epstopdf, fig2dev
21BuildRequires:  texlive-collection-fontutils
22BuildRequires:  transfig
23##BuildRequires:  tex(latex)
24##BuildRequires:  tex(xetex)
25BuildRequires:  texlive-common >= 2009
26## appendix.sty, changebar.sty, footmisc.sty, multirow.sty,
27## overpic.sty, subfigure.sty, titlesec.sty
28BuildRequires:  texlive-collection-latexextra
29## stmaryrd.sty
30BuildRequires:  texlive-collection-mathextra
31BuildRequires:  texlive-collection-htmlxml
32Requires:       libxslt docbook-dtds ImageMagick
33##Requires:       tex(xetex)
34Requires:       texlive-common >= 2009
35Requires:       texlive-collection-latexextra
36Requires:       transfig
37BuildRequires:  texlive-collection-mathextra
38##Requires:     passivetex
39Requires:       texlive-collection-htmlxml
40
41## $ rpm -qf --qf "%{name}\n" $(kpsewhich $(grep "usepackage" $(rpm -ql dblatex | grep sty) | sed -e "s,.*{,," -e "s,}.*$,.sty,")) | sort | uniq
42Requires:       texlive-collection-langcjk texlive-collection-bibtexextra
43
44%description
45dblatex is a program that transforms your SGML/XMLDocBook
46documents to DVI, PostScript or PDF by translating them
47into pure LaTeX as a first process.  MathML 2.0 markups
48are supported, too. It started as a clone of DB2LaTeX.
49
50Authors:
51--------
52   Benoît Guillon <marsgui at users dot sourceforge dot net>
53   Andreas Hoenen <andreas dot hoenen at arcor dot de>
54
55
56%prep
57%setup -q
58%patch0 -p1 -b .external-which
59%__rm -rf lib/contrib
60
61%build
62%{__python} setup.py build
63
64
65%install
66%__rm -rf $RPM_BUILD_ROOT
67#%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
68%{__python} setup.py install --root $RPM_BUILD_ROOT
69# these are already in tetex-latex:
70for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
71  %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
72done
73
74%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex
75for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
76  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
77done
78
79## also move .xetex files
80for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
81  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
82done
83
84%__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
85
86%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/dblatex
87# shipped in %%docs
88%__rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/
89
90%__sed -e 's/\r//' xsl/mathml2/README > README-xsltml
91touch -r xsl/mathml2/README README-xsltml
92%__cp -p %{SOURCE1} COPYING-docbook-xsl
93
94 
95%clean
96%__rm -rf $RPM_BUILD_ROOT
97
98
99%files
100%defattr(-,root,root,-)
101%{_mandir}/man1/dblatex.1*
102%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
103%{python_sitelib}/dbtexmf/
104%{python_sitelib}/dblatex-*.egg-info
105%{_bindir}/dblatex
106%{_datadir}/dblatex/
107%{_datadir}/texmf/tex/latex/dblatex/
108%dir %{_sysconfdir}/dblatex
109
110%post -p /usr/bin/texhash
111
112%postun -p /usr/bin/texhash
113
114%changelog
115* Fri Dec 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-3
116- added R: texlive-collection-langcjk texlive-collection-bibtexextra [Vine Linux 0002511]
117
118* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-2
119- rebuild with Python 2.7.2
120
121* Fri Jan 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
122- new upstream release
123
124* Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.3-1
125- initial build
126
127* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
129
130* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3-2
131- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
132
133* Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
134- Update to 0.3
135- Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
136
137* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
139
140* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-2
141- remove dblatex-0.2.9-xetex.patch
142
143* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-1
144- Update to 0.2.10
145
146* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
148
149* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.9-3
150- Rebuild for Python 2.6
151
152* Fri Jul  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-2
153- BR: texlive-xetex -> tex(xetex) for F-10 and later
154
155* Thu Jun 12 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-1
156- Update to latest upstream (0.2.9) (#448953)
157- Remove some redundant Requires and BuildRequires (passivetex pulls
158  in the tetex/tex requires, python dep added automatically)
159- For F-9+ BR on tex(latex) and texlive-xetex, fix the installation
160  scripts to install extra new files.
161- Add patch from dblatex mailing list for better handling of a missing
162  xetex.
163- Conditionally add .egg-info file only if F9+ to allow for unified
164  spec file
165
166* Sun Dec 16 2007 Patrice Dumas <pertusus@free.fr> - 0.2.8-2.1
167- don't install in docbook directory, it is a link to a versioned
168  directory and may break upon docbook update (#425251,#389231)
169
170* Sun Nov 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.8-1
171- Update to 0.2.8
172
173* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-16
174- convert spec to utf8
175- change to gplv2+
176
177* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-15
178- Add copyright info
179
180* Mon Nov  5 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-14
181- Req tetex-fonts for texhash
182- Fix post, postun
183
184* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-13
185- Add texhash
186
187* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
188- Fix xsl link
189
190* Sat Nov  3 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
191- Various fixes from pertusus@free.fr:
192- rm iconv stuff
193- simplify docs installation
194
195* Fri Nov  2 2007  <ndbecker2@gmail.com> - 0.2.7-11
196- Various minor fixes
197
198* Thu Nov  1 2007  <ndbecker2@gmail.com> - 0.2.7-10
199- Add some reqs and brs
200- rmdir /usr/share/dblatex/latex/{misc,contrib/example,style}
201
202* Sat Oct 27 2007  <ndbecker2@gmail.com> - 0.2.7-9
203- link /usr/share/dblatex/xsl -> /usr/share/sgml/docbook/xsl-stylesheets/dblatex
204- rmdir /usr/share/dblatex/latex/{misc,specs,style}
205- own /etc/dblatex
206- change $(...) -> `...`
207- Preserve timestamps on iconv
208
209* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-9
210- mv all .sty files to datadir/texmf/tex/latex/dblatex
211- Add Conflicts tetex-tex4ht
212- mv all xsl stuff to datadir/sgml/docbook/xsl-stylesheets/dblatex/
213
214* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
215- rm redundant latex files
216
217* Tue Sep 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
218- Fixed encodings in docs directory
219- Install docs at correct location
220
221* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-7
222- Revert back to GPLv2
223- untabify
224
225* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-6
226- Fix source URL
227- Install all docs
228- Tabify
229
230* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-5
231- Add BR tetex-latex
232
233* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-4
234- Add  BR tetex, ImageMagick
235
236* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-3
237- Add BR libxslt
238
239* Wed Sep 19 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-2
240- Add BR python-devel
241
242* Fri Sep  7 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-1
243- Initial
244
245
246
Note: See TracBrowser for help on using the repository browser.