source: projects/specs/trunk/d/db43/db43-vl.spec @ 521

Revision 521, 27.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
4%define java_arches %{ix86} alpha ia64 ppc ppc64 s390 s390x sparc sparcv9 x86_64
5
6##VINE##
7%undefine java_arches
8
9# compatibility with legacy versions of rpm
10%{!?_lib:%define _lib   lib}
11
12%define __soversion     4.3
13%define _libdb_a        libdb-%{__soversion}.a
14%define _libcxx_a       libdb_cxx-%{__soversion}.a
15
16
17Summary: The Berkeley DB database library (version 4) for C.
18Name: db43
19Version: 4.3.29
20Release: 10%{?_dist_release}
21Source: http://www.sleepycat.com/update/%{version}/db-%{version}.tar.gz
22Source1: http://www.sleepycat.com/update/1.85/db.1.85.tar.gz
23Source2: nptl-abi-note.S
24Patch1: db-4.3.29-64bit.patch
25Patch2: db-4.2.52-gcj.patch
26Patch3: db-4.3.29-sparc64.patch
27Patch10: http://www.sleepycat.com/update/1.85/patch.1.1
28Patch11: http://www.sleepycat.com/update/1.85/patch.1.2
29Patch12: http://www.sleepycat.com/update/1.85/patch.1.3
30Patch13: http://www.sleepycat.com/update/1.85/patch.1.4
31Patch14: db-1.85-errno.patch
32
33# Security/Bug Patches
34# http://www.oracle.com/technology/products/berkeley-db/db/update/4.3.29/patch.4.3.29.html
35Patch100: patch.4.3.29.1
36
37URL: http://www.sleepycat.com/
38License: GPL
39Group: System Environment/Libraries
40Obsoletes: db1, db2, db3
41BuildRequires: perl, libtool, ed, tcl >= 8.4.4
42%ifarch %{java_arches}
43BuildRequires: gcc-java
44BuildRequires: java-1.4.2-gcj-compat
45BuildRequires: java-1.4.2-gcj-compat-devel
46%endif
47BuildRoot: %{_tmppath}/%{name}-root
48
49
50%description
51The Berkeley Database (Berkeley DB) is a programmatic toolkit that
52provides embedded database support for both traditional and
53client/server applications. The Berkeley DB includes B+tree, Extended
54Linear Hashing, Fixed and Variable-length record access methods,
55transactions, locking, logging, shared memory caching, and database
56recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
57used by many applications, including Python and Perl, so this should
58be installed on all systems.
59
60
61%package -n compat32-%{name}
62Summary: The Berkeley DB database library (version 4) for C.
63Group: System Environment/Libraries
64Requires: db4 = %{version}-%{release}
65
66
67%description -n compat32-%{name}
68The Berkeley Database (Berkeley DB) is a programmatic toolkit that
69provides embedded database support for both traditional and
70client/server applications. The Berkeley DB includes B+tree, Extended
71Linear Hashing, Fixed and Variable-length record access methods,
72transactions, locking, logging, shared memory caching, and database
73recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
74used by many applications, including Python and Perl, so this should
75be installed on all systems.
76
77
78%package utils
79Summary: Command line tools for managing Berkeley DB (version 4) databases.
80Group: Applications/System
81Requires: db4 = %{version}-%{release}
82Obsoletes: db2-utils, db3-utils
83
84
85%description utils
86The Berkeley Database (Berkeley DB) is a programmatic toolkit that
87provides embedded database support for both traditional and
88client/server applications. Berkeley DB includes B+tree, Extended
89Linear Hashing, Fixed and Variable-length record access methods,
90transactions, locking, logging, shared memory caching, and database
91recovery. DB supports C, C++, Java and Perl APIs.
92
93This package contains command line tools for managing Berkeley DB
94(version 4) databases.
95
96
97%package devel
98Summary: Development files for the Berkeley DB (version 4) library.
99Group: Development/Libraries
100Requires: db4 = %{version}-%{release}
101Obsoletes: db2-devel, db3-devel
102
103
104%description devel
105The Berkeley Database (Berkeley DB) is a programmatic toolkit that
106provides embedded database support for both traditional and
107client/server applications. This package contains the header files,
108libraries, and documentation for building programs which use the
109Berkeley DB.
110
111
112%package -n compat32-%{name}-devel
113Summary: Development files for the Berkeley DB (version 4) library.
114Group: Development/Libraries
115Requires: compat32-%{name} = %{version}-%{release}
116Requires: %{name}-devel    = %{version}-%{release}
117
118
119%description -n compat32-%{name}-devel
120The Berkeley Database (Berkeley DB) is a programmatic toolkit that
121provides embedded database support for both traditional and
122client/server applications. This package contains the header files,
123libraries, and documentation for building programs which use the
124Berkeley DB.
125
126
127%package tcl
128Summary: Development files for using the Berkeley DB (version 4) with tcl.
129Group: Development/Libraries
130Requires: %{name} = %{version}-%{release}
131
132
133%description tcl
134The Berkeley Database (Berkeley DB) is a programmatic toolkit that
135provides embedded database support for both traditional and
136client/server applications. This package contains the libraries
137for building programs which use the Berkeley DB in Tcl.
138
139
140%package -n compat32-%{name}-tcl
141Summary: Development files for using the Berkeley DB (version 4) with tcl.
142Group: Development/Libraries
143Requires: compat32-%{name} = %{version}-%{release}
144Requires: %{name}-tcl      = %{version}-%{release}
145
146
147%description -n compat32-%{name}-tcl
148The Berkeley Database (Berkeley DB) is a programmatic toolkit that
149provides embedded database support for both traditional and
150client/server applications. This package contains the libraries
151for building programs which use the Berkeley DB in Tcl.
152
153
154%package java
155Summary: Development files for using the Berkeley DB (version 4) with Java.
156Group: Development/Libraries
157Requires: %{name} = %{version}-%{release}
158
159
160%description java
161The Berkeley Database (Berkeley DB) is a programmatic toolkit that
162provides embedded database support for both traditional and
163client/server applications. This package contains the libraries
164for building programs which use the Berkeley DB in Java.
165
166
167%prep
168%setup -q -n db-%{version} -a 1
169%patch1 -p1 -b .64bit
170%patch2 -p1 -b .gcj
171%patch3 -p1 -b .sparc64
172
173pushd dist
174#libtoolize --copy --force
175#cat %{_datadir}/aclocal/libtool.m4 >> aclocal.m4
176popd
177pushd db.1.85/PORT/linux
178%patch10 -p0 -b .1
179popd
180pushd db.1.85
181%patch11 -p0 -b .1
182%patch12 -p0 -b .2
183%patch13 -p0 -b .3
184%patch14 -p1 -b .errno
185popd
186
187%patch100 -p0 -b .1
188
189# Remove tags files which we don't need.
190find . -name tags | xargs rm -f
191# Define a shell function for fixing HREF references in the docs, which
192# would otherwise break when we split the docs up into subpackages.
193fixup_href() {
194    for doc in $@ ; do
195        chmod u+w ${doc}
196        sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
197            -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
198            -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
199            -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
200            -e 's,="../api_java/,="../../%{name}-devel-%{version}/api_java/,g' \
201            -e 's,="api_java/,="../%{name}-devel-%{version}/api_java/,g' \
202            -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
203            -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
204            -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
205            -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
206            -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
207            -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
208            -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
209            -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
210            -e 's,="../sleepycat/,="../../%{name}-devel-%{version}/sleepycat/,g' \
211            -e 's,="sleepycat/,="../%{name}-devel-%{version}/sleepycat/,g' \
212            -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
213            -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
214            -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
215            -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
216        touch -r ${doc} ${doc}.new
217        cat ${doc}.new > ${doc}
218        touch -r ${doc}.new ${doc}
219        rm -f ${doc}.new
220    done
221}
222
223set +x  # XXX painful to watch
224# Fix all of the HTML files.
225fixup_href `find . -name "*.html"`
226set -x  # XXX painful to watch
227
228cd dist
229#./s_config
230
231
232%build
233CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
234
235# Build the old db-185 libraries.
236make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
237
238build() {
239        test -d dist/$1 || mkdir dist/$1
240        # Static link db_dump185 with old db-185 libraries.
241        /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
242        /bin/sh libtool --mode=link    %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
243        pushd dist/$1
244        # Force the threading model used, for selecting whether or not we will
245        # depend on NPTL-specific features.
246        echo ${2:+db_cv_mutex=$2} > config.cache
247        if test -n "$nptl_lo" ; then
248                /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS \
249                        -o $nptl_lo -c $nptl_s
250        fi
251        ln -sf ../configure .
252        # XXX --enable-diagnostic should be disabled for production (but is
253        # useful).
254        # XXX --enable-debug_{r,w}op should be disabled for production.
255        %configure -C \
256                --enable-compat185 --enable-dump185 \
257                --enable-shared --enable-static --enable-rpc \
258                --enable-tcl --with-tcl=%{_libdir} \
259                --enable-cxx \
260%ifarch %{java_arches}
261                --enable-java \
262%else
263                --disable-java \
264%endif
265                --enable-test \
266                # --enable-diagnostic \
267                # --enable-debug --enable-debug_rop --enable-debug_wop \
268
269        # Remove libtool predep_objects and postdep_objects wonkiness so that
270        # building without -nostdlib doesn't include them twice.  Because we
271        # already link with g++, weird stuff happens if you don't let the
272        # compiler handle this.
273        perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
274        perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
275        perl -pi -e 's/-shared -nostdlib/-shared/' libtool
276
277#       make libdb=%{_libdb_a} libcxx=%{_libcxx_a} %{?_smp_mflags} \
278        make                                       %{?_smp_mflags} \
279                 LIBSO_LIBS='$(LIBS)'" $nptl_lo" \
280                LIBXSO_LIBS='$(LIBS)'" $nptl_lo" \
281                LIBJSO_LIBS='$(LIBS)'" $nptl_lo" \
282                LIBTSO_LIBS='$(LIBS)'" $nptl_lo"
283
284        # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
285        LDBJ=./.libs/libdb_java-%{__soversion}.la
286        if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
287            sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
288        fi
289
290        popd
291}
292
293unset nptl_s nptl_lo
294case %{_os} in
295linux|Linux)
296        nptl_s=%{SOURCE2}
297        nptl_lo=nptl-abi-note.lo
298        ;;
299esac
300build dist-tls POSIX/pthreads/library
301unset nptl_s nptl_lo
302
303
304%install
305rm -rf ${RPM_BUILD_ROOT}
306mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
307mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
308
309%makeinstall -C dist/dist-tls
310
311# XXX Nuke non-versioned archives and symlinks
312rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
313rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
314rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
315rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
316rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
317
318chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
319
320# Move the main shared library from /usr/lib* to /lib* directory.
321if [ "%{_libdir}" != "/%{_lib}" ]; then
322  mkdir -p $RPM_BUILD_ROOT/%{_lib}/
323  mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
324
325# Leave relative symlinks in %{_libdir}.
326  touch $RPM_BUILD_ROOT/rootfile
327  root=..
328  while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
329    root=${root}/..
330  done
331  rm $RPM_BUILD_ROOT/rootfile
332
333  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
334  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
335  ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
336fi
337
338# Move the header files to a subdirectory, in case we're deploying on a
339# system with multiple versions of DB installed.
340mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
341mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
342
343# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
344for i in db.h db_cxx.h db_185.h; do
345        ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
346done
347
348%ifarch %{java_arches}
349# Move java jar file to the correct place
350mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
351mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
352%endif
353
354# Eliminate installed doco
355rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
356
357# XXX Avoid Permission denied. strip when building as non-root.
358chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
359
360
361%clean
362rm -rf ${RPM_BUILD_ROOT}
363
364
365%post -p /sbin/ldconfig
366
367%postun -p /sbin/ldconfig
368
369%post -n compat32-%{name} -p /sbin/ldconfig
370
371%postun -n compat32-%{name} -p /sbin/ldconfig
372
373%post -p /sbin/ldconfig tcl
374
375%postun -p /sbin/ldconfig tcl
376
377%post -n compat32-%{name}-tcl -p /sbin/ldconfig
378
379%postun -n compat32-%{name}-tcl -p /sbin/ldconfig
380
381%post -p /sbin/ldconfig java
382
383%postun -p /sbin/ldconfig java
384
385
386%files
387%defattr(-,root,root)
388%doc LICENSE README
389/%{_lib}/libdb-%{__soversion}.so
390%{_libdir}/libdb-%{__soversion}.so
391%{_libdir}/libdb_cxx-%{__soversion}.so
392
393
394#%files utils
395#%defattr(-,root,root)
396#%doc   docs/utility
397#%{_bindir}/berkeley_db*_svc
398#%{_bindir}/db*_archive
399#%{_bindir}/db*_checkpoint
400#%{_bindir}/db*_deadlock
401#%{_bindir}/db*_dump*
402#%{_bindir}/db*_load
403#%{_bindir}/db*_printlog
404#%{_bindir}/db*_recover
405#%{_bindir}/db*_stat
406#%{_bindir}/db*_upgrade
407#%{_bindir}/db*_verify
408
409
410#%files devel
411#%defattr(-,root,root)
412#%doc   docs/api_c docs/api_cxx docs/api_tcl docs/index.html
413#%doc   docs/ref docs/sleepycat docs/images
414#%doc   examples_c examples_cxx
415#%{_libdir}/libdb.so
416#%{_libdir}/libdb_cxx.so
417#%{_libdir}/libdb-%{__soversion}.la
418#%{_libdir}/libdb_cxx-%{__soversion}.la
419#%{_libdir}/%{_libdb_a}
420#%{_libdir}/%{_libcxx_a}
421#%{_includedir}/%{name}
422#%{_includedir}/*.h
423
424
425#%files tcl
426#%defattr(-,root,root)
427#%{_libdir}/libdb_tcl-%{__soversion}.a
428#%{_libdir}/libdb_tcl-%{__soversion}.la
429#%{_libdir}/libdb_tcl-%{__soversion}.so
430
431
432#%ifarch %{java_arches}
433#%files java
434#%defattr(-,root,root)
435#%doc docs/java
436#%doc examples_java
437#%{_libdir}/libdb_java*
438#%{_datadir}/java/*.jar
439#%endif
440
441
442%if %{build_compat32}
443%files -n compat32-%{name}
444%defattr(-,root,root)
445/%{_lib}/libdb-%{__soversion}.so
446%{_libdir}/libdb-%{__soversion}.so
447%{_libdir}/libdb_cxx-%{__soversion}.so
448
449
450#%files -n compat32-%{name}-devel
451#%defattr(-,root,root)
452#%{_libdir}/libdb.so
453#%{_libdir}/libdb-%{__soversion}.la
454#%{_libdir}/libdb_cxx-%{__soversion}.la
455#%{_libdir}/%{_libdb_a}
456#%{_libdir}/%{_libcxx_a}
457
458
459#%files -n compat32-%{name}-tcl
460#%defattr(-,root,root)
461#%{_libdir}/libdb_tcl-%{__soversion}.a
462#%{_libdir}/libdb_tcl-%{__soversion}.la
463#%{_libdir}/libdb_tcl-%{__soversion}.so
464%endif
465
466
467%changelog
468* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.3.29-10
469- package name changed to db43
470- temporarily commented out "libtoolize" and "s_config" lines
471  until Vine's autotools get updated (maybe?)
472
473* Tue May 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.3.29-9vl1
474- based on 4.3.29-9.fc6, merged changes from 4.2.52-6vl7
475
476  - Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.52-6vl6
477  - changed db4-utils Group to Applications/System <BTS:VineLinux:163>
478  - changed *-devel Group to Development/Libraries
479  - changed db4-tcl Group to Devalopment/Libraries
480
481  - Fri Feb 10 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.2.52-6vl5
482  - added compat32-* packages for x86_64 architecture support
483
484* Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
485- rebuild
486
487* Wed Sep  6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
488- revert the previous fix, it crashes OOo help
489
490* Sun Sep  3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
491- fix memleak caused by SET_TXN macro in xa_db.c, when opening
492  database created with DB_XA_CREATE flag (#204920)
493
494* Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
495- fix sparc64 build (#199358)
496
497* Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
498- rebuild because of gnu_hash
499
500* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
501- rebuild
502
503* Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
504- drop useless java, lfs patches
505
506* Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
507- apply x86_64 fix from Henrik Nordstrom (#184588)
508- don't nuke non-versioned archives twice
509
510* Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
511- don't package /usr/share/doc/images in the main db4 package
512  and move it to db4-devel (#33328)
513- make db4 LFS capable (#33849)
514- move db4-devel, db4-tcl, db4-java to Development/Libraries
515  group instead of System Environment/Libraries (#54320)
516- BuildPrereq -> BuildRequires
517- don't use RPM_SOURCE_DIR
518- Obsoletes db3, db2
519
520* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
521- bump again for double-long bug on ppc(64)
522
523* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
524- rebuilt for new gcc4.1 snapshot and glibc changes
525
526* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
527- rebuilt
528
529* Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
530- New upstream release
531
532* Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
533- Re-enable java for ppc64
534
535* Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
536- Add fno-strict-aliasing for java (#168965)
537
538* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
539- no java for ppc64 for now (#166657)
540
541* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
542- FC5 is nptl only (derived from jbj's spec)
543- upgrade to 4.3.28
544
545* Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
546- re-enable db4-java
547
548* Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
549- /usr/lib/tls/ix86 dirs (#151371)
550
551* Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
552- add libdb_cxx.so link (#149191)
553
554* Fri Mar  4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
555- rebuild with gcc4.
556
557* Sat Jan  1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
558- upgrade to 4.3.27.
559
560* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
561- upgrade to 4.3.21, no db4-java for the moment again again.
562
563* Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
564- on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
565  the availability of an NPTL libpthread in glibc > 2.3.3-48
566- run ldconfig in db4-java's %%post/%%postun
567- when building java support, assume that libgcj is equivalent enough to 1.3
568
569* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
570- rebuilt
571
572* Mon Jun  7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
573- remove dangling symlinks (#123721 et al).
574- remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
575- apply 2 patches from sleepycat.
576- resurrect db4-java using sun jvm-1.4.2.
577- cripple autoconf sufficiently to build db4-java with gcj, without jvm.
578- check javac first, gcj34 next, then gcj-ssa, finally gcj.
579- add ed build dependency (#125180).
580
581* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
582- rebuilt
583
584* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
585- rebuilt
586
587* Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
588- fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
589
590* Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
591- upgrade to db-4.2.52, no db4-java for the moment.
592
593* Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
594- Add build requires tcl-devel
595
596* Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
597- symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
598  that the run-time linker can find the right copy for of apps which use an
599  RPATH to point at %%{_libdir}/libdb-4.1.so
600
601* Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
602- add another section to the ABI note for the TLS libdb so that it's marked as
603  not needing an executable stack (from Arjan Van de Ven)
604
605* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
606- build both with and without support for shared mutex locks, which require NPTL
607- make behavior wrt where we put libdb the same for all OSs
608- revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
609  doesn't work
610- fix dangling HREFs in utility docs (pointed to main docs dir, while they're
611  actually in the -utils docs dir)
612- run ldconfig when installing/removing the -utils subpackage, as it contains
613  shared libraries
614
615* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
616- fix multiple-inclusion problem of startup files when building shlibs without
617  the -nostdlib flag
618
619* Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
620- link shared libraries without -nostdlib, which created an unresolvable dep
621  on a hidden symbol
622
623* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
624- allow compiling without tcl dependency
625
626* Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
627- update to 4.2.42.
628- build in build_unix subdir.
629- eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
630- create db4-tcl sub-pkg to isolate libtcl dependencies.
631
632* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
633- rebuild
634
635* Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
636- add missing tcl-devel buildrequires (#101814)
637
638* Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
639- rebuild
640
641* Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
642- build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
643- whack out libtool predep_objects wonkiness.
644
645* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
646- rebuild.
647
648* Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
649- hack out O_DIRECT support in db4 for now.
650
651* Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
652- replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
653  cause a mismatch
654
655* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
656- rebuilt
657
658* Wed Jun  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
659- change configure to only warn if JNI includes aren't found, assuming that
660  the C compiler can find them
661- remove build requirement on jdkgcj -- gcj is sufficient
662
663* Mon May  5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
664- upgrade to 4.1.25, crypto version.
665- enable posix mutexes using nptl on all arches.
666
667* Mon Mar  3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
668- enabled db4-java for x86_64
669
670* Wed Feb  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
671- add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
672  linking with -ldb-4.0 will work again
673
674* Tue Feb  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
675- rebuild to use link the shared object with the same libraries we use
676  for the bundled utils, should pull in libpthread when needed
677- move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
678
679* Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
680- add java for s390x
681
682* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
683- rebuilt
684
685* Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
686- add java for s390
687
688* Tue Oct  8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
689- add java bits back in for x86 boxes
690
691* Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
692- Added better fix for s390/s390x/x86_64
693
694* Thu Sep 05 2002 Arjan van de Ven
695- remove java bits for x86-64
696
697* Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
698- include libdb_tcl-4.1.a library.
699- obsolete db1 packages.
700
701* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
702- include patch to avoid db_recover (#70362)
703
704* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
705- rebuilt with gcc-3.2 (we hope)
706
707* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
708- own %%{_includedir}/%{name}
709
710* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
711- build using gcc-3.2-0.1
712
713* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
714- automated rebuild
715
716* Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
717- Add java bindings
718- Fix C++ bindings
719
720* Thu May 23 2002 Tim Powers <timp@redhat.com>
721- automated rebuild
722
723* Thu May  9 2002 Jeff Johnson <jbj@redhat.com>
724- re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
725- make sure that -ldb is functional.
726
727* Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
728- avoid db_util name collisions with multiple versions installed.
729
730* Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
731- remove relocatability stuffs
732- swallow a local copy of db1 and build db185_dump statically with it, to
733  remove the build dependency and simplify bootstrapping new arches
734
735* Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
736- have subpackages obsolete their db3 counterparts, because they conflict anyway
737
738* Tue Jan  8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
739- upgrade to 4.0.14.
740
741* Sun Aug  5 2001 Nalin Dahyabhai <nalin@redhat.com>
742- fix dangling docs symlinks
743- fix dangling doc HREFs (#33328)
744- apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
745
746* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
747- turn off --enable-debug
748
749* Thu May 10 2001 Than Ngo <than@redhat.com>
750- fixed to build on s390x
751
752* Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
753- update to 3.2.9.
754
755* Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
756- rebuild to remove 777 directories.
757
758* Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
759- don't build with --enable-diagnostic.
760- add build prereq on tcl.
761- default value for %%_lib macro if not found.
762
763* Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
764- add /usr/lib/libdb-3.1.so symlink to %%files.
765- remove dangling tags symlink from examples.
766
767* Mon Oct  9 2000 Jeff Johnson <jbj@redhat.com>
768- rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
769- turn off --enable-diagnostic for performance.
770
771* Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
772- update to 3.1.17.
773- disable posix mutexes Yet Again.
774
775* Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
776- add c++ and posix mutex support.
777
778* Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
779- put nss_db into a separate package
780
781* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
782- rebuild to cope with glibc locale binary incompatibility, again
783
784* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
785- remove redundant strip of libnss_db* that is nuking symbols.
786- change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
787
788* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
789- summaries from specspo.
790- all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
791
792* Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
793- temporarily build nss_db in this package, should be moved
794  into separate nss_db package soon
795
796* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
797- rebuild to cope with glibc locale binary incompatibility
798
799* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
800- automatic rebuild
801
802* Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
803- upgrade to 3.1.14.
804- create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
805- FHS packaging.
806
807* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
808- disable tcl Yet Again, base packages cannot depend on libtcl.so.
809
810* Sat Jun  3 2000 Jeff Johnson <jbj@redhat.com>
811- enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
812
813* Tue May 30 2000 Matt Wilson <msw@redhat.com>
814- include /lib/libdb.so in the devel package
815
816* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
817- put in "System Environment/Libraries" per msw instructions.
818
819* Tue May  9 2000 Jeff Johnson <jbj@redhat.com>
820- install shared library in /lib, not /usr/lib.
821- move API docs to db3-devel.
822
823* Mon May  8 2000 Jeff Johnson <jbj@redhat.com>
824- don't rename db_* to db3_*.
825
826* Tue May  2 2000 Jeff Johnson <jbj@redhat.com>
827- disable --enable-test --enable-debug_rop --enable-debug_wop.
828- disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
829  problems.
830
831* Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
832- add 3.0.55.1 alignment patch.
833- add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
834- add --enable-tcl (needed -lpthreads).
835
836* Sat Apr  1 2000 Jeff Johnson <jbj@redhat.com>
837- add --enable-debug_{r,w}op for now.
838- add variable to set shm perms.
839
840* Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
841- update to 3.0.55
842
843* Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
844- Add --enable-cxx to configure.
845
846* Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
847- Create.
Note: See TracBrowser for help on using the repository browser.