source: projects/specs/trunk/d/db42/db42-vl.spec @ 521

Revision 521, 29.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2# the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
3%define java_arches %{ix86} alpha ia64 ppc ppc64 s390 s390x sparc sparcv9 x86_64
4# borrow the definition of nptl_arches from glibc's .spec file
5%define nptl_arches %{ix86}       ia64 ppc ppc64 s390 s390x       sparcv9 x86_64
6# define nptl_java_arches to be the intersection of java_arches and nptl_arches
7%define nptl_java_arches %{ix86}  ia64 ppc ppc64 s390 s390x       sparcv9 x86_64
8
9%undefine java_arches
10%undefine nptl_arches
11%undefine nptl_java_arches
12
13# compatibility with legacy versions of rpm
14%{!?_lib:%define _lib   lib}
15
16%define __soversion     4.2
17%define _libdb_a        libdb-%{__soversion}.a
18%define _libcxx_a       libdb_cxx-%{__soversion}.a
19
20Summary: The Berkeley DB database library (version 4) for C.
21Name: db42
22Version: 4.2.52
23Release: 6vl7
24Source: http://www.sleepycat.com/update/%{version}/db-%{version}.tar.gz
25Source1: http://www.sleepycat.com/update/1.85/db.1.85.tar.gz
26Source2: nptl-abi-note.S
27Patch0: db-4.1.25-no-jni-includes.patch
28Patch1: db-4.2.52-java.patch
29Patch2: patch.4.2.52.1
30Patch3: patch.4.2.52.2
31Patch4: db-4.2.52-gcj.patch
32Patch5: db-4.2.52-disable-pthreadsmutexes.patch
33Patch10: http://www.sleepycat.com/update/1.85/patch.1.1
34Patch11: http://www.sleepycat.com/update/1.85/patch.1.2
35Patch12: http://www.sleepycat.com/update/1.85/patch.1.3
36Patch13: http://www.sleepycat.com/update/1.85/patch.1.4
37Patch14: db-1.85-errno.patch
38URL: http://www.sleepycat.com/
39License: GPL
40Group: System Environment/Libraries
41#Obsoletes: db1, db1-devel
42Obsoletes: db1-devel
43BuildPreReq: perl, libtool, ed, tcl >= 8.4.4
44%ifarch %{java_arches}
45BuildPreReq: gcc-java
46%endif
47BuildRoot: %{_tmppath}/%{name}-%{version}-root
48Provides: db4 = %{version}
49
50%description
51The Berkeley Database (Berkeley DB) is a programmatic toolkit that
52provides embedded database support for both traditional and
53client/server applications. The Berkeley DB includes B+tree, Extended
54Linear Hashing, Fixed and Variable-length record access methods,
55transactions, locking, logging, shared memory caching, and database
56recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
57used by many applications, including Python and Perl, so this should
58be installed on all systems.
59
60%package -n compat32-%{name}
61Summary: The Berkeley DB database library (version 4) for C.
62Group: System Environment/Libraries
63Requires: db4 = %{version}-%{release}
64
65%description -n compat32-%{name}
66The Berkeley Database (Berkeley DB) is a programmatic toolkit that
67provides embedded database support for both traditional and
68client/server applications. The Berkeley DB includes B+tree, Extended
69Linear Hashing, Fixed and Variable-length record access methods,
70transactions, locking, logging, shared memory caching, and database
71recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
72used by many applications, including Python and Perl, so this should
73be installed on all systems.
74
75%package utils
76Summary: Command line tools for managing Berkeley DB (version 4) databases.
77Group: Applications/System
78Requires: db4 = %{version}-%{release}
79Obsoletes: db2-utils, db3-utils
80
81%description utils
82The Berkeley Database (Berkeley DB) is a programmatic toolkit that
83provides embedded database support for both traditional and
84client/server applications. Berkeley DB includes B+tree, Extended
85Linear Hashing, Fixed and Variable-length record access methods,
86transactions, locking, logging, shared memory caching, and database
87recovery. DB supports C, C++, Java and Perl APIs.
88
89This package contains command line tools for managing Berkeley DB
90(version 4) databases.
91
92%package devel
93Summary: Development files for the Berkeley DB (version 4) library.
94Group: Development/Libraries
95Requires: %{name} = %{version}-%{release}
96Obsoletes: db2-devel, db3-devel
97
98%description devel
99The Berkeley Database (Berkeley DB) is a programmatic toolkit that
100provides embedded database support for both traditional and
101client/server applications. This package contains the header files,
102libraries, and documentation for building programs which use the
103Berkeley DB.
104
105%package -n compat32-%{name}-devel
106Summary: Development files for the Berkeley DB (version 4) library.
107Group: Development/Libraries
108Requires: compat32-%{name} = %{version}-%{release}
109Requires: %{name}-devel    = %{version}-%{release}
110
111%description -n compat32-%{name}-devel
112The Berkeley Database (Berkeley DB) is a programmatic toolkit that
113provides embedded database support for both traditional and
114client/server applications. This package contains the header files,
115libraries, and documentation for building programs which use the
116Berkeley DB.
117
118%package tcl
119Summary: Development files for using the Berkeley DB (version 4) with tcl.
120Group: Development/Libraries
121Requires: %{name} = %{version}-%{release}
122
123%description tcl
124The Berkeley Database (Berkeley DB) is a programmatic toolkit that
125provides embedded database support for both traditional and
126client/server applications. This package contains the libraries
127for building programs which use the Berkeley DB in Tcl.
128
129%package -n compat32-%{name}-tcl
130Summary: Development files for using the Berkeley DB (version 4) with tcl.
131Group: Development/Libraries
132Requires: compat32-%{name} = %{version}-%{release}
133Requires: %{name}-tcl      = %{version}-%{release}
134
135%description -n compat32-%{name}-tcl
136The Berkeley Database (Berkeley DB) is a programmatic toolkit that
137provides embedded database support for both traditional and
138client/server applications. This package contains the libraries
139for building programs which use the Berkeley DB in Tcl.
140
141%package java
142Summary: Development files for using the Berkeley DB (version 4) with Java.
143Group: Development/Libraries
144Requires: %{name} = %{version}-%{release}
145
146%description java
147The Berkeley Database (Berkeley DB) is a programmatic toolkit that
148provides embedded database support for both traditional and
149client/server applications. This package contains the libraries
150for building programs which use the Berkeley DB in Java.
151
152%prep
153%setup -q -n db-%{version} -a 1
154#%patch0 -p1 -b .no-jni-includes
155%patch1 -p1 -b .java
156%patch2 -p0 -b .4.2.52.1
157%patch3 -p0 -b .4.2.52.2
158%patch4 -p1 -b .gcj
159%patch5 -p1 -b .disable-pthreadsmutexes
160pushd dist
161libtoolize --copy --force
162cp -f %{_datadir}/aclocal/libtool.m4 aclocal/libtool.ac
163popd
164pushd db.1.85/PORT/linux
165%patch10 -p0 -b .1
166popd
167pushd db.1.85
168%patch11 -p0 -b .1
169%patch12 -p0 -b .2
170%patch13 -p0 -b .3
171%patch14 -p1 -b .errno
172popd
173
174# Remove tags files which we don't need.
175find . -name tags | xargs rm -f
176# Define a shell function for fixing HREF references in the docs, which
177# would otherwise break when we split the docs up into subpackages.
178fixup_href() {
179    for doc in $@ ; do
180        chmod u+w ${doc}
181        sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
182            -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
183            -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
184            -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
185            -e 's,="../api_java/,="../../%{name}-devel-%{version}/api_java/,g' \
186            -e 's,="api_java/,="../%{name}-devel-%{version}/api_java/,g' \
187            -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
188            -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
189            -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
190            -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
191            -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
192            -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
193            -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
194            -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
195            -e 's,="../sleepycat/,="../../%{name}-devel-%{version}/sleepycat/,g' \
196            -e 's,="sleepycat/,="../%{name}-devel-%{version}/sleepycat/,g' \
197            -e 's,="../images/,="../../%{name}-%{version}/images/,g' \
198            -e 's,="images/,="../%{name}-%{version}/images/,g' \
199            -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
200            -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
201        touch -r ${doc} ${doc}.new
202        cat ${doc}.new > ${doc}
203        touch -r ${doc}.new ${doc}
204        rm -f ${doc}.new
205    done
206}
207
208set +x  # XXX painful to watch
209# Fix all of the HTML files.
210fixup_href `find . -name "*.html"`
211set -x  # XXX painful to watch
212
213cd dist
214./s_config
215
216%build
217CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
218
219# Build the old db-185 libraries.
220make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
221
222build() {
223        test -d dist/$1 || mkdir dist/$1
224        # Static link db_dump185 with old db-185 libraries.
225        /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
226        /bin/sh libtool --mode=link    %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
227        pushd dist/$1
228        # Force the threading model used, for selecting whether or not we will
229        # depend on NPTL-specific features.
230        local mutexes_arg=""
231        if test -n "$2" ; then
232                mutexes_arg="--enable-posixmutexes --with-mutex=$2"
233        else
234                mutexes_arg="--disable-pthreadsmutexes"
235        fi
236        if test -n "$nptl_lo" ; then
237                /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS \
238                        -o $nptl_lo -c $nptl_s
239        fi
240        ln -sf ../configure .
241        # XXX --enable-diagnostic should be disabled for production (but is
242        # useful).
243        # XXX --enable-debug_{r,w}op should be disabled for production.
244        %configure -C \
245                --enable-compat185 --enable-dump185 \
246                --enable-shared --enable-static --enable-rpc \
247                --enable-tcl --with-tcl=%{_libdir} \
248                --enable-cxx \
249%ifarch %{java_arches}
250                --enable-java \
251%else
252                --disable-java \
253%endif
254                --enable-test \
255                $mutexes_arg \
256                # --enable-diagnostic \
257                # --enable-debug --enable-debug_rop --enable-debug_wop \
258
259        # Remove libtool predep_objects and postdep_objects wonkiness so that
260        # building without -nostdlib doesn't include them twice.  Because we
261        # already link with g++, weird stuff happens if you don't let the
262        # compiler handle this.
263        perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
264        perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
265        perl -pi -e 's/-shared -nostdlib/-shared/' libtool
266
267        # VINE: remove more {pre,post}dep_objects wonkiness
268        perl -pi -e 's/^predep_objects=\`echo.*$/predep_objects=""/' libtool
269        perl -pi -e 's/^postdep_objects=\`echo.*$/postdep_objects=""/' libtool
270
271        make libdb=%{_libdb_a} libcxx=%{_libcxx_a} %{?_smp_mflags} \
272                 LIBSO_LIBS='$(LIBS)'" $nptl_lo" \
273                LIBXSO_LIBS='$(LIBS)'" $nptl_lo" \
274                LIBJSO_LIBS='$(LIBS)'" $nptl_lo" \
275                LIBTSO_LIBS='$(LIBS)'" $nptl_lo"
276
277        # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
278        LDBJ=./.libs/libdb_java-%{__soversion}.la
279        if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
280            sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
281        fi
282
283        popd
284}
285
286# comment out %ifarch for Vine Linux x86 arch
287#%ifarch %{nptl_arches}
288unset nptl_s nptl_lo
289#case %{_os} in
290#linux|Linux)
291#       nptl_s=$RPM_SOURCE_DIR/nptl-abi-note.S
292#       nptl_lo=nptl-abi-note.lo
293#       ;;
294#esac
295build dist-tls POSIX/pthreads/library
296unset nptl_s nptl_lo
297#%endif
298build dist-notls
299
300%install
301rm -rf ${RPM_BUILD_ROOT}
302mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
303mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
304mkdir -p ${RPM_BUILD_ROOT}/%{_lib}
305
306# comment out %ifarch for Vine Linux x86 arch
307#%ifarch %{nptl_arches}
308%makeinstall -C dist/dist-tls
309
310chmod +x ${RPM_BUILD_ROOT}/%{_libdir}/*.so*
311mkdir -p ${RPM_BUILD_ROOT}{/%{_lib},%{_libdir}}/tls
312mv ${RPM_BUILD_ROOT}/%{_libdir}/libdb*%{__soversion}.so ${RPM_BUILD_ROOT}/%{_libdir}/tls/
313#%endif
314%makeinstall -C dist/dist-notls
315
316# XXX Nuke non-versioned archives and symlinks
317rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
318rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
319rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
320rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
321rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
322
323chmod +x $RPM_BUILD_ROOT/%{_libdir}/*.so*
324
325# Move the main shared library to lib directory, but leave the unversioned .so
326# symlink in the usual place to link against.
327if [ "%{_libdir}" != "/%{_lib}" ]; then
328        # Move the non-tls library.
329        mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
330        # Move the tls library, if we have one.
331        mkdir -p $RPM_BUILD_ROOT/%{_lib}/tls
332        if test -e $RPM_BUILD_ROOT/%{_libdir}/tls/libdb-%{__soversion}.so ; then
333                mv $RPM_BUILD_ROOT/%{_libdir}/tls/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/tls/
334        fi
335        # Leave relative symlinks in %{_libdir}.
336        touch $RPM_BUILD_ROOT/rootfile
337        root=..
338        while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
339                root=${root}/..
340        done
341        rm $RPM_BUILD_ROOT/rootfile
342        ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
343        ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
344        # Leave relative symlinks in %{_libdir}/tls.
345        if test -e $RPM_BUILD_ROOT/%{_lib}/tls/libdb-%{__soversion}.so ; then
346                ln -sf ${root}/../%{_lib}/tls/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/tls/
347        fi
348fi
349
350# Move the x86 libraries into platform-specific subdirectories so that the
351# tls-enabled glibc doesn't try to use NPTL-dependent libdb on real i386s,
352# because it doesn't provide an NPTL libpthread for that platform.
353%ifarch %{ix86}
354case %{_target_platform} in
355        i386*|i486*) arches="i486 i586 i686";;
356        i586*) arches="i586 i686";;
357        i686*) arches="i686";;
358        athlon*) arches="athlon";;
359        *) arches=%{_target_cpu};;
360esac
361# "Move" the libraries by linking them.
362for targetarch in $arches ; do
363        mkdir -p $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}
364        ln $RPM_BUILD_ROOT/%{_libdir}/tls/lib* $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}/
365        if [ "%{_libdir}" != "/%{_lib}" ]; then
366                mkdir -p $RPM_BUILD_ROOT/%{_lib}/tls/${targetarch}
367                ln $RPM_BUILD_ROOT/%{_lib}/tls/lib* $RPM_BUILD_ROOT/%{_lib}/tls/${targetarch}/
368        fi
369done
370rm $RPM_BUILD_ROOT/{%{_lib},%{_libdir}}/tls/lib*
371
372# Now fix the symlinks.
373if [ "%{_libdir}" != "/%{_lib}" ]; then
374        # In with the new.
375        for targetarch in $arches ; do
376                mkdir -p $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}
377                ln -sf ${root}/../../%{_lib}/tls/${targetarch}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/tls/${targetarch}/
378        done
379fi
380%endif
381
382# Move the header files to a subdirectory, in case we're deploying on a
383# system with multiple versions of DB installed.
384mkdir -p $RPM_BUILD_ROOT/%{_includedir}/db4
385mv $RPM_BUILD_ROOT/%{_includedir}/*.h $RPM_BUILD_ROOT/%{_includedir}/db4/
386
387# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
388for i in db.h db_cxx.h db_185.h; do
389        ln -s db4/$i $RPM_BUILD_ROOT%{_includedir}
390done
391
392%ifarch %{java_arches}
393# Move java jar file to the correct place
394mkdir -p $RPM_BUILD_ROOT%{_datadir}/java
395mv $RPM_BUILD_ROOT%{_libdir}/*.jar $RPM_BUILD_ROOT%{_datadir}/java
396%endif
397
398# Eliminate installed doco
399rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
400
401# XXX Avoid Permission denied. strip when building as non-root.
402chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
403
404%clean
405rm -rf ${RPM_BUILD_ROOT}
406
407%post -p /sbin/ldconfig
408
409%postun -p /sbin/ldconfig
410
411%post -n compat32-%{name} -p /sbin/ldconfig
412
413%postun -n compat32-%{name} -p /sbin/ldconfig
414
415%post -p /sbin/ldconfig tcl
416
417%postun -p /sbin/ldconfig tcl
418
419%post -n compat32-%{name}-tcl -p /sbin/ldconfig
420
421%postun -n compat32-%{name}-tcl -p /sbin/ldconfig
422
423%post -p /sbin/ldconfig java
424
425%postun -p /sbin/ldconfig java
426
427%files
428%defattr(-,root,root)
429%doc LICENSE README docs/images
430/%{_lib}/libdb-%{__soversion}.so
431%{_libdir}/libdb-%{__soversion}.so
432%{_libdir}/libdb_cxx-%{__soversion}.so
433%ifarch %{nptl_arches}
434%ifarch %{ix86}
435/%{_lib}/tls/*/libdb-%{__soversion}.so
436%{_libdir}/tls/*/libdb-%{__soversion}.so
437%{_libdir}/tls/*/libdb_cxx-%{__soversion}.so
438%else
439/%{_lib}/tls/libdb-%{__soversion}.so
440%{_libdir}/tls/libdb-%{__soversion}.so
441%{_libdir}/tls/libdb_cxx-%{__soversion}.so
442%endif
443%endif
444
445#%files utils
446#%defattr(-,root,root)
447#%doc   docs/utility
448#%{_bindir}/berkeley_db*_svc
449#%{_bindir}/db*_archive
450#%{_bindir}/db*_checkpoint
451#%{_bindir}/db*_deadlock
452#%{_bindir}/db*_dump*
453#%{_bindir}/db*_load
454#%{_bindir}/db*_printlog
455#%{_bindir}/db*_recover
456#%{_bindir}/db*_stat
457#%{_bindir}/db*_upgrade
458#%{_bindir}/db*_verify
459
460#%files devel
461#%defattr(-,root,root)
462#%doc   docs/api_c docs/api_cxx docs/api_tcl docs/index.html
463#%doc   docs/ref docs/sleepycat
464#%doc   examples_c examples_cxx
465#%{_libdir}/libdb.so
466#%{_libdir}/libdb-%{__soversion}.la
467#%{_libdir}/libdb_cxx-%{__soversion}.la
468#%{_libdir}/%{_libdb_a}
469#%{_libdir}/%{_libcxx_a}
470#%{_includedir}/%{name}
471#%{_includedir}/*.h
472
473#%files tcl
474#%defattr(-,root,root)
475#%{_libdir}/libdb_tcl-%{__soversion}.a
476#%{_libdir}/libdb_tcl-%{__soversion}.la
477#%{_libdir}/libdb_tcl-%{__soversion}.so
478#%ifarch %{nptl_arches}
479#%ifnarch %{ix86}
480#%{_libdir}/tls/libdb_tcl-%{__soversion}.so
481#%else
482#%{_libdir}/tls/*/libdb_tcl-%{__soversion}.so
483#%endif
484#%endif
485
486#%ifarch %{java_arches}
487#%files java
488#%defattr(-,root,root)
489#%doc docs/java
490#%doc examples_java
491#%{_libdir}/libdb_java*
492#%{_datadir}/java/*.jar
493#%endif
494#%ifarch %{nptl_java_arches}
495#%ifnarch %{ix86}
496#%{_libdir}/tls/libdb_java*
497#%else
498#%{_libdir}/tls/*/libdb_java*
499#%endif
500#%endif
501
502%if %{build_compat32}
503%files -n compat32-%{name}
504%defattr(-,root,root)
505/%{_lib}/libdb-%{__soversion}.so
506%{_libdir}/libdb-%{__soversion}.so
507%{_libdir}/libdb_cxx-%{__soversion}.so
508%ifarch %{nptl_arches}
509/%{_lib}/tls/*/libdb-%{__soversion}.so
510%{_libdir}/tls/*/libdb-%{__soversion}.so
511%{_libdir}/tls/*/libdb_cxx-%{__soversion}.so
512%endif
513
514#%files -n compat32-%{name}-devel
515#%defattr(-,root,root)
516#%{_libdir}/libdb.so
517#%{_libdir}/libdb-%{__soversion}.la
518#%{_libdir}/libdb_cxx-%{__soversion}.la
519#%{_libdir}/%{_libdb_a}
520#%{_libdir}/%{_libcxx_a}
521
522#%files -n compat32-%{name}-tcl
523#%defattr(-,root,root)
524#%{_libdir}/libdb_tcl-%{__soversion}.a
525#%{_libdir}/libdb_tcl-%{__soversion}.la
526#%{_libdir}/libdb_tcl-%{__soversion}.so
527#%ifarch %{nptl_arches}
528#%{_libdir}/tls/*/libdb_tcl-%{__soversion}.so
529#%endif
530%endif
531
532%changelog
533* Tue May 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.52-6vl7
534- package name renamed from db4 to db42 (VineSeed now has db4-4.3.x)
535- rebuilt with new toolchain
536
537* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.52-6vl6
538- changed db4-utils Group to Applications/System <BTS:VineLinux:163>
539- changed *-devel Group to Development/Libraries
540- changed db4-tcl Group to Devalopment/Libraries
541
542* Fri Feb 10 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.2.52-6vl5
543- added compat32-* packages for x86_64 architecture support
544
545* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.2.52-6vl4
546- add Patch5.
547- disable mutexes.
548
549* Thu Oct 21 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.52-6vl3
550- fixed spec file for build on x86 arch
551  comment out %ifarch and nptl_s, nptl_so
552
553* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.52-6vl2
554- undefine nptl_arches (as Vine's glibc does)
555
556* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.2.52-6vl1
557- updated to 4.2.52 (based on Fedora's 4.2.52-6) and merged with 4.0.14-15vl3
558- java_arches and nptl_java_arches undefined
559- older Vine package's changelogs were as follows:
560
561  - Fri Feb 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.14-15vl3
562  - remove Obsoletes: db[123]
563
564  - Tue Feb 17 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.14-15vl2
565  - rebuild
566  - added Obsoletes: db[123]
567  - remove BuildPreReq: jdkgcj
568  - undefine java_arches
569
570  - Sat Jan 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.14-15vl1
571  - deleted Obsoletes: db1
572    (Obsoletes: db1 is too early for Vine:
573     we need more work/time to resolve db[1234] disorder...)
574
575  - Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.14-15vl0
576  - rebuilt for Vine Linux
577
578* Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
579- on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
580  the availability of an NPTL libpthread in glibc > 2.3.3-48
581- run ldconfig in db4-java's %%post/%%postun
582- when building java support, assume that libgcj is equivalent enough to 1.3
583
584* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
585- rebuilt
586
587* Mon Jun  7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
588- remove dangling symlinks (#123721 et al).
589- remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
590- apply 2 patches from sleepycat.
591- resurrect db4-java using sun jvm-1.4.2.
592- cripple autoconf sufficiently to build db4-java with gcj, without jvm.
593- check javac first, gcj34 next, then gcj-ssa, finally gcj.
594- add ed build dependency (#125180).
595
596* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
597- rebuilt
598
599* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
600- rebuilt
601
602* Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
603- fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
604
605* Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
606- upgrade to db-4.2.52, no db4-java for the moment.
607
608* Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
609- Add build requires tcl-devel
610
611* Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
612- symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
613  that the run-time linker can find the right copy for of apps which use an
614  RPATH to point at %%{_libdir}/libdb-4.1.so
615
616* Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
617- add another section to the ABI note for the TLS libdb so that it's marked as
618  not needing an executable stack (from Arjan Van de Ven)
619
620* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
621- build both with and without support for shared mutex locks, which require NPTL
622- make behavior wrt where we put libdb the same for all OSs
623- revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
624  doesn't work
625- fix dangling HREFs in utility docs (pointed to main docs dir, while they're
626  actually in the -utils docs dir)
627- run ldconfig when installing/removing the -utils subpackage, as it contains
628  shared libraries
629
630* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
631- fix multiple-inclusion problem of startup files when building shlibs without
632  the -nostdlib flag
633
634* Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
635- link shared libraries without -nostdlib, which created an unresolvable dep
636  on a hidden symbol
637
638* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
639- allow compiling without tcl dependency
640
641* Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
642- update to 4.2.42.
643- build in build_unix subdir.
644- eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
645- create db4-tcl sub-pkg to isolate libtcl dependencies.
646
647* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
648- rebuild
649
650* Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
651- add missing tcl-devel buildrequires (#101814)
652
653* Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
654- rebuild
655
656* Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
657- build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
658- whack out libtool predep_objects wonkiness.
659
660* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
661- rebuild.
662
663* Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
664- hack out O_DIRECT support in db4 for now.
665
666* Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
667- replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
668  cause a mismatch
669
670* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
671- rebuilt
672
673* Wed Jun  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
674- change configure to only warn if JNI includes aren't found, assuming that
675  the C compiler can find them
676- remove build requirement on jdkgcj -- gcj is sufficient
677
678* Mon May  5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
679- upgrade to 4.1.25, crypto version.
680- enable posix mutexes using nptl on all arches.
681
682* Mon Mar  3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
683- enabled db4-java for x86_64
684
685* Wed Feb  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
686- add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
687  linking with -ldb-4.0 will work again
688
689* Tue Feb  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
690- rebuild to use link the shared object with the same libraries we use
691  for the bundled utils, should pull in libpthread when needed
692- move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
693
694* Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
695- add java for s390x
696
697* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
698- rebuilt
699
700* Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
701- add java for s390
702
703* Tue Oct  8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
704- add java bits back in for x86 boxes
705
706* Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
707- Added better fix for s390/s390x/x86_64
708
709* Thu Sep 05 2002 Arjan van de Ven
710- remove java bits for x86-64
711
712* Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
713- include libdb_tcl-4.1.a library.
714- obsolete db1 packages.
715
716* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
717- include patch to avoid db_recover (#70362)
718
719* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
720- rebuilt with gcc-3.2 (we hope)
721
722* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
723- own %%{_includedir}/%{name}
724
725* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
726- build using gcc-3.2-0.1
727
728* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
729- automated rebuild
730
731* Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
732- Add java bindings
733- Fix C++ bindings
734
735* Thu May 23 2002 Tim Powers <timp@redhat.com>
736- automated rebuild
737
738* Thu May  9 2002 Jeff Johnson <jbj@redhat.com>
739- re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
740- make sure that -ldb is functional.
741
742* Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
743- avoid db_util name collisions with multiple versions installed.
744
745* Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
746- remove relocatability stuffs
747- swallow a local copy of db1 and build db185_dump statically with it, to
748  remove the build dependency and simplify bootstrapping new arches
749
750* Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
751- have subpackages obsolete their db3 counterparts, because they conflict anyway
752
753* Tue Jan  8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
754- upgrade to 4.0.14.
755
756* Sun Aug  5 2001 Nalin Dahyabhai <nalin@redhat.com>
757- fix dangling docs symlinks
758- fix dangling doc HREFs (#33328)
759- apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
760
761* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
762- turn off --enable-debug
763
764* Thu May 10 2001 Than Ngo <than@redhat.com>
765- fixed to build on s390x
766
767* Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
768- update to 3.2.9.
769
770* Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
771- rebuild to remove 777 directories.
772
773* Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
774- don't build with --enable-diagnostic.
775- add build prereq on tcl.
776- default value for %%_lib macro if not found.
777
778* Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
779- add /usr/lib/libdb-3.1.so symlink to %%files.
780- remove dangling tags symlink from examples.
781
782* Mon Oct  9 2000 Jeff Johnson <jbj@redhat.com>
783- rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
784- turn off --enable-diagnostic for performance.
785
786* Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
787- update to 3.1.17.
788- disable posix mutexes Yet Again.
789
790* Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
791- add c++ and posix mutex support.
792
793* Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
794- put nss_db into a separate package
795
796* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
797- rebuild to cope with glibc locale binary incompatibility, again
798
799* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
800- remove redundant strip of libnss_db* that is nuking symbols.
801- change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
802
803* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
804- summaries from specspo.
805- all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
806
807* Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
808- temporarily build nss_db in this package, should be moved
809  into separate nss_db package soon
810
811* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
812- rebuild to cope with glibc locale binary incompatibility
813
814* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
815- automatic rebuild
816
817* Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
818- upgrade to 3.1.14.
819- create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
820- FHS packaging.
821
822* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
823- disable tcl Yet Again, base packages cannot depend on libtcl.so.
824
825* Sat Jun  3 2000 Jeff Johnson <jbj@redhat.com>
826- enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
827
828* Tue May 30 2000 Matt Wilson <msw@redhat.com>
829- include /lib/libdb.so in the devel package
830
831* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
832- put in "System Environment/Libraries" per msw instructions.
833
834* Tue May  9 2000 Jeff Johnson <jbj@redhat.com>
835- install shared library in /lib, not /usr/lib.
836- move API docs to db3-devel.
837
838* Mon May  8 2000 Jeff Johnson <jbj@redhat.com>
839- don't rename db_* to db3_*.
840
841* Tue May  2 2000 Jeff Johnson <jbj@redhat.com>
842- disable --enable-test --enable-debug_rop --enable-debug_wop.
843- disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
844  problems.
845
846* Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
847- add 3.0.55.1 alignment patch.
848- add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
849- add --enable-tcl (needed -lpthreads).
850
851* Sat Apr  1 2000 Jeff Johnson <jbj@redhat.com>
852- add --enable-debug_{r,w}op for now.
853- add variable to set shm perms.
854
855* Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
856- update to 3.0.55
857
858* Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
859- Add --enable-cxx to configure.
860
861* Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
862- Create.
Note: See TracBrowser for help on using the repository browser.