source: projects/specs/trunk/d/db4/db4-vl.spec @ 8162

Revision 8162, 30.0 KB checked in by tomop, 10 years ago (diff)

updated many packages.

RevLine 
[521]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
4%define java_arches %{ix86} alpha ia64 ppc s390 s390x sparc sparcv9 x86_64
5
6##VINE##
7%undefine java_arches
8
9%define __soversion     4.8
10%define _libdb_a        libdb-%{__soversion}.a
11%define _libcxx_a       libdb_cxx-%{__soversion}.a
12
13Summary: The Berkeley DB database library (version 4) for C
14Name: db4
[2211]15Version: 4.8.30
[8162]16Release: 2%{?_dist_release}
[521]17
18Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
19Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
20
21# patches for db1.85
22Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
23Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
24Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
25Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
26
27Patch20: db-1.85-errno.patch
28Patch22: db-4.6.21-1.85-compat.patch
29Patch24: db-4.5.20-jni-include-dir.patch
30
31URL: http://www.oracle.com/database/berkeley-db/
32License: BSD-style
33Group: System Environment/Libraries
34Obsoletes: db1, db2, db3
35BuildRequires: perl, libtool, ed, tcl >= 8.4.4
36#BuildRequires: util-linux-ng
37%ifarch %{java_arches}
38BuildRequires: gcc-java
39BuildRequires: java-1.5.0-gcj
40BuildRequires: java-1.5.0-gcj-devel
41%endif
42BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
43
44
45%description
46The Berkeley Database (Berkeley DB) is a programmatic toolkit that
47provides embedded database support for both traditional and
48client/server applications. The Berkeley DB includes B+tree, Extended
49Linear Hashing, Fixed and Variable-length record access methods,
50transactions, locking, logging, shared memory caching, and database
51recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
52used by many applications, including Python and Perl, so this should
53be installed on all systems.
54
55
56%package -n compat32-%{name}
57Summary: The Berkeley DB database library (version 4) for C.
58Group: System Environment/Libraries
59Requires: db4 = %{version}-%{release}
60
61%description -n compat32-%{name}
62The Berkeley Database (Berkeley DB) is a programmatic toolkit that
63provides embedded database support for both traditional and
64client/server applications. The Berkeley DB includes B+tree, Extended
65Linear Hashing, Fixed and Variable-length record access methods,
66transactions, locking, logging, shared memory caching, and database
67recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
68used by many applications, including Python and Perl, so this should
69be installed on all systems.
70
71
72%package cxx
73Summary: The Berkeley DB database library (version 4) for C++
74Group: System Environment/Libraries
75
76%description cxx
77The Berkeley Database (Berkeley DB) is a programmatic toolkit that
78provides embedded database support for both traditional and
79client/server applications. The Berkeley DB includes B+tree, Extended
80Linear Hashing, Fixed and Variable-length record access methods,
81transactions, locking, logging, shared memory caching, and database
82recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
83used by many applications, including Python and Perl, so this should
84be installed on all systems.
85
86
87%package -n compat32-%{name}-cxx
88Summary: The Berkeley DB database library (version 4) for C++
89Group: System Environment/Libraries
90
91%description -n compat32-%{name}-cxx
92The Berkeley Database (Berkeley DB) is a programmatic toolkit that
93provides embedded database support for both traditional and
94client/server applications. The Berkeley DB includes B+tree, Extended
95Linear Hashing, Fixed and Variable-length record access methods,
96transactions, locking, logging, shared memory caching, and database
97recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
98used by many applications, including Python and Perl, so this should
99be installed on all systems.
100
101
102%package utils
103Summary: Command line tools for managing Berkeley DB (version 4) databases
104Group: Applications/System
105Requires: db4 = %{version}-%{release}
106Obsoletes: db1-utils, db2-utils, db3-utils
107
108%description utils
109The Berkeley Database (Berkeley DB) is a programmatic toolkit that
110provides embedded database support for both traditional and
111client/server applications. Berkeley DB includes B+tree, Extended
112Linear Hashing, Fixed and Variable-length record access methods,
113transactions, locking, logging, shared memory caching, and database
114recovery. DB supports C, C++, Java and Perl APIs.
115
116
117%package devel
118Summary: C development files for the Berkeley DB (version 4) library
119Group: Development/Libraries
120Requires: db4 = %{version}-%{release}
121Obsoletes: db1-devel, db2-devel, db3-devel
122
123%description devel
124The Berkeley Database (Berkeley DB) is a programmatic toolkit that
125provides embedded database support for both traditional and
126client/server applications. This package contains the header files,
127libraries, and documentation for building programs which use the
128Berkeley DB.
129
130
131%package -n compat32-%{name}-devel
132Summary: Development files for the Berkeley DB (version 4) library.
133Group: Development/Libraries
134Requires: compat32-%{name} = %{version}-%{release}
135Requires: %{name}-devel    = %{version}-%{release}
136
137%description -n compat32-%{name}-devel
138The Berkeley Database (Berkeley DB) is a programmatic toolkit that
139provides embedded database support for both traditional and
140client/server applications. This package contains the header files,
141libraries, and documentation for building programs which use the
142Berkeley DB.
143
144
145%package tcl
146Summary: Development files for using the Berkeley DB (version 4) with tcl
147Group: Development/Libraries
148Requires: %{name} = %{version}-%{release}
149
150%description tcl
151The Berkeley Database (Berkeley DB) is a programmatic toolkit that
152provides embedded database support for both traditional and
153client/server applications. This package contains the libraries
154for building programs which use the Berkeley DB in Tcl.
155
156
157%package -n compat32-%{name}-tcl
158Summary: Development files for using the Berkeley DB (version 4) with tcl.
159Group: Development/Libraries
160Requires: compat32-%{name} = %{version}-%{release}
161Requires: %{name}-tcl      = %{version}-%{release}
162
163%description -n compat32-%{name}-tcl
164The Berkeley Database (Berkeley DB) is a programmatic toolkit that
165provides embedded database support for both traditional and
166client/server applications. This package contains the libraries
167for building programs which use the Berkeley DB in Tcl.
168
169
170%package java
171Summary: Development files for using the Berkeley DB (version 4) with Java
172Group: Development/Libraries
173Requires: %{name} = %{version}-%{release}
174
175%description java
176The Berkeley Database (Berkeley DB) is a programmatic toolkit that
177provides embedded database support for both traditional and
178client/server applications. This package contains the libraries
179for building programs which use the Berkeley DB in Java.
180
181
182%prep
183%setup -q -n db-%{version} -a 1
184
185pushd db.1.85/PORT/linux
186%patch10 -p0 -b .1.1
187popd
188pushd db.1.85
189%patch11 -p0 -b .1.2
190%patch12 -p0 -b .1.3
191%patch13 -p0 -b .1.4
192%patch20 -p1 -b .errno
193popd
194
195%patch22 -p1 -b .185compat
196%patch24 -p1 -b .4.5.20.jni
197
198# Remove tags files which we don't need.
199find . -name tags | xargs rm -f
200# Define a shell function for fixing HREF references in the docs, which
201# would otherwise break when we split the docs up into subpackages.
202fixup_href() {
203    for doc in $@ ; do
204        chmod u+w ${doc}
205        sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
206            -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
207            -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
208            -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
209            -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
210            -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
211            -e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
212            -e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
213            -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
214            -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
215            -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
216            -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
217            -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
218            -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
219            -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
220            -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
221            -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
222            -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
223        touch -r ${doc} ${doc}.new
224        cat ${doc}.new > ${doc}
225        touch -r ${doc}.new ${doc}
226        rm -f ${doc}.new
227    done
228}
229
230set +x  # XXX painful to watch
231# Fix all of the HTML files.
232fixup_href `find . -name "*.html"`
233set -x  # XXX painful to watch
234
235cd dist
236./s_config
237
238
239%build
240CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
241
242# Build the old db-185 libraries.
243make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
244
245build() {
246        test -d dist/$1 || mkdir dist/$1
247        # Static link db_dump185 with old db-185 libraries.
[8162]248        /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
249        /bin/sh libtool --tag=LD --mode=link    %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
[521]250
251        pushd dist/$1
252        ln -sf ../configure .
253        # XXX --enable-diagnostic should be disabled for production (but is
254        # useful).
255        # XXX --enable-debug_{r,w}op should be disabled for production.
256        %configure -C \
257                --enable-compat185 --enable-dump185 \
258                --enable-shared --enable-static \
259                --enable-tcl --with-tcl=%{_libdir} \
260                --enable-cxx \
261%ifarch %{java_arches}
262                --enable-java \
263%else
264                --disable-java \
265%endif
266                --enable-test \
267                # --enable-diagnostic \
268                # --enable-debug --enable-debug_rop --enable-debug_wop \
269
270        # Remove libtool predep_objects and postdep_objects wonkiness so that
271        # building without -nostdlib doesn't include them twice.  Because we
272        # already link with g++, weird stuff happens if you don't let the
273        # compiler handle this.
274        perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
275        perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
276        perl -pi -e 's/-shared -nostdlib/-shared/' libtool
277
278        make    %{?_smp_mflags}
279
280        # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
281        LDBJ=./.libs/libdb_java-%{__soversion}.la
282        if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
283            sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
284        fi
285
286        popd
287}
288
289build dist-tls
290
291
292%install
293rm -rf ${RPM_BUILD_ROOT}
294mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
295mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
296
297%makeinstall -C dist/dist-tls
298
299# XXX Nuke non-versioned archives and symlinks
300rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
301rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
302rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
303rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
304rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
305
306chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
307
308# Move the main shared library from /usr/lib* to /lib* directory.
309if [ "%{_libdir}" != "/%{_lib}" ]; then
310  mkdir -p $RPM_BUILD_ROOT/%{_lib}/
311  mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
312
313# Leave relative symlinks in %{_libdir}.
314  touch $RPM_BUILD_ROOT/rootfile
315  root=..
316  while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
317    root=${root}/..
318  done
319  rm $RPM_BUILD_ROOT/rootfile
320
321  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
322  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
323  ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
324fi
325
326# Move the header files to a subdirectory, in case we're deploying on a
327# system with multiple versions of DB installed.
328mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
329mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
330
331# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
332for i in db.h db_cxx.h db_185.h; do
333        ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
334done
335
336%ifarch %{java_arches}
337# Move java jar file to the correct place
338mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
339mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
340%endif
341
342# Eliminate installed doco
343rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
344
345# XXX Avoid Permission denied. strip when building as non-root.
346chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
347
348
349%clean
350rm -rf ${RPM_BUILD_ROOT}
351
352
[8162]353%post
354/sbin/ldconfig
[521]355
[8162]356%postun
357/sbin/ldconfig
[521]358
[8162]359%post -n compat32-%{name}
360/sbin/ldconfig
[521]361
[8162]362%postun -n compat32-%{name}
363/sbin/ldconfig
[521]364
[8162]365%post cxx
366/sbin/ldconfig
[521]367
[8162]368%postun cxx
369/sbin/ldconfig
[521]370
[8162]371%post -n compat32-%{name}-cxx
372/sbin/ldconfig
[521]373
[8162]374%postun -n compat32-%{name}-cxx
375/sbin/ldconfig
[521]376
[8162]377%post tcl
378/sbin/ldconfig
[521]379
[8162]380%postun tcl
381/sbin/ldconfig
[521]382
[8162]383%post -n compat32-%{name}-tcl
384/sbin/ldconfig
[521]385
[8162]386%postun -n compat32-%{name}-tcl
387/sbin/ldconfig
[521]388
[8162]389%post java
390 -p /sbin/ldconfig
[521]391
[8162]392%postun java
393/sbin/ldconfig
[521]394
395
396%files
397%defattr(-,root,root)
398%doc LICENSE README
399/%{_lib}/libdb-%{__soversion}.so
400%{_libdir}/libdb-%{__soversion}.so
401
402
403%files cxx
404%defattr(-,root,root)
405%{_libdir}/libdb_cxx-%{__soversion}.so
406
407
408%files utils
409%defattr(-,root,root)
410%doc    docs/utility
411%{_bindir}/db*_archive
412%{_bindir}/db*_checkpoint
413%{_bindir}/db*_deadlock
414%{_bindir}/db*_dump*
415%{_bindir}/db*_load
416%{_bindir}/db*_printlog
417%{_bindir}/db*_recover
418%{_bindir}/db*_stat
419%{_bindir}/db*_upgrade
420%{_bindir}/db*_verify
421%{_bindir}/db*_hotbackup
422%{_bindir}/db*_sql
423
424
425%files devel
426%defattr(-,root,root)
427%doc    docs/api_c docs/api_cxx docs/api_tcl docs/index.html
428%doc    docs/ref docs/images
429%doc    examples_c examples_cxx
430%{_libdir}/libdb.so
431%{_libdir}/libdb-%{__soversion}.la
432%{_libdir}/%{_libdb_a}
433%{_libdir}/libdb_cxx.so
434%{_libdir}/libdb_cxx-%{__soversion}.la
435%{_libdir}/%{_libcxx_a}
436%dir %{_includedir}/%{name}
437%{_includedir}/%{name}/db.h
438%{_includedir}/%{name}/db_185.h
439%{_includedir}/%{name}/db_cxx.h
440%{_includedir}/db.h
441%{_includedir}/db_185.h
442%{_includedir}/db_cxx.h
443
444
445%files tcl
446%defattr(-,root,root)
447%{_libdir}/libdb_tcl-%{__soversion}.a
448%{_libdir}/libdb_tcl-%{__soversion}.la
449%{_libdir}/libdb_tcl-%{__soversion}.so
450
451
452%ifarch %{java_arches}
453%files java
454%defattr(-,root,root)
455%doc docs/java
456%doc examples_java
457%{_libdir}/libdb_java*
458%{_datadir}/java/*.jar
459%endif
460
461%if %{build_compat32}
462%files -n compat32-%{name}
463%defattr(-,root,root)
464/%{_lib}/libdb-%{__soversion}.so
465%{_libdir}/libdb-%{__soversion}.so
466
467
468%files -n compat32-%{name}-cxx
469%defattr(-,root,root)
470%{_libdir}/libdb_cxx-%{__soversion}.so
471
472
473%files -n compat32-%{name}-devel
474%defattr(-,root,root)
475%{_libdir}/libdb.so
476%{_libdir}/libdb-%{__soversion}.la
477%{_libdir}/libdb_cxx-%{__soversion}.la
478%{_libdir}/%{_libdb_a}
479%{_libdir}/%{_libcxx_a}
480
481
482%files -n compat32-%{name}-tcl
483%defattr(-,root,root)
484%{_libdir}/libdb_tcl-%{__soversion}.a
485%{_libdir}/libdb_tcl-%{__soversion}.la
486%{_libdir}/libdb_tcl-%{__soversion}.so
487%endif
488
489
490%changelog
[8162]491* Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.30-2
492- rebuilt with current environment.
493
[2211]494* Mon Nov 15 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.30-1
495- new upstream release.
496
[521]497* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.8.26-2
498- rebuilt with gcc-4.4.3-3 on ppc
499
500* Mon Feb 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.26-1
501- update to 4.8.26
502- remove '--enable-rpc'
503  - rpc support is removed from db4
504
505* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6.21-6
506- initial build of db-4.6.21 on Vine Linux
507- temporarily commented out "libtoolize" and "s_config" lines
508  until Vine's autotools get updated (maybe?)
509
[8162]510* Thu Apr  3 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-5
[521]511- add upstream patch to fix a race condition between checkpoint
512  and DB->close which can result in the checkpoint thread self-deadlocking
513
514* Mon Mar 10 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-4
515- don't list headers twice in filelist (#436701)
516
517* Mon Feb 25 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-3
518- manual rebuild because of gcc-4.3 (#434185)
519
520* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.6.21-2
521- Autorebuild for GCC 4.3
522
523* Thu Oct 11 2007 Jindrich Novy <jnovy@redhat.com> 4.6.21-1
524- update to 4.6.21
525- own %%{_includedir}/db4 (#274251)
526
527* Mon Sep  3 2007 Jindrich Novy <jnovy@redhat.com> 4.6.19-1
528- update to 4.6.19 (#273461)
529
[8162]530* Wed Aug 29 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-2
[521]531- rebuild for BuildID
532- BR util-linux-ng
533
534* Mon Jul 30 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-1
535- update to 4.6.18
536- drop upstream patches for 4.5.20 and gcj patch
537- remove nptl-abi-note.S, useless as we are definitely
538  running kernel >= 2.4.20 (#245416)
539- move C++ stuff to subpackages to reduce dependency bloat (#220484)
540- package db_codegen
541- correct open() calls so that new db4 compiles with the new glibc
542
543* Sat Mar 24 2007 Thomas Fitzsimmons <fitzsim@redhat.com> 4.5.20-5
544- Require java-1.5.0-gcj and java-1.5.0-gcj-devel for build.
545
546* Mon Dec  4 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-4
547- apply upstream patches for 4.5.20
548  (Java API <-> core API related fixes)
549
550* Fri Dec  1 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-3
551- temporarily remove ppc64 from java arches
552
553* Sun Nov 26 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-2
554- sync db4 and compat-db licenses to BSD-style as the result of
555  consultation with legal department
556- fix some rpmlint warnings
557
558* Fri Nov 10 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-1
559- update to db-4.5.20 (#198038)
560- fix BuildRoot
561- drop .64bit patch
562- patch/source URLs now point to correct location
563
564* Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
565- rebuild
566
567* Wed Sep  6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
568- revert the previous fix, it crashes OOo help
569
570* Sun Sep  3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
571- fix memleak caused by SET_TXN macro in xa_db.c, when opening
572  database created with DB_XA_CREATE flag (#204920)
573
574* Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
575- fix sparc64 build (#199358)
576
577* Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
578- rebuild because of gnu_hash
579
580* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
581- rebuild
582
583* Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
584- drop useless java, lfs patches
585
586* Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
587- apply x86_64 fix from Henrik Nordstrom (#184588)
588- don't nuke non-versioned archives twice
589
590* Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
591- don't package /usr/share/doc/images in the main db4 package
592  and move it to db4-devel (#33328)
593- make db4 LFS capable (#33849)
594- move db4-devel, db4-tcl, db4-java to Development/Libraries
595  group instead of System Environment/Libraries (#54320)
596- BuildPrereq -> BuildRequires
597- don't use RPM_SOURCE_DIR
598- Obsoletes db3, db2
599
600* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
601- bump again for double-long bug on ppc(64)
602
603* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
604- rebuilt for new gcc4.1 snapshot and glibc changes
605
606* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
607- rebuilt
608
609* Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
610- New upstream release
611
612* Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
613- Re-enable java for ppc64
614
615* Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
616- Add fno-strict-aliasing for java (#168965)
617
618* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
619- no java for ppc64 for now (#166657)
620
621* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
622- FC5 is nptl only (derived from jbj's spec)
623- upgrade to 4.3.28
624
625* Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
626- re-enable db4-java
627
628* Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
629- /usr/lib/tls/ix86 dirs (#151371)
630
631* Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
632- add libdb_cxx.so link (#149191)
633
634* Fri Mar  4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
635- rebuild with gcc4.
636
637* Sat Jan  1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
638- upgrade to 4.3.27.
639
640* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
641- upgrade to 4.3.21, no db4-java for the moment again again.
642
643* Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
644- on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
645  the availability of an NPTL libpthread in glibc > 2.3.3-48
646- run ldconfig in db4-java's %%post/%%postun
647- when building java support, assume that libgcj is equivalent enough to 1.3
648
649* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
650- rebuilt
651
652* Mon Jun  7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
653- remove dangling symlinks (#123721 et al).
654- remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
655- apply 2 patches from sleepycat.
656- resurrect db4-java using sun jvm-1.4.2.
657- cripple autoconf sufficiently to build db4-java with gcj, without jvm.
658- check javac first, gcj34 next, then gcj-ssa, finally gcj.
659- add ed build dependency (#125180).
660
661* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
662- rebuilt
663
664* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
665- rebuilt
666
667* Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
668- fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
669
670* Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
671- upgrade to db-4.2.52, no db4-java for the moment.
672
673* Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
674- Add build requires tcl-devel
675
676* Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
677- symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
678  that the run-time linker can find the right copy for of apps which use an
679  RPATH to point at %%{_libdir}/libdb-4.1.so
680
681* Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
682- add another section to the ABI note for the TLS libdb so that it's marked as
683  not needing an executable stack (from Arjan Van de Ven)
684
685* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
686- build both with and without support for shared mutex locks, which require NPTL
687- make behavior wrt where we put libdb the same for all OSs
688- revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
689  doesn't work
690- fix dangling HREFs in utility docs (pointed to main docs dir, while they're
691  actually in the -utils docs dir)
692- run ldconfig when installing/removing the -utils subpackage, as it contains
693  shared libraries
694
695* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
696- fix multiple-inclusion problem of startup files when building shlibs without
697  the -nostdlib flag
698
699* Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
700- link shared libraries without -nostdlib, which created an unresolvable dep
701  on a hidden symbol
702
703* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
704- allow compiling without tcl dependency
705
706* Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
707- update to 4.2.42.
708- build in build_unix subdir.
709- eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
710- create db4-tcl sub-pkg to isolate libtcl dependencies.
711
712* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
713- rebuild
714
715* Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
716- add missing tcl-devel buildrequires (#101814)
717
718* Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
719- rebuild
720
721* Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
722- build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
723- whack out libtool predep_objects wonkiness.
724
725* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
726- rebuild.
727
728* Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
729- hack out O_DIRECT support in db4 for now.
730
731* Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
732- replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
733  cause a mismatch
734
735* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
736- rebuilt
737
738* Wed Jun  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
739- change configure to only warn if JNI includes aren't found, assuming that
740  the C compiler can find them
741- remove build requirement on jdkgcj -- gcj is sufficient
742
743* Mon May  5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
744- upgrade to 4.1.25, crypto version.
745- enable posix mutexes using nptl on all arches.
746
747* Mon Mar  3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
748- enabled db4-java for x86_64
749
750* Wed Feb  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
751- add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
752  linking with -ldb-4.0 will work again
753
754* Tue Feb  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
755- rebuild to use link the shared object with the same libraries we use
756  for the bundled utils, should pull in libpthread when needed
757- move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
758
759* Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
760- add java for s390x
761
762* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
763- rebuilt
764
765* Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
766- add java for s390
767
768* Tue Oct  8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
769- add java bits back in for x86 boxes
770
771* Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
772- Added better fix for s390/s390x/x86_64
773
774* Thu Sep 05 2002 Arjan van de Ven
775- remove java bits for x86-64
776
777* Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
778- include libdb_tcl-4.1.a library.
779- obsolete db1 packages.
780
781* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
782- include patch to avoid db_recover (#70362)
783
784* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
785- rebuilt with gcc-3.2 (we hope)
786
787* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
788- own %%{_includedir}/%{name}
789
790* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
791- build using gcc-3.2-0.1
792
793* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
794- automated rebuild
795
796* Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
797- Add java bindings
798- Fix C++ bindings
799
800* Thu May 23 2002 Tim Powers <timp@redhat.com>
801- automated rebuild
802
803* Thu May  9 2002 Jeff Johnson <jbj@redhat.com>
804- re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
805- make sure that -ldb is functional.
806
807* Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
808- avoid db_util name collisions with multiple versions installed.
809
810* Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
811- remove relocatability stuffs
812- swallow a local copy of db1 and build db185_dump statically with it, to
813  remove the build dependency and simplify bootstrapping new arches
814
[8162]815* Sun Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
[521]816- have subpackages obsolete their db3 counterparts, because they conflict anyway
817
818* Tue Jan  8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
819- upgrade to 4.0.14.
820
821* Sun Aug  5 2001 Nalin Dahyabhai <nalin@redhat.com>
822- fix dangling docs symlinks
823- fix dangling doc HREFs (#33328)
824- apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
825
826* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
827- turn off --enable-debug
828
829* Thu May 10 2001 Than Ngo <than@redhat.com>
830- fixed to build on s390x
831
832* Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
833- update to 3.2.9.
834
835* Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
836- rebuild to remove 777 directories.
837
838* Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
839- don't build with --enable-diagnostic.
840- add build prereq on tcl.
841- default value for %%_lib macro if not found.
842
843* Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
844- add /usr/lib/libdb-3.1.so symlink to %%files.
845- remove dangling tags symlink from examples.
846
847* Mon Oct  9 2000 Jeff Johnson <jbj@redhat.com>
848- rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
849- turn off --enable-diagnostic for performance.
850
851* Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
852- update to 3.1.17.
853- disable posix mutexes Yet Again.
854
855* Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
856- add c++ and posix mutex support.
857
858* Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
859- put nss_db into a separate package
860
861* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
862- rebuild to cope with glibc locale binary incompatibility, again
863
864* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
865- remove redundant strip of libnss_db* that is nuking symbols.
866- change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
867
868* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
869- summaries from specspo.
870- all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
871
872* Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
873- temporarily build nss_db in this package, should be moved
874  into separate nss_db package soon
875
876* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
877- rebuild to cope with glibc locale binary incompatibility
878
879* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
880- automatic rebuild
881
882* Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
883- upgrade to 3.1.14.
884- create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
885- FHS packaging.
886
887* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
888- disable tcl Yet Again, base packages cannot depend on libtcl.so.
889
890* Sat Jun  3 2000 Jeff Johnson <jbj@redhat.com>
891- enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
892
893* Tue May 30 2000 Matt Wilson <msw@redhat.com>
894- include /lib/libdb.so in the devel package
895
896* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
897- put in "System Environment/Libraries" per msw instructions.
898
899* Tue May  9 2000 Jeff Johnson <jbj@redhat.com>
900- install shared library in /lib, not /usr/lib.
901- move API docs to db3-devel.
902
903* Mon May  8 2000 Jeff Johnson <jbj@redhat.com>
904- don't rename db_* to db3_*.
905
906* Tue May  2 2000 Jeff Johnson <jbj@redhat.com>
907- disable --enable-test --enable-debug_rop --enable-debug_wop.
908- disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
909  problems.
910
911* Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
912- add 3.0.55.1 alignment patch.
913- add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
914- add --enable-tcl (needed -lpthreads).
915
916* Sat Apr  1 2000 Jeff Johnson <jbj@redhat.com>
917- add --enable-debug_{r,w}op for now.
918- add variable to set shm perms.
919
920* Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
921- update to 3.0.55
922
923* Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
924- Add --enable-cxx to configure.
925
926* Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
927- Create.
Note: See TracBrowser for help on using the repository browser.