source: projects/specs/trunk/d/db3/db3-vl.spec @ 521

Revision 521, 9.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# compatibility with legacy rpm
2%{!?_lib:%define _lib   lib}
3
4%define __s             -s
5%define __soversion     3.2
6%define _libdb_a        libdb-%{__soversion}.a
7%define _libcxx_a       libdb_cxx-%{__soversion}.a
8
9Summary:     The Berkeley DB database library for C.
10Summary(ja): C ÍÑ Berkeley DB ¥Ç¡¼¥¿¥Ù¡¼¥¹¥é¥¤¥Ö¥é¥ê
11Name:        db3
12Version:     3.2.9
13Release:     1vl2
14Source:      http://www.sleepycat.com/update/%{version}/db-%{version}.tar.gz
15URL:         http://www.sleepycat.com
16Copyright:   GPL
17Group:       System Environment/Libraries
18
19%ifos linux
20# XXX written as a file prereq in order to build with glibc-2.1.3
21BuildPreReq: /usr/lib/libdb1.a
22%endif
23BuildPreReq: tcl
24
25BuildRoot:   %{_tmppath}/%{name}-%{version}-root
26Prefix:      %{_prefix}
27
28
29%description
30The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
31embedded database support for both traditional and client/server applications.
32Berkeley DB is used by many applications, including Python and Perl, so this
33should be installed on all systems.
34
35
36%package utils
37Summary:     Command line tools for managing Berkeley DB databases.
38Summary(ja): Berkeley DB ¥Ç¡¼¥¿¥Ù¡¼¥¹ÍÑ¥³¥Þ¥ó¥É¥é¥¤¥ó¥Ä¡¼¥ë
39Group:       Applications/Databases
40Requires:    db3 = %{version}
41Prefix:      %{_prefix}
42
43
44%description utils
45The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
46embedded database support for both traditional and client/server applications.
47Berkeley DB includes B+tree, Extended Linear Hashing, Fixed and Variable-length
48record access methods, transactions, locking, logging, shared memory caching
49and database recovery. DB supports C, C++, Java and Perl APIs.
50
51This package contains command line tools for managing Berkeley DB databases.
52
53
54%package devel
55Summary:     Development libraries/header files for the Berkeley DB library.
56Summary(ja): Berkeley DB Íѳ«È¯¥é¥¤¥Ö¥é¥ê/¥Ø¥Ã¥À¥Õ¥¡¥¤¥ë
57Group:       System Environment/Libraries
58Requires:    db3 = %{version}
59Prefix:      %{_prefix}
60
61
62%description devel
63The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides
64embedded database support for both traditional and client/server applications.
65Berkeley DB includes B+tree, Extended Linear Hashing, Fixed and Variable-length
66record access methods, transactions, locking, logging, shared memory caching
67and database recovery. DB supports C, C++, Java and Perl APIs.
68
69This package contains the header files, libraries, and documentation for
70building programs which use Berkeley DB.
71
72
73%prep
74%setup -q -n db-%{version}
75
76
77%build
78
79cd build_unix
80
81# XXX --enable-posixmutexes is useful for threads but useless for interprocess locking.
82# XXX --enable-diagnostic should be disabled for production (but is useful).
83# XXX --enable-debug_{r,w}op should be disabled for production.
84# XXX --enable-java
85CFLAGS="$RPM_OPT_FLAGS" ../dist/configure --prefix=%{_prefix} --enable-debug --enable-compat185 --enable-dump185 --enable-shared --enable-static --enable-rpc --enable-tcl --with-tcl=%{_prefix}/lib --enable-cxx --enable-test # --enable-diagnostic --enable-debug --enable-debug_rop --enable-debug_wop # --enable-posixmutexes
86
87make libdb=%{_libdb_a} %{_libdb_a}
88make libcxx=%{_libcxx_a} %{_libcxx_a}
89
90# Static link with old db-185 libraries.
91/bin/sh ./libtool --mode=compile cc -c -O2 -g -g -I/usr/include/db1 -I../dist/../include -D_REENTRANT  ../dist/../db_dump185/db_dump185.c
92cc %{__s} -static -o db_dump185 db_dump185.lo -L%{_libdir} -ldb1
93
94# Compile rest normally.
95make libdb=%{_libdb_a} libcxx=%{_libcxx_a} TCFLAGS='-I$(builddir) -I/usr/include' LDFLAGS="%{__s}"
96
97# remove dangling tags symlink from examples.
98rm -f examples_cxx/tags
99rm -f examples_c/tags
100
101
102%install
103rm -rf ${RPM_BUILD_ROOT}
104mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
105mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib
106
107cd build_unix
108
109# XXX install_java
110make libdb=%{_libdb_a} libcxx=%{_libcxx_a} LDFLAGS="%{__s}" prefix=${RPM_BUILD_ROOT}%{_prefix} install_include install_dynamic install_static install_dynamic_cxx install_static_cxx install_tcl install_utilities
111
112# XXX annoying
113set -x
114( cd ${RPM_BUILD_ROOT}
115
116%ifos linux
117  mkdir -p ./%{_lib}
118  mv .%{_prefix}/lib/libdb[-.]*so* ./%{_lib}
119  if [ "%{_libdir}" != "%{_prefix}/lib" ]; then
120    mkdir -p .%{_libdir}
121    mv .%{_prefix}/lib/libdb* .%{_libdir}
122  fi
123%endif
124
125  mkdir -p .%{_includedir}/db3
126  mv .%{_prefix}/include/*.h .%{_includedir}/db3
127  ln -sf db3/db.h .%{_includedir}/db.h
128# XXX Rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
129  ln -sf ../../lib/libdb-%{__soversion}.so .%{_libdir}/libdb-%{__soversion}.so
130# XXX This is needed for packaging db3 for Red Hat 6.x
131#  for F in .%{_prefix}/bin/db_* ; do
132#    mv $F `echo $F | sed -e 's,/db_,/db3_,'`
133#  done
134)
135set +x
136
137# XXX libdb-3.1.so is in /lib teach libtool as well
138#perl -pi -e 's,/usr,,' ${RPM_BUILD_ROOT}%{_libdir}/libdb-%{__soversion}.la
139
140
141%clean
142rm -rf ${RPM_BUILD_ROOT}
143
144
145%post -p /sbin/ldconfig
146
147
148%postun -p /sbin/ldconfig
149
150
151%files
152%defattr(-,root,root)
153%doc LICENSE README docs/images
154%ifos linux
155/%{_lib}/libdb-%{__soversion}.so
156%else
157%{_libdir}/libdb-%{__soversion}.so
158%endif
159%{_libdir}/libdb_cxx-%{__soversion}.so
160
161
162%files utils
163%defattr(-,root,root)
164%doc    docs/utility
165%{_libdir}/libdb_tcl.so
166%{_libdir}/libdb_tcl-%{__soversion}.la
167%{_libdir}/libdb_tcl-%{__soversion}.so
168%{_bindir}/berkeley_db_svc
169%{_bindir}/db*_archive
170%{_bindir}/db*_checkpoint
171%{_bindir}/db*_deadlock
172%{_bindir}/db*_dump
173%{_bindir}/db*_dump185
174%{_bindir}/db*_load
175%{_bindir}/db*_printlog
176%{_bindir}/db*_recover
177%{_bindir}/db*_stat
178%{_bindir}/db*_upgrade
179%{_bindir}/db*_verify
180
181
182%files devel
183%defattr(-,root,root)
184%doc    docs/api_c docs/api_cxx docs/api_java docs/api_tcl docs/index.html
185%doc    docs/ref docs/sleepycat
186%doc    examples_c examples_cxx
187%{_libdir}/libdb-%{__soversion}.la
188%{_libdir}/libdb_cxx-%{__soversion}.la
189%{_libdir}/%{_libdb_a}
190%{_libdir}/%{_libcxx_a}
191%{_includedir}/db3/db.h
192%{_includedir}/db3/db_185.h
193%{_includedir}/db3/db_cxx.h
194%{_includedir}/db.h
195%ifos linux
196/%{_lib}/libdb.so
197/%{_libdir}/libdb-%{__soversion}.so
198%else
199%{_libdir}/libdb.so
200%endif
201%{_libdir}/libdb_cxx.so
202
203
204%changelog
205* Tue Dec 11 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.2.9-1vl2
206- increased release number for VineSeed main tree :)
207
208* Thu May 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
209- 3.2.9-1vl1
210- based on 3.2.9 from Rawhide
211- rebuilt for VineSeed
212
213* Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
214- update to 3.2.9.
215
216* Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
217- rebuild to remove 777 directories.
218
219* Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
220- don't build with --enable-diagnostic.
221- add build prereq on tcl.
222- default value for %%_lib macro if not found.
223
224* Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
225- add /usr/lib/libdb-3.1.so symlink to %%files.
226- remove dangling tags symlink from examples.
227
228* Mon Oct  9 2000 Jeff Johnson <jbj@redhat.com>
229- rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
230- turn off --enable-diagnostic for performance.
231
232* Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
233- update to 3.1.17.
234- disable posix mutexes Yet Again.
235
236* Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
237- add c++ and posix mutex support.
238
239* Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
240- put nss_db into a separate package
241
242* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
243- rebuild to cope with glibc locale binary incompatibility, again
244
245* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
246- remove redundant strip of libnss_db* that is nuking symbols.
247- change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
248
249* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
250- summaries from specspo.
251- all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
252
253* Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
254- temporarily build nss_db in this package, should be moved
255  into separate nss_db package soon
256
257* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
258- rebuild to cope with glibc locale binary incompatibility
259
260* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
261- automatic rebuild
262
263* Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
264- upgrade to 3.1.14.
265- create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
266- FHS packaging.
267
268* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
269- disable tcl Yet Again, base packages cannot depend on libtcl.so.
270
271* Sat Jun  3 2000 Jeff Johnson <jbj@redhat.com>
272- enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
273
274* Tue May 30 2000 Matt Wilson <msw@redhat.com>
275- include /lib/libdb.so in the devel package
276
277* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
278- put in "System Environment/Libraries" per msw instructions.
279
280* Tue May  9 2000 Jeff Johnson <jbj@redhat.com>
281- install shared library in /lib, not /usr/lib.
282- move API docs to db3-devel.
283
284* Mon May  8 2000 Jeff Johnson <jbj@redhat.com>
285- don't rename db_* to db3_*.
286
287* Tue May  2 2000 Jeff Johnson <jbj@redhat.com>
288- disable --enable-test --enable-debug_rop --enable-debug_wop.
289- disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
290  problems.
291
292* Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
293- add 3.0.55.1 alignment patch.
294- add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
295- add --enable-tcl (needed -lpthreads).
296
297* Sat Apr  1 2000 Jeff Johnson <jbj@redhat.com>
298- add --enable-debug_{r,w}op for now.
299- add variable to set shm perms.
300
301* Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
302- update to 3.0.55
303
304* Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
305- Add --enable-cxx to configure.
306
307* Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
308- Create.
Note: See TracBrowser for help on using the repository browser.