source: projects/specs/trunk/d/datamash/datamash-vl.spec @ 10720

Revision 10720, 2.3 KB checked in by ara_t, 8 years ago (diff)

first commit

Line 
1%define pkg_name    datamash
2%define pkg_version 1.1.0
3%define pkg_release 1%{?_dist_release}
4
5Summary: A statistics tool for command-line interface
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv3+
11Group:   Applications/Edutainment
12URL:     https://www.gnu.org/software/datamash/
13Source0: http://ftp.gnu.org/gnu/datamash/%{name}-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: ara_t
20
21
22%description
23GNU datamash is a command-line program which performs basic numeric,
24textual and statistical operations on input textual data files.
25
26GNU datamash is designed for ease of use, strict input validation,
27and robust operation. If datamash is not available, some operations
28could be performed using existing software (such as awk, Perl, R).
29Using Datamash has the following advantages over simple one-liners:
30 - Datamash performs strict input validation on the input, and provides
31   informative error messages when invalid input is found.
32 - Datamash operations are simpler to type, and less error-prone than
33   writing one-liners.
34 - Datamash supports header lines (-H/--headers) on all operations.
35 - Datamash supports printing the entire line (-f/--full), not just
36   the field being processed.
37 - Datamash's output is suitable for both interactive command-line usage,
38   and for scripting, automation and down-stream processing by other tools.
39GNU datamash is a command-line program which performs basic numeric,
40textual and statistical operations on input textual data files.
41#'
42
43%prep
44%{__rm} -rf ${RPM_BUILD_ROOT}
45%setup -q
46%{configure}
47
48%build
49%{__make} %{?_smp_mflags}
50
51%install
52%{make_install}
53%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
54
55%check
56%{__make} %{?_smp_mflags} check
57
58%clean
59%{__rm} -rf ${RPM_BUILD_ROOT}
60
61%post
62%{_syssbindir}/install-info --info-dir=%{_infodir} \
63 %{_infodir}/datamash.info.gz || :
64
65%preun
66if [ "$1" = "0" ]; then
67    %{_syssbindir}/install-info --delete --info-dir=%{_infodir} \
68     %{_infodir}/datamash.info.gz || :
69fi
70
71
72%files
73%defattr(-, root, root)
74%doc ABOUT-NLS AUTHORS COPYING ChangeLog NEWS
75%doc README README-release THANKS TODO
76%{_bindir}/
77%{_datadir}/%{name}/
78%{_datadir}/info/
79%{_datadir}/locale/
80%{_mandir}/man1/
81
82
83%changelog
84* Sun Jul 31 2016 Toshiaki Ara <ara_t@384.jp> 1.1.0-1
85- new package
Note: See TracBrowser for help on using the repository browser.