source: projects/specs/trunk/d/dante/dante-vl.spec @ 521

Revision 521, 8.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _localstatedir /var
2Summary: A free Socks v4/v5 client implementation
3Summary(ja): Socks v4/v5 クライアントのフリーな実装
4Name: dante
5Version: 1.1.14
6# define for pre-releases, undefine for normal releases.
7%undefine pre
8Release: 1%{?_dist_release}
9License: BSD-type
10Group: Applications/Internet
11URL: http://www.inet.no/dante/
12%define distname %{name}-%{version}%{?pre:-%{pre}}
13Source: ftp://ftp.inet.no/pub/socks/%{distname}.tar.gz
14Source1: sockd.conf
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16BuildPreReq: pam-devel tcp_wrappers
17Requires: pam
18
19%description
20Dante is a free implementation of the proxy protocols socks version 4,
21socks version 5 (rfc1928) and msproxy. It can be used as a firewall
22between networks. It is being developed by Inferno Nettverk A/S, a
23Norwegian consulting company. Commercial support is available.
24
25This package contains the dynamic libraries required to "socksify"
26existing applications to become socks clients.
27
28%description -l ja
29dante は proxy プロトコルである socks バージョン4,socks バージョン5
30(rfc1928), mxproxy のフリー実装です.ネットワーク間のファイアーウォールと
31して使うことが出来ます.開発はノルウェーのコンサルタント会社である
32Inferno Netverk A/S で行われています.コマーシャルサポートもあります.
33
34このパッケージには,既存のアプリケーションを socks クライアントに
35するのに必要なダイナミックライブラリが収められています.
36
37%package server
38Summary: A free Socks v4/v5 server implementation
39Summary(ja): Socks v4/v5 サーバのフリーな実装
40Group: System Environment/Daemons
41Requires: dante = %{version}
42PreReq: /sbin/chkconfig
43
44%description server
45This package contains the socks proxy daemon and its documentation.
46The sockd is the server part of the Dante socks proxy package and
47allows socks clients to connect through it to the network.
48
49%description server -l ja
50このパッケージには socks プロキシデーモンとそのドキュメントが
51収められています.sockd は Dante socks プロキシパッケージの
52サーバ部分で,socks クライアントは sockd サーバを介することにより
53ネットワークに接続出来ます.
54
55%package devel
56Summary: development libraries for socks
57Summary(ja): socks 用開発ライブラリ
58Group: Development/Libraries
59Requires: dante = %{version}
60
61%description devel
62Additional libraries required to compile programs that use socks.
63
64%description devel -l ja
65socks を使うプログラムをコンパイルするのに必要な追加ライブラリです.
66
67%prep
68%setup -q -n %{distname}
69
70# no need to preload libdl.so explicitly.
71%{__sed} -e 's/@SOCKSIFY_PRELOAD_LIBS@//' bin/socksify.in >bin/socksify.in.new
72%{__mv} bin/socksify.in.new bin/socksify.in
73
74# This file is embedded here instead of being another source in order
75# to the prefix directory
76cat >sockd.init <<EOF
77#!/bin/sh
78#
79# sockd         This shell script takes care of starting and stopping
80#               the Dante server.
81#
82# chkconfig: 2345 65 35
83# description: sockd implements a socks v4/v5 proxy server
84
85# Source function library.
86. /etc/rc.d/init.d/functions
87
88# Source networking configuration.
89. /etc/sysconfig/network
90
91# Check that networking is up.
92[ \${NETWORKING} = "no" ] && exit 0
93
94[ -f %{_sbindir}/sockd ] || exit 0
95[ -f %{_sysconfdir}/sockd.conf ] || exit 0
96
97# See how we were called.
98case "\$1" in
99  start)
100        # Start daemons.
101        echo -n "Starting sockd: "
102        daemon %{_sbindir}/sockd -D
103        echo
104        touch %{_var}/lock/subsys/sockd
105        ;;
106  stop)
107        # Stop daemons.
108        echo -n "Shutting down sockd: "
109        killproc sockd
110        echo
111        rm -f %{_var}/lock/subsys/sockd
112        ;;
113  restart)
114        \$0 stop
115        \$0 start
116        ;;
117  status)
118        status sockd
119        ;;
120  *)
121        echo "Usage: sockd {start|stop|restart|status}"
122        exit 1
123esac
124
125exit 0
126EOF
127
128%build
129%configure
130%{__make}
131
132%install
133%{__rm} -rf %{buildroot}
134%{makeinstall}
135
136#set library as executable - prevent ldd from complaining
137%{__chmod} +x %{buildroot}%{_libdir}/*.so.*.*
138%{__install}  -d %{buildroot}%{_sysconfdir}/rc.d/init.d %{buildroot}%{_bindir}
139%{__install} -m 644 example/socks-simple.conf %{buildroot}%{_sysconfdir}/socks.conf
140%{__install} -m 644 %{_sourcedir}/sockd.conf %{buildroot}%{_sysconfdir}
141%{__install} -m 755 sockd.init %{buildroot}%{_sysconfdir}/rc.d/init.d/sockd
142
143## remove unuse files
144rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
145
146
147%clean
148%{__rm} -rf %{buildroot}
149
150
151%post -p /sbin/ldconfig
152%postun -p /sbin/ldconfig
153
154%post server
155/sbin/chkconfig --add sockd
156
157%preun server
158if [ "$1" = 0 ]; then
159        service sockd stop >/dev/null 2>&1
160        /sbin/chkconfig --del sockd
161fi
162
163%postun server
164if [ "$1" -ge "1" ]; then
165        service sockd condrestart > /dev/null 2>&1
166fi
167
168%files
169%defattr(-,root,root)
170%doc BUGS CREDITS INSTALL LICENSE NEWS README SUPPORT TODO
171%doc doc/README* doc/rfc* doc/SOCKS4.protocol doc/faq.tex
172%doc example/{socks.conf,socks-simple-withoutnameserver.conf,sockd.conf,socks-simple.conf}
173%{_libdir}/libsocks.so.0.1.0
174%{_libdir}/libsocks.so.0
175%{_libdir}/libdsocks.so.0.1.0
176%{_libdir}/libdsocks.so.0
177%{_libdir}/libdsocks.so
178%{_bindir}/socksify
179%{_mandir}/man5/socks.conf.5*
180%config(noreplace) %{_sysconfdir}/socks.conf
181
182
183%files server
184%defattr(-,root,root)
185%{_mandir}/man8/sockd.8*
186%{_sbindir}/sockd
187%{_mandir}/man5/sockd.conf.5*
188%config(noreplace) %{_sysconfdir}/sockd.conf
189%config %{_sysconfdir}/rc.d/init.d/sockd
190
191
192%files devel
193%defattr(-,root,root)
194%{_libdir}/libsocks.so
195#%{_libdir}/libsocks.la
196%{_libdir}/libsocks.a
197#%{_libdir}/libdsocks.la
198%{_includedir}/socks.h
199
200
201%changelog
202* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.14-1vl5
203- applied new versioning policy, spec in utf-8
204- removed *.la
205
206* Mon May 10 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
207- 1.1.14-0vl1: built for VineSeed
208- use/change macros for dirs (/etc, /var)
209- re-enable chkconfig and add stop/restart on uninstall/upgrade
210- include our sockd.conf (Source1) based on example/sockd-basic.conf
211
212* Mon Nov 24 2003 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
213- 1.1.14-0vl0.26.0: new upstream release
214- remove preloading libdl.so (in glibc-devel) from socksify
215
216* Mon Dec 02 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
217- 1.1.13-0vl0.26.0: built for Vine Linux 2.5/2.6
218
219* Mon Dec 02 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
220- 1.1.13-0vl0.21.0: built for Vine Linux 2.1.x
221- new upstream release:
222  dante-config_parse.patch and dante-recvmsg.patch are incorporated.
223- set noreplace flag to sock{s,d}.conf
224- remove BuildPreReq: flex
225
226* Mon May 13 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
227- 1.1.12-0vl7: built for Vine Linux 2.5
228
229* Mon May 13 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
230- 1.1.12-0vl6: built for Vine Linux 2.1.x
231- change dante-recvmsg.patch to fix core dump with libdsocks
232
233* Wed Apr 24 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
234- 1.1.12-0vl5: built for Vine Linux 2.5
235
236* Sat Apr 20 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
237- 1.1.12-0vl4: built for Vine Linux 2.1.x
238- replaced source with full-release of 1.1.12.
239- replaced dante-recvmsg.patch with one from original author
240- added dependencies (pam, tcp_wrappers)
241
242* Sun Mar 31 2002 Jun Nishii <jun@vinelinux.org>
243- 1.1.12-0vl3: rebuild for Vine Linux 2.5
244
245* Mon Mar 18 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
246- 1.1.12-0vl2: patch to include/{common,sockd}.h
247
248* Thu Feb 14 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
249- 1.1.12-0vl1: updated to 1.1.12-pre1 and modified spec for pre-releases
250
251* Mon Feb 11 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
252- 1.1.11-0vl2: patch to lib/config_parse.y
253
254* Fri Dec 14 2001 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
255- 1.1.11-0vl1
256
257* Sat Nov 10 2001 akira yamada <akira@vinelinux.org> 1.1.10-0vl2
258- moved libsocs.so to dante-devel from dante.
259- added defattr for dante-devel.
260- added BuildPreReq: flex
261
262* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
263- 1.1.10-0vl1: updated to 1.1.10 with a bit better macros and minor spec fixes
264- fixed Group
265
266* Fri May 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
267- 1.1.9-1vl1
268- based on 1.1.9-1 generated from original tarball (by rpm -ts)
269- rebuilt for Vine Linux
270- modified spec file
271
272* Thu Oct 12 2000 Karl-Andre' Skevik <karls@inet.no>
273-use of macros for directory locations/paths
274-explicitly name documentation files
275-run chkconfig --del before files are deleted on uninstall
276
277* Wed Mar 10 1999 Karl-Andre' Skevik <karls@inet.no>
278- Integrated into CVS
279- socksify patch no longer needed
280
281* Thu Mar 04 1999 Oren Tirosh <oren@hishome.net>
282- configurable %{prefix}, fixed daemon init script
283- added /lib/libdl.so to socksify
284
285* Wed Mar 03 1999 Oren Tirosh <oren@hishome.net>
286- First spec file for Dante
Note: See TracBrowser for help on using the repository browser.