source: projects/specs/trunk/d/dSFMT/dSFMT-vl.spec @ 11714

Revision 11714, 3.5 KB checked in by ara_t, 6 years ago (diff)

dSFMT: initial commit

Line 
1%define pkg_name    dSFMT
2%define pkg_version 2.2.3
3%define pkg_release 1%{?_dist_release}
4
5Summary: Double precision SIMD-oriented Fast Mersenne Twister
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD
11Group:   System Environment/Libraries
12URL:     http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT
13
14Source0: http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT/%{name}-src-%{version}.tar.gz
15
16Patch0: %{name}-%{version}_sharedlib.patch
17Patch1: %{name}-%{version}_pkgconfig.patch
18Patch2: %{name}-%{version}_exportfuns.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: nkf
22
23
24%description
25The purpose of dSFMT is to speed up the generation by avoiding
26the expensive conversion of integer to double (floating point).
27dSFMT directly generates double precision floating point
28pseudo-random numbers which have the IEEE Standard for Binary
29Floating-Point Arithmetic (ANSI/IEEE Std 754-1985) format.
30
31dSFMT is only available on the CPUs which use IEEE 754 format
32double precision floating point numbers.
33
34dSFMT doesn't support integer outputs.
35dSFMT supports the output of double precision floating point
36pseudo-random numbers which distribute in the range of
37[1, 2), [0, 1), (0, 1] and (0, 1).
38And it also supports the various periods form 2^521 - 1 to 2^132049 - 1.
39#'
40
41%description -l ja
42dSFMT の開発目的は整数から浮動小数点数への変換のコストを避けることにあります。
43dSFMT は IEEE Standard for Binary Floating-Point Arithmetic (ANSI/IEEE Std
44754-1985) 形式の倍精度浮動小数点擬似乱数を直接生成します。 したがって、dSFMT
45は IEEE 754 形式の倍精度浮動小数点数を使用する CPU でしか利用出来ません。
46
47dSFMT は整数の出力をサポートしません。
48dSFMT がサポートするのは [1, 2), [0, 1), (0, 1], (0, 1) の範囲に分布する
49倍精度浮動小数点擬 似乱数です。また、2^521 - 1 から 2^216091 - 1 までの様々な
50周期をサポートします。
51
52
53%package devel
54Summary: Development files for %{name}
55Group:   Development/Libraries
56Requires: %{name} = %{version}-%{release}
57
58%description devel
59The %{name}-devel package contains libraries and header files for
60developing applications that use %{name}.
61
62
63%prep
64%setup -q -n %{name}-src-%{version}
65%patch0 -p1 -b .sharedlib
66%patch1 -p0 -b .pkgconfig
67%patch2 -p1 -b .exportfuns
68
69nkf -w -Lu --overwrite README.jp.txt
70
71%build
72%{__make} %{?_smp_mflags} sharedlib \
73 libdir=%{_libdir} CCFLAGS="-fPIC %{optflags}"
74
75%install
76%{make_install} libdir=%{_libdir}
77%{__install} -pm644 %{name}.pc ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/
78
79%check
80%{__make} std-check
81
82%clean
83%{__rm} -rf ${RPM_BUILD_ROOT}
84
85%post -p %{_syssbindir}/ldconfig
86
87%postun -p %{_syssbindir}/ldconfig
88
89
90%files
91%doc CHANGE-LOG.txt LICENSE.txt README.txt README.jp.txt
92%doc html/
93%{_libdir}/*.so.*
94
95%files devel
96%{_libdir}/*.so
97%{_libdir}/pkgconfig/%{name}.pc
98%{_includedir}/*.h
99
100
101%changelog
102* Sat Jun 09 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
103- initial build for Vine Linux
104
105* Wed Sep 3 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 2.2.3-4
106- Move documentation to -devel-doc package.
107- Run tests (modify and simplify Makefile patch to do this).
108
109* Sat Jun 28 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 2.2.3-3
110- Add patch to export functions required to use the library.
111
112* Tue Jun 17 2014 Xavier Lamien <laxathom@fedoraproject.org> - 2.2.3-2
113- Update license.
114- lower variable into Makefile.
115
116* Thu Jun  5 2014 Xavier Lamien <laxathom@fedoraproject.org> - 2.2.3-1
117- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.