source: projects/specs/trunk/c/cups-pdf/cups-pdf-vl.spec @ 9436

Revision 9436, 7.0 KB checked in by inagaki, 9 years ago (diff)

2015-03-16 Ryoichi INAGAKI <ryo1@…>

  • bluefish, cups-pdf: updated
  • graphviz: rebuilt and added lua subpackage
RevLine 
[9436]1Name:           cups-pdf
2Version:        2.6.1
3Release:        1%{?_dist_release}
4Summary:        Extension for creating pdf-Files with CUPS
5Summary(ja):    CUPS を用いた仮想 PDF プリンター
[521]6
[9436]7Group:          Applications/Publishing
8URL:            http://www.cups-pdf.de/
9License:        GPLv2+
10
11Source0:        http://www.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/src/%{name}_%{version}.tar.gz
12Source1:        INSTALL.cups-pdf
13Patch0:         cups-pdf-conf-vine.patch
14# Handle ${DESKTOP} from config
15Patch2:         cups-pdf-desktop.patch
16# Handle new lines in title
17Patch3:         cups-pdf-title.patch
18# Fix build warning
19Patch4:         cups-pdf-build.patch
20# Report error/success in log
21Patch5:         cups-pdf-result.patch
22
[521]23BuildRoot: %{_tmppath}/%{name}-%{version}-root
[9436]24#BuildRequires:  cups-devel
25Requires:       ghostscript, cups
26Requires(post):   cups
27Requires(postun): cups
[521]28
29# These are the defaults paths defined in config.h
30# CUPS-PDF spool directory
[9436]31%global CPSPOOL   %{_localstatedir}/spool/cups-pdf/SPOOL
[521]32
33# CUPS-PDF output directory
[9436]34%global CPOUT     %{_localstatedir}/spool/cups-pdf
[521]35
36# CUPS-PDF log directory
[9436]37%global CPLOG     %{_localstatedir}/log/cups
[521]38
39# CUPS-PDF cups-pdf.conf config file
[9436]40%global ETCCUPS   %(cups-config --serverroot 2>/dev/null || echo %{_sysconfdir}/cups)
[521]41
42# Additional path to backend directory
[9436]43%global CPBACKEND %(cups-config --serverbin  2>/dev/null || echo %{_libdir}/cups)/backend
[521]44
45
46%description
[9436]47"cups-pdf" is a backend script for use with CUPS - the "Common UNIX Printing
48System" (see more for CUPS under http://www.cups.org/).
49"cups-pdf" uses the ghostscript pdfwrite device to produce PDF Files.
[521]50
[9436]51This version has been modified to store the PDF files on the Desktop of the
52user. This behavior can be changed by editing the configuration file.
53
[521]54%description -l ja
[9436]55cups-pdf は CUPS (Common UNIX Printing System, http://www.cups.org/) を用いたいわゆる仮想 PDF プリンタのためのバックエンドスクリプトです。
56cups-pdf は PDF ファイルを生成するために Ghostscript の pdfwrite デバイスを使います。
[521]57
[9436]58CUPS が動作しているときに %{name} をインストールすると、自動的に "CUPS-PDF Printer" として CUPS の設定を行います。
[521]59
60
61%prep
62%setup -n %{name}-%{version}
63%patch0 -p1 -b .vine
[9436]64%patch2 -p0 -b .desktop
65%patch3 -p0 -b .title
66%patch4 -p0 -b .build
67%patch5 -p0 -b .result
[521]68
[9436]69cp -p %{SOURCE1} INSTALL.RPM
[521]70
71%build
72pushd src
73%{__cc} $RPM_OPT_FLAGS -o cups-pdf cups-pdf.c
74popd
75
76# Avoid perl dependencies
77%{__chmod} -x contrib/pstitleiconv-0.2/pstitleiconv
78%{__chmod} -x contrib/cups-pdf-dispatch-0.1/cups-pdf-dispatch
79%{__chmod} -x contrib/SELinux-HOWTO/update-module
80
81%install
[2778]82%__rm -rf ${RPM_BUILD_ROOT}
[521]83
[2778]84%__mkdir_p $RPM_BUILD_ROOT%{CPBACKEND}
85%__mkdir_p $RPM_BUILD_ROOT%{CPSPOOL}
86%__mkdir_p $RPM_BUILD_ROOT%{CPOUT}
87%__mkdir_p $RPM_BUILD_ROOT%{CPLOG}
88%__mkdir_p $RPM_BUILD_ROOT%{CPBACKEND}
89%__mkdir_p $RPM_BUILD_ROOT%{ETCCUPS}
90%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/cups/model/
91%__install -m644 extra/CUPS-PDF.ppd $RPM_BUILD_ROOT%{_datadir}/cups/model/
[9436]92%__install -m644 extra/cups-pdf.conf $RPM_BUILD_ROOT%{ETCCUPS}/
[2778]93%__install -m755 src/cups-pdf $RPM_BUILD_ROOT%{CPBACKEND}
[521]94
95
96%clean
[2778]97[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
[521]98
99
100%post
101# First install : create the printer if cupsd is running
102if [ "$1" -eq "1" -a -f "%{_var}/run/cupsd.pid" ]
103then
104    /sbin/service cups condrestart
105    if [ -d /proc/$(cat %{_var}/run/cupsd.pid) ]
106    then
107        echo "Install CUPS-PDF Printer ... "
108        /usr/sbin/lpadmin -p Cups-PDF -v cups-pdf:/ -m CUPS-PDF.ppd -E || :
109    fi
110fi
111
112%postun
113if [ "$1" -eq "0" ]; then
114    # Delete the printer
115    echo "Remove CUPS-PDF Printer ... "
116    /usr/sbin/lpadmin -x Cups-PDF || :
117fi
118
119
120%files
121%defattr(-,root,root)
[9436]122%doc ChangeLog COPYING README INSTALL.RPM contrib/
[521]123%dir %{CPSPOOL}
124%dir %{CPOUT}
125%attr(700, root, root) %{CPBACKEND}/cups-pdf
[9436]126%config(noreplace) %{ETCCUPS}/cups-pdf.conf
[521]127%{_datadir}/cups/model/CUPS-PDF.ppd
128
[9436]129%changelog
130* Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.1-1
131- new upstream release
132- updated Patch0
133- added Patch3, 4 and 5 from Fedora
134  * Mon Sep 23 2013 Remi Collet <remi@fedoraproject.org> 2.6.1-7
135  - report success/error in log file #1010434
136  * Tue Mar 19 2013 Remi Collet <remi@fedoraproject.org> 2.6.1-4
137  - fix title detection
138  - fix build warning
[521]139
[2778]140* Fri Feb 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.1-1
141- new upstream release
142- fixed %%description -l ja
143
[521]144* Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.0-4
145- rename Patch0 to cups-pdf-conf-vine.patch
146- updated cups-pdf-conf-vine.patch
147  - set Truncate 256
148- change cups-pdf.conf to %%config(noreplace) in %%files section
149
150* Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.5.0-3
151- updated cups-pdf.conf.vl.patch: set DecodeHexStrings 1 (Experimental)
152
153* Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.5.0-2
154- added cups-pdf_2.5.0-4.diff.gz from Ubuntu
155  - applied 60_cups-pdf_remove-contrib-SELinux-HOWTO-bashisms.patch
156  - applied 70_cups-pdf_support-pdf-workflow.patch
157- added some comments in %%description -l ja
158- added echo "install/remove CUPS-PDF Printer" in %%post and %%postun
159- removed INSTALL and added README in %%doc
160
161* Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.5.0-1
162- new upstream release
163- updated the URL tag
164- correct the License tag
165
166* Tue Dec 30 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.8-2
167- fixed typo in spec
168
169* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-1
170- new upstream release
171
172* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.6-1vl5
173- applied new versioning policy, spec in utf-8
174
175* Thu Jun 28 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.4.6-0vl2
176- rebuld for VineSeed
177
178* Thu Jun 28 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.4.6-0vl1
179- source update
180- delete -dNOKANJI option of Ghostscript
181
182* Sun Mar 25 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.4.5-0vl1
183- initial build for Vine Linux 4.1
184
185* Mon Sep 26 2005       Christian Ellsworth C. <k.ellsworth@gmail.com>
186- adapted to fit the new runtime config file of version 2.0
187
188* Sat Mar 05 2005       Christian Ellsworth C. <k.ellsworth@gmail.com>
189- adapted to cups-pdf 1.7.0
190- added auto configure a cups-pdf printer
191
192* Tue Feb 22 2005       Christian Ellsworth C. <k.ellsworth@gmail.com>
193- adapted to cups-pdf 1.6.6
194
195* Thu Aug 12 2004       Volker Behr <vrbehr@cip.physik.uni-wuerzburg.de>
196- adapted to cups-pdf 1.5.2
197
198* Sat Jan 31 2004       Volker Behr <vrbehr@cip.physik.uni-wuerzburg.de>
199- adapetd to cups-pdf 1.4.0 and new building environment
200
201* Wed Jan 14 2004       Mark Lane <harddata.com>
202- fixed the specfile so that x86_64 version installs the filter
203- in /usr/lib64 instead of /usr/lib
204
205* Sun Nov 02 2003       Volker Behr <vrbehr@cip.physik.uni-wuerzburg.de>
206- third release of cups-pdf, RPM-Edition for cups-pdf 1.3
207
208* Tue Sep 09 2003       Dirk Schwier <rpms@raumhochdrei.de>
209- second Release of cups-pdf, RPM-Edition for cups-pdf 1.1
210
211* Tue May 27 2003       Dirk Schwier <rpms@raumhochdrei.de>
212- we're proud to present the first version of cups-pdf, RPM-Edition
213
214# end of file
Note: See TracBrowser for help on using the repository browser.