source: projects/specs/trunk/c/cups-filters/cups-filters-vl.spec @ 9752

Revision 9752, 14.4 KB checked in by tomop, 9 years ago (diff)

cups-2.1.0-1, etc.

Line 
1# we build CUPS also with relro
2%global _hardened_build 1
3
4Summary: OpenPrinting CUPS filters and backends
5Name:    cups-filters
6Version: 1.0.76
7Release: 1%{?_dist_release}
8
9# For a breakdown of the licensing, see COPYING file
10# GPLv2:   filters: commandto*, imagetoraster, pdftops, rasterto*,
11#                   imagetopdf, pstopdf, texttopdf
12#         backends: parallel, serial
13# GPLv2+:  filters: gstopxl, textonly, texttops, imagetops
14# GPLv3:   filters: bannertopdf
15# GPLv3+:  filters: urftopdf
16# LGPLv2+:   utils: cups-browsed
17# MIT:     filters: gstoraster, pdftoijs, pdftoopvp, pdftopdf, pdftoraster
18License: GPLv2 and GPLv2+ and GPLv3 and GPLv3+ and LGPLv2+ and MIT
19
20Group:   System Environment/Base
21Url:     http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
22Source0: http://www.openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
23
24#Patch1: cups-filters-pdf-landscape.patch
25Patch2: cups-filters-dbus.patch
26#Patch3: cups-filters-memory-leaks.patch
27#Patch4: cups-filters-filter-costs.patch
28
29Requires: cups
30Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
31
32# Obsolete cups-php (bug #971741)
33Obsoletes: cups-php < 1:1.6.0-1
34# Don't Provide it because we don't build the php module
35#Provides: cups-php = 1:1.6.0-1
36
37BuildRequires: cups-devel
38# pdftopdf
39BuildRequires: qpdf-devel
40# pdftops
41BuildRequires: poppler-utils
42# pdftoijs, pdftoopvp, pdftoraster, gstoraster
43BuildRequires: poppler-devel
44BuildRequires: libjpeg-devel
45BuildRequires: libpng-devel
46BuildRequires: libtiff-devel
47BuildRequires: zlib-devel
48BuildRequires: pkgconfig dbus-devel
49# libijs
50BuildRequires: ghostscript-devel
51BuildRequires: freetype2-devel
52BuildRequires: fontconfig-devel
53BuildRequires: lcms2-devel
54# cups-browsed
55BuildRequires: avahi-devel avahi-glib-devel
56
57# Make sure we get postscriptdriver tags.
58BuildRequires: python-cups
59
60# Testing font for test scripts.
61BuildRequires: TrueType-dejavu
62
63# autogen.sh
64BuildRequires: autoconf
65BuildRequires: automake
66BuildRequires: libtool
67
68Requires: poppler-utils
69# pstopdf
70Requires: bc grep sed
71
72# cups-browsed
73#Requires(post): systemd
74#Requires(preun): systemd
75#Requires(postun): systemd
76
77# Ghostscript CUPS filters live here since Ghostscript 9.08.
78Provides: ghostscript-cups = 9.08
79Obsoletes: ghostscript-cups < 9.08
80
81Vendor: Project Vine
82Distribution: Vine Linux
83Packager: tomop
84
85%package libs
86Summary: OpenPrinting CUPS filters and backends - cupsfilters and fontembed libraries
87Group:   System Environment/Libraries
88# LGPLv2: libcupsfilters
89# MIT:    libfontembed
90License: LGPLv2 and MIT
91
92%package devel
93Summary: OpenPrinting CUPS filters and backends - development environment
94Group:   Development/Libraries
95License: LGPLv2 and MIT
96Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
97
98%description
99Contains backends, filters, and other software that was
100once part of the core CUPS distribution but is no longer maintained by
101Apple Inc. In addition it contains additional filters developed
102independently of Apple, especially filters for the PDF-centric printing
103workflow introduced by OpenPrinting.
104
105%description libs
106This package provides cupsfilters and fontembed libraries.
107
108%description devel
109This is the development package for OpenPrinting CUPS filters and backends.
110
111%prep
112%setup -q
113
114# Fix PDF landscape printing (bug #768811).
115#%patch1 -p1 -b .pdf-landscape
116
117# Include dbus so that colord support works (bug #1026928).
118%patch2 -p1 -b .dbus
119
120# Fix memory leaks in cups-browsed (bug #1027317).
121#%patch3 -p1 -b .memory-leaks
122
123# Adjust filter costs so application/vnd.adobe-read-postscript input
124# doesn't go via pstotiff (bug #1008166).
125#%patch4 -p1 -b .filter-costs
126
127%build
128# work-around Rpath
129./autogen.sh
130
131# --with-pdftops=hybrid - use Poppler's pdftops instead of Ghostscript for
132#                         Brother, Minolta, and Konica Minolta to work around
133#                         bugs in the printer's PS interpreters
134# --with-rcdir=no - don't install SysV init script
135export IJS_CFLAGS="-I/usr/include/ijs"
136export IJS_LIBS="-lijs"
137%configure --disable-static \
138           --disable-silent-rules \
139           --with-pdftops=hybrid \
140           --enable-dbus \
141           --with-rcdir=%{_sysconfdir} \
142           --with-test-font-path=/usr/share/fonts/TrueType-dejavu/DejaVuSans.ttf
143
144make %{?_smp_mflags}
145
146%install
147make install DESTDIR=%{buildroot}
148
149# https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
150mkdir __doc
151mv  %{buildroot}%{_datadir}/doc/cups-filters/* __doc
152rm -rf %{buildroot}%{_datadir}/doc/cups-filters
153
154# Don't ship libtool la files.
155rm -f %{buildroot}%{_libdir}/lib*.la
156
157# Not sure what is this good for.
158rm -f %{buildroot}%{_bindir}/ttfread
159
160# systemd unit file
161#mkdir -p %{buildroot}%{_unitdir}
162#install -p -m 644 utils/cups-browsed.service %{buildroot}%{_unitdir}
163
164# SysV initscripts
165rm -rf %{buildroot}%{_sysconfdir}/rc{0,2,3,5}.d
166rm -rf %{buildroot}%{_sysconfdir}/rc.d
167mkdir -p %{buildroot}%{_sysconfdir}/rc.d
168mv -f %{buildroot}%{_sysconfdir}/init.d %{buildroot}%{_sysconfdir}/rc.d/
169
170%check
171make check
172
173%post
174#%systemd_post cups-browsed.service
175
176# Initial installation
177if [ $1 -eq 1 ] ; then
178    IN=%{_sysconfdir}/cups/cupsd.conf
179    OUT=%{_sysconfdir}/cups/cups-browsed.conf
180    keyword=BrowsePoll
181
182    # We can remove this after few releases, it's just for the introduction of cups-browsed.
183    if [ -f "$OUT" ]; then
184        echo -e "\n# NOTE: This file is not part of CUPS. You need to start & enable cups-browsed service." >> "$OUT"
185    fi
186
187    # move BrowsePoll from cupsd.conf to cups-browsed.conf
188    if [ -f "$IN" ] && grep -iq ^$keyword "$IN"; then
189        if ! grep -iq ^$keyword "$OUT"; then
190            (cat >> "$OUT" <<EOF
191
192# Settings automatically moved from cupsd.conf by RPM package:
193EOF
194            ) || :
195            (grep -i ^$keyword "$IN" >> "$OUT") || :
196            #systemctl enable cups-browsed.service >/dev/null 2>&1 || :
197        fi
198        sed -i -e "s,^$keyword,#$keyword directive moved to cups-browsed.conf\n#$keyword,i" "$IN" || :
199    fi
200fi
201
202%preun
203#%systemd_preun cups-browsed.service
204
205%postun
206#%systemd_postun_with_restart cups-browsed.service
207
208%post libs
209/sbin/ldconfig
210
211%postun libs
212/sbin/ldconfig
213
214
215%files
216%doc __doc/README __doc/AUTHORS __doc/NEWS
217%config(noreplace) %{_sysconfdir}/cups/cups-browsed.conf
218%config(noreplace) %{_sysconfdir}/fonts/conf.d/99pdftoopvp.conf
219%{_bindir}/foomatic-rip
220%attr(0755,root,root) %{_cups_serverbin}/filter/*
221%exclude %{_cups_serverbin}/filter/pdftoraster
222%exclude %{_cups_serverbin}/filter/textonly
223%attr(0755,root,root) %{_cups_serverbin}/backend/implicitclass
224%attr(0755,root,root) %{_cups_serverbin}/backend/parallel
225# Serial backend needs to run as root (bug #212577#c4).
226%attr(0700,root,root) %{_cups_serverbin}/backend/serial
227%{_datadir}/cups/banners
228%{_datadir}/cups/charsets
229%{_datadir}/cups/data/*
230# this needs to be in the main package because of cupsfilters.drv
231%{_datadir}/cups/ppdc/pcl.h
232%{_datadir}/cups/drv/cupsfilters.drv
233%{_datadir}/cups/mime/cupsfilters.types
234%{_datadir}/cups/mime/cupsfilters.convs
235%{_datadir}/ppd/cupsfilters
236%{_sbindir}/cups-browsed
237#%{_unitdir}/cups-browsed.service
238%{_initdir}/cups-browsed
239%{_mandir}/man1/foomatic-rip.1.gz
240%{_mandir}/man8/cups-browsed.8.gz
241%{_mandir}/man5/cups-browsed.conf.5.gz
242
243%files libs
244%doc __doc/COPYING fontembed/README
245%{_libdir}/libcupsfilters.so.*
246%{_libdir}/libfontembed.so.*
247
248%files devel
249%{_includedir}/cupsfilters
250%{_includedir}/fontembed
251%{_datadir}/cups/ppdc/escp.h
252%{_libdir}/pkgconfig/libcupsfilters.pc
253%{_libdir}/pkgconfig/libfontembed.pc
254%{_libdir}/libcupsfilters.so
255%{_libdir}/libfontembed.so
256
257%changelog
258* Sun Oct  4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.76-1
259- new upstream release.
260
261* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.54-2
262- rebuild with poppler-0.26.2
263
264* Sun Jun  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.54-1
265- new upstream release.
266
267* Fri May 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.53-1
268- update to 1.0.53
269
270* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.43-1
271- new upstream release.
272- initial build for Vine Linux.
273
274* Tue Nov 19 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-4
275- Adjust filter costs so application/vnd.adobe-read-postscript input
276  doesn't go via pstotiff (bug #1008166).
277
278* Thu Nov 14 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.41-3
279- Fix memory leaks in cups-browsed (bug #1027317).
280
281* Wed Nov  6 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-2
282- Include dbus so that colord support works (bug #1026928).
283
284* Wed Oct 30 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.41-1
285- 1.0.41 - PPD-less printing support
286
287* Mon Oct 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-4
288- Fix socket leaks in the BrowsePoll code (bug #1021512).
289
290* Wed Oct 16 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-3
291- Ship the gstoraster MIME conversion rule now we provide that filter
292  (bug #1019261).
293
294* Fri Oct 11 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-2
295- Fix PDF landscape printing (bug #768811).
296
297* Fri Oct 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.40-1
298- 1.0.40
299- Use new "hybrid" pdftops renderer.
300
301* Thu Oct 03 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.39-1
302- 1.0.39
303- Removed obsolete patches "pdf-landscape" and "browsepoll-notifications"
304
305* Tue Oct  1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-4
306- Use IPP notifications for BrowsePoll when possible (bug #975241).
307
308* Tue Oct  1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-3
309- Fixes for some printf-type format mismatches (bug #1014093).
310
311* Tue Sep 17 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-2
312- Fix landscape printing for PDFs (bug #768811).
313
314* Wed Sep 04 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.38-1
315- 1.0.38
316
317* Thu Aug 29 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.37-1
318- 1.0.37.
319
320* Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-5
321- Added build dependency - font required for running tests
322
323* Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-4
324- Added checking phase (make check)
325
326* Wed Aug 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-3
327- Upstream patch to re-work filter costs (bug #998977). No longer need
328  text filter costs patch as paps gets used by default now if
329  installed.
330
331* Mon Aug 19 2013 Marek Kasik <mkasik@redhat.com> - 1.0.36-2
332- Rebuild (poppler-0.24.0)
333
334* Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-1
335- 1.0.36.
336
337* Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-7
338- Upstream patch to move in filters from ghostscript.
339
340* Tue Jul 30 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-6
341- Set cost for text filters to 200 so that the paps filter gets
342  preference for the time being (bug #988909).
343
344* Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-5
345- Handle page-label when printing n-up as well.
346
347* Tue Jul 23 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-4
348- Added support for page-label (bug #987515).
349
350* Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-3
351- Rebuild (qpdf-5.0.0)
352
353* Mon Jul 01 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-2
354- add cups-browsed(8) and cups-browsed.conf(5)
355- don't reverse lookup IP address in URI (#975822)
356
357* Wed Jun 26 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-1
358- 1.0.35
359
360* Mon Jun 24 2013 Marek Kasik <mkasik@redhat.com> - 1.0.34-9
361- Rebuild (poppler-0.22.5)
362
363* Wed Jun 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-8
364- fix the note we add in cups-browsed.conf
365
366* Wed Jun 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-7
367- Obsolete cups-php (#971741)
368
369* Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-6
370- one more cups-browsed leak fixed (#959682)
371
372* Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-5
373- perl is actually not required by pstopdf, because the calling is in dead code
374
375* Mon Jun 03 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-4
376- fix resource leaks and other problems found by Coverity & Valgrind (#959682)
377
378* Wed May 15 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-3
379- ship ppdc/pcl.h because of cupsfilters.drv
380
381* Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-2
382- pstopdf requires bc (#960315)
383
384* Thu Apr 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-1
385- 1.0.34
386
387* Fri Apr 05 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.33-1
388- 1.0.33
389- removed cups-filters-1.0.32-null-info.patch, accepted by upstream
390
391* Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-2
392- fixed segfault when info is NULL
393
394* Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-1
395- 1.0.32
396
397* Fri Mar 29 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-3
398- add note to cups-browsed.conf
399
400* Thu Mar 28 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-2
401- check cupsd.conf existence prior to grepping it (#928816)
402
403* Fri Mar 22 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-1
404- 1.0.31
405
406* Tue Mar 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-4
407- revert previous change
408
409* Wed Mar 13 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-3
410- don't ship banners for now (#919489)
411
412* Tue Mar 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-2
413- move BrowsePoll from cupsd.conf to cups-browsed.conf in %%post
414
415* Fri Mar 08 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-1
416- 1.0.30: CUPS browsing and broadcasting in cups-browsed
417
418* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-4
419- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
420
421* Sat Jan 19 2013 Rex Dieter <rdieter@fedoraproject.org> 1.0.29-3
422- backport upstream buildfix for poppler-0.22.x
423
424* Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 1.0.29-2
425- rebuild due to "jpeg8-ABI" feature drop
426
427* Thu Jan 03 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.29-1
428- 1.0.29
429
430* Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.28-1
431- 1.0.28: cups-browsed daemon and service
432
433* Thu Nov 29 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.25-1
434- 1.0.25
435
436* Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.24-1
437- 1.0.24
438
439* Wed Aug 22 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.23-1
440- 1.0.23: old pdftopdf removed
441
442* Tue Aug 21 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.22-1
443- 1.0.22: new pdftopdf (uses qpdf instead of poppler)
444
445* Wed Aug 08 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-4
446- rebuild
447
448* Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-3
449- commented multiple licensing breakdown (#832130)
450- verbose build output
451
452* Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-2
453- BuildRequires: poppler-cpp-devel (to build against poppler-0.20)
454
455* Mon Jul 23 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-1
456- 1.0.20
457
458* Tue Jul 17 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.19-1
459- 1.0.19
460
461* Wed May 30 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.18-1
462- initial spec file
Note: See TracBrowser for help on using the repository browser.