source: projects/specs/trunk/c/createrepo_c/createrepo_c-vl.spec @ 12476

Revision 12476, 16.7 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

createrepo_c-0.16.0-1

dovecot-2.3.11.3-2

libsmbios-2.4.3-2

python-sphinx-3.2.1-2

python-sphinxcontrib-jsmath-1.0.1-10

rspamd-2.5-3

strongswan-5.9.0-1

system-storage-manager-1.4-1

trousers-0.3.14-1

Line 
1%{!?_licensedir:%global license %%doc}
2
3%global bash_completion %config%{_sysconfdir}/bash_completion.d/createrepo_c.bash
4
5%{!?python2_sitearch:%global python2_sitearch %{python_sitearch}}
6
7%bcond_without python3
8%bcond_with    drpm
9
10Summary:        Creates a common metadata repository
11Name:           createrepo_c
12Version:        0.16.0
13Release:        1%{?_dist_release}
14Group:          admin-tools
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18License:        GPLv2+
19URL:            https://github.com/rpm-software-management/createrepo_c
20Source0:        %{url}/archive/%{version}/%{name}-%{version}.tar.gz
21
22BuildRequires:  cmake
23BuildRequires:  gcc
24BuildRequires:  bzip2-devel
25BuildRequires:  doxygen
26BuildRequires:  expat-devel
27BuildRequires:  file-devel
28BuildRequires:  glib2-devel >= 2.22.0
29BuildRequires:  curl-devel
30BuildRequires:  libxml2-devel
31BuildRequires:  openssl-devel
32BuildRequires:  rpm-devel >= 4.8.0-28
33BuildRequires:  sqlite-devel
34BuildRequires:  xz-devel
35BuildRequires:  zlib-devel
36Requires:       %{name}-libs =  %{version}-%{release}
37%if 0%{?rhel} == 6
38Requires: rpm >= 4.8.0-28
39%else
40BuildRequires:  bash-completion
41Requires: rpm >= 4.9.0
42%endif
43%if %{with drpm}
44BuildRequires:  drpm-devel >= 0.1.3
45%endif
46
47%description
48C implementation of Createrepo.
49A set of utilities (createrepo_c, mergerepo_c, modifyrepo_c)
50for generating a common metadata repository from a directory of
51rpm packages and maintaining it.
52
53
54%package libs
55Summary:    Library for repodata manipulation
56Group:      system
57
58%description libs
59Libraries for applications using the createrepo_c library
60for easy manipulation with a repodata.
61
62
63%package devel
64Summary:    Library for repodata manipulation
65Group:      programming
66Requires:   %{name}-libs%{?_isa} = %{version}-%{release}
67
68%description devel
69This package contains the createrepo_c C library and header files.
70These development files are for easy manipulation with a repodata.
71
72
73%if %{with python3}
74%package -n python3-%{name}
75Summary:        Python 3 bindings for the createrepo_c library
76Group:          programming
77%{?python_provide:%python_provide python3-%{name}}
78BuildRequires:  python3-rpm-macros
79BuildRequires:  python3-devel
80BuildRequires:  python3-nose
81BuildRequires:  python3-sphinx
82Requires:       %{name}-libs = %{version}-%{release}
83
84%description -n python3-%{name}
85Python 3 bindings for the createrepo_c library.
86%endif
87
88
89%prep
90%setup -q
91mkdir build
92
93
94%build
95# Build createrepo_c with Python
96pushd build
97%cmake ../ \
98        -DPYTHON_DESIRED:FILEPATH=%{__python3} \
99        -DWITH_ZCHUNK=OFF \
100        -DWITH_LIBMODULEMD=OFF \
101        -DENABLE_DRPM=OFF
102
103make %{?_smp_mflags} RPM_OPT_FLAGS="%{optflags}"
104# Build C documentation
105make doc-c
106popd
107
108
109%install
110rm -rf %{buildroot}
111pushd build
112  make install DESTDIR=%{buildroot}
113popd
114
115ln -sr %{buildroot}%{_bindir}/createrepo_c %{buildroot}%{_bindir}/createrepo
116ln -sr %{buildroot}%{_bindir}/mergerepo_c %{buildroot}%{_bindir}/mergerepo
117ln -sr %{buildroot}%{_bindir}/modifyrepo_c %{buildroot}%{_bindir}/modifyrepo
118
119
120%check
121pushd build
122  # Compile C tests
123  make tests
124  # Run Python3 tests
125  make ARGS="-V" test
126popd
127
128
129%post libs -p /sbin/ldconfig
130%postun libs -p /sbin/ldconfig
131
132
133%files
134%license COPYING
135%doc README.md
136%{_mandir}/man8/createrepo_c.8*
137%{_mandir}/man8/mergerepo_c.8*
138%{_mandir}/man8/modifyrepo_c.8*
139%{_mandir}/man8/sqliterepo_c.8*
140#%{bash_completion}
141%{_bindir}/createrepo_c
142%{_bindir}/mergerepo_c
143%{_bindir}/modifyrepo_c
144%{_bindir}/sqliterepo_c
145%{_bindir}/createrepo
146%{_bindir}/mergerepo
147%{_bindir}/modifyrepo
148%dir %{_datadir}/bash-completion
149%dir %{_datadir}/bash-completion/completions
150%{_datadir}/bash-completion/completions/*
151
152%files libs
153%license COPYING
154%{_libdir}/lib%{name}.so.*
155
156%files devel
157%doc build/doc/html
158%{_libdir}/lib%{name}.so
159%{_libdir}/pkgconfig/%{name}.pc
160%{_includedir}/%{name}/
161
162%if %{with python3}
163%files -n python3-%{name}
164%{python3_sitearch}/*
165%endif
166
167
168%changelog
169* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.16.0-1
170- new upstream release.
171
172* Mon May 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.13.2-1
173- new upstream release.
174
175* Mon Dec 10 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.11.1-1
176- new upstream release.
177
178* Sun Jul 17 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.10.0-6
179- initial build for Vine Linux.
180
181* Tue Apr 12 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.10.0-5
182- Make drpm builds conditional
183
184* Sun Apr 10 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.10.0-4
185- Don't own python3_sitearch dir in python3 subpkg
186- Use %%license macro
187- Follow modern packaging guidelines
188- Cleanups in spec file
189- Follow packaging guidelines about SourceURL
190- Fix license
191
192* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-3
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
194
195* Fri Jan 8 2016 Orion Poplawski <orion@cora.nwra.com> - 0.10.0-2
196- Remove comments causing trouble with post/postun scriptlets
197
198* Tue Jan   5 2016 Tomas Mlcoch <tmlcoch at redhat.com> - 0.10.0-1
199- Python 3 support (made by Ralph Bean)
200- Modify gen_rst.py to indicate --sqliterepo is an option too (Neal Gompa)
201- Do not compress manpages at generation time (Neal Gompa)
202
203* Tue Oct  20 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.9.1-1
204- Fix double free during parsing broken XML metadata (Issue #33)
205- Tests: Add acceptance test for --general-compress-type option
206- Fix 'CR_CW_UNKNOWN_COMPRESSION cannot be used' error
207- Refactoring: Fix compiler warnings
208- Add --general-compress-type option (RhBug 1253850)
209- Enable drpm support when drpm library is detected on system (RhBug: 1261031) (Issue #37)
210- fix traceback on non-complete datetime information (Jarek Polok)
211- parsehdr: Skip broken dependency with bad (non-numerical) epoch and print warning about that
212  (https://lists.fedoraproject.org/pipermail/devel/2015-August/213882.html)
213- misc: cr_str_to_evr(): Return NULL instead of "0" for bad (non-numerical) epoch
214- updateinfo: Fix a typo in the package release attribute (Luke Macken)
215- CMake: Don't require CXX compiler
216- Tests for different checksum type for RPMs and repodata files (#31)
217- Support different checksum type for RPMs and repodata files (#31)
218
219* Tue Jul   7 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.9.0-2
220- Add drpm as a BuildRequire
221
222* Thu May  28 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.9.0-1
223- mergerepo_c: Prepend protocol (file://) for URLs in pkgorigins (if --koji is used)
224- Update bash completion
225- doc: Update manpages
226- mergerepo: Fix NVR merging method
227- mergerepo: Fix behavior of --all param
228- createrepo: Add --cut-dirs and --location-prefix options
229- misc: Add cr_cut_dirs()
230- mergerepo: Use better version comparison algorithm
231- utils: Port cr_cmp_version_str() to rpm's algorithm (rpmvercmp)
232- misc: Rename elements in cr_Version structure
233- mergerepo: Fix version-release comparison for packages when --all is used
234- mergerepo: Show warnings if some groupfile cannot be automatically used
235- mergerepo: Exit with error code when a groupfile cannot be copied
236
237* Fri May  15 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.8.3-1
238- mergerepo: Do not prepend file:// if protocol is already specified
239
240* Thu May  14 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.8.2-1
241- doc: Add man pages for sqliterepo and update manpages for other tools
242- mergerepo: Work only with noarch packages if --koji is used and
243  no archlist is specified
244- mergerepo: Use file:// protocol in local baseurl
245- mergerepo: Do not include baseurl for first repo if --koji is specified (RhBug: 1220082)
246- mergerepo_c: Support multilib arch for --koji repos
247- mergerepo_c: Refactoring
248- Print debug message with version in each tool when --verbose is used
249- modifyrepo: Don't override file with itself (RhBug: 1215229)
250
251* Wed May   6 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.8.1-1
252- Fix bash completion for RHEL 6
253
254* Tue May   5 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.8.0-1
255- New tool Sqliterepo_c - It generates sqlite databases into repos
256  where the sqlite is missing.
257- Internal refactoring and code cleanup
258
259* Fri Feb  20 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.7-1
260- Proper directory for temporary files when --local-sqlite is used (Issue #12)
261- Bring bash completion install dir and filenames up to date with current bash-completion
262
263* Thu Jan   8 2015 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.6-1
264- Python: Add __contains__ method to Repomd() class
265
266* Sun Dec  28 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.5-1
267- Python repomd: Support for iteration and indexing by type - e.g. record = repomd['primary']
268- Show warning if an XML parser probably parsed a bad type of medata (New XML parser warning type CR_XML_WARNING_BADMDTYPE)
269- drpm library: Explicitly try to locate libdrpm.so.0
270- deltarpms: Don't show options for delta rpms if support is not available
271
272* Tue Nov  11 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.4-1
273- createrepo_c, mergerepo_c: Follow redirs by default while downloading remote repos
274- mergerepo_c: Fix segfault when a package without sourcerpm is part of metadata and --koji option is used
275
276* Mon Nov  10 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.3-1
277- xml_parser: Add file path into error messages
278- Refactor: Replace g_error() with g_critical() (RhBug: 1162102)
279
280* Thu Nov  06 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.2-1
281- createrepo_c: New option --local-sqlite
282
283* Fri Oct  31 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.1-1
284- Mergerepo: Fix mergerepo
285- Mergerepo: Add some debugging of metadata read.
286
287* Mon Oct  20 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.7.0-1
288- deltarpms: Update module to work with current version of drpm
289- mergerepo_c: Add --omit-baseurl option
290- craterepo_c: Gen empty repo if empty pkglist is used
291- Docs: Output python docs to separate directory
292- Several small fixes
293
294* Tue Aug  12 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.6.1-1
295- updateinfo: Use Python datetime objects in python bindings
296
297* Tue Aug   5 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.6.0-1
298- Support for updateinfo.xml manipulation (including Python bindings)
299
300* Fri Jul  18 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.5.0-1
301- Experimental delta rpm (DRPM) support (Disabled in Fedora build).
302
303* Thu Jun  26 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.4.1-1
304- Initialize threads correctly on old versions of GLib2 (RhBug: 1108787)
305- Do not print log domain (get rid off C_CREATEREPOLIB prefix in log messages)
306- Implements support for --cachedir
307- New option --retain-old-md-by-age
308- Few small API changes
309
310* Tue May   6 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.4.0-1
311- Change default behavior of repodata files handling. (RhBug: 1094539)
312  See: https://github.com/Tojaj/createrepo_c/wiki/New-File-Handling
313  By default, createrepo leaves old groupfiles (comps files)
314  in the repodata/ directory during update.
315  Createrepo_c did the same thing but the version 0.4.0 changes this behaviour.
316
317* Thu Apr  10 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.3.1-2
318- Support for weak and rich dependecies
319
320* Mon Mar  10 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.3.0-1
321- Relevant only for developers using createrepo_c library: New approach for
322  metadata loading in case of internal high-level parser functions (see commit
323  messages for more information: d6ed327595, 0b0e75203e, ad1e8450f5)
324- Support for changelog limit value == -1 (include all changelogs)
325- Update debug compilation flags
326- Update man pages (Add synompsis with usage)
327- Update usage examples in help
328
329* Thu Feb  20 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.2.2-1
330- Temporary remove deltarepo subpackages
331- cmake: Do not install deltarepo stuff yet
332- helper: Removed cr_remove_metadata() and cr_get_list_of_md_locations()
333- Add module helpers
334- Sanitize strings before writting them to XML or sqlitedb (ISSUE #3)
335
336* Mon Jan  27 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.2.1-3
337- New expert option: --ignore-lock
338
339* Mon Jan  20 2014 Tomas Mlcoch <tmlcoch at redhat.com> - 0.2.1-2
340- More effort to avoid residual .repodata/ directory on error
341- Add deltarepo and python-deltarepo subpackages
342- Add modifyrepo_c
343- Add documentation for python bindings
344- Refactored code & a lot of little bug fixes
345
346* Wed Aug  14 2013 Tomas Mlcoch <tmlcoch at redhat.com> - 0.2.1-1
347- checksum: Set SHA to be the same as SHA1 (For compatibility with original
348  Createrepo)
349
350* Mon Aug   5 2013 Tomas Mlcoch <tmlcoch at redhat.com> - 0.2.0-1
351- Speedup (More parallelization)
352- Changed C API
353- Add python bindings
354- A lot of bugfixes
355- Add new make targets: tests (make tests - builds c tests) and test
356  (make test - runs c and python test suits).
357- Changed interface of most of C modules - Better error reporting
358  (Add GError ** param).
359- Experimental Python bindings (Beware: The interface is not final yet!).
360- package: Add cr_package_copy method.
361- sqlite: Do not recreate tables and triggers while opening existing db.
362- mergerepo_c: Implicitly use --all with --koji.
363- Man page update.
364
365* Thu Apr  11 2013 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.17-3
366- mergerepo_c: Add --simple-md-filenames and --unique-md-filenames
367options. (RhBug: 950994)
368- mergerepo_c: Always include noarch while mimic koji
369mergerepos. (RhBug: 950991)
370- Rename cr_package_parser_shutdown to cr_package_parser_cleanup()
371- cr_db_info_update is now safe from sqlinjection.
372
373* Mon Mar  25 2013 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.17-1
374- Fix double free() when old metadata parsing failed. (related to RhBug: 920795)
375- Convert all strings to UTF-8 while dumping XML. (related RhBug: 920795)
376
377* Mon Mar  11 2013 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.16-2
378- Remove creation of own empty rpm keyring for a transaction set.
379This is not necessary since rpm-4.8.0-28 (rpm commit
380cad147070e5513312d851f44998012e8f0cdf1e3). Moreover, own rpm keyring
381causes a race condition in threads (causing double free()) which use
382rpmReadPackageFile() called from cr_package_from_rpm().
383
384* Thu Mar  07 2013 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.16-1
385- Fix usage of rpm keyring (RhBug:918645)
386- More generic interface of repomd module
387- Code refactoring
388- Add some usage examples into the doxygen documentation and .h files
389- Rename version constants in version.h
390- New function cr_package_nevra (returns package nevra string)
391
392* Mon Feb  11 2013 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.15-1
393- Fix bug in final move from .repodata/ -> repodata/
394- Fix warnings from RPM library. RPM library is thread-unsafe. This
395includes also reading headers. Use of empty keyring for rpm transaction
396should work around the problem.
397
398* Tue Nov  27 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.14-1
399- Fix filelists database generation (use '.' instead of '' for current dir)
400
401* Tue Nov  20 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.13-1
402- Fix race-condition during task buffering in createrepo_c
403
404* Tue Nov  20 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.12-2
405- Fix removing old repomd.xml while --update
406
407* Thu Nov  15 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.12-1
408- Fix bug in sqlite filelists database
409- Fix memory leak
410
411* Fri Nov  09 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.11-1
412- Deterministic output! Packages in output repodata are now sorted
413by ASCII value
414- Support for Koji mergerepos behaviour in mergerepo_c
415(new --koji, --groupfile and --blocked params)
416- Better atomicity while finall move .repodata/ -> repodata/
417- Repomd module supports pkgorigins record
418- Some new functions in misc module
419- Small changes in library interface
420
421* Wed Oct  03 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.10-1
422- Another memory usage optimalization
423
424* Mon Sep  03 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.9-1
425- Some changes in library interface
426- Memory usage optimalization
427- Fix a segfault and a race condition
428- New cmd options: --read-pkgs-list and --retain-old-md param
429- Few other bugfixes
430
431* Wed Aug  15 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.8-1
432- New interface of repomd module
433- New cmd options: --repo --revision --distro --content --basedir
434- New createrepo_c specific cmd option --keep-all-metadata
435- Few bugfixes
436
437* Thu Jul  26 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.7-1
438- SQLite support
439- Bash completion
440- createrepo_c support for --compress-type param
441- Improved logging
442- Subpackages -devel and -libsi
443- Relicensed to GPLv2
444- Doxygen documentation in devel package
445- README update
446
447* Mon Jun  11 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.5-1
448- Support for .xz compression
449- Unversioned .so excluded from installation
450
451* Mon Jun   4 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.4-1
452- New mergerepo params: --all, --noarch-repo and --method
453- Fix segfault when more than one --excludes param used
454
455* Mon May  28 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.3-1
456- Set RelWithDebInfo as default cmake build type
457
458* Wed May  23 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.2-1
459- Add version.h header file
460
461* Wed May  23 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.1-1
462- Add license
463
464* Wed May  9 2012 Tomas Mlcoch <tmlcoch at redhat.com> - 0.1.0-1
465- First public release
Note: See TracBrowser for help on using the repository browser.