source: projects/specs/trunk/c/cracklib/cracklib-vl.spec @ 521

Revision 521, 12.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Reflects the values hard-coded in various Makefile.am's in the source tree.
2%define dictdir %{_datadir}/cracklib
3%define dictpath %{_datadir}/cracklib/pw_dict
4
5Summary: A password-checking library.
6Summary(ja): パスワードチェック用ライブラリ
7Name: cracklib
8Version: 2.8.12
9Release: 3%{?_dist_release}
10Group: System Environment/Libraries
11URL: http://sourceforge.net/projects/cracklib/
12License: GPLv2
13
14Source0: http://www.crypticide.org/users/alecm/security/cracklib-%{version}.tar.gz
15# Retrieved at 20070213003424Z.
16Source1: http://prdownloads.sourceforge.net/cracklib/cracklib-words.gz
17
18Source10: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/computer/Domains.gz
19Source11: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/computer/Dosref.gz
20Source12: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/computer/Ftpsites.gz
21Source13: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/computer/Jargon.gz
22Source14: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/computer/common-passwords.txt.gz
23Source15: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/computer/etc-hosts.gz
24Source16: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/movieTV/Movies.gz
25Source17: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/movieTV/Python.gz
26Source18: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/movieTV/Trek.gz
27Source19: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/literature/LCarrol.gz
28Source20: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/literature/Paradise.Lost.gz
29Source21: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/literature/cartoon.gz
30Source22: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/literature/myths-legends.gz
31Source23: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/literature/sf.gz
32Source24: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/literature/shakespeare.gz
33Source25: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/ASSurnames.gz
34Source26: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/Congress.gz
35Source27: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/Family-Names.gz
36Source28: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/Given-Names.gz
37Source29: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/famous.gz
38Source30: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/fast-names.gz
39Source31: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/female-names.gz
40Source32: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/male-names.gz
41Source33: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/names.french.gz
42Source34: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/names.hp.gz
43Source35: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/other-names.gz
44Source36: ftp://ftp.cerias.purdue.edu/pub/dict/wordlists/names/surnames.finnish.gz
45
46# No upstream source for this; it came in as a bugzilla attachment.
47Source37: pass_file.gz
48
49Patch0: cracklib-2.8.10-suffix.patch
50Patch1: cracklib-2.8.12-inttypes.patch
51Patch2: cracklib-2.8.10-docstring.patch
52Patch3: cracklib-2.8.12-gettext.patch
53
54Buildroot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: words, automake, libtool
56Conflicts: cracklib-dicts < 2.8
57
58%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
59
60%description
61CrackLib tests passwords to determine whether they match certain
62security-oriented characteristics, with the purpose of stopping users
63from choosing passwords that are easy to guess. CrackLib performs
64several tests on passwords: it tries to generate words from a username
65and gecos entry and checks those words against the password; it checks
66for simplistic patterns in passwords; and it checks for the password
67in a dictionary.
68
69CrackLib is actually a library containing a particular C function
70which is used to check the password, as well as other C
71functions. CrackLib is not a replacement for a passwd program; it must
72be used in conjunction with an existing passwd program.
73
74Install the cracklib package if you need a program to check users'
75passwords to see if they are at least minimally secure. If you install
76CrackLib, you will also want to install the cracklib-dicts package.
77
78
79%package -n compat32-%{name}
80Summary: A password-checking library.
81Summary(ja): パスワードチェック用ライブラリ
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84
85
86%description -n compat32-%{name}
87CrackLib tests passwords to determine whether they match certain
88security-oriented characteristics, with the purpose of stopping users
89from choosing passwords that are easy to guess. CrackLib performs
90several tests on passwords: it tries to generate words from a username
91and gecos entry and checks those words against the password; it checks
92for simplistic patterns in passwords; and it checks for the password
93in a dictionary.
94
95CrackLib is actually a library containing a particular C function
96which is used to check the password, as well as other C
97functions. CrackLib is not a replacement for a passwd program; it must
98be used in conjunction with an existing passwd program.
99
100Install the cracklib package if you need a program to check users'
101passwords to see if they are at least minimally secure. If you install
102CrackLib, you will also want to install the cracklib-dicts package.
103
104
105%package dicts
106Summary: The standard CrackLib dictionaries.
107Summary(ja): CrackLib 標準辞書
108Group: System Environment/Libraries
109Requires: words >= 2-13
110
111
112%description dicts
113The cracklib-dicts package includes the CrackLib dictionaries.
114CrackLib will need to use the dictionary appropriate to your system,
115which is normally put in /usr/share/dict/words. Cracklib-dicts also
116contains the utilities necessary for the creation of new dictionaries.
117
118If you are installing CrackLib, you should also install cracklib-dicts.
119
120
121%package -n compat32-%{name}-dicts
122Summary: The standard CrackLib dictionaries.
123Summary(ja): CrackLib 標準辞書
124Group: System Environment/Libraries
125Requires: compat32-%{name} = %{version}-%{release}
126Requires: %{name}-dicts    = %{version}-%{release}
127
128
129%description -n compat32-%{name}-dicts
130The cracklib-dicts package includes the CrackLib dictionaries.
131CrackLib will need to use the dictionary appropriate to your system,
132which is normally put in /usr/share/dict/words. Cracklib-dicts also
133contains the utilities necessary for the creation of new dictionaries.
134
135If you are installing CrackLib, you should also install cracklib-dicts.
136
137
138%prep
139%setup -q
140%patch0 -p1 -b .suffix
141cp lib/packer.h lib/packer.h.in
142%patch1 -p1 -b .inttypes
143%patch2 -p1 -b .docstring
144%patch3 -p1 -b .gettext
145autoreconf -f -i
146mkdir cracklib-dicts
147for dict in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} \
148            %{SOURCE15} %{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} \
149            %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} \
150            %{SOURCE25} %{SOURCE26} %{SOURCE27} %{SOURCE28} %{SOURCE29} \
151            %{SOURCE30} %{SOURCE31} %{SOURCE32} %{SOURCE33} %{SOURCE34} \
152            %{SOURCE35} %{SOURCE36} %{SOURCE37} %{SOURCE1}
153do
154        cp -fv ${dict} cracklib-dicts/
155done
156chmod +x util/cracklib-format
157
158%build
159%configure --with-pic --without-python --with-default-dict=%{dictpath} --disable-static
160make
161
162%install
163[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
164make install DESTDIR=$RPM_BUILD_ROOT
165./util/cracklib-format cracklib-dicts/* | \
166./util/cracklib-packer $RPM_BUILD_ROOT/%{dictpath}
167./util/cracklib-format $RPM_BUILD_ROOT/%{dictdir}/cracklib-small | \
168./util/cracklib-packer $RPM_BUILD_ROOT/%{dictdir}/cracklib-small
169rm -f $RPM_BUILD_ROOT/%{dictdir}/cracklib-small
170
171sed s,/usr/lib/cracklib_dict,%{dictpath},g lib/crack.h > $RPM_BUILD_ROOT/%{_includedir}/crack.h
172ln -s cracklib-format $RPM_BUILD_ROOT/%{_sbindir}/mkdict
173ln -s cracklib-packer $RPM_BUILD_ROOT/%{_sbindir}/packer
174touch $RPM_BUILD_ROOT/top
175
176toprelpath=..
177touch $RPM_BUILD_ROOT/top
178while ! test -f $RPM_BUILD_ROOT/%{_libdir}/$toprelpath/top ; do
179        toprelpath=../$toprelpath
180done
181rm -f $RPM_BUILD_ROOT/top
182if test %{dictpath} != %{_libdir}/cracklib_dict ; then
183ln -s $toprelpath%{dictpath}.hwm $RPM_BUILD_ROOT/%{_libdir}/cracklib_dict.hwm
184ln -s $toprelpath%{dictpath}.pwd $RPM_BUILD_ROOT/%{_libdir}/cracklib_dict.pwd
185ln -s $toprelpath%{dictpath}.pwi $RPM_BUILD_ROOT/%{_libdir}/cracklib_dict.pwi
186fi
187rm -f $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/cracklibmodule.*a
188rm -f $RPM_BUILD_ROOT/%{_libdir}/libcrack.la
189
190%find_lang %{name}
191
192
193%clean
194[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
195
196
197%post -p /sbin/ldconfig
198
199%postun -p /sbin/ldconfig
200
201%post -n compat32-%{name} -p /sbin/ldconfig
202
203%postun -n compat32-%{name} -p /sbin/ldconfig
204
205%triggerpostun -p /sbin/ldconfig -- cracklib < 2.7-24
206
207%files -f %{name}.lang
208%defattr(-,root,root)
209%doc README README-WORDS NEWS README-LICENSE AUTHORS
210%{_includedir}/*
211%{_libdir}/libcrack.so*
212#{_libdir}/libcrack.a*
213%dir %{_datadir}/cracklib
214%{_datadir}/cracklib/cracklib.magic
215%{_sbindir}/*cracklib*
216
217
218%files dicts
219%defattr(-,root,root)
220%dir %{_datadir}/cracklib
221%{_datadir}/cracklib/pw_dict.*
222%{_datadir}/cracklib/cracklib-small.*
223%{_libdir}/cracklib_dict.*
224%{_sbindir}/mkdict
225%{_sbindir}/packer
226
227
228%if %{build_compat32}
229%files -n compat32-%{name}
230%defattr(-,root,root)
231%{_libdir}/libcrack.so*
232#{_libdir}/libcrack.a*
233
234
235%files -n compat32-%{name}-dicts
236%defattr(-,root,root)
237%{_libdir}/cracklib_dict.*
238%endif
239
240
241%changelog
242* Tue May 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.12-3
243- fixed errors rebuilding with libtool-2
244- added Patch3: cracklib-2.8.12-gettext.patch
245
246* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.12-2
247- spec in utf-8
248
249* Tue May 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.12-1
250- update to 2.8.12, which was relicensed to GPLv2
251
252* Fri Mar 17 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.8.6-0vl2
253- updated files section for compat32-* packages
254
255* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
256- new upstream release
257- import some changes from FC
258
259* Fri Feb 10 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 2.7-27vl2
260- added compat32-* packages for x86_64 architecture support
261
262* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.7-27vl1
263- cracklib.spec -> cracklib-vl.spec
264- substantially rebuild
265  * Wed Feb  4 2004 Nalin Dahyabhai <nalin@redhat.com> 2.7-26
266  - update URL (previous page moved) (#114894)
267
268  * Fri Jan 30 2004 Nalin Dahyabhai <nalin@redhat.com> 2.7-25
269  - fix ldconfig invocation in trigger for older versions which included the
270    soname symlink (#114620)
271
272
273* Fri Dec 06 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.7-19vl1
274- based on 2.7-19 from Rawhide and built for Vine Linux
275- added Japanese summary
276
277* Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7-19
278- fix for builds on multilib systems (set DICTPATH properly)
279
280* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
281- automated rebuild
282
283* Sun May 26 2002 Tim Powers <timp@redhat.com>
284- automated rebuild
285
286* Thu May  9 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7-16
287- rebuild in new environment
288
289* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 2.7-15
290- rebuild
291
292* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
293- automated rebuild
294
295* Tue Oct  2 2001 Nalin Dahyabhai <nalin@redhat.com> 2.7-13
296- use getpwuid_r instead of getpwuid
297
298* Fri Aug  3 2001 Nalin Dahyabhai <nalin@redhat.com> 2.7-12
299- remove cruft that ldconfig already knows how to manage
300- don't explicitly strip anything -- the brp setup decides that
301- tweak the header so that it can be used in C++ (#46685)
302- buildprereq the words package
303
304* Tue Jun 26 2001 Florian La Roche <Florian.LaRoche@redhat.de>
305- add link from library major version number
306
307* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
308- Bump release + rebuild.
309
310* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
311- automatic rebuild
312
313* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
314- FHS fixes
315- fix undeclared function warnings from the new compiler
316- fix URL
317
318* Fri Apr 07 2000 Trond Eivind Glomsr <teg@redhat.com>
319- switched to use /usr/share/dict/words
320
321* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
322- strip binaries
323
324* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
325- auto rebuild in the new build environment (release 4)
326
327* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
328- build for glibc 2.1
329
330* Sat May 09 1998 Prospector System <bugs@redhat.com>
331- translations modified for de, fr, tr
332
333* Tue Mar 10 1998 Cristian Gafton <gafton@redhat.com>
334- updated to 2.7
335- build shared libraries
336
337* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
338- added -fPIC
339
340* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
341- basic spec file cleanups
342
343* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
344- built against glibc
Note: See TracBrowser for help on using the repository browser.