source: projects/specs/trunk/c/cproto/cproto-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Generates function prototypes and variable declarations from C code.
2Summary(ja): C コードから関数プロトタイプと変数宣言を生成するツール
3Name: cproto
4Version: 4.7c
5Release: 6%{?_dist_release}
6License: Public Domain
7Group: Development/Tools
8Source: ftp://invisible-island.net/cproto/cproto-4_7c.tgz
9Patch1: cproto-4.6.1-patch
10Patch2: cproto-4.6-varargs.patch
11Patch3: cproto-4.6-bison.patch
12Prefix: %{_prefix}
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15
16%description
17Cproto generates function prototypes and variable declarations from C
18source code. Cproto can also convert function definitions between the
19old style and the ANSI C style. This conversion will overwrite the
20original files, however, so be sure to make a backup copy of your
21original files in case something goes wrong. Cproto uses a Yacc
22generated parser, so it should not be confused by complex function
23definitions as much as other prototype generators.
24
25%description -l ja
26cproto は C のソースコードから関数プロトタイプと変数宣言を生成します.
27cproto は古い形式と ANSI C 形式の関数定義の相互変換も行うことが出来ます.
28この変換を行うとオリジナルのファイルを上書きしてしまいますので,もしもの
29時の為にオリジナルファイルのバックアップは必ず取っておいて下さい.
30cproto は yacc により生成された解析器を使用しますので,他のプロトタイプ
31生成プログラムとは異なり,複雑な関数定義も難なく処理出来ます.
32
33cproto は C プログラマにとっては便利なプログラムですので,
34C でプログラムをする際には cproto をインストールして下さい.
35
36
37%prep
38%setup -q -n cproto-4_7c
39
40%build
41export CPP="/lib/cpp"
42export CPPFLAGS="-DOPT_LINTLIBRARY $RPM_OPT_FLAGS"
43export CFLAGS="-DOPT_LINTLIBRARY $RPM_OPT_FLAGS"
44%configure --exec-prefix=%{_prefix}
45make
46
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%makeinstall mandir=$RPM_BUILD_ROOT/%{_mandir}/man1
52
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57
58%files
59%defattr(-,root,root)
60%doc CHANGES README
61%{_prefix}/bin/cproto
62%{_mandir}/man1/cproto.*
63
64
65%changelog
66* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 4.7c-6vl5
67- applied new versioning policy, spec in utf-8
68
69* Sun Apr 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7c-5vl1
70- based on 4.7c-5 from Fedora development
71  * Wed Feb  9 2005 Jindrich Novy <jnovy@redhat.com> 4.7c-4
72  - add RPM_OPT_FLAGS to CFLAGS
73  - convert Copyright to License
74  - rebuild with -D_FORTIFY_SOURCE=2
75  * Thu Oct 14 2004 Jindrich Novy <jnovy@redhat.com> 4.7c-3
76  - define OPT_LINTLIBRARY to enable type definitions output
77    and other cproto features disabled otherwise
78- s/Copyright/License/
79- updated URL
80
81* Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6-13vl1
82- based on 4.6-13 from Rawhide and built for Vine Linux
83- added Japanese summary and description
84
85* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
86- automated rebuild
87
88* Mon Jun 17 2002 Bill Nottingham <notting@redhat.com> 4.6-12
89- don't strip it
90
91* Thu May 23 2002 Tim Powers <timp@redhat.com>
92- automated rebuild
93
94* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
95- automated rebuild
96
97* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
98- predefine __builtin_va_list (#46246, original patch from <urban@teststation.com>)
99
100* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
101- actually *apply* the 4.6.1 patch. Fixes #35654, at least.
102
103* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
104- rebuild because of broken fileutils
105
106* Mon Oct 13 2000 Bill Nottingham <notting@redhat.com>
107- use /lib/cpp, not gcc -E, again (#20535)
108
109* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
110- automatic rebuild
111
112* Tue Jun  6 2000 Bill Nottingham <notting@redhat.com>
113- rebuild against glibc-2.2, FHS stuff
114
115* Tue Feb  1 2000 Bill Nottingham <notting@redhat.com>
116- use /lib/cpp, not gcc -E (#8612)
117
118* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
119- auto rebuild in the new build environment (release 2)
120
121* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
122- update to 4.6.1 (#1516).
123- use %configure
124
125* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
126- build for 6.0
127
128* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
129- build root
130
131* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
132- translations modified for de, fr, tr
133
134* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
135- built against glibc
Note: See TracBrowser for help on using the repository browser.