source: projects/specs/trunk/c/cpio/cpio-vl.spec @ 521

Revision 521, 8.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%ifos linux
2%define _bindir         /bin
3%define _libexecdir     /sbin
4%endif
5
6Summary: A GNU archiving program.
7Summary(ja): GNU アーカイブプログラム
8Name: cpio
9Version: 2.10
10Release: 1%{?_dist_release}
11License: GPL
12Group: Applications/Archiving
13URL: ftp://ftp.gnu.org/pub/gnu/cpio/
14Source: ftp://ftp.gnu.org/gnu/cpio/cpio-%{version}.tar.bz2
15#Source: ftp://alpha.gnu.org/gnu/cpio/cpio-%{version}.tar.bz2
16Source1: cpio.1
17Patch1: cpio-2.6-setLocale.patch
18Patch2: cpio-2.9-rh.patch
19Patch3: cpio-2.9-chmodRaceC.patch
20Patch4: cpio-2.9-exitCode.patch
21Patch5: cpio-2.9-dir_perm.patch
22Patch6: cpio-2.9-dev_number.patch
23
24%ifnos linux
25Requires(post): /sbin/rmt
26%endif
27Requires(post): /sbin/install-info
28Requires(preun): /sbin/install-info
29BuildRequires: texinfo autoconf gettext
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31
32
33%description
34GNU cpio copies files into or out of a cpio or tar archive.  Archives
35are files which contain a collection of other files plus information
36about them, such as their file name, owner, timestamps, and access
37permissions.  The archive can be another file on the disk, a magnetic
38tape, or a pipe.  GNU cpio supports the following archive formats:  binary,
39old ASCII, new ASCII, crc, HPUX binary, HPUX old ASCII, old tar and POSIX.1
40tar.  By default, cpio creates binary format archives, so that they are
41compatible with older cpio programs.  When it is extracting files from
42archives, cpio automatically recognizes which kind of archive it is reading
43and can read archives created on machines with a different byte-order.
44
45Install cpio if you need a program to manage file archives.
46
47
48%description -l ja
49GNU cpio は cpio アーカイブ或いは tar アーカイブにファイルをコピーしたり
50取り出したりするプログラムです.アーカイブというのは,(1つ以上の)ファイルと
51その情報(ファイル名,オーナー,更新日付,パーミッション等)がまとめられた
521つのファイルのことです.アーカイブはディスク上のファイル,磁気テープ,
53或いはパイプであっても構いません.
54GNU cpio がサポートしているアーカイブ形式は以下の通りです:
55    バイナリ, old ASCII, new ASCII, crc, HPUX バイナリ, HPUX old ASCII,
56    old tar, POSIX.1 tar
57デフォルトでは cpio はバイナリ形式のアーカイブを作成します.
58これは古いバージョンの cpio との互換性の為です.
59アーカイブを展開する場合は,cpio はアーカイブの形式を自動認識しますし,
60バイトオーダの異なる機械で作成されたアーカイブを読むことも可能です.
61
62ファイルアーカイブを扱うプログラムが必要なら,cpio をインストールして下さい.
63
64
65%prep
66%setup -q
67%patch1  -p1 -b .setLocale
68%patch2  -p1 -b .rh
69%patch3  -p1 -b .chmodRaceC
70%patch4  -p1 -b .exitCode
71%patch5  -p1 -b .dir_perm
72%patch6  -p1 -b .dev_number
73
74autoheader
75
76%build
77
78CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -pedantic -Wall" %configure
79make %{?_smp_mflags}
80
81%install
82rm -rf $RPM_BUILD_ROOT
83
84make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install
85
86{ cd $RPM_BUILD_ROOT
87
88%ifos linux
89# XXX these from mt-st
90  rm -f .%{_bindir}/mt .%{_mandir}/man1/mt.1
91%endif
92}
93
94rm -f $RPM_BUILD_ROOT%{_infodir}/dir
95rm -f $RPM_BUILD_ROOT/sbin/rmt
96rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*.1*
97install -c -p -m 0644 %{SOURCE1} ${RPM_BUILD_ROOT}%{_mandir}/man1
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post
103/sbin/install-info %{_infodir}/cpio.info.gz %{_infodir}/dir
104
105%preun
106if [ $1 = 0 ]; then
107    /sbin/install-info --delete %{_infodir}/cpio.info.gz %{_infodir}/dir
108fi
109
110
111%files
112%defattr(-,root,root)
113%doc AUTHORS ChangeLog NEWS README THANKS TODO
114%ifnos linux
115%{_libexecdir}/*
116%endif
117%{_bindir}/*
118%{_mandir}/man*/*
119%{_infodir}/*.info*
120%{_datadir}/locale/*
121
122%changelog
123* Fri Jan  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10-1
124- new upstream release
125
126* Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.90-1vl5
127- new upstream from alpha version
128- applied new versioning policy
129- spec in UTF-8
130- added Patch5 and 6 from FC
131  * Fri Jul 18 2008 Kamil Dudka <kdudka@redhat.com> 2.9.90-2
132  - Support major/minor device numbers over 127 (bz#450109)
133  * Mon Mar 03 2008 Radek Brich <rbrich@redhat.com> 2.9-7
134  - fix -dir_perm patch to restore permissions correctly even
135    in passthrough mode -- revert affected code to cpio 2.8 state
136    (bz#430835)
137
138* Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9-1vl1
139- new upstream release
140
141* Sat Apr 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6-5vl1
142- based on Fedora development 2.6-5
143  * Mon Jan 24 2005 Peter Vrabec <pvrabec@redhat.com>
144  - insecure file creation (#145721)
145  * Mon Jan 17 2005 Peter Vrabec <pvrabec@redhat.com>
146  - fix symlinks pack (#145225)
147  * Fri Jan 14 2005 Peter Vrabec <pvrabec@redhat.com>
148  - new fixed version of lfs patch (#144688)
149  * Tue Nov 09 2004 Peter Vrabec <pvrabec@redhat.com>
150  - fixed "cpio -oH ustar (or tar) saves bad mtime date after Jan 10 2004" (#114580)
151  * Mon Nov 01 2004 Peter Vrabec <pvrabec@redhat.com>
152  - support large files > 2GB (#105617)
153
154* Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.5-1vl1
155- based on 2.5-1 from rawhide and built for Vine Linux
156- added Japanese summary and description
157
158* Mon Nov 18 2002 Jeff Johnson <jbj@redhat.com> 2.5-1
159- update 2.5, restack and consolidate patches.
160- don't apply (but include for now) freebsd and #56346 patches.
161- add url (#54598).
162
163* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 2.4.2-30
164- rebuild from CVS.
165
166* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
167- automated rebuild
168
169* Thu May 23 2002 Tim Powers <timp@redhat.com>
170- automated rebuild
171
172* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
173- automated rebuild
174
175* Thu Nov 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.2-25
176- Fix up extraction of multiply linked files when the first link is
177  excluded (Bug #56346)
178
179* Mon Oct  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.4.2-24
180- Merge and adapt patches from FreeBSD, this should fix FIFO handling
181
182* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
183- Add and adapt Debian patch (pl36), fixes #45285 and a couple of other issues
184
185* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
186- Bump release + rebuild.
187
188* Tue Aug  8 2000 Jeff Johnson <jbj@redhat.com>
189- update man page with decription of -c behavior (#10581).
190
191* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
192- automatic rebuild
193
194* Thu Jun 29 2000 Preston Brown <pbrown@redhat.com>
195- patch from HJ Lu for better error codes upon exit
196
197* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
198- FHS packaging.
199
200* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
201- missing defattr.
202
203* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
204- handle compressed manpages
205
206* Fri Dec 17 1999 Jeff Johnson <jbj@redhat.com>
207- revert the stdout patch (#3358), restoring original GNU cpio behavior
208  (#6376, #7538), the patch was dumb.
209
210* Tue Aug 31 1999 Jeff Johnson <jbj@redhat.com>
211- fix infinite loop unpacking empty files with hard links (#4208).
212- stdout should contain progress information (#3358).
213
214* Sun Mar 21 1999 Crstian Gafton <gafton@redhat.com>
215- auto rebuild in the new build environment (release 12)
216
217* Sat Dec  5 1998 Jeff Johnson <jbj@redhat.com>
218- longlong dev wrong with "-o -H odc" headers (formerly "-oc").
219
220* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
221- patch to compile on glibc 2.1, where strdup is a macro
222
223* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
224- Fiddle bindir/libexecdir to get RH install correct.
225- Don't include /sbin/rmt -- use the rmt from dump package.
226- Don't include /bin/mt -- use the mt from mt-st package.
227- Add prereq's
228
229* Tue Jun 30 1998 Jeff Johnson <jbj@redhat.com>
230- fix '-c' to duplicate svr4 behavior (problem #438)
231- install support programs & info pages
232
233* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
234- translations modified for de, fr, tr
235
236* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
237- added BuildRoot
238- removed "(used by RPM)" comment in Summary
239
240* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
241- built against glibc
242- no longer statically linked as RPM doesn't use cpio for unpacking packages
Note: See TracBrowser for help on using the repository browser.