source: projects/specs/trunk/c/courier-imap/courier-imap-vl.spec @ 521

Revision 521, 5.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Courier-IMAP IMAP server
2Name: courier-imap
3Version: 4.7.0
4Release: 1%{?_dist_release}
5License: GPL
6Group: System Environment/Daemons
7Source: http://prdownloads.sourceforge.net/courier/%{name}-%{version}.tar.bz2
8Patch: courier-imap-startconf.patch
9Patch2: courier-imap-apop.patch
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11Requires: /sbin/chkconfig
12Requires: courier-authlib
13BuildRequires: openssl-devel gdbm-devel pam-devel
14BuildRequires: courier-authlib-devel
15BuildRequires: libidn-devel
16
17%description
18Courier-IMAP is an IMAP server for Maildir mailboxes.  This package contains
19the standalone version of the IMAP server that's included in the Courier
20mail server package.  This package is a standalone version for use with
21other mail servers.  Do not install this package if you intend to install the
22full Courier mail server.  Install the Courier package instead.
23
24
25%prep
26%setup -q
27%patch -b .orig
28%patch2 -p1 -b .orig
29
30cp imap/README README.imap
31cp imap/README.proxy* .
32cp maildir/README.maildirquota.txt README.maildirquota
33cp maildir/README.sharedfolders.txt README.sharedfolders
34
35
36%build
37%configure \
38        --bindir=%{_sbindir} \
39        --sysconfdir=%{_sysconfdir}/%{name} \
40        --libexecdir=%{_libexecdir}/%{name} \
41        --datadir=%{_datadir}/%{name} \
42        --localstatedir=/var/run \
43        --enable-unicode \
44        --with-redhat
45        #--with-authdaemonvar=/var/run/authdaemon.%{name} \
46        #--without-authldap \
47        #--without-authmysql \
48        #--without-authpgsql \
49
50make
51make check
52
53%install
54rm -rf %{buildroot}
55mkdir -p %{buildroot}/etc/pam.d
56make install-strip DESTDIR=%{buildroot}
57
58mkdir -p %{buildroot}/%{_initdir}
59install -m 755 courier-imap.sysvinit %{buildroot}%{_initdir}/courier-imap
60
61
62cd %{buildroot}/%{_sysconfdir}/%{name}
63for dist in *.dist; do
64        mv $dist ${dist%.dist}
65done
66cd -
67
68touch %{buildroot}/var/run/imapd.pid
69touch %{buildroot}/var/run/imapd-ssl.pid
70touch %{buildroot}/var/run/imapd.pid.lock
71touch %{buildroot}/var/run/imapd-ssl.pid.lock
72
73touch %{buildroot}/var/run/pop3d.pid
74touch %{buildroot}/var/run/pop3d-ssl.pid
75touch %{buildroot}/var/run/pop3d.pid.lock
76touch %{buildroot}/var/run/pop3d-ssl.pid.lock
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%post
84/sbin/chkconfig --del courier-imap
85/sbin/chkconfig --add courier-imap
86
87
88%preun
89if test "$1" = "0"
90then
91        rm -f /var/run/couriersslcache
92        /sbin/chkconfig --del courier-imap
93fi
94
95%{_libexecdir}/%{name}/imapd.rc stop
96%{_libexecdir}/%{name}/imapd-ssl.rc stop
97%{_libexecdir}/%{name}/pop3d.rc stop
98%{_libexecdir}/%{name}/pop3d-ssl.rc stop
99
100
101
102%files
103%defattr(-,root,root)
104%doc NEWS AUTHORS COPYING imap/BUGS README README.imap README.maildirquota
105%doc README.sharedfolders
106%doc README.proxy*
107%doc README.apop
108%dir %{_sysconfdir}/%{name}
109%config %{_sysconfdir}/%{name}/*
110%config %{_sysconfdir}/pam.d/imap
111%config %{_sysconfdir}/pam.d/pop3
112%{_initdir}/courier-imap
113%{_libexecdir}/courier-imap/
114%{_sbindir}/*
115%{_datadir}/courier-imap/
116%{_mandir}/man*/*
117%ghost /var/run/*.pid
118%ghost /var/run/*.lock
119
120
121%changelog
122* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.7.0-1
123- new upstream release.
124- added "BR: libidn-devel".
125
126* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.6.0-1
127- new upstream release.
128- updated APOP patch.
129
130* Sat Aug 30 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.3-1vl5
131- applied new versioning policy
132
133* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 4.0.3-0vl2
134- new upstream release
135
136* Mon Mar 21 2005 UECHI Yasumasa <uechi@potaway.net> 4.0.2-0vl2
137- new upstream release
138
139* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 4.0.1-0vl3
140- new upstream release
141- authentication library is separated from this package
142- add README.proxy* to %doc
143- revise apop patch
144
145* Mon Sep 20 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.8-0vl1
146- new upstream version
147
148* Mon Jun 15 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.5-0vl1
149- new upstream version
150
151* Sat May 22 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.4-0vl1
152- new upstream version
153- revise apop patch
154
155* Thu Apr 01 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.3-0vl1
156- new upstream version
157
158* Sun Mar 28 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.2-0vl2
159- build with openssl-0.9.7d
160
161* Sat Mar 27 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.2-0vl1
162- new upstream version
163
164* Fri Mar 12 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.1-0vl1
165- new upstream version
166
167* Tue Mar 09 2004 UECHI Yasumasa <uechi@potaway.net> 3.0.0-0vl1
168- new upstream version
169- revise courier-imap-startconf.patch
170- use wildcard in files section (%{_sbindir}, %{_sysconfig}/%{name})
171
172* Fri Nov 28 2003 UECHI Yasumasa <uh@u.dhis.portside.net> 2.2.1-0vl1
173- new upstream version
174- add --with-redhat option to configure script
175
176* Fri Oct 31 2003 UECHI Yasumasa <uh@u.dhis.portside.net> 2.2.0-0vl1
177- new upstream version
178
179* Tue Sep 30 2003 UECHI Yasumasa <uh@u.dhis.portside.net> 2.1.2-0vl1
180- new upstream version
181
182* Mon Aug 18 2003 UECHI Yasumasa <uh@u.dhis.portside.net> 2.1.0-0vl1
183- new upstream version
184
185* Sat May 17 2003 UECHI Yasumasa <uh@u.dhis.portside.net> 1.7.3-0vl1
186- new upstream version
187- fix apop patch for 1.7.3
188
189* Tue Apr 22 2003 HOTTA Michihide <hotta@net-newbie.com> 1.7.1-0vl2
190- add apop patch
191
192* Wed Mar 26 2003 UECHI Yasumasa <uh@u.dhis.portside.net> 1.7.1-0vl1
193- new upstream version
194
195* Tue Dec 31 2002 UECHI Yasumasa <uh@u.dhis.portside.net> 1.6.2-0vl1
196- new upstream version
197
198* Sun Dec 01 2002 UECHI Yasumasa <uh@u.dhis.portside.net> 1.6.1-0vl2
199- use --enable-unicode in configure script
200
201* Tue Nov 12 2002 UECHI Yasumasa <uh@u.dhis.portside.net> 1.6.1-0vl1
202- new upstream release
203
204* Sat Oct 26 2002 UECHI Yasumasa <uh@u.dhis.portside.net> 1.6.0-0vl1
205- new upstream releas
206- /usr/bin/* moved to /usr/sbin/
207
208* Fri Aug  9 2002 UECHI Yasumasa <uh@u.dhis.portside.net> 1.5.3-0vl1
209- version up to 1.5.3
210
211* Wed Mar 20 2002 UECHI Yasumasa <uh@u.dhis.portside.net> 1.4.3-0vl1
212- initial release
Note: See TracBrowser for help on using the repository browser.