source: projects/specs/trunk/c/coreutils/coreutils-vl.spec @ 7168

Revision 7168, 23.6 KB checked in by daisuke, 11 years ago (diff)

coreutils: update to 8.20

Line 
1Summary: The GNU core utilities: a set of tools commonly used in shell scripts
2Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
3Name:    coreutils
4Version: 8.20
5Release: 1%{?_dist_release}
6License: GPL
7Group:   System Environment/Base
8Url:     http://www.gnu.org/software/coreutils/
9
10Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
11Source101:  coreutils-DIR_COLORS
12Source102:  coreutils-DIR_COLORS.lightbgcolor
13Source103:  coreutils-DIR_COLORS.256color
14Source105:  coreutils-colorls.sh
15Source106:  coreutils-colorls.csh
16
17# Vine sources
18Source1000: coreutils-8.10-ja.po
19
20# From upstream
21
22# Fedora patches
23#general patch to workaround koji build system issues
24Patch100: coreutils-6.10-configuration.patch
25#add note about no difference between binary/text mode on Linux - md5sum manpage
26Patch101: coreutils-6.10-manpages.patch
27#temporarily workaround probable kernel issue with TCSADRAIN(#504798)
28Patch102: coreutils-7.4-sttytcsadrain.patch
29#do display processor type for uname -p/-i based on uname(2) syscall
30Patch103: coreutils-8.2-uname-processortype.patch
31#df --direct
32Patch104: coreutils-df-direct.patch
33
34# sh-utils
35Patch713: coreutils-4.5.3-langinfo.patch
36
37# (sb) lin18nux/lsb compliance
38Patch800: coreutils-8.19-i18n.patch
39
40#getgrouplist() patch from Ulrich Drepper.
41Patch908: coreutils-getgrouplist.patch
42#Prevent buffer overflow in who(1) (bug #158405).
43Patch912: coreutils-overflow.patch
44
45BuildRoot: %{_tmppath}/%{name}-%{version}-root
46BuildRequires:  gettext libtermcap-devel bison
47BuildRequires: texinfo >= 4.3
48BuildRequires: autoconf >= 2.58, automake >= 1.11.2
49BuildRequires: libcap-devel
50BuildRequires: libattr-devel
51BuildRequires: libacl-devel
52BuildRequires: gmp-devel
53
54Requires(pre):         install-info
55Requires(preun):      install-info
56Requires(post):        install-info, grep, findutils
57
58# Require a C library that doesn't put LC_TIME files in our way.
59Conflicts: glibc < 2.2
60
61Provides:       fileutils = %version, sh-utils = %version, stat, textutils = %version
62Obsoletes:      fileutils sh-utils stat textutils
63Provides:       mktemp = %version
64Obsoletes:      mktemp
65# su/runuser moved to util-linux
66Requires: util-linux >= 2.22.1
67
68%description
69These are the GNU core utilities.  This package is the combination of
70the old GNU fileutils, sh-utils, and textutils packages.
71
72%description -l ja
73このパッケージには GNU のコアユーティリティが収録されています。
74コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
75sh-utils, textutils を統合したパッケージです。
76
77
78%prep
79%setup -q
80
81# From upstream
82
83
84# Fedora patches
85%patch100 -p1 -b .chgrp
86%patch101 -p1 -b .manpages
87%patch102 -p1 -b .tcsadrain
88%patch103 -p1 -b .sysinfo
89%patch104 -p1 -b .dfdirect
90
91# sh-utils
92#%patch703 -p1 -b .dateman
93#%patch706 -p1 -b .pam
94%patch713 -p1 -b .langinfo
95
96# li18nux/lsb
97%patch800 -p1 -b .i18n
98
99# Coreutils
100%patch908 -p1 -b .getgrouplist
101%patch912 -p1 -b .overflow
102
103# copy updated ja.po
104mv po/ja.po po/ja.po.orig
105cp -f %{SOURCE1000} po/ja.po
106
107%build
108export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
109%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
110touch aclocal.m4 configure config.hin Makefile.in */Makefile.in
111aclocal -I m4
112autoconf --force
113automake --copy --force --add-missing
114%configure --enable-largefile \
115           --enable-install-program=hostname,arch \
116           --with-tty-group \
117           DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
118
119touch man/*.x
120
121%__make all %{?_smp_mflags}
122
123%__make -C po update-gmo
124
125[[ -f ChangeLog && -f ChangeLog.bz2  ]] || bzip2 -9f ChangeLog
126
127# XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
128sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
129
130
131%install
132rm -rf $RPM_BUILD_ROOT
133%__make DESTDIR=$RPM_BUILD_ROOT install
134
135# man pages are not installed with make install
136%__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
137
138# fix japanese catalog file
139if [ -d $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES ]; then
140   mkdir -p $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
141   mv $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES/*mo \
142                $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
143   rm -rf $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC
144fi
145
146# let be compatible with old fileutils, sh-utils and textutils packages :
147mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
148for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
149         link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
150         stty sync touch true uname unlink
151do
152        mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
153done
154
155# chroot was in /usr/sbin :
156mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
157# {cat,sort,cut} were previously moved from bin to /usr/bin and linked into
158for i in env cut; do ln -sf ../../bin/$i $RPM_BUILD_ROOT/usr/bin; done
159
160mkdir -p $RPM_BUILD_ROOT/etc/profile.d
161install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
162install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.lightbgcolor
163install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
164install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
165install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
166
167# These come from util-linux and/or procps.
168for i in hostname uptime kill ; do
169        rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
170done
171
172bzip2 -f9 old/*/C* || :
173
174%find_lang %name
175
176# (sb) Deal with Installed (but unpackaged) file(s) found
177rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
178
179# FIXME: remove readlink which conflict with tetex's.
180#rm -f $RPM_BUILD_ROOT%{_bindir}/readlink
181#rm -f $RPM_BUILD_ROOT%{_mandir}/man1/readlink*
182
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187%pre
188# Remove these old glibc files on upgrade (bug #84090).
189for file in $(find /usr/share/locale -type f -name LC_TIME); do
190        [ -x /bin/rm ] && /bin/rm -f "$file"
191done
192
193# We must desinstall theses info files since they're merged in
194# coreutils.info. else their postun'll be runned too last
195# and install-info'll faill badly because of doubles
196for file in sh-utils.info textutils.info fileutils.info; do
197        if [ -f /usr/share/info/$file.bz2 ]; then
198                /sbin/install-info /usr/share/info/$file.bz2 --dir=/usr/share/info/dir --remove &> /dev/null
199        fi
200done
201
202%preun
203if [ $1 = 0 ]; then
204    [ -f %{_infodir}/%{name}.info.gz ] && \
205      /sbin/install-info --delete %{_infodir}/%{name}.info.gz \
206        %{_infodir}/dir || :
207fi
208
209%post
210/bin/grep -v '(sh-utils)\|(fileutils)\|(textutils)' %{_infodir}/dir > \
211  %{_infodir}/dir.rpmmodify || exit 0
212    /bin/mv -f %{_infodir}/dir.rpmmodify %{_infodir}/dir
213[ -f %{_infodir}/%{name}.info.gz ] && \
214  /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
215
216%files -f %{name}.lang
217%defattr(-,root,root)
218%config(noreplace) %{_sysconfdir}/DIR_COLORS*
219%config(noreplace) %{_sysconfdir}/profile.d/*
220%doc COPYING ABOUT-NLS ChangeLog.bz2 NEWS README THANKS TODO old/*
221/bin/*
222%{_bindir}/*
223%{_libexecdir}/coreutils
224%{_infodir}/coreutils*
225%{_mandir}/man*/*
226%{_sbindir}/chroot
227
228%changelog
229* Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.20-1
230- update to 8.20
231
232* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-2
233- update ja.po
234- add BR: libcap-devel, gmp-devel, libattr-devel, libacl-devel
235
236* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-1
237- update to 8.10
238
239* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
240- rebuilt against curent toolchain
241- spec in UTF-8
242
243* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
244- new upstream release
245- drop obsolete patches
246- import some patched from fedora-devel
247- add Obsoletes/Provides mktemp
248
249* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
250- new upstream release
251
252* Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
253- new upstream release
254
255* Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
256- new upstream release
257- drop opsolete patches
258- import some patches from FC
259
260* Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
261- now readlink is kept as it is, since tetex-3.0 don't have readlink.
262
263* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
264- updated ja.po
265
266* Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
267- remove selinux related pam-module from /etc/pam.d/su
268
269* Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
270- update ja.po
271
272* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
273- initial build for Vine Linux
274  - some modifications are merged from fileutils-4.1-10.1vl4
275- disable make check
276
277* Sat Feb  5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
278- Undo last change (bug #145266).
279
280* Fri Feb  4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
281- Special case for ia32e in uname (bug #145266).
282
283* Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
284- Fixed zh_CN translation (bug #144845).  Patch from Mitrophan Chin.
285
286* Mon Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
287- Fix to only setdefaultfilecon if not overridden by command line
288
289* Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
290- Change install to restorecon if it can
291
292* Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
293- Fixed small bug in i18n patch.
294
295* Mon Dec  6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
296- Don't set fs uid until after pam_open_session (bug #77791).
297
298* Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
299- Fixed colorls.csh (bug #139988).  Patch from Miloslav Trmac.
300
301* Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com>
302- Updated URL (bug #138279).
303
304* Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
305- Handle the return code of function calls in runcon.
306
307* Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
308- Prevent compiler warning in coreutils-i18n.patch (bug #136090).
309
310* Tue Oct  5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
311- getgrouplist() patch from Ulrich Drepper.
312- The selinux patch should be applied last.
313
314* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
315- Mv runuser to /sbin
316
317* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
318- Fix runuser man page.
319
320* Mon Oct  4 2004 Tim Waugh <twaugh@redhat.com>
321- Fixed build.
322
323* Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
324- Add runuser as similar to su, but only runable by root
325
326* Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
327- chown(1) patch from Ulrich Drepper.
328
329* Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
330- SELinux patch fix: don't display '(null)' if getfilecon() fails
331  (bug #131196).
332
333* Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
334- Fixed colorls.csh quoting (bug #102412).
335- Fixed another join LSB test failure (bug #121153).
336
337* Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
338- Fixed sort -t LSB test failure (bug #121154).
339- Fixed join LSB test failure (bug #121153).
340
341* Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
342- Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
343- SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
344
345* Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
346- Added 'konsole' TERM to DIR_COLORS (bug #129544).
347
348* Wed Aug  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
349- Added 'gnome' TERM to DIR_COLORS (bug #129112).
350- Worked around a bash bug #129128.
351- Fixed an i18n patch bug in cut (bug #129114).
352
353* Tue Aug  3 2004 Tim Waugh <twaugh@redhat.com>
354- Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
355  (bug #128948).
356
357* Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
358- Fixed field extraction in sort (bug #127694).
359
360* Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
361- Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
362
363* Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
364- Move pam-xauth to after pam-selinux
365
366* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
367- rebuilt
368
369* Mon Jun  7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
370- Fix ls -Z (bug #125447).
371
372* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
373- Build requires bison (bug #125290).
374
375* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
376- Fix selinux patch causing problems with ls --format=... (bug #125238).
377
378* Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
379- Change su to use pam_selinux open and pam_selinux close
380
381* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
382- Don't call access() on symlinks about to be removed (bug #124699).
383
384* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
385- Fix ja translation (bug #124862).
386
387* Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
388- rebuild
389
390* Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
391- Mention pam in the info for su (bug #122592).
392- Remove wheel group rant again (bug #122886).
393- Change default behaviour for chgrp/chown (bug #123263).  Patch from
394  upstream.
395
396* Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
397- compiling su PIE
398
399* Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
400- Build requires new versions of autoconf and automake (bug #123098).
401
402* Tue May  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
403- Fix join -t (bug #122435).
404
405* Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
406- Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
407
408* Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
409- Add ls -LZ fix
410- Fix chcon to handle "."
411
412* Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
413- Apply upstream fix for non-zero seconds for --date="10:00 +0100".
414
415* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
416- If preserve fails, report as warning unless user requires preserve
417
418* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
419- Make mv default to preserve on context
420
421* Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
422- 5.2.1.
423
424* Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
425- Add '-Z' to 'ls --help' output (bug #118108).
426
427* Fri Mar  5 2004 Tim Waugh <twaugh@redhat.com>
428- Fix deref-args test case for rebuilding under SELinux (bug #117556).
429
430* Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
431- kill(1) offloaded to util-linux altogether.
432
433* Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
434- Ship the real '[', not a symlink.
435
436* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
437- Apply Paul Eggert's chown patch (bug #116536).
438- Merged chdir patch into pam patch where it belongs.
439
440* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
441- Fixed i18n patch bug causing sort -M not to work (bug #116575).
442
443* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
444- Reinstate kill binary, just not its man page (bug #116463).
445
446* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
447- Updated ls-stat patch.
448
449* Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
450- fix chcon to ignore . and .. directories for recursing
451
452* Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
453- Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
454- 5.2.0.
455
456* Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
457- More AFS patch tidying.
458
459* Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
460- fix chcon to handle -h qualifier properly, eliminate potential crash
461
462* Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
463- Stop 'sort -g' leaking memory (i18n patch bug #115620).
464- Don't ship kill, since util-linux already does.
465- Tidy AFS patch.
466
467* Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
468- 5.1.3.
469- Patches ported forward or removed.
470
471* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
472- rebuilt
473
474* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
475- Change /etc/pam.d/su to remove preservuser and add multiple
476
477* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
478- Change is_selinux_enabled to is_selinux_enabled > 0
479
480* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
481- Add pam_selinux to pam file to allow switching of roles within selinux
482
483* Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
484- The textutils-2.0.17-mem.patch is no longer needed.
485
486* Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
487- Fixed autoconf test causing builds to fail.
488
489* Tue Dec  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
490- Fix copying to non xattr files
491
492* Thu Dec  4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
493- Fix column widths problems in ls.
494
495* Tue Dec  2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
496- Speed up md5sum by disabling speed-up asm.
497
498* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
499- Try again
500
501* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
502- Fix move on non SELinux kernels
503
504* Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
505- Fixed useless acl dependencies (bug #106141).
506
507* Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
508- Fix id -Z
509
510* Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
511- Turn on SELinux
512- Fix chcon error handling
513
514* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
515- Turn off SELinux
516
517* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
518- Turn on SELinux
519
520* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
521- Turn off SELinux
522
523* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
524- Turn on SELinux
525
526* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
527- allow compiling without pam support
528
529* Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
530- Make split(1) handle large files (bug #106700).
531
532* Thu Oct  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
533- Turn off SELinux
534
535* Wed Oct  8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
536- Cleanup SELinux patch
537
538* Fri Oct  3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
539- Restrict ACL support to only those programs needing it (bug #106141).
540- Fix default PATH for LSB (bug #102567).
541
542* Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
543- Turn off SELinux
544
545* Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
546- Turn on SELinux
547
548* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
549- Turn off SELinux
550
551* Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
552- Only call getfilecon if the user requested it.
553- build with selinux
554
555* Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
556- Documentation fix (bug #102697).
557
558* Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
559- Made su use pam again (oops).
560- Fixed another i18n bug causing sort --month-sort to fail.
561- Don't run dubious stty test, since it fails when backgrounded
562  (bug #102033).
563- Re-enable make check.
564
565* Fri Aug  8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
566- Don't run 'make check' for this build (build environment problem).
567- Another uninitialized variable in i18n (from bug #98683).
568
569* Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
570- Internationalize runcon
571- Update latest chcon from NSA
572
573* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
574- Re-enable make check.
575
576* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
577- Don't run 'make check' for this build (build environment problem).
578
579* Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
580- Actually use the ACL patch (bug #100519).
581
582* Wed Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
583- Convert to SELinux
584
585* Mon Jun  9 2003 Tim Waugh <twaugh@redhat.com>
586- Removed samefile patch.  Now the test suite passes.
587
588* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
589- rebuilt
590
591* Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
592- Both kon and kterm support colours (bug #83701).
593- Fix 'ls -l' alignment in zh_CN locale (bug #88346).
594
595* Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
596- Prevent file descriptor leakage in du (bug #90563).
597- Build requires recent texinfo (bug #90439).
598
599* Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
600- Allow obsolete options unless POSIXLY_CORRECT is set.
601
602* Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
603- Fold bug was introduced by i18n patch; fixed there instead.
604
605* Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
606- fix segfault in fold (#88683)
607
608* Sat Apr  5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
609- 5.0.
610
611* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
612- Use _smp_mflags.
613
614* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
615- Remove overwrite patch.
616- No longer seem to need nolibrt, errno patches.
617
618* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
619- No longer seem to need danglinglink, prompt, lug, touch_errno patches.
620
621* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
622- 4.5.11.
623- Use packaged readlink.
624
625* Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
626- 4.5.10.
627- Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
628- Drop fr_fix, LC_TIME, preserve, regex patches.
629
630* Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
631- Fixed another i18n patch bug (bug #82032).
632
633* Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
634- Fix sort(1) efficiency in multibyte encoding (bug #82032).
635
636* Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
637- Ship readlink(1) (bug #84200).
638
639* Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
640- Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
641
642* Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
643- Require glibc >= 2.2 (bug #84090).
644
645* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
646- fix group (#84095)
647
648* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
649- rebuilt
650
651* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
652- Fix rm(1) man page.
653
654* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
655- Fix re_compile_pattern check.
656- Fix su hang (bug #81653).
657
658* Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
659- Fix memory size calculation.
660
661* Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
662- Fix mv error message (bug #79809).
663
664* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
665- added PreReq on grep
666
667* Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
668- Fix cp --preserve with multiple arguments.
669
670* Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
671- Turn on colorls for screen (bug #78816).
672
673* Mon Dec  9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
674- Fix mv (bug #79283).
675- Add patch27 (nogetline).
676
677* Sun Dec  1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
678- use the su.pamd from sh-utils since it works properly with multilib systems
679
680* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
681- Fix test suite quoting problems.
682
683* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
684- Fix scriplets.
685- Fix i18n patch so it doesn't break uniq.
686- Fix several other patches to either make the test suite pass or
687  not run the relevant tests.
688- Run 'make check'.
689- Fix file list.
690
691* Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
692- Adapted for Red Hat Linux.
693- Self-host for help2man.
694- Don't ship readlink just yet (maybe later).
695- Merge patches from fileutils and sh-utils (textutils ones are already
696  merged it seems).
697- Keep the binaries where the used to be (in particular, id and stat).
698
699* Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
700- LI18NUX/LSB compliance (patch800)
701- Installed (but unpackaged) file(s) - /usr/share/info/dir
702
703* Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
704- new release
705- rediff patch 180
706- merge patch 150 into 180
707
708* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
709- move su back to /bin
710
711* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
712- patch 0 : lg locale is illegal and must be renamed lug (pablo)
713
714* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
715- fix conflict with procps
716
717* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
718- patch 105 : fix install -s
719
720* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
721- fix build
722- don't chmode two times su
723- build with large file support
724- fix description
725- various spec cleanups
726- fix chroot installation
727- fix missing /bin/env
728- add old fileutils, sh-utils & textutils ChangeLogs
729
730* Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
731- initial release (merge fileutils, sh-utils & textutils)
732- obsoletes/provides: sh-utils/fileutils/textutils
733- fileutils stuff go in 1xx range
734- sh-utils stuff go in 7xx range
735- textutils stuff go in 5xx range
736- drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
737  most of them)
738- rediff patches 103, 105, 111, 113, 180, 706
739- temporary disable patch 3 & 4
740- fix fileutils url
Note: See TracBrowser for help on using the repository browser.