source: projects/specs/trunk/c/coreutils/coreutils-vl.spec @ 521

Revision 521, 24.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The GNU core utilities: a set of tools commonly used in shell scripts
2Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
3Name:    coreutils
4Version: 6.11
5Release: 2%{?_dist_release}
6License: GPL
7Group:   System Environment/Base
8Url:     http://www.gnu.org/software/coreutils/
9
10Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
11Source101:  coreutils-DIR_COLORS
12Source102:  coreutils-DIR_COLORS.xterm
13Source103:  coreutils-DIR_COLORS.256color
14Source105:  coreutils-colorls.sh
15Source106:  coreutils-colorls.csh
16Source200:  coreutils-su.pamd
17Source201:  coreutils-runuser.pamd
18Source202:  coreutils-su-l.pamd
19Source203:  coreutils-runuser-l.pamd
20
21# Vine sources
22Source1000: coreutils-5.94-ja.po
23
24# From upstream
25
26
27# Fedora patches
28Patch100: coreutils-chgrp.patch
29Patch102: coreutils-6.10-manpages.patch
30#Patch103: coreutils-6.10-longoptions.patch
31
32# sh-utils
33#Patch703: sh-utils-2.0.11-dateman.patch
34Patch704: sh-utils-1.16-paths.patch
35# RMS will never accept the PAM patch because it removes his historical
36# rant about Twenex and the wheel group, so we'll continue to maintain
37# it here indefinitely.
38Patch706: coreutils-pam.patch
39Patch713: coreutils-4.5.3-langinfo.patch
40Patch715: coreutils-4.5.3-sysinfo.patch
41
42# (sb) lin18nux/lsb compliance
43Patch800: coreutils-i18n.patch
44
45Patch900: coreutils-setsid.patch
46Patch907: coreutils-5.2.1-runuser.patch
47Patch908: coreutils-getgrouplist.patch
48Patch912: coreutils-overflow.patch
49Patch915: coreutils-split-pam.patch
50Patch916: coreutils-getfacl-exit-code.patch
51
52BuildRoot: %{_tmppath}/%{name}-%{version}-root
53BuildRequires:  gettext libtermcap-devel bison
54%{?!nopam:BuildRequires: pam-devel}
55BuildRequires: texinfo >= 4.3
56BuildRequires: autoconf >= 2.58, automake >= 1.10
57Prereq:        install-info
58%{?!nopam:Requires: pam >= 0.66-12}
59Prereq: grep, findutils
60
61# Require a C library that doesn't put LC_TIME files in our way.
62Conflicts: glibc < 2.2
63
64Provides:       fileutils = %version, sh-utils = %version, stat, textutils = %version
65Obsoletes:      fileutils sh-utils stat textutils
66Provides:       mktemp = %version
67Obsoletes:      mktemp
68
69%description
70These are the GNU core utilities.  This package is the combination of
71the old GNU fileutils, sh-utils, and textutils packages.
72
73%description -l ja
74このパッケージには GNU のコアユーティリティが収録されています。
75コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
76sh-utils, textutils を統合したパッケージです。
77
78
79%prep
80%setup -q
81
82# From upstream
83
84
85# Fedora patches
86%patch100 -p1 -b .chgrp
87%patch102 -p1 -b .manpages
88#%patch103 -p1 -b .longopt
89
90# sh-utils
91#%patch703 -p1 -b .dateman
92%patch704 -p1 -b .paths
93%patch706 -p1 -b .pam
94%patch713 -p1 -b .langinfo
95%patch715 -p1 -b .sysinfo
96
97# li18nux/lsb
98%patch800 -p1 -b .i18n
99
100# Coreutils
101%patch900 -p1 -b .setsid
102%patch907 -p1 -b .runuser
103%patch908 -p1 -b .getgrouplist
104%patch912 -p1 -b .overflow
105%patch915 -p1 -b .splitl
106%patch916 -p1 -b .getfacl-exit-code
107
108# copy updated ja.po
109mv po/ja.po po/ja.po.orig
110cp -f %{SOURCE1000} po/ja.po
111
112%build
113%ifarch s390 s390x
114export CFLAGS="$RPM_OPT_FLAGS -fPIC"
115%else
116export CFLAGS="$RPM_OPT_FLAGS -fpic"
117%endif
118%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
119touch aclocal.m4 configure config.hin Makefile.in */Makefile.in */*/Makefile.in
120aclocal -I m4
121autoconf --force
122automake --copy --force
123%configure --enable-largefile --with-afs %{?!nopam:--enable-pam} \
124|| :
125%__make all %{?_smp_mflags} \
126        %{?!nopam:CPPFLAGS="-DUSE_PAM"} \
127        su_LDFLAGS="-pie %{?!nopam:-lpam -lpam_misc}"
128
129%__make -C po update-gmo
130
131[[ -f ChangeLog && -f ChangeLog.bz2  ]] || bzip2 -9f ChangeLog
132
133# disable make check, because some tests can not run in non-root user.
134## Run the test suite.
135#make check
136
137# XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
138perl -pi -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
139
140
141%install
142rm -rf $RPM_BUILD_ROOT
143%makeinstall
144
145# man pages are not installed with make install
146%__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
147
148# fix japanese catalog file
149if [ -d $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES ]; then
150   mkdir -p $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
151   mv $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES/*mo \
152                $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
153   rm -rf $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC
154fi
155
156# let be compatible with old fileutils, sh-utils and textutils packages :
157mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
158%{?!nopam:mkdir -p $RPM_BUILD_ROOT%_sysconfdir/pam.d}
159for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
160         link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
161         stty sync touch true uname unlink
162do
163        mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
164done
165
166# chroot was in /usr/sbin :
167mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
168# {cat,sort,cut} were previously moved from bin to /usr/bin and linked into
169for i in env cut; do ln -sf ../../bin/$i $RPM_BUILD_ROOT/usr/bin; done
170
171mkdir -p $RPM_BUILD_ROOT/etc/profile.d
172install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
173install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.xterm
174install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
175install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
176install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
177
178# su
179install -m 4755 src/su $RPM_BUILD_ROOT/bin
180install -m 755 src/runuser $RPM_BUILD_ROOT/sbin
181
182# These come from util-linux and/or procps.
183for i in hostname uptime kill ; do
184        rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
185done
186
187%{?!nopam:install -p -m 644 %SOURCE200 $RPM_BUILD_ROOT%_sysconfdir/pam.d/su}
188%{?!nopam:install -p -m 644 %SOURCE202 $RPM_BUILD_ROOT%_sysconfdir/pam.d/su-l}
189%{?!nopam:install -p -m 644 %SOURCE201 $RPM_BUILD_ROOT%_sysconfdir/pam.d/runuser}
190%{?!nopam:install -p -m 644 %SOURCE203 $RPM_BUILD_ROOT%_sysconfdir/pam.d/runuser-l}
191
192bzip2 -f9 old/*/C* || :
193
194%find_lang %name
195
196# (sb) Deal with Installed (but unpackaged) file(s) found
197rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
198
199# FIXME: remove readlink which conflict with tetex's.
200#rm -f $RPM_BUILD_ROOT%{_bindir}/readlink
201#rm -f $RPM_BUILD_ROOT%{_mandir}/man1/readlink*
202
203
204%clean
205rm -rf $RPM_BUILD_ROOT
206
207%pre
208# Remove these old glibc files on upgrade (bug #84090).
209for file in $(find /usr/share/locale -type f -name LC_TIME); do
210        [ -x /bin/rm ] && /bin/rm -f "$file"
211done
212
213# We must desinstall theses info files since they're merged in
214# coreutils.info. else their postun'll be runned too last
215# and install-info'll faill badly because of doubles
216for file in sh-utils.info textutils.info fileutils.info; do
217        if [ -f /usr/share/info/$file.bz2 ]; then
218                /sbin/install-info /usr/share/info/$file.bz2 --dir=/usr/share/info/dir --remove &> /dev/null
219        fi
220done
221
222%preun
223if [ $1 = 0 ]; then
224    [ -f %{_infodir}/%{name}.info.gz ] && \
225      /sbin/install-info --delete %{_infodir}/%{name}.info.gz \
226        %{_infodir}/dir || :
227fi
228
229%post
230/bin/grep -v '(sh-utils)\|(fileutils)\|(textutils)' %{_infodir}/dir > \
231  %{_infodir}/dir.rpmmodify || exit 0
232    /bin/mv -f %{_infodir}/dir.rpmmodify %{_infodir}/dir
233[ -f %{_infodir}/%{name}.info.gz ] && \
234  /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
235
236%files -f %{name}.lang
237%defattr(-,root,root)
238%config(noreplace) %{_sysconfdir}/DIR_COLORS*
239%config(noreplace) %{_sysconfdir}/profile.d/*
240%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su}
241%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su-l}
242%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser}
243%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser-l}
244%doc COPYING ABOUT-NLS ChangeLog.bz2 NEWS README THANKS TODO old/*
245/bin/*
246%{_bindir}/*
247%{_infodir}/coreutils*
248%{_mandir}/man*/*
249%{_sbindir}/chroot
250/sbin/runuser
251
252%changelog
253* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
254- rebuilt against curent toolchain
255- spec in UTF-8
256
257* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
258- new upstream release
259- drop obsolete patches
260- import some patched from fedora-devel
261- add Obsoletes/Provides mktemp
262
263* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
264- new upstream release
265
266* Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
267- new upstream release
268
269* Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
270- new upstream release
271- drop opsolete patches
272- import some patches from FC
273
274* Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
275- now readlink is kept as it is, since tetex-3.0 don't have readlink.
276
277* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
278- updated ja.po
279
280* Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
281- remove selinux related pam-module from /etc/pam.d/su
282
283* Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
284- update ja.po
285
286* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
287- initial build for Vine Linux
288  - some modifications are merged from fileutils-4.1-10.1vl4
289- disable make check
290
291* Sat Feb  5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
292- Undo last change (bug #145266).
293
294* Fri Feb  4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
295- Special case for ia32e in uname (bug #145266).
296
297* Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
298- Fixed zh_CN translation (bug #144845).  Patch from Mitrophan Chin.
299
300* Mon Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
301- Fix to only setdefaultfilecon if not overridden by command line
302
303* Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
304- Change install to restorecon if it can
305
306* Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
307- Fixed small bug in i18n patch.
308
309* Mon Dec  6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
310- Don't set fs uid until after pam_open_session (bug #77791).
311
312* Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
313- Fixed colorls.csh (bug #139988).  Patch from Miloslav Trmac.
314
315* Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com>
316- Updated URL (bug #138279).
317
318* Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
319- Handle the return code of function calls in runcon.
320
321* Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
322- Prevent compiler warning in coreutils-i18n.patch (bug #136090).
323
324* Tue Oct  5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
325- getgrouplist() patch from Ulrich Drepper.
326- The selinux patch should be applied last.
327
328* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
329- Mv runuser to /sbin
330
331* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
332- Fix runuser man page.
333
334* Mon Oct  4 2004 Tim Waugh <twaugh@redhat.com>
335- Fixed build.
336
337* Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
338- Add runuser as similar to su, but only runable by root
339
340* Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
341- chown(1) patch from Ulrich Drepper.
342
343* Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
344- SELinux patch fix: don't display '(null)' if getfilecon() fails
345  (bug #131196).
346
347* Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
348- Fixed colorls.csh quoting (bug #102412).
349- Fixed another join LSB test failure (bug #121153).
350
351* Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
352- Fixed sort -t LSB test failure (bug #121154).
353- Fixed join LSB test failure (bug #121153).
354
355* Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
356- Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
357- SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
358
359* Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
360- Added 'konsole' TERM to DIR_COLORS (bug #129544).
361
362* Wed Aug  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
363- Added 'gnome' TERM to DIR_COLORS (bug #129112).
364- Worked around a bash bug #129128.
365- Fixed an i18n patch bug in cut (bug #129114).
366
367* Tue Aug  3 2004 Tim Waugh <twaugh@redhat.com>
368- Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
369  (bug #128948).
370
371* Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
372- Fixed field extraction in sort (bug #127694).
373
374* Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
375- Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
376
377* Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
378- Move pam-xauth to after pam-selinux
379
380* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
381- rebuilt
382
383* Mon Jun  7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
384- Fix ls -Z (bug #125447).
385
386* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
387- Build requires bison (bug #125290).
388
389* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
390- Fix selinux patch causing problems with ls --format=... (bug #125238).
391
392* Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
393- Change su to use pam_selinux open and pam_selinux close
394
395* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
396- Don't call access() on symlinks about to be removed (bug #124699).
397
398* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
399- Fix ja translation (bug #124862).
400
401* Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
402- rebuild
403
404* Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
405- Mention pam in the info for su (bug #122592).
406- Remove wheel group rant again (bug #122886).
407- Change default behaviour for chgrp/chown (bug #123263).  Patch from
408  upstream.
409
410* Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
411- compiling su PIE
412
413* Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
414- Build requires new versions of autoconf and automake (bug #123098).
415
416* Tue May  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
417- Fix join -t (bug #122435).
418
419* Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
420- Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
421
422* Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
423- Add ls -LZ fix
424- Fix chcon to handle "."
425
426* Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
427- Apply upstream fix for non-zero seconds for --date="10:00 +0100".
428
429* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
430- If preserve fails, report as warning unless user requires preserve
431
432* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
433- Make mv default to preserve on context
434
435* Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
436- 5.2.1.
437
438* Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
439- Add '-Z' to 'ls --help' output (bug #118108).
440
441* Fri Mar  5 2004 Tim Waugh <twaugh@redhat.com>
442- Fix deref-args test case for rebuilding under SELinux (bug #117556).
443
444* Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
445- kill(1) offloaded to util-linux altogether.
446
447* Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
448- Ship the real '[', not a symlink.
449
450* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
451- Apply Paul Eggert's chown patch (bug #116536).
452- Merged chdir patch into pam patch where it belongs.
453
454* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
455- Fixed i18n patch bug causing sort -M not to work (bug #116575).
456
457* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
458- Reinstate kill binary, just not its man page (bug #116463).
459
460* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
461- Updated ls-stat patch.
462
463* Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
464- fix chcon to ignore . and .. directories for recursing
465
466* Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
467- Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
468- 5.2.0.
469
470* Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
471- More AFS patch tidying.
472
473* Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
474- fix chcon to handle -h qualifier properly, eliminate potential crash
475
476* Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
477- Stop 'sort -g' leaking memory (i18n patch bug #115620).
478- Don't ship kill, since util-linux already does.
479- Tidy AFS patch.
480
481* Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
482- 5.1.3.
483- Patches ported forward or removed.
484
485* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
486- rebuilt
487
488* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
489- Change /etc/pam.d/su to remove preservuser and add multiple
490
491* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
492- Change is_selinux_enabled to is_selinux_enabled > 0
493
494* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
495- Add pam_selinux to pam file to allow switching of roles within selinux
496
497* Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
498- The textutils-2.0.17-mem.patch is no longer needed.
499
500* Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
501- Fixed autoconf test causing builds to fail.
502
503* Tue Dec  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
504- Fix copying to non xattr files
505
506* Thu Dec  4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
507- Fix column widths problems in ls.
508
509* Tue Dec  2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
510- Speed up md5sum by disabling speed-up asm.
511
512* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
513- Try again
514
515* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
516- Fix move on non SELinux kernels
517
518* Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
519- Fixed useless acl dependencies (bug #106141).
520
521* Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
522- Fix id -Z
523
524* Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
525- Turn on SELinux
526- Fix chcon error handling
527
528* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
529- Turn off SELinux
530
531* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
532- Turn on SELinux
533
534* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
535- Turn off SELinux
536
537* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
538- Turn on SELinux
539
540* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
541- allow compiling without pam support
542
543* Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
544- Make split(1) handle large files (bug #106700).
545
546* Thu Oct  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
547- Turn off SELinux
548
549* Wed Oct  8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
550- Cleanup SELinux patch
551
552* Fri Oct  3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
553- Restrict ACL support to only those programs needing it (bug #106141).
554- Fix default PATH for LSB (bug #102567).
555
556* Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
557- Turn off SELinux
558
559* Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
560- Turn on SELinux
561
562* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
563- Turn off SELinux
564
565* Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
566- Only call getfilecon if the user requested it.
567- build with selinux
568
569* Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
570- Documentation fix (bug #102697).
571
572* Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
573- Made su use pam again (oops).
574- Fixed another i18n bug causing sort --month-sort to fail.
575- Don't run dubious stty test, since it fails when backgrounded
576  (bug #102033).
577- Re-enable make check.
578
579* Fri Aug  8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
580- Don't run 'make check' for this build (build environment problem).
581- Another uninitialized variable in i18n (from bug #98683).
582
583* Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
584- Internationalize runcon
585- Update latest chcon from NSA
586
587* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
588- Re-enable make check.
589
590* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
591- Don't run 'make check' for this build (build environment problem).
592
593* Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
594- Actually use the ACL patch (bug #100519).
595
596* Wed Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
597- Convert to SELinux
598
599* Mon Jun  9 2003 Tim Waugh <twaugh@redhat.com>
600- Removed samefile patch.  Now the test suite passes.
601
602* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
603- rebuilt
604
605* Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
606- Both kon and kterm support colours (bug #83701).
607- Fix 'ls -l' alignment in zh_CN locale (bug #88346).
608
609* Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
610- Prevent file descriptor leakage in du (bug #90563).
611- Build requires recent texinfo (bug #90439).
612
613* Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
614- Allow obsolete options unless POSIXLY_CORRECT is set.
615
616* Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
617- Fold bug was introduced by i18n patch; fixed there instead.
618
619* Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
620- fix segfault in fold (#88683)
621
622* Sat Apr  5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
623- 5.0.
624
625* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
626- Use _smp_mflags.
627
628* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
629- Remove overwrite patch.
630- No longer seem to need nolibrt, errno patches.
631
632* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
633- No longer seem to need danglinglink, prompt, lug, touch_errno patches.
634
635* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
636- 4.5.11.
637- Use packaged readlink.
638
639* Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
640- 4.5.10.
641- Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
642- Drop fr_fix, LC_TIME, preserve, regex patches.
643
644* Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
645- Fixed another i18n patch bug (bug #82032).
646
647* Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
648- Fix sort(1) efficiency in multibyte encoding (bug #82032).
649
650* Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
651- Ship readlink(1) (bug #84200).
652
653* Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
654- Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
655
656* Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
657- Require glibc >= 2.2 (bug #84090).
658
659* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
660- fix group (#84095)
661
662* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
663- rebuilt
664
665* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
666- Fix rm(1) man page.
667
668* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
669- Fix re_compile_pattern check.
670- Fix su hang (bug #81653).
671
672* Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
673- Fix memory size calculation.
674
675* Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
676- Fix mv error message (bug #79809).
677
678* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
679- added PreReq on grep
680
681* Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
682- Fix cp --preserve with multiple arguments.
683
684* Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
685- Turn on colorls for screen (bug #78816).
686
687* Mon Dec  9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
688- Fix mv (bug #79283).
689- Add patch27 (nogetline).
690
691* Sun Dec  1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
692- use the su.pamd from sh-utils since it works properly with multilib systems
693
694* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
695- Fix test suite quoting problems.
696
697* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
698- Fix scriplets.
699- Fix i18n patch so it doesn't break uniq.
700- Fix several other patches to either make the test suite pass or
701  not run the relevant tests.
702- Run 'make check'.
703- Fix file list.
704
705* Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
706- Adapted for Red Hat Linux.
707- Self-host for help2man.
708- Don't ship readlink just yet (maybe later).
709- Merge patches from fileutils and sh-utils (textutils ones are already
710  merged it seems).
711- Keep the binaries where the used to be (in particular, id and stat).
712
713* Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
714- LI18NUX/LSB compliance (patch800)
715- Installed (but unpackaged) file(s) - /usr/share/info/dir
716
717* Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
718- new release
719- rediff patch 180
720- merge patch 150 into 180
721
722* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
723- move su back to /bin
724
725* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
726- patch 0 : lg locale is illegal and must be renamed lug (pablo)
727
728* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
729- fix conflict with procps
730
731* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
732- patch 105 : fix install -s
733
734* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
735- fix build
736- don't chmode two times su
737- build with large file support
738- fix description
739- various spec cleanups
740- fix chroot installation
741- fix missing /bin/env
742- add old fileutils, sh-utils & textutils ChangeLogs
743
744* Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
745- initial release (merge fileutils, sh-utils & textutils)
746- obsoletes/provides: sh-utils/fileutils/textutils
747- fileutils stuff go in 1xx range
748- sh-utils stuff go in 7xx range
749- textutils stuff go in 5xx range
750- drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
751  most of them)
752- rediff patches 103, 105, 111, 113, 180, 706
753- temporary disable patch 3 & 4
754- fix fileutils url
Note: See TracBrowser for help on using the repository browser.