source: projects/specs/trunk/c/coreutils/coreutils-vl.spec @ 10288

Revision 10288, 24.2 KB checked in by Takemikaduchi, 8 years ago (diff)

task-all-codecs: remove xine-lib-esd
others: new upstream release

Line 
1Summary: The GNU core utilities: a set of tools commonly used in shell scripts
2Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
3Name:    coreutils
4Version: 8.25
5Release: 1%{?_dist_release}
6License: GPL
7Group:   System Environment/Base
8Url:     http://www.gnu.org/software/coreutils/
9
10Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
11Source101:  coreutils-DIR_COLORS
12Source102:  coreutils-DIR_COLORS.lightbgcolor
13Source103:  coreutils-DIR_COLORS.256color
14Source105:  coreutils-colorls.sh
15Source106:  coreutils-colorls.csh
16
17# Vine sources
18Source1000: coreutils-8.10-ja.po
19
20# From upstream
21
22# Fedora patches
23#general patch to workaround koji build system issues
24Patch100: coreutils-6.10-configuration.patch
25#add note about no difference between binary/text mode on Linux - md5sum manpage
26Patch101: coreutils-6.10-manpages.patch
27#do display processor type for uname -p/-i based on uname(2) syscall
28Patch103: coreutils-8.2-uname-processortype.patch
29#df --direct
30Patch104: coreutils-df-direct.patch
31
32# sh-utils
33Patch713: coreutils-4.5.3-langinfo.patch
34
35# (sb) lin18nux/lsb compliance
36Patch800: coreutils-i18n.patch
37# (sb) lin18nux/lsb compliance - expand/unexpand
38Patch801: coreutils-i18n-expand-unexpand.patch
39# The unexpand patch above is not correct. Sent to the patch authors
40Patch803: coreutils-i18n-fix-unexpand.patch
41# i18n patch for cut - old version - used
42Patch804: coreutils-i18n-cut-old.patch
43
44#getgrouplist() patch from Ulrich Drepper.
45Patch908: coreutils-getgrouplist.patch
46#Prevent buffer overflow in who(1) (bug #158405).
47Patch912: coreutils-overflow.patch
48
49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50BuildRequires:  gettext libtermcap-devel bison
51BuildRequires: texinfo >= 4.3
52BuildRequires: autoconf >= 2.58, automake >= 1.11.2
53BuildRequires: libcap-devel
54BuildRequires: libattr-devel
55BuildRequires: libacl-devel
56BuildRequires: gmp-devel
57
58Requires(pre):         install-info
59Requires(preun):      install-info
60Requires(post):        install-info, grep, findutils
61
62# Require a C library that doesn't put LC_TIME files in our way.
63Conflicts: glibc < 2.2
64
65Provides:       fileutils = %version, sh-utils = %version, stat, textutils = %version
66Obsoletes:      fileutils sh-utils stat textutils
67Provides:       mktemp = %version
68Obsoletes:      mktemp
69
70%description
71These are the GNU core utilities.  This package is the combination of
72the old GNU fileutils, sh-utils, and textutils packages.
73
74%description -l ja
75このパッケージには GNU のコアユーティリティが収録されています。
76コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
77sh-utils, textutils を統合したパッケージです。
78
79
80%prep
81%setup -q
82
83# From upstream
84
85# Fedora patches
86%patch100 -p1 -b .chgrp
87%patch101 -p1 -b .manpages
88%patch103 -p1 -b .sysinfo
89%patch104 -p1 -b .dfdirect
90
91# sh-utils
92#%patch703 -p1 -b .dateman
93#%patch706 -p1 -b .pam
94%patch713 -p1 -b .langinfo
95
96# li18nux/lsb
97%patch800 -p1 -b .i18n
98%patch801 -p1 -b .i18n-expand
99%patch803 -p1 -b .i18n-fix-expand
100%patch804 -p1 -b .i18n-cutold
101
102# Coreutils
103%patch908 -p1 -b .getgrouplist
104%patch912 -p1 -b .overflow
105
106# copy updated ja.po
107mv po/ja.po po/ja.po.orig
108cp -f %{SOURCE1000} po/ja.po
109
110%build
111export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
112%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
113touch aclocal.m4 configure config.hin Makefile.in */Makefile.in
114aclocal -I m4
115autoconf --force
116automake --copy --force --add-missing
117%configure --enable-largefile \
118           --enable-install-program=hostname,arch \
119           --with-tty-group \
120           DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
121
122touch man/*.x
123
124%__make all %{?_smp_mflags}
125
126%__make -C po update-gmo
127
128[[ -f ChangeLog && -f ChangeLog.bz2  ]] || bzip2 -9f ChangeLog
129
130# XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
131sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
132
133
134%install
135rm -rf $RPM_BUILD_ROOT
136%__make DESTDIR=$RPM_BUILD_ROOT install
137
138# man pages are not installed with make install
139%__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
140
141# fix japanese catalog file
142if [ -d $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES ]; then
143   mkdir -p $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
144   mv $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES/*mo \
145                $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
146   rm -rf $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC
147fi
148
149# let be compatible with old fileutils, sh-utils and textutils packages :
150mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
151for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
152         link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
153         stty sync touch true uname unlink
154do
155        mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
156done
157
158# chroot was in /usr/sbin :
159mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
160# {cat,sort,cut} were previously moved from bin to /usr/bin and linked into
161for i in env cut; do ln -sf ../../bin/$i $RPM_BUILD_ROOT/usr/bin; done
162
163mkdir -p $RPM_BUILD_ROOT/etc/profile.d
164install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
165install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.lightbgcolor
166install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
167install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
168install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
169
170# These come from util-linux and/or procps.
171for i in hostname uptime kill ; do
172        rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
173done
174
175bzip2 -f9 old/*/C* || :
176
177%find_lang %name
178
179# (sb) Deal with Installed (but unpackaged) file(s) found
180rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
181
182# FIXME: remove readlink which conflict with tetex's.
183#rm -f $RPM_BUILD_ROOT%{_bindir}/readlink
184#rm -f $RPM_BUILD_ROOT%{_mandir}/man1/readlink*
185
186
187%clean
188rm -rf $RPM_BUILD_ROOT
189
190%pre
191# Remove these old glibc files on upgrade (bug #84090).
192for file in $(find /usr/share/locale -type f -name LC_TIME); do
193        [ -x /bin/rm ] && /bin/rm -f "$file"
194done
195
196# We must desinstall theses info files since they're merged in
197# coreutils.info. else their postun'll be runned too last
198# and install-info'll faill badly because of doubles
199for file in sh-utils.info textutils.info fileutils.info; do
200        if [ -f /usr/share/info/$file.bz2 ]; then
201                /sbin/install-info /usr/share/info/$file.bz2 --dir=/usr/share/info/dir --remove &> /dev/null
202        fi
203done
204
205%preun
206if [ $1 = 0 ]; then
207    [ -f %{_infodir}/%{name}.info.gz ] && \
208      /sbin/install-info --delete %{_infodir}/%{name}.info.gz \
209        %{_infodir}/dir || :
210fi
211
212%post
213/bin/grep -v '(sh-utils)\|(fileutils)\|(textutils)' %{_infodir}/dir > \
214  %{_infodir}/dir.rpmmodify || exit 0
215    /bin/mv -f %{_infodir}/dir.rpmmodify %{_infodir}/dir
216[ -f %{_infodir}/%{name}.info.gz ] && \
217  /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
218
219%files -f %{name}.lang
220%defattr(-,root,root)
221%config(noreplace) %{_sysconfdir}/DIR_COLORS*
222%config(noreplace) %{_sysconfdir}/profile.d/*
223%doc COPYING ABOUT-NLS ChangeLog.bz2 NEWS README THANKS TODO old/*
224/bin/*
225%{_bindir}/*
226%{_libexecdir}/coreutils
227%{_infodir}/coreutils*
228%{_mandir}/man*/*
229%{_sbindir}/chroot
230
231%changelog
232* Fri May 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.25-1
233- update to 8.25
234- remove Patch1,102
235- import patches from fedora package
236  - update Patch104,800
237  - add Patch801,803,804
238
239* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.23-1
240- update to 8.23
241- add Patch1 (coreutils-8.23-chroot-chdir.patch) from fedora
242- update Patch100,104,800
243- remove Requires: util-linux (BTS:2854)
244
245* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.20-2
246- rebuild with VineSeed environment
247
248* Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.20-1
249- update to 8.20
250
251* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-2
252- update ja.po
253- add BR: libcap-devel, gmp-devel, libattr-devel, libacl-devel
254
255* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-1
256- update to 8.10
257
258* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
259- rebuilt against curent toolchain
260- spec in UTF-8
261
262* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
263- new upstream release
264- drop obsolete patches
265- import some patched from fedora-devel
266- add Obsoletes/Provides mktemp
267
268* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
269- new upstream release
270
271* Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
272- new upstream release
273
274* Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
275- new upstream release
276- drop opsolete patches
277- import some patches from FC
278
279* Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
280- now readlink is kept as it is, since tetex-3.0 don't have readlink.
281
282* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
283- updated ja.po
284
285* Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
286- remove selinux related pam-module from /etc/pam.d/su
287
288* Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
289- update ja.po
290
291* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
292- initial build for Vine Linux
293  - some modifications are merged from fileutils-4.1-10.1vl4
294- disable make check
295
296* Sat Feb  5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
297- Undo last change (bug #145266).
298
299* Fri Feb  4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
300- Special case for ia32e in uname (bug #145266).
301
302* Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
303- Fixed zh_CN translation (bug #144845).  Patch from Mitrophan Chin.
304
305* Tue Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
306- Fix to only setdefaultfilecon if not overridden by command line
307
308* Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
309- Change install to restorecon if it can
310
311* Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
312- Fixed small bug in i18n patch.
313
314* Mon Dec  6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
315- Don't set fs uid until after pam_open_session (bug #77791).
316
317* Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
318- Fixed colorls.csh (bug #139988).  Patch from Miloslav Trmac.
319
320* Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com>
321- Updated URL (bug #138279).
322
323* Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
324- Handle the return code of function calls in runcon.
325
326* Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
327- Prevent compiler warning in coreutils-i18n.patch (bug #136090).
328
329* Tue Oct  5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
330- getgrouplist() patch from Ulrich Drepper.
331- The selinux patch should be applied last.
332
333* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
334- Mv runuser to /sbin
335
336* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
337- Fix runuser man page.
338
339* Mon Oct  4 2004 Tim Waugh <twaugh@redhat.com>
340- Fixed build.
341
342* Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
343- Add runuser as similar to su, but only runable by root
344
345* Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
346- chown(1) patch from Ulrich Drepper.
347
348* Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
349- SELinux patch fix: don't display '(null)' if getfilecon() fails
350  (bug #131196).
351
352* Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
353- Fixed colorls.csh quoting (bug #102412).
354- Fixed another join LSB test failure (bug #121153).
355
356* Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
357- Fixed sort -t LSB test failure (bug #121154).
358- Fixed join LSB test failure (bug #121153).
359
360* Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
361- Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
362- SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
363
364* Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
365- Added 'konsole' TERM to DIR_COLORS (bug #129544).
366
367* Wed Aug  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
368- Added 'gnome' TERM to DIR_COLORS (bug #129112).
369- Worked around a bash bug #129128.
370- Fixed an i18n patch bug in cut (bug #129114).
371
372* Tue Aug  3 2004 Tim Waugh <twaugh@redhat.com>
373- Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
374  (bug #128948).
375
376* Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
377- Fixed field extraction in sort (bug #127694).
378
379* Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
380- Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
381
382* Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
383- Move pam-xauth to after pam-selinux
384
385* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
386- rebuilt
387
388* Mon Jun  7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
389- Fix ls -Z (bug #125447).
390
391* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
392- Build requires bison (bug #125290).
393
394* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
395- Fix selinux patch causing problems with ls --format=... (bug #125238).
396
397* Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
398- Change su to use pam_selinux open and pam_selinux close
399
400* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
401- Don't call access() on symlinks about to be removed (bug #124699).
402
403* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
404- Fix ja translation (bug #124862).
405
406* Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
407- rebuild
408
409* Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
410- Mention pam in the info for su (bug #122592).
411- Remove wheel group rant again (bug #122886).
412- Change default behaviour for chgrp/chown (bug #123263).  Patch from
413  upstream.
414
415* Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
416- compiling su PIE
417
418* Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
419- Build requires new versions of autoconf and automake (bug #123098).
420
421* Tue May  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
422- Fix join -t (bug #122435).
423
424* Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
425- Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
426
427* Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
428- Add ls -LZ fix
429- Fix chcon to handle "."
430
431* Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
432- Apply upstream fix for non-zero seconds for --date="10:00 +0100".
433
434* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
435- If preserve fails, report as warning unless user requires preserve
436
437* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
438- Make mv default to preserve on context
439
440* Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
441- 5.2.1.
442
443* Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
444- Add '-Z' to 'ls --help' output (bug #118108).
445
446* Fri Mar  5 2004 Tim Waugh <twaugh@redhat.com>
447- Fix deref-args test case for rebuilding under SELinux (bug #117556).
448
449* Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
450- kill(1) offloaded to util-linux altogether.
451
452* Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
453- Ship the real '[', not a symlink.
454
455* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
456- Apply Paul Eggert's chown patch (bug #116536).
457- Merged chdir patch into pam patch where it belongs.
458
459* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
460- Fixed i18n patch bug causing sort -M not to work (bug #116575).
461
462* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
463- Reinstate kill binary, just not its man page (bug #116463).
464
465* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
466- Updated ls-stat patch.
467
468* Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
469- fix chcon to ignore . and .. directories for recursing
470
471* Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
472- Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
473- 5.2.0.
474
475* Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
476- More AFS patch tidying.
477
478* Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
479- fix chcon to handle -h qualifier properly, eliminate potential crash
480
481* Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
482- Stop 'sort -g' leaking memory (i18n patch bug #115620).
483- Don't ship kill, since util-linux already does.
484- Tidy AFS patch.
485
486* Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
487- 5.1.3.
488- Patches ported forward or removed.
489
490* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
491- rebuilt
492
493* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
494- Change /etc/pam.d/su to remove preservuser and add multiple
495
496* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
497- Change is_selinux_enabled to is_selinux_enabled > 0
498
499* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
500- Add pam_selinux to pam file to allow switching of roles within selinux
501
502* Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
503- The textutils-2.0.17-mem.patch is no longer needed.
504
505* Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
506- Fixed autoconf test causing builds to fail.
507
508* Tue Dec  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
509- Fix copying to non xattr files
510
511* Thu Dec  4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
512- Fix column widths problems in ls.
513
514* Tue Dec  2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
515- Speed up md5sum by disabling speed-up asm.
516
517* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
518- Try again
519
520* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
521- Fix move on non SELinux kernels
522
523* Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
524- Fixed useless acl dependencies (bug #106141).
525
526* Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
527- Fix id -Z
528
529* Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
530- Turn on SELinux
531- Fix chcon error handling
532
533* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
534- Turn off SELinux
535
536* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
537- Turn on SELinux
538
539* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
540- Turn off SELinux
541
542* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
543- Turn on SELinux
544
545* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
546- allow compiling without pam support
547
548* Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
549- Make split(1) handle large files (bug #106700).
550
551* Thu Oct  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
552- Turn off SELinux
553
554* Wed Oct  8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
555- Cleanup SELinux patch
556
557* Fri Oct  3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
558- Restrict ACL support to only those programs needing it (bug #106141).
559- Fix default PATH for LSB (bug #102567).
560
561* Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
562- Turn off SELinux
563
564* Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
565- Turn on SELinux
566
567* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
568- Turn off SELinux
569
570* Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
571- Only call getfilecon if the user requested it.
572- build with selinux
573
574* Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
575- Documentation fix (bug #102697).
576
577* Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
578- Made su use pam again (oops).
579- Fixed another i18n bug causing sort --month-sort to fail.
580- Don't run dubious stty test, since it fails when backgrounded
581  (bug #102033).
582- Re-enable make check.
583
584* Fri Aug  8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
585- Don't run 'make check' for this build (build environment problem).
586- Another uninitialized variable in i18n (from bug #98683).
587
588* Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
589- Internationalize runcon
590- Update latest chcon from NSA
591
592* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
593- Re-enable make check.
594
595* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
596- Don't run 'make check' for this build (build environment problem).
597
598* Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
599- Actually use the ACL patch (bug #100519).
600
601* Fri Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
602- Convert to SELinux
603
604* Mon Jun  9 2003 Tim Waugh <twaugh@redhat.com>
605- Removed samefile patch.  Now the test suite passes.
606
607* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
608- rebuilt
609
610* Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
611- Both kon and kterm support colours (bug #83701).
612- Fix 'ls -l' alignment in zh_CN locale (bug #88346).
613
614* Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
615- Prevent file descriptor leakage in du (bug #90563).
616- Build requires recent texinfo (bug #90439).
617
618* Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
619- Allow obsolete options unless POSIXLY_CORRECT is set.
620
621* Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
622- Fold bug was introduced by i18n patch; fixed there instead.
623
624* Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
625- fix segfault in fold (#88683)
626
627* Sat Apr  5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
628- 5.0.
629
630* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
631- Use _smp_mflags.
632
633* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
634- Remove overwrite patch.
635- No longer seem to need nolibrt, errno patches.
636
637* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
638- No longer seem to need danglinglink, prompt, lug, touch_errno patches.
639
640* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
641- 4.5.11.
642- Use packaged readlink.
643
644* Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
645- 4.5.10.
646- Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
647- Drop fr_fix, LC_TIME, preserve, regex patches.
648
649* Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
650- Fixed another i18n patch bug (bug #82032).
651
652* Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
653- Fix sort(1) efficiency in multibyte encoding (bug #82032).
654
655* Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
656- Ship readlink(1) (bug #84200).
657
658* Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
659- Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
660
661* Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
662- Require glibc >= 2.2 (bug #84090).
663
664* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
665- fix group (#84095)
666
667* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
668- rebuilt
669
670* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
671- Fix rm(1) man page.
672
673* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
674- Fix re_compile_pattern check.
675- Fix su hang (bug #81653).
676
677* Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
678- Fix memory size calculation.
679
680* Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
681- Fix mv error message (bug #79809).
682
683* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
684- added PreReq on grep
685
686* Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
687- Fix cp --preserve with multiple arguments.
688
689* Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
690- Turn on colorls for screen (bug #78816).
691
692* Mon Dec  9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
693- Fix mv (bug #79283).
694- Add patch27 (nogetline).
695
696* Sun Dec  1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
697- use the su.pamd from sh-utils since it works properly with multilib systems
698
699* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
700- Fix test suite quoting problems.
701
702* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
703- Fix scriplets.
704- Fix i18n patch so it doesn't break uniq.
705- Fix several other patches to either make the test suite pass or
706  not run the relevant tests.
707- Run 'make check'.
708- Fix file list.
709
710* Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
711- Adapted for Red Hat Linux.
712- Self-host for help2man.
713- Don't ship readlink just yet (maybe later).
714- Merge patches from fileutils and sh-utils (textutils ones are already
715  merged it seems).
716- Keep the binaries where the used to be (in particular, id and stat).
717
718* Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
719- LI18NUX/LSB compliance (patch800)
720- Installed (but unpackaged) file(s) - /usr/share/info/dir
721
722* Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
723- new release
724- rediff patch 180
725- merge patch 150 into 180
726
727* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
728- move su back to /bin
729
730* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
731- patch 0 : lg locale is illegal and must be renamed lug (pablo)
732
733* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
734- fix conflict with procps
735
736* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
737- patch 105 : fix install -s
738
739* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
740- fix build
741- don't chmode two times su
742- build with large file support
743- fix description
744- various spec cleanups
745- fix chroot installation
746- fix missing /bin/env
747- add old fileutils, sh-utils & textutils ChangeLogs
748
749* Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
750- initial release (merge fileutils, sh-utils & textutils)
751- obsoletes/provides: sh-utils/fileutils/textutils
752- fileutils stuff go in 1xx range
753- sh-utils stuff go in 7xx range
754- textutils stuff go in 5xx range
755- drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
756  most of them)
757- rediff patches 103, 105, 111, 113, 180, 706
758- temporary disable patch 3 & 4
759- fix fileutils url
Note: See TracBrowser for help on using the repository browser.