source: projects/specs/trunk/c/coreutils/coreutils-vl.spec @ 9319

Revision 9319, 23.9 KB checked in by Takemikaduchi, 9 years ago (diff)

update to 8.23 & fix BTS:2854

Line 
1Summary: The GNU core utilities: a set of tools commonly used in shell scripts
2Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
3Name:    coreutils
4Version: 8.23
5Release: 1%{?_dist_release}
6License: GPL
7Group:   System Environment/Base
8Url:     http://www.gnu.org/software/coreutils/
9
10Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
11Source101:  coreutils-DIR_COLORS
12Source102:  coreutils-DIR_COLORS.lightbgcolor
13Source103:  coreutils-DIR_COLORS.256color
14Source105:  coreutils-colorls.sh
15Source106:  coreutils-colorls.csh
16
17# Vine sources
18Source1000: coreutils-8.10-ja.po
19
20# From upstream
21Patch1: coreutils-8.23-chroot-chdir.patch
22
23# Fedora patches
24#general patch to workaround koji build system issues
25Patch100: coreutils-6.10-configuration.patch
26#add note about no difference between binary/text mode on Linux - md5sum manpage
27Patch101: coreutils-6.10-manpages.patch
28#temporarily workaround probable kernel issue with TCSADRAIN(#504798)
29Patch102: coreutils-7.4-sttytcsadrain.patch
30#do display processor type for uname -p/-i based on uname(2) syscall
31Patch103: coreutils-8.2-uname-processortype.patch
32#df --direct
33Patch104: coreutils-df-direct.patch
34
35# sh-utils
36Patch713: coreutils-4.5.3-langinfo.patch
37
38# (sb) lin18nux/lsb compliance
39Patch800: coreutils-i18n.patch
40
41#getgrouplist() patch from Ulrich Drepper.
42Patch908: coreutils-getgrouplist.patch
43#Prevent buffer overflow in who(1) (bug #158405).
44Patch912: coreutils-overflow.patch
45
46BuildRoot: %{_tmppath}/%{name}-%{version}-root
47BuildRequires:  gettext libtermcap-devel bison
48BuildRequires: texinfo >= 4.3
49BuildRequires: autoconf >= 2.58, automake >= 1.11.2
50BuildRequires: libcap-devel
51BuildRequires: libattr-devel
52BuildRequires: libacl-devel
53BuildRequires: gmp-devel
54
55Requires(pre):         install-info
56Requires(preun):      install-info
57Requires(post):        install-info, grep, findutils
58
59# Require a C library that doesn't put LC_TIME files in our way.
60Conflicts: glibc < 2.2
61
62Provides:       fileutils = %version, sh-utils = %version, stat, textutils = %version
63Obsoletes:      fileutils sh-utils stat textutils
64Provides:       mktemp = %version
65Obsoletes:      mktemp
66
67%description
68These are the GNU core utilities.  This package is the combination of
69the old GNU fileutils, sh-utils, and textutils packages.
70
71%description -l ja
72このパッケージには GNU のコアユーティリティが収録されています。
73コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
74sh-utils, textutils を統合したパッケージです。
75
76
77%prep
78%setup -q
79
80# From upstream
81%patch1 -p1 -b .chdir
82
83# Fedora patches
84%patch100 -p1 -b .chgrp
85%patch101 -p1 -b .manpages
86%patch102 -p1 -b .tcsadrain
87%patch103 -p1 -b .sysinfo
88%patch104 -p1 -b .dfdirect
89
90# sh-utils
91#%patch703 -p1 -b .dateman
92#%patch706 -p1 -b .pam
93%patch713 -p1 -b .langinfo
94
95# li18nux/lsb
96%patch800 -p1 -b .i18n
97
98# Coreutils
99%patch908 -p1 -b .getgrouplist
100%patch912 -p1 -b .overflow
101
102# copy updated ja.po
103mv po/ja.po po/ja.po.orig
104cp -f %{SOURCE1000} po/ja.po
105
106%build
107export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
108%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
109touch aclocal.m4 configure config.hin Makefile.in */Makefile.in
110aclocal -I m4
111autoconf --force
112automake --copy --force --add-missing
113%configure --enable-largefile \
114           --enable-install-program=hostname,arch \
115           --with-tty-group \
116           DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
117
118touch man/*.x
119
120%__make all %{?_smp_mflags}
121
122%__make -C po update-gmo
123
124[[ -f ChangeLog && -f ChangeLog.bz2  ]] || bzip2 -9f ChangeLog
125
126# XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
127sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
128
129
130%install
131rm -rf $RPM_BUILD_ROOT
132%__make DESTDIR=$RPM_BUILD_ROOT install
133
134# man pages are not installed with make install
135%__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
136
137# fix japanese catalog file
138if [ -d $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES ]; then
139   mkdir -p $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
140   mv $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES/*mo \
141                $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
142   rm -rf $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC
143fi
144
145# let be compatible with old fileutils, sh-utils and textutils packages :
146mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
147for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
148         link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
149         stty sync touch true uname unlink
150do
151        mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
152done
153
154# chroot was in /usr/sbin :
155mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
156# {cat,sort,cut} were previously moved from bin to /usr/bin and linked into
157for i in env cut; do ln -sf ../../bin/$i $RPM_BUILD_ROOT/usr/bin; done
158
159mkdir -p $RPM_BUILD_ROOT/etc/profile.d
160install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
161install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.lightbgcolor
162install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
163install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
164install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
165
166# These come from util-linux and/or procps.
167for i in hostname uptime kill ; do
168        rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
169done
170
171bzip2 -f9 old/*/C* || :
172
173%find_lang %name
174
175# (sb) Deal with Installed (but unpackaged) file(s) found
176rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
177
178# FIXME: remove readlink which conflict with tetex's.
179#rm -f $RPM_BUILD_ROOT%{_bindir}/readlink
180#rm -f $RPM_BUILD_ROOT%{_mandir}/man1/readlink*
181
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186%pre
187# Remove these old glibc files on upgrade (bug #84090).
188for file in $(find /usr/share/locale -type f -name LC_TIME); do
189        [ -x /bin/rm ] && /bin/rm -f "$file"
190done
191
192# We must desinstall theses info files since they're merged in
193# coreutils.info. else their postun'll be runned too last
194# and install-info'll faill badly because of doubles
195for file in sh-utils.info textutils.info fileutils.info; do
196        if [ -f /usr/share/info/$file.bz2 ]; then
197                /sbin/install-info /usr/share/info/$file.bz2 --dir=/usr/share/info/dir --remove &> /dev/null
198        fi
199done
200
201%preun
202if [ $1 = 0 ]; then
203    [ -f %{_infodir}/%{name}.info.gz ] && \
204      /sbin/install-info --delete %{_infodir}/%{name}.info.gz \
205        %{_infodir}/dir || :
206fi
207
208%post
209/bin/grep -v '(sh-utils)\|(fileutils)\|(textutils)' %{_infodir}/dir > \
210  %{_infodir}/dir.rpmmodify || exit 0
211    /bin/mv -f %{_infodir}/dir.rpmmodify %{_infodir}/dir
212[ -f %{_infodir}/%{name}.info.gz ] && \
213  /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
214
215%files -f %{name}.lang
216%defattr(-,root,root)
217%config(noreplace) %{_sysconfdir}/DIR_COLORS*
218%config(noreplace) %{_sysconfdir}/profile.d/*
219%doc COPYING ABOUT-NLS ChangeLog.bz2 NEWS README THANKS TODO old/*
220/bin/*
221%{_bindir}/*
222%{_libexecdir}/coreutils
223%{_infodir}/coreutils*
224%{_mandir}/man*/*
225%{_sbindir}/chroot
226
227%changelog
228* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.23-1
229- update to 8.23
230- add Patch1 (coreutils-8.23-chroot-chdir.patch) from fedora
231- update Patch100,104,800
232- remove Requires: util-linux (BTS:2854)
233
234* Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.20-2
235- rebuild with VineSeed environment
236
237* Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.20-1
238- update to 8.20
239
240* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-2
241- update ja.po
242- add BR: libcap-devel, gmp-devel, libattr-devel, libacl-devel
243
244* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-1
245- update to 8.10
246
247* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
248- rebuilt against curent toolchain
249- spec in UTF-8
250
251* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
252- new upstream release
253- drop obsolete patches
254- import some patched from fedora-devel
255- add Obsoletes/Provides mktemp
256
257* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
258- new upstream release
259
260* Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
261- new upstream release
262
263* Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
264- new upstream release
265- drop opsolete patches
266- import some patches from FC
267
268* Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
269- now readlink is kept as it is, since tetex-3.0 don't have readlink.
270
271* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
272- updated ja.po
273
274* Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
275- remove selinux related pam-module from /etc/pam.d/su
276
277* Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
278- update ja.po
279
280* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
281- initial build for Vine Linux
282  - some modifications are merged from fileutils-4.1-10.1vl4
283- disable make check
284
285* Sat Feb  5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
286- Undo last change (bug #145266).
287
288* Fri Feb  4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
289- Special case for ia32e in uname (bug #145266).
290
291* Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
292- Fixed zh_CN translation (bug #144845).  Patch from Mitrophan Chin.
293
294* Tue Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
295- Fix to only setdefaultfilecon if not overridden by command line
296
297* Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
298- Change install to restorecon if it can
299
300* Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
301- Fixed small bug in i18n patch.
302
303* Mon Dec  6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
304- Don't set fs uid until after pam_open_session (bug #77791).
305
306* Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
307- Fixed colorls.csh (bug #139988).  Patch from Miloslav Trmac.
308
309* Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com>
310- Updated URL (bug #138279).
311
312* Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
313- Handle the return code of function calls in runcon.
314
315* Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
316- Prevent compiler warning in coreutils-i18n.patch (bug #136090).
317
318* Tue Oct  5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
319- getgrouplist() patch from Ulrich Drepper.
320- The selinux patch should be applied last.
321
322* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
323- Mv runuser to /sbin
324
325* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
326- Fix runuser man page.
327
328* Mon Oct  4 2004 Tim Waugh <twaugh@redhat.com>
329- Fixed build.
330
331* Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
332- Add runuser as similar to su, but only runable by root
333
334* Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
335- chown(1) patch from Ulrich Drepper.
336
337* Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
338- SELinux patch fix: don't display '(null)' if getfilecon() fails
339  (bug #131196).
340
341* Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
342- Fixed colorls.csh quoting (bug #102412).
343- Fixed another join LSB test failure (bug #121153).
344
345* Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
346- Fixed sort -t LSB test failure (bug #121154).
347- Fixed join LSB test failure (bug #121153).
348
349* Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
350- Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
351- SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
352
353* Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
354- Added 'konsole' TERM to DIR_COLORS (bug #129544).
355
356* Wed Aug  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
357- Added 'gnome' TERM to DIR_COLORS (bug #129112).
358- Worked around a bash bug #129128.
359- Fixed an i18n patch bug in cut (bug #129114).
360
361* Tue Aug  3 2004 Tim Waugh <twaugh@redhat.com>
362- Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
363  (bug #128948).
364
365* Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
366- Fixed field extraction in sort (bug #127694).
367
368* Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
369- Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
370
371* Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
372- Move pam-xauth to after pam-selinux
373
374* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
375- rebuilt
376
377* Mon Jun  7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
378- Fix ls -Z (bug #125447).
379
380* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
381- Build requires bison (bug #125290).
382
383* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
384- Fix selinux patch causing problems with ls --format=... (bug #125238).
385
386* Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
387- Change su to use pam_selinux open and pam_selinux close
388
389* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
390- Don't call access() on symlinks about to be removed (bug #124699).
391
392* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
393- Fix ja translation (bug #124862).
394
395* Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
396- rebuild
397
398* Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
399- Mention pam in the info for su (bug #122592).
400- Remove wheel group rant again (bug #122886).
401- Change default behaviour for chgrp/chown (bug #123263).  Patch from
402  upstream.
403
404* Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
405- compiling su PIE
406
407* Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
408- Build requires new versions of autoconf and automake (bug #123098).
409
410* Tue May  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
411- Fix join -t (bug #122435).
412
413* Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
414- Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
415
416* Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
417- Add ls -LZ fix
418- Fix chcon to handle "."
419
420* Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
421- Apply upstream fix for non-zero seconds for --date="10:00 +0100".
422
423* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
424- If preserve fails, report as warning unless user requires preserve
425
426* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
427- Make mv default to preserve on context
428
429* Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
430- 5.2.1.
431
432* Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
433- Add '-Z' to 'ls --help' output (bug #118108).
434
435* Fri Mar  5 2004 Tim Waugh <twaugh@redhat.com>
436- Fix deref-args test case for rebuilding under SELinux (bug #117556).
437
438* Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
439- kill(1) offloaded to util-linux altogether.
440
441* Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
442- Ship the real '[', not a symlink.
443
444* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
445- Apply Paul Eggert's chown patch (bug #116536).
446- Merged chdir patch into pam patch where it belongs.
447
448* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
449- Fixed i18n patch bug causing sort -M not to work (bug #116575).
450
451* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
452- Reinstate kill binary, just not its man page (bug #116463).
453
454* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
455- Updated ls-stat patch.
456
457* Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
458- fix chcon to ignore . and .. directories for recursing
459
460* Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
461- Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
462- 5.2.0.
463
464* Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
465- More AFS patch tidying.
466
467* Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
468- fix chcon to handle -h qualifier properly, eliminate potential crash
469
470* Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
471- Stop 'sort -g' leaking memory (i18n patch bug #115620).
472- Don't ship kill, since util-linux already does.
473- Tidy AFS patch.
474
475* Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
476- 5.1.3.
477- Patches ported forward or removed.
478
479* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
480- rebuilt
481
482* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
483- Change /etc/pam.d/su to remove preservuser and add multiple
484
485* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
486- Change is_selinux_enabled to is_selinux_enabled > 0
487
488* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
489- Add pam_selinux to pam file to allow switching of roles within selinux
490
491* Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
492- The textutils-2.0.17-mem.patch is no longer needed.
493
494* Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
495- Fixed autoconf test causing builds to fail.
496
497* Tue Dec  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
498- Fix copying to non xattr files
499
500* Thu Dec  4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
501- Fix column widths problems in ls.
502
503* Tue Dec  2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
504- Speed up md5sum by disabling speed-up asm.
505
506* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
507- Try again
508
509* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
510- Fix move on non SELinux kernels
511
512* Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
513- Fixed useless acl dependencies (bug #106141).
514
515* Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
516- Fix id -Z
517
518* Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
519- Turn on SELinux
520- Fix chcon error handling
521
522* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
523- Turn off SELinux
524
525* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
526- Turn on SELinux
527
528* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
529- Turn off SELinux
530
531* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
532- Turn on SELinux
533
534* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
535- allow compiling without pam support
536
537* Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
538- Make split(1) handle large files (bug #106700).
539
540* Thu Oct  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
541- Turn off SELinux
542
543* Wed Oct  8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
544- Cleanup SELinux patch
545
546* Fri Oct  3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
547- Restrict ACL support to only those programs needing it (bug #106141).
548- Fix default PATH for LSB (bug #102567).
549
550* Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
551- Turn off SELinux
552
553* Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
554- Turn on SELinux
555
556* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
557- Turn off SELinux
558
559* Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
560- Only call getfilecon if the user requested it.
561- build with selinux
562
563* Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
564- Documentation fix (bug #102697).
565
566* Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
567- Made su use pam again (oops).
568- Fixed another i18n bug causing sort --month-sort to fail.
569- Don't run dubious stty test, since it fails when backgrounded
570  (bug #102033).
571- Re-enable make check.
572
573* Fri Aug  8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
574- Don't run 'make check' for this build (build environment problem).
575- Another uninitialized variable in i18n (from bug #98683).
576
577* Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
578- Internationalize runcon
579- Update latest chcon from NSA
580
581* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
582- Re-enable make check.
583
584* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
585- Don't run 'make check' for this build (build environment problem).
586
587* Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
588- Actually use the ACL patch (bug #100519).
589
590* Fri Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
591- Convert to SELinux
592
593* Mon Jun  9 2003 Tim Waugh <twaugh@redhat.com>
594- Removed samefile patch.  Now the test suite passes.
595
596* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
597- rebuilt
598
599* Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
600- Both kon and kterm support colours (bug #83701).
601- Fix 'ls -l' alignment in zh_CN locale (bug #88346).
602
603* Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
604- Prevent file descriptor leakage in du (bug #90563).
605- Build requires recent texinfo (bug #90439).
606
607* Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
608- Allow obsolete options unless POSIXLY_CORRECT is set.
609
610* Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
611- Fold bug was introduced by i18n patch; fixed there instead.
612
613* Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
614- fix segfault in fold (#88683)
615
616* Sat Apr  5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
617- 5.0.
618
619* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
620- Use _smp_mflags.
621
622* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
623- Remove overwrite patch.
624- No longer seem to need nolibrt, errno patches.
625
626* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
627- No longer seem to need danglinglink, prompt, lug, touch_errno patches.
628
629* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
630- 4.5.11.
631- Use packaged readlink.
632
633* Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
634- 4.5.10.
635- Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
636- Drop fr_fix, LC_TIME, preserve, regex patches.
637
638* Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
639- Fixed another i18n patch bug (bug #82032).
640
641* Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
642- Fix sort(1) efficiency in multibyte encoding (bug #82032).
643
644* Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
645- Ship readlink(1) (bug #84200).
646
647* Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
648- Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
649
650* Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
651- Require glibc >= 2.2 (bug #84090).
652
653* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
654- fix group (#84095)
655
656* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
657- rebuilt
658
659* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
660- Fix rm(1) man page.
661
662* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
663- Fix re_compile_pattern check.
664- Fix su hang (bug #81653).
665
666* Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
667- Fix memory size calculation.
668
669* Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
670- Fix mv error message (bug #79809).
671
672* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
673- added PreReq on grep
674
675* Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
676- Fix cp --preserve with multiple arguments.
677
678* Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
679- Turn on colorls for screen (bug #78816).
680
681* Mon Dec  9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
682- Fix mv (bug #79283).
683- Add patch27 (nogetline).
684
685* Sun Dec  1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
686- use the su.pamd from sh-utils since it works properly with multilib systems
687
688* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
689- Fix test suite quoting problems.
690
691* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
692- Fix scriplets.
693- Fix i18n patch so it doesn't break uniq.
694- Fix several other patches to either make the test suite pass or
695  not run the relevant tests.
696- Run 'make check'.
697- Fix file list.
698
699* Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
700- Adapted for Red Hat Linux.
701- Self-host for help2man.
702- Don't ship readlink just yet (maybe later).
703- Merge patches from fileutils and sh-utils (textutils ones are already
704  merged it seems).
705- Keep the binaries where the used to be (in particular, id and stat).
706
707* Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
708- LI18NUX/LSB compliance (patch800)
709- Installed (but unpackaged) file(s) - /usr/share/info/dir
710
711* Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
712- new release
713- rediff patch 180
714- merge patch 150 into 180
715
716* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
717- move su back to /bin
718
719* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
720- patch 0 : lg locale is illegal and must be renamed lug (pablo)
721
722* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
723- fix conflict with procps
724
725* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
726- patch 105 : fix install -s
727
728* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
729- fix build
730- don't chmode two times su
731- build with large file support
732- fix description
733- various spec cleanups
734- fix chroot installation
735- fix missing /bin/env
736- add old fileutils, sh-utils & textutils ChangeLogs
737
738* Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
739- initial release (merge fileutils, sh-utils & textutils)
740- obsoletes/provides: sh-utils/fileutils/textutils
741- fileutils stuff go in 1xx range
742- sh-utils stuff go in 7xx range
743- textutils stuff go in 5xx range
744- drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
745  most of them)
746- rediff patches 103, 105, 111, 113, 180, 706
747- temporary disable patch 3 & 4
748- fix fileutils url
Note: See TracBrowser for help on using the repository browser.