source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 9125

Revision 9125, 32.8 KB checked in by Takemikaduchi, 9 years ago (diff)

add Patch1000

Line 
1%define pango_version 1.36.3
2%define gtk3_version 3.14.0
3%define gnome_desktop3_version 3.14.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 2.32.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.8
16%define mm_version 0.7.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.14.2
22Release: 2%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.14/gnome-control-center-%{version}.tar.xz
28
29Patch1: control-center-3.8.1-gpermission.patch
30# patch for Vine
31Patch1000: control-center-3.14.2-datetime-vine.patch
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: inagaki, daisuke, Takemikaduchi
36
37BuildRoot: %{_tmppath}/%{name}-%{version}-root
38
39Obsoletes: gnome, control-center-devel < 2.0
40Obsoletes: fontilus, themus
41
42Provides: gnome-volume-manager < 2.25
43Obsoletes: gnome-volume-manager < 2.25
44
45Requires: usermode >= %{usermode_version}
46Requires: gnome-settings-daemon
47Requires: gnome-icon-theme
48Requires: gnome-desktop3 >= %{gnome_desktop_version}
49Requires: dbus-x11
50Requires: apg
51Requires(post,postun): desktop-file-utils shared-mime-info gtk3
52
53BuildRequires: gnome-common
54BuildRequires: pango-devel >= %{pango_version}
55BuildRequires: gtk3-devel >= %{gtk3_version}
56BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
57BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
58BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
59BuildRequires: startup-notification-devel >= %{startup_notification_version}
60BuildRequires: libxklavier-devel >= %{libxklavier_version}
61BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
62BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
63BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
64BuildRequires: gnome-settings-daemon-devel
65BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
66BuildRequires: nautilus-devel
67BuildRequires: alsa-lib-devel
68BuildRequires: autoconf
69BuildRequires: gettext-devel
70BuildRequires: librsvg2-devel
71BuildRequires: libXScrnSaver-devel
72BuildRequires: libXxf86misc-devel
73BuildRequires: libSM-devel
74BuildRequires: unique3-devel
75BuildRequires: polkit-devel
76BuildRequires: libgtop2-devel
77BuildRequires: upower-devel
78BuildRequires: pulseaudio-libs-devel
79BuildRequires: cups-devel
80BuildRequires: cheese-devel
81BuildRequires: grilo-devel
82BuildRequires: gstreamer-plugins-base-devel
83BuildRequires: gnome-online-accounts-devel
84BuildRequires: colord-devel
85BuildRequires: colord-gtk-devel
86BuildRequires: libnm-gtk-devel >= %{nm_version}
87BuildRequires: NetworkManager-glib-devel >= %{nm_version}
88BuildRequires: ModemManager-glib-devel >= %{mm_version}
89BuildRequires: libnotify-devel >= %{libnotify_version}
90BuildRequires: libwacom-devel
91BuildRequires: libpwquality-devel
92BuildRequires: ibus-devel
93BuildRequires: accountsservice-devel
94BuildRequires: gnome-online-accounts-devel
95BuildRequires: libsmbclient-devel
96
97%description
98GNOME (the GNU Network Object Model Environment) is an attractive and
99easy-to-use GUI desktop environment. The control-center package
100provides the GNOME Control Center utilities that allow you to setup
101and configure your system's GNOME environment (things like the desktop
102background and theme, the screensaver, the window manager, system
103sounds, and mouse behavior).
104
105If you install GNOME, you need to install control-center.
106
107%description -l ja
108GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
109GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
110環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
111す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
112ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
113
114%package devel
115Summary: Development files for GNOME Control Center
116Summary(ja): GNOME コントロールセンターの開発用ファイル
117Group: Development/Libraries
118Requires: %{name} = %{version}-%{release}
119
120%description devel
121Development tool for GNOME Control Center
122
123%descriotion -l ja devel
124GNOME コントロールセンターの開発用ファイルが含まれています。
125
126%prep
127%setup -q -n gnome-control-center-%{version}
128%patch1 -p1
129%patch1000 -p1 -b .vine
130
131%build
132autoreconf -if
133%configure --disable-static  \
134    --disable-update-mimedb \
135    --enable-ibus
136    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
137
138# drop unneeded direct library deps with --as-needed
139# libtool doesn't make this easy, so we do it the hard way
140sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
141
142make %{?_smp_mflags}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147make install DESTDIR=$RPM_BUILD_ROOT
148
149desktop-file-install --delete-original                  \
150  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
151  --add-only-show-in GNOME                              \
152  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
153
154# we do want this
155mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
156
157# We don't want these
158rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
159rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
160
161# remove useless libtool archive files
162find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
163
164# don't package mime caches
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
170rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
171rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
172rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
173
174rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
175rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
176
177%find_lang gnome-control-center-2.0
178%find_lang gnome-control-center-2.0-timezones
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183%post
184/sbin/ldconfig
185
186update-desktop-database %{_datadir}/applications >& /dev/null ||:
187update-mime-database %{_datadir}/mime > /dev/null
188touch --no-create %{_datadir}/icons/hicolor
189if [ -x /usr/bin/gtk-update-icon-cache ]; then
190  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
191fi
192
193%postun
194/sbin/ldconfig
195update-desktop-database %{_datadir}/applications >& /dev/null ||:
196update-mime-database %{_datadir}/mime > /dev/null
197touch --no-create %{_datadir}/icons/hicolor
198if [ -x /usr/bin/gtk-update-icon-cache ]; then
199  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
200fi
201
202%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
203%defattr(-, root, root)
204%doc AUTHORS COPYING ChangeLog NEWS README
205%{_bindir}/gnome-control-center
206%{_libexecdir}/cc-remote-login-helper
207%{_libexecdir}/gnome-control-center-search-provider
208%dir %{_datadir}/gnome/wm-properties
209%dir %{_datadir}/gnome-control-center
210%{_datadir}/applications/*
211%{_datadir}/bash-completion/completions/gnome-control-center
212%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
213%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
214%{_datadir}/gnome-control-center/datetime
215%{_datadir}/gnome-control-center/icons
216%{_datadir}/gnome-control-center/keybindings
217%{_datadir}/gnome-control-center/pixmaps
218%{_datadir}/gnome-control-center/sounds
219%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
220%{_datadir}/icons/*
221%{_datadir}/pixmaps/*
222%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
223%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
224%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
225%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
226%{_datadir}/sounds/*
227%{_mandir}/man1/gnome-control-center.1.gz
228
229%files devel
230%defattr(-, root, root)
231%{_datadir}/pkgconfig/*
232
233
234%changelog
235* Sun Nov 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-2
236- add Patch1000 (control-center-3.14.2-datetime-vine.patch)
237
238* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
239- new upstream release
240
241* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
242- new upstream release
243
244* Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-3
245- rebuild with upower-0.99.1
246
247* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-2
248- rebuild with libgtop2-2.30.0
249
250* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
251- new upstream release
252
253* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
254- new upstream release
255- add BuildRequires: grilo-devel
256
257* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
258- new upstream release
259- remove Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
260
261* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
262- new upstream release
263- add BuildRequires: NetworkManager-glib-devel, ModemManager-glib-devel, libsmbclient-devel
264- add Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
265
266* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
267- new upstream release
268
269* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
270- new upstream release
271
272* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
273- new upstream release
274- remove Patch0 (control-center-3.8.1-git20130424.patch)
275
276* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
277- add Patch1 (control-center-3.8.1-gpermission.patch)
278
279* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
280- new upstream release
281- remove BuildRequires: gnome-panel-devel, metacity-devel
282- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
283- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
284- add Patch0 (control-center-3.8.1-git20130424.patch)
285
286* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
287- new upstream release
288
289* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
290- new upstream release
291
292* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
293- new upstream release
294
295* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
296- new upstream release
297- add BuildRequires: libpwquality-devel
298
299* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
300- new upstream release
301
302* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
303- new upstream release
304- remove BuildRequires: GConf2-devel, libbonobo-devel
305- add BuildRequires: libwacom-devel
306
307* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
308- new upstream release
309
310* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
311- new upstream release
312
313* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
314- rebuild with NetworkManager-0.9
315- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
316
317* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
318- new upstream release
319
320* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
321- new upstream release
322
323* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
324- new upstream release
325- remove Patch0
326
327* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
328- new upstream release
329- add BuildRequires: libnotify-devel
330- add Patch0 (control-center-3.1.5-crash-layout.patch)
331
332* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
333- new upstream release
334- change BuildRequires: gtk3-devel instead of gtk2-devel
335- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
336- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
337- change BuildRequires: unique3-devel instead of unique-devel
338- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
339                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
340                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
341- add Requires: apg
342- drop all Patches
343- add Provides: and Obsoletes: gnome-volume-manager
344
345* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
346- update desktop-effect-integration patch
347  - fix freeze on changing metacity to compiz
348  - run compiz directly instead of compiz-gtk
349  - drop use of jockey-gtk
350- update ja.po
351
352* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
353- new upstream release
354
355* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
356- update translation.
357
358* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
359- update translation.
360
361* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
362- update Source21(gnome-control-center-2.32.0-vine.ja.po)
363
364* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
365- new upstream release
366- drop Patch22, Patch30, Patch52
367- fix %files
368
369* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
370- rebuilt with rpm-4.8.1 for pkg-config (too)
371
372* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
373- rebuild with rpm-4.8.1 for pkg-config file
374- add Requires: %{name}=%{version}-%{release}
375
376* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
377- rebuild with evolution-data-server-2.30.2
378
379* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
380- new upstream release
381
382* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
383- new upstream release
384- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
385- add BuildRequires: gnome-common, unique-devel
386
387* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
388- enable Patch101,110-112 and 500
389
390* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
391- new upstream release
392- disabled Patch101, 110-112 and 500
393
394* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
395- update notification-theme.patch
396  - use vine theme if NotificationTheme is not set in meta-theme.
397
398* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
399- add Patch510: use Sans for font-properties sample font.
400- add BR: librsvg2-devel, libXScrnSaver-devel
401- remove BR: esound
402
403* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
404- add Patch37: Don't rely on _BACKUP property for xkb initialization
405
406* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
407- renumber patch10 to patch1010
408  - do not check gdm fprint plugin
409- add Patch101: show aspect in drop down menu
410- add Patch110: modify gnome-mouse-properties to fit smaller screen
411- add Patch111: modify gnome-about-me to fit smaller screen
412- add Patch112: modify gnome-display-properties to fit smaller screen
413
414* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
415- update Patch100 to use compiz-gtk instead of compiz
416
417* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
418- update ja.po
419
420* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
421- import upstream patchs (10,22,3[0-6])
422
423* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
424- add nautilus-devel to BR: not Requires:
425
426* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
427- new upstream release
428- update ja.po
429- add BR: nautilus-devel
430
431* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
432- drop Patch20 which need new XInput API
433- update Patch23
434
435* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
436- add Patch20,22.23 from ubuntu
437  - patch20 to add touchpad configuration
438  - patch22 to add aspect setting in randr capplet
439  - patch23 to integrate desktop setting into appearance-properties
440
441* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
442- new upstream release
443
444* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
445- new upstream release
446
447* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
448- add gnome-typing-monitor to %%files
449
450* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
451- add Patch100 for new RandR capplet. (fc)
452
453* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
454- new upstream release
455- dropped Patch8 (merged into upstream)
456
457* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
458- new upstream release
459- added Patch7 and Patch8 from Fedora
460  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
461  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
462  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
463  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
464  - Remove a nonfunctional button from the a11y preferences
465- added BuildRequires: gnome-settings-daemon, gnome-panel
466- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
467- removed Requires: xscreensaver
468
469* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
470- new upstream release based on Fedora
471- added BuildRequires: gnome-settings-daemon
472
473* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
474- new upstream release based on Fedora
475  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
476  - Fix the orca command in the default applications capplet (#351471)
477
478* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
479- add BuildReq: libgnomekbd-devel
480
481* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
482- rebuilt with evolution-data-server-devel-1.10.1
483
484* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
485- add BuildReq: evolution-data-server-devel
486
487* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
488- new upstream release
489- remove unneeded? patch10
490
491* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
492- added Patch10 to supress /dev/pmu warning messages on some ppc models
493
494* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
495- new upstream release
496
497* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
498- new upstream release
499
500* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
501- run gtk-update-icon-cache in %%post script.
502
503* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
504- new upstream release
505- drop Patch10,it is merged in upstream
506
507* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
508- add Patch10 for correct textdomain name in
509  default-applications-properties(Bug332833)
510- add Patch100 for change default-applications settings for vine
511
512* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
513- new upstream release
514
515* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
516- new upstream release
517
518* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
519- new upstream release
520
521* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
522- new upstream release
523- enable alsa support
524
525* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
526- new upstream release
527
528* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
529- fixed type in %%post script
530
531* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
532- clear the old defaults of xkb
533
534* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
535- remove bonobo-activation dependency
536
537* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
538- new upstream version
539
540* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
541- new upstream release
542- add Japanese summay to devel package
543
544* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
545- new upstream release
546
547* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
548- modify patch11 to use NeoVine theme instead of BeCool.
549
550* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
551- rebuild with new toolchain
552
553* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
554- new upstream release
555- remove obsolete ja.po
556
557* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
558- change required version of metacity to 2.4.34 on alpha
559
560* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
561- new upstream release
562
563* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
564- new upstream release
565
566* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
567- add more missing files and schemas...
568
569* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
570- add missing file in %{_libdir}/gnome-vfs-2.0/
571
572* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
573- new upstream release
574- this is experimental version
575- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
576
577* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
578- new upstream release
579
580* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
581- import patch6 (upstream paches) from rawhide package.
582
583* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
584- import patch1-5 (upstream paches) from rawhide package.
585
586* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
587- new upstream release
588
589* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
590- rebuild
591
592* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
593- new upstream release
594
595* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
596- new upstream release
597
598* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
599- new upstream release
600
601* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
602- change default gtk1 theme from Raleigh to BeCool.
603
604* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
605- add BuildRequires/Requires.
606- fixed kanjicode of specfile
607
608* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
609- remove bogus message in %%post scripts.
610
611* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
612- add patch10 to modify some desktop files
613- update ja.po
614
615* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
616- update ja.po
617
618* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
619- update ja.po
620
621* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
622- new upstream release
623
624* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
625- add devel package
626- add window-manager-settings files.
627
628* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
629- modify dependancies.
630
631* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
632- build for Vine Linux
633- new upstream release from gnome-2.1.4
634
635* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
636- Allow setting custom mime handlers
637
638* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
639- make desktop file symlinks absolute #71991
640- add po files from cvs.gnome.org
641
642* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
643- Fix up keyboard handling
644
645* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
646- Fixes for #68735
647
648* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
649- New version.  Fix up metacity theme locations
650
651* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
652- Switch the gtk1 theme along with the gtk2 theme
653- Add the ability to switch the window manager theme through the theme capplet
654- Add two more font options to the font property dialog
655- Add a bunch of missing unrefs of the result of gconf_client_get_default()
656
657* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
658- fix desktop files more
659- copy icons to /usr/share/pixmaps
660
661* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
662- munge the desktop files correctly
663- obsolete control-center-devel, #69168
664- replace gnomecc.desktop with a file from redhat-menus
665
666* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
667- Fix crasher bug in xftprefs patch
668
669* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
670- Change the default rendering style to be "Best Shapes", not "Best Contrast"
671
672* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
673- Add Xft / XSETTINGS support
674
675* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
676- fix %%post so schemas get installed
677 
678* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
679- 2.0.0
680- add new default editor schemas
681- fix find_lang
682
683* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
684- rebuild for new libraries
685- remove a no-longer-existing schemas file from post
686- use desktop-file-install
687
688* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
689- rebuild in different environment
690
691* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
692- rebuild with new dependent libs
693
694* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
695- rebuild in different environment
696
697* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
698- rebuild in different environment
699- build requires bonobo-activation
700
701* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
702- 1.99.10
703
704* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
705- 1.99.9
706
707* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
708- Move to GNOME 2 version
709
710* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
711- merge in translations
712
713* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
714- Make the theme selector write fontsets, not fonts (#62413)
715
716* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
717- really put screensaver capplet back (I think)
718
719* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
720- revert xscreensaver change
721
722* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
723- init "Scaled" radio button correctly #61913
724
725* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
726- change path to windowmaker config tool again, #61824
727
728* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
729- rather than keep patching and patching it, use xscreensaver's own
730  capplet
731
732* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
733- rebuild in Hampton
734
735* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
736- Rebuild package.
737
738* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
739- rebuilt against new openssl
740
741* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
742- automake14
743- don't run auto* again in ccsingle subdir, not sure why we did that
744
745* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
746- rebuild with new gnome-libs so that libcapplet has right cflags/libs
747- pixbufflags patch to make the rebuild work
748- compileflags patch to make control-center-single work
749
750* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
751- fix #52831 (UI properties in Programs menu)
752
753* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
754- Add po files from sources.redhat.com
755
756* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
757- set the _XROOTCOLOR_PIXEL property, should fix
758  bug #52141
759
760* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
761- Update translation.
762- Add CJK fontset patch
763
764* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
765- New control-center-single to handle exiting, #51665
766
767* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
768- remove .desktop file for gnomecc, so it won't appear
769  in panel menu, #49653
770
771* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
772- allow to build without depending on control-center-devel
773
774* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
775- Add BuildRequires
776
777* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
778- New version of control-center-single
779
780* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
781- Change default background to the same as the nautilus one
782
783* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
784- add hack to default to standalone control panels
785
786* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
787- Bump release + rebuild.
788
789* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
790- putting in tree for David
791
792* Tue May 22 2001 David Sainty <dsainty@redhat.com>
793- improve DPMS patch for the try case, and enable patch
794
795* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
796- add patch to use xscreensaver's DPMS stuff, require that version
797
798* Fri Apr 20 2001  <jrb@redhat.com>
799- New Version (1.4.0.1)
800
801* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
802- kick the mixer once on startup if we aren't running esd
803
804* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
805- translations
806
807* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
808- Rebuild for GTK+-1.2.9 include paths
809
810* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
811- langify
812- don't define and use "ver" at the top of the file
813- move changelog to sane location
814
815* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
816- Apply patch from bug #23782 to see how it works
817
818* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
819- Include fvwm2.desktop in WM's
820
821* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
822- Added Japanese patch.
823
824* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
825- Update release.
826
827* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
828- Again, fix problem with solid backgrounds in bg-properties capplet
829  (patch got lost somewhere)
830
831* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
832- Up Epoch and release
833
834* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
835- Handle unreadable desktop files without crashing
836
837* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
838- Fix problem with backgrounds bigger than screen.
839
840* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
841- Fix problem when ~/.gtkrc does not already exist.
842- Fix problem with solid backgrounds in bg-properties capplet
843
844* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
845- Sort of fix problem with people hitting OK while the
846  "Save Session" dialog is still up. (Session won't be saved,
847  but at least the selected entry will be correctly kept.)
848- Fix history list in background properties capplet
849- Fix problems with temporary files in theme-selector capplet
850
851* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
852- automatic rebuild
853
854* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
855- Require redhat-logos
856- Some spec file and FHS fixes
857- reposition embedded logo a bit
858
859* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
860- Add big change to use gdk-pixbuf for backgrounds and add
861  the ability to emboss the background with a logo
862
863* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
864- revert .so strip
865
866* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
867- strip .so lib
868- use configure macro
869
870* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
871- changed to work with 1.0.40
872
873* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
874- Added fixrevert bug to fix bug in theme selector.
875
876* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
877- updated RPM to use new control-center.
878
879* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
880- fixed sound-properties to only disable sound when run with --init-settings-..
881- removed debugging output from several capplets, fixed try behaviour of sm and
882  gnome-edit capplets
883- fixed bug in screensaver and background props
884- added new icons
885
886* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
887- added a patch to fix the close dialog
888- added a patch to limit the number of bg's in the history.
889
890* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
891- vesion 1.0.5
892- removed all patches >10 other then dontstartesd.
893
894* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
895- removed UI props till it works better
896
897* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
898- make sure we DONT inadvertantly start esd by calling esd_open_...
899
900* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
901- changed default bg color to '#356390'
902
903* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
904- prime file selector path for browse in background-props if
905  "/usr/share/pixmaps/backgrounds/" exists.
906- fix behavior of file selector when you delete/cancel/ok it
907
908* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
909- added patch to fix trying in theme selector
910- disabled crystal screensaver, it does evil things to preview in capplet
911
912* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
913- version 1.0.4, fixes problems with sndprops and theme props among
914  other things.
915
916* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
917- fix sound-properties capplet so Try/Revert doesnt come on unless user
918  changes something
919- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
920- strip binaries
921
922* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
923- version 1.0.3
924- added patch to make esd release after 30 sec of inactivity
925
926* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
927- version 1.0.2
928- turned off sound by default
929
930* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
931- version 1.0.1
932
933* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
934- version 0.99.8.1
935- added etc/CORBA/servers/* to file list
936
937* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
938- update to 0.99.8
939- added /usr/lib/cappletConf.sh
940
941* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
942- update to 0.99.5.1
943
944* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
945- update to 0.99.5
946
947* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
948- update to 0.99.3.1
949
950* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
951- update to 0.99.3
952- seems like patch for non-standard xscreensaver placement was already in
953  prestine sources(?)
954
955* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
956- updated to 0.99.1
957- temporary hack patch to get path to work to non-standard placement
958  of xscreensaver binaries in RH 5.2
959
960* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
961- Created for the new control-center branch
962
Note: See TracBrowser for help on using the repository browser.