source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 9102

Revision 9102, 32.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define pango_version 1.36.3
2%define gtk3_version 3.14.0
3%define gnome_desktop3_version 3.14.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 2.32.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.8
16%define mm_version 0.7.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.14.2
22Release: 1%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.14/gnome-control-center-%{version}.tar.xz
28
29Patch1: control-center-3.8.1-gpermission.patch
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: inagaki, daisuke, Takemikaduchi
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36
37Obsoletes: gnome, control-center-devel < 2.0
38Obsoletes: fontilus, themus
39
40Provides: gnome-volume-manager < 2.25
41Obsoletes: gnome-volume-manager < 2.25
42
43Requires: usermode >= %{usermode_version}
44Requires: gnome-settings-daemon
45Requires: gnome-icon-theme
46Requires: gnome-desktop3 >= %{gnome_desktop_version}
47Requires: dbus-x11
48Requires: apg
49Requires(post,postun): desktop-file-utils shared-mime-info gtk3
50
51BuildRequires: gnome-common
52BuildRequires: pango-devel >= %{pango_version}
53BuildRequires: gtk3-devel >= %{gtk3_version}
54BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
55BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
56BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
57BuildRequires: startup-notification-devel >= %{startup_notification_version}
58BuildRequires: libxklavier-devel >= %{libxklavier_version}
59BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
60BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
61BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
62BuildRequires: gnome-settings-daemon-devel
63BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
64BuildRequires: nautilus-devel
65BuildRequires: alsa-lib-devel
66BuildRequires: autoconf
67BuildRequires: gettext-devel
68BuildRequires: librsvg2-devel
69BuildRequires: libXScrnSaver-devel
70BuildRequires: libXxf86misc-devel
71BuildRequires: libSM-devel
72BuildRequires: unique3-devel
73BuildRequires: polkit-devel
74BuildRequires: libgtop2-devel
75BuildRequires: upower-devel
76BuildRequires: pulseaudio-libs-devel
77BuildRequires: cups-devel
78BuildRequires: cheese-devel
79BuildRequires: grilo-devel
80BuildRequires: gstreamer-plugins-base-devel
81BuildRequires: gnome-online-accounts-devel
82BuildRequires: colord-devel
83BuildRequires: colord-gtk-devel
84BuildRequires: libnm-gtk-devel >= %{nm_version}
85BuildRequires: NetworkManager-glib-devel >= %{nm_version}
86BuildRequires: ModemManager-glib-devel >= %{mm_version}
87BuildRequires: libnotify-devel >= %{libnotify_version}
88BuildRequires: libwacom-devel
89BuildRequires: libpwquality-devel
90BuildRequires: ibus-devel
91BuildRequires: accountsservice-devel
92BuildRequires: gnome-online-accounts-devel
93BuildRequires: libsmbclient-devel
94
95%description
96GNOME (the GNU Network Object Model Environment) is an attractive and
97easy-to-use GUI desktop environment. The control-center package
98provides the GNOME Control Center utilities that allow you to setup
99and configure your system's GNOME environment (things like the desktop
100background and theme, the screensaver, the window manager, system
101sounds, and mouse behavior).
102
103If you install GNOME, you need to install control-center.
104
105%description -l ja
106GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
107GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
108環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
109す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
110ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
111
112%package devel
113Summary: Development files for GNOME Control Center
114Summary(ja): GNOME コントロールセンターの開発用ファイル
115Group: Development/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description devel
119Development tool for GNOME Control Center
120
121%descriotion -l ja devel
122GNOME コントロールセンターの開発用ファイルが含まれています。
123
124%prep
125%setup -q -n gnome-control-center-%{version}
126%patch1 -p1
127
128%build
129autoreconf -if
130%configure --disable-static  \
131    --disable-update-mimedb \
132    --enable-ibus
133    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
134
135# drop unneeded direct library deps with --as-needed
136# libtool doesn't make this easy, so we do it the hard way
137sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
138
139make %{?_smp_mflags}
140
141%install
142rm -rf $RPM_BUILD_ROOT
143
144make install DESTDIR=$RPM_BUILD_ROOT
145
146desktop-file-install --delete-original                  \
147  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
148  --add-only-show-in GNOME                              \
149  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
150
151# we do want this
152mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
153
154# We don't want these
155rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
156rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
157
158# remove useless libtool archive files
159find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
160
161# don't package mime caches
162rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
163rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
164rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
169rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
170
171rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
172rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
173
174%find_lang gnome-control-center-2.0
175%find_lang gnome-control-center-2.0-timezones
176
177%clean
178rm -rf $RPM_BUILD_ROOT
179
180%post
181/sbin/ldconfig
182
183update-desktop-database %{_datadir}/applications >& /dev/null ||:
184update-mime-database %{_datadir}/mime > /dev/null
185touch --no-create %{_datadir}/icons/hicolor
186if [ -x /usr/bin/gtk-update-icon-cache ]; then
187  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
188fi
189
190%postun
191/sbin/ldconfig
192update-desktop-database %{_datadir}/applications >& /dev/null ||:
193update-mime-database %{_datadir}/mime > /dev/null
194touch --no-create %{_datadir}/icons/hicolor
195if [ -x /usr/bin/gtk-update-icon-cache ]; then
196  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
197fi
198
199%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
200%defattr(-, root, root)
201%doc AUTHORS COPYING ChangeLog NEWS README
202%{_bindir}/gnome-control-center
203%{_libexecdir}/cc-remote-login-helper
204%{_libexecdir}/gnome-control-center-search-provider
205%dir %{_datadir}/gnome/wm-properties
206%dir %{_datadir}/gnome-control-center
207%{_datadir}/applications/*
208%{_datadir}/bash-completion/completions/gnome-control-center
209%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
210%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
211%{_datadir}/gnome-control-center/datetime
212%{_datadir}/gnome-control-center/icons
213%{_datadir}/gnome-control-center/keybindings
214%{_datadir}/gnome-control-center/pixmaps
215%{_datadir}/gnome-control-center/sounds
216%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
217%{_datadir}/icons/*
218%{_datadir}/pixmaps/*
219%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
220%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
221%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
222%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
223%{_datadir}/sounds/*
224%{_mandir}/man1/gnome-control-center.1.gz
225
226%files devel
227%defattr(-, root, root)
228%{_datadir}/pkgconfig/*
229
230
231%changelog
232* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
233- new upstream release
234
235* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
236- new upstream release
237
238* Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-3
239- rebuild with upower-0.99.1
240
241* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-2
242- rebuild with libgtop2-2.30.0
243
244* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
245- new upstream release
246
247* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
248- new upstream release
249- add BuildRequires: grilo-devel
250
251* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
252- new upstream release
253- remove Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
254
255* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
256- new upstream release
257- add BuildRequires: NetworkManager-glib-devel, ModemManager-glib-devel, libsmbclient-devel
258- add Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
259
260* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
261- new upstream release
262
263* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
264- new upstream release
265
266* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
267- new upstream release
268- remove Patch0 (control-center-3.8.1-git20130424.patch)
269
270* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
271- add Patch1 (control-center-3.8.1-gpermission.patch)
272
273* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
274- new upstream release
275- remove BuildRequires: gnome-panel-devel, metacity-devel
276- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
277- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
278- add Patch0 (control-center-3.8.1-git20130424.patch)
279
280* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
281- new upstream release
282
283* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
284- new upstream release
285
286* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
287- new upstream release
288
289* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
290- new upstream release
291- add BuildRequires: libpwquality-devel
292
293* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
294- new upstream release
295
296* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
297- new upstream release
298- remove BuildRequires: GConf2-devel, libbonobo-devel
299- add BuildRequires: libwacom-devel
300
301* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
302- new upstream release
303
304* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
305- new upstream release
306
307* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
308- rebuild with NetworkManager-0.9
309- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
310
311* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
312- new upstream release
313
314* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
315- new upstream release
316
317* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
318- new upstream release
319- remove Patch0
320
321* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
322- new upstream release
323- add BuildRequires: libnotify-devel
324- add Patch0 (control-center-3.1.5-crash-layout.patch)
325
326* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
327- new upstream release
328- change BuildRequires: gtk3-devel instead of gtk2-devel
329- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
330- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
331- change BuildRequires: unique3-devel instead of unique-devel
332- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
333                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
334                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
335- add Requires: apg
336- drop all Patches
337- add Provides: and Obsoletes: gnome-volume-manager
338
339* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
340- update desktop-effect-integration patch
341  - fix freeze on changing metacity to compiz
342  - run compiz directly instead of compiz-gtk
343  - drop use of jockey-gtk
344- update ja.po
345
346* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
347- new upstream release
348
349* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
350- update translation.
351
352* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
353- update translation.
354
355* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
356- update Source21(gnome-control-center-2.32.0-vine.ja.po)
357
358* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
359- new upstream release
360- drop Patch22, Patch30, Patch52
361- fix %files
362
363* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
364- rebuilt with rpm-4.8.1 for pkg-config (too)
365
366* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
367- rebuild with rpm-4.8.1 for pkg-config file
368- add Requires: %{name}=%{version}-%{release}
369
370* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
371- rebuild with evolution-data-server-2.30.2
372
373* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
374- new upstream release
375
376* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
377- new upstream release
378- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
379- add BuildRequires: gnome-common, unique-devel
380
381* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
382- enable Patch101,110-112 and 500
383
384* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
385- new upstream release
386- disabled Patch101, 110-112 and 500
387
388* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
389- update notification-theme.patch
390  - use vine theme if NotificationTheme is not set in meta-theme.
391
392* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
393- add Patch510: use Sans for font-properties sample font.
394- add BR: librsvg2-devel, libXScrnSaver-devel
395- remove BR: esound
396
397* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
398- add Patch37: Don't rely on _BACKUP property for xkb initialization
399
400* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
401- renumber patch10 to patch1010
402  - do not check gdm fprint plugin
403- add Patch101: show aspect in drop down menu
404- add Patch110: modify gnome-mouse-properties to fit smaller screen
405- add Patch111: modify gnome-about-me to fit smaller screen
406- add Patch112: modify gnome-display-properties to fit smaller screen
407
408* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
409- update Patch100 to use compiz-gtk instead of compiz
410
411* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
412- update ja.po
413
414* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
415- import upstream patchs (10,22,3[0-6])
416
417* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
418- add nautilus-devel to BR: not Requires:
419
420* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
421- new upstream release
422- update ja.po
423- add BR: nautilus-devel
424
425* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
426- drop Patch20 which need new XInput API
427- update Patch23
428
429* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
430- add Patch20,22.23 from ubuntu
431  - patch20 to add touchpad configuration
432  - patch22 to add aspect setting in randr capplet
433  - patch23 to integrate desktop setting into appearance-properties
434
435* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
436- new upstream release
437
438* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
439- new upstream release
440
441* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
442- add gnome-typing-monitor to %%files
443
444* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
445- add Patch100 for new RandR capplet. (fc)
446
447* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
448- new upstream release
449- dropped Patch8 (merged into upstream)
450
451* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
452- new upstream release
453- added Patch7 and Patch8 from Fedora
454  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
455  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
456  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
457  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
458  - Remove a nonfunctional button from the a11y preferences
459- added BuildRequires: gnome-settings-daemon, gnome-panel
460- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
461- removed Requires: xscreensaver
462
463* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
464- new upstream release based on Fedora
465- added BuildRequires: gnome-settings-daemon
466
467* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
468- new upstream release based on Fedora
469  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
470  - Fix the orca command in the default applications capplet (#351471)
471
472* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
473- add BuildReq: libgnomekbd-devel
474
475* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
476- rebuilt with evolution-data-server-devel-1.10.1
477
478* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
479- add BuildReq: evolution-data-server-devel
480
481* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
482- new upstream release
483- remove unneeded? patch10
484
485* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
486- added Patch10 to supress /dev/pmu warning messages on some ppc models
487
488* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
489- new upstream release
490
491* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
492- new upstream release
493
494* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
495- run gtk-update-icon-cache in %%post script.
496
497* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
498- new upstream release
499- drop Patch10,it is merged in upstream
500
501* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
502- add Patch10 for correct textdomain name in
503  default-applications-properties(Bug332833)
504- add Patch100 for change default-applications settings for vine
505
506* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
507- new upstream release
508
509* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
510- new upstream release
511
512* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
513- new upstream release
514
515* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
516- new upstream release
517- enable alsa support
518
519* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
520- new upstream release
521
522* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
523- fixed type in %%post script
524
525* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
526- clear the old defaults of xkb
527
528* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
529- remove bonobo-activation dependency
530
531* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
532- new upstream version
533
534* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
535- new upstream release
536- add Japanese summay to devel package
537
538* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
539- new upstream release
540
541* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
542- modify patch11 to use NeoVine theme instead of BeCool.
543
544* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
545- rebuild with new toolchain
546
547* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
548- new upstream release
549- remove obsolete ja.po
550
551* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
552- change required version of metacity to 2.4.34 on alpha
553
554* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
555- new upstream release
556
557* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
558- new upstream release
559
560* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
561- add more missing files and schemas...
562
563* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
564- add missing file in %{_libdir}/gnome-vfs-2.0/
565
566* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
567- new upstream release
568- this is experimental version
569- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
570
571* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
572- new upstream release
573
574* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
575- import patch6 (upstream paches) from rawhide package.
576
577* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
578- import patch1-5 (upstream paches) from rawhide package.
579
580* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
581- new upstream release
582
583* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
584- rebuild
585
586* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
587- new upstream release
588
589* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
590- new upstream release
591
592* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
593- new upstream release
594
595* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
596- change default gtk1 theme from Raleigh to BeCool.
597
598* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
599- add BuildRequires/Requires.
600- fixed kanjicode of specfile
601
602* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
603- remove bogus message in %%post scripts.
604
605* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
606- add patch10 to modify some desktop files
607- update ja.po
608
609* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
610- update ja.po
611
612* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
613- update ja.po
614
615* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
616- new upstream release
617
618* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
619- add devel package
620- add window-manager-settings files.
621
622* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
623- modify dependancies.
624
625* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
626- build for Vine Linux
627- new upstream release from gnome-2.1.4
628
629* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
630- Allow setting custom mime handlers
631
632* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
633- make desktop file symlinks absolute #71991
634- add po files from cvs.gnome.org
635
636* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
637- Fix up keyboard handling
638
639* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
640- Fixes for #68735
641
642* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
643- New version.  Fix up metacity theme locations
644
645* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
646- Switch the gtk1 theme along with the gtk2 theme
647- Add the ability to switch the window manager theme through the theme capplet
648- Add two more font options to the font property dialog
649- Add a bunch of missing unrefs of the result of gconf_client_get_default()
650
651* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
652- fix desktop files more
653- copy icons to /usr/share/pixmaps
654
655* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
656- munge the desktop files correctly
657- obsolete control-center-devel, #69168
658- replace gnomecc.desktop with a file from redhat-menus
659
660* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
661- Fix crasher bug in xftprefs patch
662
663* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
664- Change the default rendering style to be "Best Shapes", not "Best Contrast"
665
666* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
667- Add Xft / XSETTINGS support
668
669* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
670- fix %%post so schemas get installed
671 
672* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
673- 2.0.0
674- add new default editor schemas
675- fix find_lang
676
677* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
678- rebuild for new libraries
679- remove a no-longer-existing schemas file from post
680- use desktop-file-install
681
682* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
683- rebuild in different environment
684
685* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
686- rebuild with new dependent libs
687
688* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
689- rebuild in different environment
690
691* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
692- rebuild in different environment
693- build requires bonobo-activation
694
695* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
696- 1.99.10
697
698* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
699- 1.99.9
700
701* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
702- Move to GNOME 2 version
703
704* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
705- merge in translations
706
707* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
708- Make the theme selector write fontsets, not fonts (#62413)
709
710* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
711- really put screensaver capplet back (I think)
712
713* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
714- revert xscreensaver change
715
716* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
717- init "Scaled" radio button correctly #61913
718
719* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
720- change path to windowmaker config tool again, #61824
721
722* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
723- rather than keep patching and patching it, use xscreensaver's own
724  capplet
725
726* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
727- rebuild in Hampton
728
729* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
730- Rebuild package.
731
732* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
733- rebuilt against new openssl
734
735* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
736- automake14
737- don't run auto* again in ccsingle subdir, not sure why we did that
738
739* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
740- rebuild with new gnome-libs so that libcapplet has right cflags/libs
741- pixbufflags patch to make the rebuild work
742- compileflags patch to make control-center-single work
743
744* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
745- fix #52831 (UI properties in Programs menu)
746
747* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
748- Add po files from sources.redhat.com
749
750* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
751- set the _XROOTCOLOR_PIXEL property, should fix
752  bug #52141
753
754* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
755- Update translation.
756- Add CJK fontset patch
757
758* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
759- New control-center-single to handle exiting, #51665
760
761* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
762- remove .desktop file for gnomecc, so it won't appear
763  in panel menu, #49653
764
765* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
766- allow to build without depending on control-center-devel
767
768* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
769- Add BuildRequires
770
771* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
772- New version of control-center-single
773
774* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
775- Change default background to the same as the nautilus one
776
777* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
778- add hack to default to standalone control panels
779
780* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
781- Bump release + rebuild.
782
783* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
784- putting in tree for David
785
786* Tue May 22 2001 David Sainty <dsainty@redhat.com>
787- improve DPMS patch for the try case, and enable patch
788
789* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
790- add patch to use xscreensaver's DPMS stuff, require that version
791
792* Fri Apr 20 2001  <jrb@redhat.com>
793- New Version (1.4.0.1)
794
795* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
796- kick the mixer once on startup if we aren't running esd
797
798* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
799- translations
800
801* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
802- Rebuild for GTK+-1.2.9 include paths
803
804* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
805- langify
806- don't define and use "ver" at the top of the file
807- move changelog to sane location
808
809* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
810- Apply patch from bug #23782 to see how it works
811
812* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
813- Include fvwm2.desktop in WM's
814
815* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
816- Added Japanese patch.
817
818* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
819- Update release.
820
821* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
822- Again, fix problem with solid backgrounds in bg-properties capplet
823  (patch got lost somewhere)
824
825* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
826- Up Epoch and release
827
828* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
829- Handle unreadable desktop files without crashing
830
831* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
832- Fix problem with backgrounds bigger than screen.
833
834* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
835- Fix problem when ~/.gtkrc does not already exist.
836- Fix problem with solid backgrounds in bg-properties capplet
837
838* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
839- Sort of fix problem with people hitting OK while the
840  "Save Session" dialog is still up. (Session won't be saved,
841  but at least the selected entry will be correctly kept.)
842- Fix history list in background properties capplet
843- Fix problems with temporary files in theme-selector capplet
844
845* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
846- automatic rebuild
847
848* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
849- Require redhat-logos
850- Some spec file and FHS fixes
851- reposition embedded logo a bit
852
853* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
854- Add big change to use gdk-pixbuf for backgrounds and add
855  the ability to emboss the background with a logo
856
857* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
858- revert .so strip
859
860* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
861- strip .so lib
862- use configure macro
863
864* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
865- changed to work with 1.0.40
866
867* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
868- Added fixrevert bug to fix bug in theme selector.
869
870* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
871- updated RPM to use new control-center.
872
873* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
874- fixed sound-properties to only disable sound when run with --init-settings-..
875- removed debugging output from several capplets, fixed try behaviour of sm and
876  gnome-edit capplets
877- fixed bug in screensaver and background props
878- added new icons
879
880* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
881- added a patch to fix the close dialog
882- added a patch to limit the number of bg's in the history.
883
884* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
885- vesion 1.0.5
886- removed all patches >10 other then dontstartesd.
887
888* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
889- removed UI props till it works better
890
891* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
892- make sure we DONT inadvertantly start esd by calling esd_open_...
893
894* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
895- changed default bg color to '#356390'
896
897* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
898- prime file selector path for browse in background-props if
899  "/usr/share/pixmaps/backgrounds/" exists.
900- fix behavior of file selector when you delete/cancel/ok it
901
902* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
903- added patch to fix trying in theme selector
904- disabled crystal screensaver, it does evil things to preview in capplet
905
906* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
907- version 1.0.4, fixes problems with sndprops and theme props among
908  other things.
909
910* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
911- fix sound-properties capplet so Try/Revert doesnt come on unless user
912  changes something
913- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
914- strip binaries
915
916* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
917- version 1.0.3
918- added patch to make esd release after 30 sec of inactivity
919
920* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
921- version 1.0.2
922- turned off sound by default
923
924* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
925- version 1.0.1
926
927* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
928- version 0.99.8.1
929- added etc/CORBA/servers/* to file list
930
931* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
932- update to 0.99.8
933- added /usr/lib/cappletConf.sh
934
935* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
936- update to 0.99.5.1
937
938* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
939- update to 0.99.5
940
941* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
942- update to 0.99.3.1
943
944* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
945- update to 0.99.3
946- seems like patch for non-standard xscreensaver placement was already in
947  prestine sources(?)
948
949* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
950- updated to 0.99.1
951- temporary hack patch to get path to work to non-standard placement
952  of xscreensaver binaries in RH 5.2
953
954* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
955- Created for the new control-center branch
956
Note: See TracBrowser for help on using the repository browser.