source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 521

Revision 521, 31.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define gettext_package gnome-control-center-2.0
2
3%define pango_version 1.22.0
4%define gtk2_version 2.14.0
5%define gconf2_version 2.24.0
6%define gnome_desktop_version 2.24.0
7%define libbonobo_version 2.24.1
8%define libgnomekbd_version 2.28.0
9%define gnome_vfs2_version 2.24.1
10%define desktop_file_utils_version 0.3
11%define startup_notification_version 0.7
12%define libxklavier_version 4.0
13%define gnome_doc_utils_version 0.6
14%define gnome_menus_version 2.26.0
15%define vine_menus_version 3.0
16%define metacity_version 2.26.0
17%define evolution_data_server_version 2.26.0
18%define libcanberra_version 0.9
19%define usermode_version 1.83
20
21Summary: GNOME Control Center.
22Summary(ja): GNOME コントロールセンター
23Name: control-center
24Version: 2.28.1
25Release: 2%{?_dist_release}
26License: GPLv2+ and GFDL+
27Group: User Interface/Desktops
28URL: http://www.gnome.org
29
30Source: gnome-control-center-%{version}.tar.bz2
31
32# icons for ubuntu visual effects integration.
33Source20: control-center-visual-effects-icons.tar.bz2
34# messages for visual effects
35Source21: gnome-control-center-2.28.1-ja.po
36
37# fc
38Patch3: control-center-2.19.3-no-gnome-common.patch
39# http://bugzilla.gnome.org/show_bug.cgi?id=497807
40Patch5: background-location.patch
41# Fix some useless warnings in libslab
42# http://bugzilla.gnome.org/show_bug.cgi?id=439398
43Patch6: gnome-control-center-2.19.90-no-warnings.patch
44
45# http://bugzilla.gnome.org/show_bug.cgi?id=545075
46Patch22: slab-icon-names.patch
47
48# http://bugzilla.gnome.org/show_bug.cgi?id=555591
49Patch30: default-layout-toggle.patch
50
51# https://bugzilla.gnome.org/show_bug.cgi?id=600021
52Patch31: 0001-Fix-all-the-keybindings-showing-up-when-using-compiz.patch
53
54# http://bugzilla.gnome.org/show_bug.cgi?id=588729
55Patch45: mnemonic.patch
56
57# http://mail.gnome.org/archives/gnomecc-list/2009-July/msg00015.html
58Patch46: no-tweaks.patch
59
60# http://bugzilla.gnome.org/show_bug.cgi?id=590349
61Patch47: save-as.patch
62
63# https://bugzilla.gnome.org/show_bug.cgi?id=596369
64Patch50: fix-background-tooltips.patch
65
66# https://bugzilla.gnome.org/show_bug.cgi?id=593866
67Patch51: mirror-crash.patch
68
69# https://bugzilla.gnome.org/show_bug.cgi?id=597066
70Patch52: shell-markup.patch
71
72# https://bugzilla.gnome.org/show_bug.cgi?id=596939
73Patch53: keybinding-bugs.patch
74
75# https://bugzilla.gnome.org/show_bug.cgi?id=592348
76Patch54: about-me-delete.patch
77
78Patch55: finger-icons.patch
79
80Patch56: best-shapes.patch
81
82# ubuntu
83Patch101: gnome-control-center-2.28.1-aspect-in-dropdown.patch
84Patch110: gnome-control-center-2.28.1-gnome-mouse-properties-small-screen.patch
85Patch111: gnome-control-center-2.28.1-gnome-about-me-small-screen.patch
86Patch112: gnome-control-center-2.28.1-display-properties-fit-small-screen.patch
87
88# vine
89Patch500: gnome-control-center-2.28.1-desktop-effects-integration-vine.patch
90Patch510: gnome-control-center-2.26.0-use-sans-for-sample-font.patch
91
92# vine default applications
93Patch1000: control-center-2.24.0.1-default-applications.patch
94Patch1010: control-center-pam-fprintd-avail.patch
95
96Vendor: Project Vine
97Distribution: Vine Linux
98Packager: inagaki, daisuke
99
100BuildRoot: %{_tmppath}/%{name}-%{version}-root
101
102Obsoletes: gnome, control-center-devel < 2.0
103Obsoletes: fontilus, themus
104Requires: metacity >= %{metacity_version}
105Requires: usermode >= %{usermode_version}
106Requires: gnome-settings-daemon
107Requires: gnome-icon-theme
108Requires: gnome-desktop >= %{gnome_desktop_version}
109Requires: dbus-x11
110Requires(post,pre,preun): GConf2
111Requires(post,postun): desktop-file-utils shared-mime-info gtk2
112
113BuildRequires: pango-devel >= %{pango_version}
114BuildRequires: gtk2-devel >= %{gtk2_version}
115BuildRequires: GConf2-devel >= %{gconf2_version}
116BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
117BuildRequires: libbonobo-devel >= %{libbonobo_version}
118BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
119BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
120BuildRequires: startup-notification-devel >= %{startup_notification_version}
121BuildRequires: libxklavier-devel >= %{libxklavier_version}
122BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
123BuildRequires: gnome-panel
124BuildRequires: metacity-devel >= %{metacity_version}
125BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
126BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
127BuildRequires: gnome-settings-daemon-devel
128BuildRequires: libcanberra-devel >= %{libcanberra_version}
129BuildRequires: nautilus-devel
130BuildRequires: alsa-lib-devel
131#BuildRequires: automake
132BuildRequires: autoconf
133BuildRequires: gettext-devel
134BuildRequires: librsvg2-devel
135BuildRequires: libXScrnSaver-devel
136
137%description
138GNOME (the GNU Network Object Model Environment) is an attractive and
139easy-to-use GUI desktop environment. The control-center package
140provides the GNOME Control Center utilities that allow you to setup
141and configure your system's GNOME environment (things like the desktop
142background and theme, the screensaver, the window manager, system
143sounds, and mouse behavior).
144
145If you install GNOME, you need to install control-center.
146
147%description -l ja
148GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
149GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
150環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
151す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
152ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
153
154%package devel
155Summary: Development files for GNOME Control Center
156Summary(ja): GNOME コントロールセンターの開発用ファイル
157Group: Development/Libraries
158
159%description devel
160Development tool for GNOME Control Center
161
162%descriotion -l ja devel
163GNOME コントロールセンターの開発用ファイルが含まれています。
164
165%prep
166%setup -q -n gnome-control-center-%{version} -a 20
167
168# patches from fedora
169%patch3 -p1 -b .no-gnome-common
170%patch5 -p1 -b .background-location
171pushd libslab
172%patch6 -p0 -b .warnings
173popd
174#%patch10 -p0 -b .pam-fprintd
175%patch22 -p0 -b .slab-icon-names
176%patch30 -p1 -b .default-layout-toggle
177%patch46 -p1 -b .no-tweaks
178%patch47 -p1 -b .save-as
179%patch50 -p1 -b .fix-background-tooltips
180%patch51 -p1 -b .mirror-crash
181%patch52 -p1 -b .shell-markup
182%patch53 -p1 -b .keybinding-bugs
183%patch54 -p1 -b .about-me-delete
184%patch55 -p1 -b .finger-icons
185%patch56 -p1 -b .best-shapes
186
187# patches from ubuntu
188%patch101 -p1 -b .aspect-in-dropdown.patch
189%patch110 -p1 -b .gnome-mouse-properties_small_screen.patch
190%patch111 -p1 -b .gnome-about-me_small_screen.patch
191%patch112 -p1 -b .display_properties_fit_small_screen.patch
192
193# Vine patches
194# desktop integration based on ubuntu patch
195%patch500 -p1 -b .desktop-effects-integration
196# use Sans for font-properties sample font.
197%patch510 -p1 -b .use-sans-for-sample-font
198
199# Vine Linux configuration patches
200%patch1000 -p1 -b .default-applications
201%patch1010 -p0 -b .pam-fprintd
202
203# add translations for visual effect integration
204cp -f %{SOURCE21} po/ja.po
205
206%build
207autoreconf -f -i
208
209%configure --disable-static  \
210    --enable-gstreamer \
211    --enable-alsa  \
212    --enable-aboutme \
213    --disable-scrollkeeper \
214    --disable-schemas-install \
215    --disable-update-mimedb \
216    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
217make %{?_smp_mflags}
218
219%install
220rm -rf $RPM_BUILD_ROOT
221
222export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
223make install DESTDIR=$RPM_BUILD_ROOT
224unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
225
226for i in apps_gnome_settings_daemon_default_editor.schemas              \
227            apps_gnome_settings_daemon_keybindings.schemas              \
228            apps_gnome_settings_daemon_screensaver.schemas              \
229            desktop_gnome_font_rendering.schemas ; do                   \
230            rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/$i ;      \
231done
232
233# Add a "valid" OnlyShowIn entry, otherwise desktop-file-install complains
234sed -i -e "s/OnlyShowIn=;/OnlyShowIn=GNOME;/"  \
235  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-theme-installer.desktop
236
237desktop-file-install --vendor gnome --delete-original                   \
238  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
239  --add-only-show-in GNOME                                              \
240  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
241
242sed -i -e "s/OnlyShowIn=GNOME;/OnlyShowIn=;/"  \
243  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-theme-installer.desktop
244
245# https://bugzilla.redhat.com/show_bug.cgi?id=161489
246sed -i -e "s/OnlyShowIn=GNOME;//"  \
247  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-default-applications.desktop
248
249# install visual effect icons
250install -m644 visual-effects/*.svg $RPM_BUILD_ROOT%{_datadir}/gnome-control-center/pixmaps/
251
252# we do want this
253mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
254
255# We don't want these
256rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
257rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
258
259# remove useless libtool archive files
260find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
261
262# don't package mime caches
263rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
264rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
265rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
266rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
267rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
268rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
269rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
270rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
271
272%find_lang %{gettext_package}
273
274%clean
275rm -rf $RPM_BUILD_ROOT
276
277%post
278/sbin/ldconfig
279export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
280SCHEMAS="control-center.schemas fontilus.schemas"
281for S in $SCHEMAS; do
282  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null 2>&1 || :
283done
284
285update-desktop-database %{_datadir}/applications >& /dev/null ||:
286update-mime-database %{_datadir}/mime > /dev/null
287touch --no-create %{_datadir}/icons/hicolor
288if [ -x /usr/bin/gtk-update-icon-cache ]; then
289  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
290fi
291
292%pre
293if [ "$1" -gt 1 ]; then
294    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
295    SCHEMAS="fontilus.schemas control-center.schemas"
296    for S in $SCHEMAS; do
297        gconftool-2 --makefile-uninstall-rule \
298            %{_sysconfdir}/gconf/schemas/$S > /dev/null 2>&1 || :
299    done
300fi
301
302%preun
303if [ "$1" -eq 0 ]; then
304    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
305    SCHEMAS="fontilus.schemas control-center.schemas"
306    for S in $SCHEMAS; do
307        gconftool-2 --makefile-uninstall-rule \
308            %{_sysconfdir}/gconf/schemas/$S > /dev/null 2>&1 || :
309    done
310fi
311
312%postun
313/sbin/ldconfig
314update-desktop-database %{_datadir}/applications >& /dev/null ||:
315update-mime-database %{_datadir}/mime > /dev/null
316touch --no-create %{_datadir}/icons/hicolor
317if [ -x /usr/bin/gtk-update-icon-cache ]; then
318  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
319fi
320
321%files -f %{gettext_package}.lang
322%defattr(-, root, root)
323%doc AUTHORS COPYING ChangeLog NEWS README
324%dir %{_libdir}/window-manager-settings
325%dir %{_datadir}/gnome/wm-properties
326%dir %{_datadir}/gnome-control-center
327%dir %{_datadir}/gnome-control-center/keybindings
328%{_datadir}/gnome-control-center/keybindings/*.xml
329%{_datadir}/gnome-control-center/default-apps/*.xml
330%{_datadir}/gnome-control-center/pixmaps
331%{_datadir}/gnome-control-center/ui
332%{_datadir}/applications/*
333%{_datadir}/gnome/help/*
334%{_datadir}/omf/control-center
335%{_datadir}/desktop-directories/*
336#{_datadir}/dbus-1/services/*
337%{_datadir}/mime/packages/gnome-theme-package.xml
338%{_datadir}/icons/*
339# list all binaries explicitly, so we notice if one goes missing
340%{_bindir}/gnome-about-me
341%{_bindir}/gnome-appearance-properties
342%{_bindir}/gnome-at-mobility
343%{_bindir}/gnome-at-properties
344%{_bindir}/gnome-at-visual
345%{_bindir}/gnome-control-center
346%{_bindir}/gnome-default-applications-properties
347%{_bindir}/gnome-display-properties
348%{_bindir}/gnome-keybinding-properties
349%{_bindir}/gnome-keyboard-properties
350%{_bindir}/gnome-mouse-properties
351%{_bindir}/gnome-network-properties
352%{_bindir}/gnome-typing-monitor
353%{_bindir}/gnome-window-properties
354%{_bindir}/gnome-font-viewer
355%{_bindir}/gnome-thumbnail-font
356%{_libdir}/*.so.*
357%{_libdir}/window-manager-settings/*
358#{_libexecdir}/*
359%{_sysconfdir}/gconf/schemas/*.schemas
360%{_sysconfdir}/xdg/menus/gnomecc.menu
361%{_sysconfdir}/xdg/autostart/gnome-at-session.desktop
362
363%files devel
364%defattr(-, root, root)
365%{_libdir}/pkgconfig/*
366%{_datadir}/pkgconfig/*
367%{_libdir}/*.so
368%{_includedir}/*
369
370
371%changelog
372* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
373- enable Patch101,110-112 and 500
374
375* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
376- new upstream release
377- disabled Patch101, 110-112 and 500
378
379* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
380- update notification-theme.patch
381  - use vine theme if NotificationTheme is not set in meta-theme.
382
383* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
384- add Patch510: use Sans for font-properties sample font.
385- add BR: librsvg2-devel, libXScrnSaver-devel
386- remove BR: esound
387
388* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
389- add Patch37: Don't rely on _BACKUP property for xkb initialization
390
391* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
392- renumber patch10 to patch1010
393  - do not check gdm fprint plugin
394- add Patch101: show aspect in drop down menu
395- add Patch110: modify gnome-mouse-properties to fit smaller screen
396- add Patch111: modify gnome-about-me to fit smaller screen
397- add Patch112: modify gnome-display-properties to fit smaller screen
398
399* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
400- update Patch100 to use compiz-gtk instead of compiz
401
402* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
403- update ja.po
404
405* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
406- import upstream patchs (10,22,3[0-6])
407
408* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
409- add nautilus-devel to BR: not Requires:
410
411* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
412- new upstream release
413- update ja.po
414- add BR: nautilus-devel
415
416* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
417- drop Patch20 which need new XInput API
418- update Patch23
419
420* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
421- add Patch20,22.23 from ubuntu
422  - patch20 to add touchpad configuration
423  - patch22 to add aspect setting in randr capplet
424  - patch23 to integrate desktop setting into appearance-properties
425
426* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
427- new upstream release
428
429* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
430- new upstream release
431
432* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
433- add gnome-typing-monitor to %%files
434
435* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
436- add Patch100 for new RandR capplet. (fc)
437
438* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
439- new upstream release
440- dropped Patch8 (merged into upstream)
441
442* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
443- new upstream release
444- added Patch7 and Patch8 from Fedora
445  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
446  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
447  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
448  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
449  - Remove a nonfunctional button from the a11y preferences
450- added BuildRequires: gnome-settings-daemon, gnome-panel
451- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
452- removed Requires: xscreensaver
453
454* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
455- new upstream release based on Fedora
456- added BuildRequires: gnome-settings-daemon
457
458* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
459- new upstream release based on Fedora
460  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
461  - Fix the orca command in the default applications capplet (#351471)
462
463* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
464- add BuildReq: libgnomekbd-devel
465
466* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
467- rebuilt with evolution-data-server-devel-1.10.1
468
469* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
470- add BuildReq: evolution-data-server-devel
471
472* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
473- new upstream release
474- remove unneeded? patch10
475
476* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
477- added Patch10 to supress /dev/pmu warning messages on some ppc models
478
479* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
480- new upstream release
481
482* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
483- new upstream release
484
485* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
486- run gtk-update-icon-cache in %%post script.
487
488* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
489- new upstream release
490- drop Patch10,it is merged in upstream
491
492* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
493- add Patch10 for correct textdomain name in
494  default-applications-properties(Bug332833)
495- add Patch100 for change default-applications settings for vine
496
497* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
498- new upstream release
499
500* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
501- new upstream release
502
503* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
504- new upstream release
505
506* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
507- new upstream release
508- enable alsa support
509
510* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
511- new upstream release
512
513* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
514- fixed type in %%post script
515
516* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
517- clear the old defaults of xkb
518
519* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
520- remove bonobo-activation dependency
521
522* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
523- new upstream version
524
525* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
526- new upstream release
527- add Japanese summay to devel package
528
529* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
530- new upstream release
531
532* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
533- modify patch11 to use NeoVine theme instead of BeCool.
534
535* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
536- rebuild with new toolchain
537
538* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
539- new upstream release
540- remove obsolete ja.po
541
542* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
543- change required version of metacity to 2.4.34 on alpha
544
545* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
546- new upstream release
547
548* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
549- new upstream release
550
551* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
552- add more missing files and schemas...
553
554* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
555- add missing file in %{_libdir}/gnome-vfs-2.0/
556
557* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
558- new upstream release
559- this is experimental version
560- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
561
562* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
563- new upstream release
564
565* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
566- import patch6 (upstream paches) from rawhide package.
567
568* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
569- import patch1-5 (upstream paches) from rawhide package.
570
571* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
572- new upstream release
573
574* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
575- rebuild
576
577* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
578- new upstream release
579
580* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
581- new upstream release
582
583* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
584- new upstream release
585
586* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
587- change default gtk1 theme from Raleigh to BeCool.
588
589* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
590- add BuildRequires/Requires.
591- fixed kanjicode of specfile
592
593* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
594- remove bogus message in %%post scripts.
595
596* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
597- add patch10 to modify some desktop files
598- update ja.po
599
600* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
601- update ja.po
602
603* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
604- update ja.po
605
606* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
607- new upstream release
608
609* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
610- add devel package
611- add window-manager-settings files.
612
613* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
614- modify dependancies.
615
616* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
617- build for Vine Linux
618- new upstream release from gnome-2.1.4
619
620* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
621- Allow setting custom mime handlers
622
623* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
624- make desktop file symlinks absolute #71991
625- add po files from cvs.gnome.org
626
627* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
628- Fix up keyboard handling
629
630* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
631- Fixes for #68735
632
633* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
634- New version.  Fix up metacity theme locations
635
636* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
637- Switch the gtk1 theme along with the gtk2 theme
638- Add the ability to switch the window manager theme through the theme capplet
639- Add two more font options to the font property dialog
640- Add a bunch of missing unrefs of the result of gconf_client_get_default()
641
642* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
643- fix desktop files more
644- copy icons to /usr/share/pixmaps
645
646* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
647- munge the desktop files correctly
648- obsolete control-center-devel, #69168
649- replace gnomecc.desktop with a file from redhat-menus
650
651* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
652- Fix crasher bug in xftprefs patch
653
654* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
655- Change the default rendering style to be "Best Shapes", not "Best Contrast"
656
657* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
658- Add Xft / XSETTINGS support
659
660* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
661- fix %%post so schemas get installed
662 
663* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
664- 2.0.0
665- add new default editor schemas
666- fix find_lang
667
668* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
669- rebuild for new libraries
670- remove a no-longer-existing schemas file from post
671- use desktop-file-install
672
673* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
674- rebuild in different environment
675
676* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
677- rebuild with new dependent libs
678
679* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
680- rebuild in different environment
681
682* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
683- rebuild in different environment
684- build requires bonobo-activation
685
686* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
687- 1.99.10
688
689* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
690- 1.99.9
691
692* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
693- Move to GNOME 2 version
694
695* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
696- merge in translations
697
698* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
699- Make the theme selector write fontsets, not fonts (#62413)
700
701* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
702- really put screensaver capplet back (I think)
703
704* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
705- revert xscreensaver change
706
707* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
708- init "Scaled" radio button correctly #61913
709
710* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
711- change path to windowmaker config tool again, #61824
712
713* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
714- rather than keep patching and patching it, use xscreensaver's own
715  capplet
716
717* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
718- rebuild in Hampton
719
720* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
721- Rebuild package.
722
723* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
724- rebuilt against new openssl
725
726* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
727- automake14
728- don't run auto* again in ccsingle subdir, not sure why we did that
729
730* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
731- rebuild with new gnome-libs so that libcapplet has right cflags/libs
732- pixbufflags patch to make the rebuild work
733- compileflags patch to make control-center-single work
734
735* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
736- fix #52831 (UI properties in Programs menu)
737
738* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
739- Add po files from sources.redhat.com
740
741* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
742- set the _XROOTCOLOR_PIXEL property, should fix
743  bug #52141
744
745* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
746- Update translation.
747- Add CJK fontset patch
748
749* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
750- New control-center-single to handle exiting, #51665
751
752* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
753- remove .desktop file for gnomecc, so it won't appear
754  in panel menu, #49653
755
756* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
757- allow to build without depending on control-center-devel
758
759* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
760- Add BuildRequires
761
762* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
763- New version of control-center-single
764
765* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
766- Change default background to the same as the nautilus one
767
768* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
769- add hack to default to standalone control panels
770
771* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
772- Bump release + rebuild.
773
774* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
775- putting in tree for David
776
777* Tue May 22 2001 David Sainty <dsainty@redhat.com>
778- improve DPMS patch for the try case, and enable patch
779
780* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
781- add patch to use xscreensaver's DPMS stuff, require that version
782
783* Fri Apr 20 2001  <jrb@redhat.com>
784- New Version (1.4.0.1)
785
786* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
787- kick the mixer once on startup if we aren't running esd
788
789* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
790- translations
791
792* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
793- Rebuild for GTK+-1.2.9 include paths
794
795* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
796- langify
797- don't define and use "ver" at the top of the file
798- move changelog to sane location
799
800* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
801- Apply patch from bug #23782 to see how it works
802
803* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
804- Include fvwm2.desktop in WM's
805
806* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
807- Added Japanese patch.
808
809* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
810- Update release.
811
812* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
813- Again, fix problem with solid backgrounds in bg-properties capplet
814  (patch got lost somewhere)
815
816* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
817- Up Epoch and release
818
819* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
820- Handle unreadable desktop files without crashing
821
822* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
823- Fix problem with backgrounds bigger than screen.
824
825* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
826- Fix problem when ~/.gtkrc does not already exist.
827- Fix problem with solid backgrounds in bg-properties capplet
828
829* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
830- Sort of fix problem with people hitting OK while the
831  "Save Session" dialog is still up. (Session won't be saved,
832  but at least the selected entry will be correctly kept.)
833- Fix history list in background properties capplet
834- Fix problems with temporary files in theme-selector capplet
835
836* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
837- automatic rebuild
838
839* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
840- Require redhat-logos
841- Some spec file and FHS fixes
842- reposition embedded logo a bit
843
844* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
845- Add big change to use gdk-pixbuf for backgrounds and add
846  the ability to emboss the background with a logo
847
848* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
849- revert .so strip
850
851* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
852- strip .so lib
853- use configure macro
854
855* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
856- changed to work with 1.0.40
857
858* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
859- Added fixrevert bug to fix bug in theme selector.
860
861* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
862- updated RPM to use new control-center.
863
864* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
865- fixed sound-properties to only disable sound when run with --init-settings-..
866- removed debugging output from several capplets, fixed try behaviour of sm and
867  gnome-edit capplets
868- fixed bug in screensaver and background props
869- added new icons
870
871* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
872- added a patch to fix the close dialog
873- added a patch to limit the number of bg's in the history.
874
875* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
876- vesion 1.0.5
877- removed all patches >10 other then dontstartesd.
878
879* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
880- removed UI props till it works better
881
882* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
883- make sure we DONT inadvertantly start esd by calling esd_open_...
884
885* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
886- changed default bg color to '#356390'
887
888* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
889- prime file selector path for browse in background-props if
890  "/usr/share/pixmaps/backgrounds/" exists.
891- fix behavior of file selector when you delete/cancel/ok it
892
893* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
894- added patch to fix trying in theme selector
895- disabled crystal screensaver, it does evil things to preview in capplet
896
897* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
898- version 1.0.4, fixes problems with sndprops and theme props among
899  other things.
900
901* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
902- fix sound-properties capplet so Try/Revert doesnt come on unless user
903  changes something
904- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
905- strip binaries
906
907* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
908- version 1.0.3
909- added patch to make esd release after 30 sec of inactivity
910
911* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
912- version 1.0.2
913- turned off sound by default
914
915* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
916- version 1.0.1
917
918* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
919- version 0.99.8.1
920- added etc/CORBA/servers/* to file list
921
922* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
923- update to 0.99.8
924- added /usr/lib/cappletConf.sh
925
926* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
927- update to 0.99.5.1
928
929* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
930- update to 0.99.5
931
932* Mon Jan 20 1999 Michael Fulbright <drmike@redhat.com>
933- update to 0.99.3.1
934
935* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
936- update to 0.99.3
937- seems like patch for non-standard xscreensaver placement was already in
938  prestine sources(?)
939
940* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
941- updated to 0.99.1
942- temporary hack patch to get path to work to non-standard placement
943  of xscreensaver binaries in RH 5.2
944
945* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
946- Created for the new control-center branch
947
Note: See TracBrowser for help on using the repository browser.