source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 5168

Revision 5168, 30.4 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pango_version 1.28.4
2%define gtk3_version 3.2.0
3%define gconf2_version 3.2.0
4%define gnome_desktop3_version 3.2.0
5%define libbonobo_version 2.32.0
6%define libgnomekbd_version 2.32.0
7%define gnome_vfs2_version 2.24.4
8%define desktop_file_utils_version 0.3
9%define startup_notification_version 0.7
10%define libxklavier_version 5.0
11%define gnome_doc_utils_version 0.20
12%define gnome_menus_version 2.30.0
13%define vine_menus_version 3.0
14%define metacity_version 2.30.3
15%define evolution_data_server_version 2.32.0
16%define libcanberra_version 0.9
17%define usermode_version 1.83
18%define libnotify_version 0.7.3
19%define nm_version 0.9.0
20
21Summary: GNOME Control Center.
22Summary(ja): GNOME コントロールセンター
23Name: control-center
24Version: 3.2.2
25Release: 1%{?_dist_release}
26License: GPLv2+ and GFDL+
27Group: User Interface/Desktops
28URL: http://www.gnome.org
29
30Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.2/gnome-control-center-%{version}.tar.xz
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: inagaki, daisuke, Takemikaduchi
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37
38Obsoletes: gnome, control-center-devel < 2.0
39Obsoletes: fontilus, themus
40
41Provides: gnome-volume-manager < 2.25
42Obsoletes: gnome-volume-manager < 2.25
43
44Requires: metacity >= %{metacity_version}
45Requires: usermode >= %{usermode_version}
46Requires: gnome-settings-daemon
47Requires: gnome-icon-theme
48Requires: gnome-desktop3 >= %{gnome_desktop_version}
49Requires: dbus-x11
50Requires: apg
51Requires(post,pre,preun): GConf2
52Requires(post,postun): desktop-file-utils shared-mime-info gtk3
53
54BuildRequires: gnome-common
55BuildRequires: pango-devel >= %{pango_version}
56BuildRequires: gtk3-devel >= %{gtk3_version}
57BuildRequires: GConf2-devel >= %{gconf2_version}
58BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
59BuildRequires: libbonobo-devel >= %{libbonobo_version}
60BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
61BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
62BuildRequires: startup-notification-devel >= %{startup_notification_version}
63BuildRequires: libxklavier-devel >= %{libxklavier_version}
64BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
65BuildRequires: gnome-panel-devel
66BuildRequires: metacity-devel >= %{metacity_version}
67BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
68BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
69BuildRequires: gnome-settings-daemon-devel
70BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
71BuildRequires: nautilus-devel
72BuildRequires: alsa-lib-devel
73BuildRequires: autoconf
74BuildRequires: gettext-devel
75BuildRequires: librsvg2-devel
76BuildRequires: libXScrnSaver-devel
77BuildRequires: libXxf86misc-devel
78BuildRequires: libSM-devel
79BuildRequires: unique3-devel
80BuildRequires: polkit-devel
81BuildRequires: libgtop2-devel
82BuildRequires: upower-devel
83BuildRequires: pulseaudio-libs-devel
84BuildRequires: cups-devel
85BuildRequires: cheese-devel
86BuildRequires: gstreamer-plugins-base-devel
87BuildRequires: gnome-online-accounts-devel
88BuildRequires: colord-devel
89BuildRequires: NetworkManager-gtk-devel >= %{nm_version}
90BuildRequires: libnotify-devel >= %{libnotify_version}
91
92%description
93GNOME (the GNU Network Object Model Environment) is an attractive and
94easy-to-use GUI desktop environment. The control-center package
95provides the GNOME Control Center utilities that allow you to setup
96and configure your system's GNOME environment (things like the desktop
97background and theme, the screensaver, the window manager, system
98sounds, and mouse behavior).
99
100If you install GNOME, you need to install control-center.
101
102%description -l ja
103GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
104GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
105環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
106す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
107ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
108
109%package devel
110Summary: Development files for GNOME Control Center
111Summary(ja): GNOME コントロールセンターの開発用ファイル
112Group: Development/Libraries
113Requires: %{name} = %{version}-%{release}
114
115%description devel
116Development tool for GNOME Control Center
117
118%descriotion -l ja devel
119GNOME コントロールセンターの開発用ファイルが含まれています。
120
121%prep
122%setup -q -n gnome-control-center-%{version}
123
124%build
125%configure --disable-static  \
126    --disable-scrollkeeper \
127    --disable-update-mimedb \
128    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
129
130# drop unneeded direct library deps with --as-needed
131# libtool doesn't make this easy, so we do it the hard way
132sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
133
134make %{?_smp_mflags}
135
136%install
137rm -rf $RPM_BUILD_ROOT
138
139export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
140make install DESTDIR=$RPM_BUILD_ROOT
141unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
142
143for i in apps_gnome_settings_daemon_default_editor.schemas              \
144            apps_gnome_settings_daemon_keybindings.schemas              \
145            apps_gnome_settings_daemon_screensaver.schemas              \
146            desktop_gnome_font_rendering.schemas ; do                   \
147            rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/$i ;      \
148done
149
150#desktop-file-install --vendor gnome --delete-original                   \
151#  --dir $RPM_BUILD_ROOT%{_datadir}/applications                                \
152#  --add-only-show-in GNOME                                              \
153#  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
154
155# install visual effect icons
156# install -m644 visual-effects/*.svg $RPM_BUILD_ROOT%{_datadir}/gnome-control-center/pixmaps/
157
158# we do want this
159mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
160
161# We don't want these
162rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
163rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
164
165# remove useless libtool archive files
166find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
167
168# don't package mime caches
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
170rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
171rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
172rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
173rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
174rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
175rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
176rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
177
178rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
179rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
180
181%find_lang gnome-control-center-2.0
182%find_lang gnome-control-center-2.0-timezones
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187%post
188/sbin/ldconfig
189
190update-desktop-database %{_datadir}/applications >& /dev/null ||:
191update-mime-database %{_datadir}/mime > /dev/null
192touch --no-create %{_datadir}/icons/hicolor
193if [ -x /usr/bin/gtk-update-icon-cache ]; then
194  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
195fi
196
197%postun
198/sbin/ldconfig
199update-desktop-database %{_datadir}/applications >& /dev/null ||:
200update-mime-database %{_datadir}/mime > /dev/null
201touch --no-create %{_datadir}/icons/hicolor
202if [ -x /usr/bin/gtk-update-icon-cache ]; then
203  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
204fi
205
206%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
207%defattr(-, root, root)
208%doc AUTHORS COPYING ChangeLog NEWS README
209%dir %{_datadir}/gnome/wm-properties
210%dir %{_datadir}/gnome-control-center
211%{_datadir}/applications/*
212%{_datadir}/desktop-directories/*
213%{_datadir}/gnome/help/*
214%{_datadir}/gnome-control-center/datetime
215%{_datadir}/gnome-control-center/icons
216%{_datadir}/gnome-control-center/keybindings
217%{_datadir}/gnome-control-center/pixmaps
218%{_datadir}/gnome-control-center/sounds
219%{_datadir}/gnome-control-center/ui
220%{_datadir}/icons/*
221%{_datadir}/omf/control-center
222%{_datadir}/pixmaps/*
223%{_datadir}/sounds/*
224# list all binaries explicitly, so we notice if one goes missing
225%{_bindir}/gnome-control-center
226%{_bindir}/gnome-sound-applet
227%{_libdir}/*.so.*
228%{_libdir}/control-center-1/panels/*.so
229#{_libexecdir}/*
230%{_sysconfdir}/xdg/menus/gnomecc.menu
231%{_sysconfdir}/xdg/autostart/gnome-sound-applet.desktop
232
233%files devel
234%defattr(-, root, root)
235%{_datadir}/pkgconfig/*
236%{_libdir}/*.so
237
238
239%changelog
240* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
241- new upstream release
242
243* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
244- new upstream release
245
246* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
247- rebuild with NetworkManager-0.9
248- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
249
250* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
251- new upstream release
252
253* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
254- new upstream release
255
256* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
257- new upstream release
258- remove Patch0
259
260* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
261- new upstream release
262- add BuildRequires: libnotify-devel
263- add Patch0 (control-center-3.1.5-crash-layout.patch)
264
265* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
266- new upstream release
267- change BuildRequires: gtk3-devel instead of gtk2-devel
268- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
269- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
270- change BuildRequires: unique3-devel instead of unique-devel
271- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
272                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
273                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
274- add Requires: apg
275- drop all Patches
276- add Provides: and Obsoletes: gnome-volume-manager
277
278* Sun Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
279- update desktop-effect-integration patch
280  - fix freeze on changing metacity to compiz
281  - run compiz directly instead of compiz-gtk
282  - drop use of jockey-gtk
283- update ja.po
284
285* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
286- new upstream release
287
288* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
289- update translation.
290
291* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
292- update translation.
293
294* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
295- update Source21(gnome-control-center-2.32.0-vine.ja.po)
296
297* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
298- new upstream release
299- drop Patch22, Patch30, Patch52
300- fix %files
301
302* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
303- rebuilt with rpm-4.8.1 for pkg-config (too)
304
305* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
306- rebuild with rpm-4.8.1 for pkg-config file
307- add Requires: %{name}=%{version}-%{release}
308
309* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
310- rebuild with evolution-data-server-2.30.2
311
312* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
313- new upstream release
314
315* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
316- new upstream release
317- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
318- add BuildRequires: gnome-common, unique-devel
319
320* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
321- enable Patch101,110-112 and 500
322
323* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
324- new upstream release
325- disabled Patch101, 110-112 and 500
326
327* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
328- update notification-theme.patch
329  - use vine theme if NotificationTheme is not set in meta-theme.
330
331* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
332- add Patch510: use Sans for font-properties sample font.
333- add BR: librsvg2-devel, libXScrnSaver-devel
334- remove BR: esound
335
336* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
337- add Patch37: Don't rely on _BACKUP property for xkb initialization
338
339* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
340- renumber patch10 to patch1010
341  - do not check gdm fprint plugin
342- add Patch101: show aspect in drop down menu
343- add Patch110: modify gnome-mouse-properties to fit smaller screen
344- add Patch111: modify gnome-about-me to fit smaller screen
345- add Patch112: modify gnome-display-properties to fit smaller screen
346
347* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
348- update Patch100 to use compiz-gtk instead of compiz
349
350* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
351- update ja.po
352
353* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
354- import upstream patchs (10,22,3[0-6])
355
356* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
357- add nautilus-devel to BR: not Requires:
358
359* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
360- new upstream release
361- update ja.po
362- add BR: nautilus-devel
363
364* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
365- drop Patch20 which need new XInput API
366- update Patch23
367
368* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
369- add Patch20,22.23 from ubuntu
370  - patch20 to add touchpad configuration
371  - patch22 to add aspect setting in randr capplet
372  - patch23 to integrate desktop setting into appearance-properties
373
374* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
375- new upstream release
376
377* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
378- new upstream release
379
380* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
381- add gnome-typing-monitor to %%files
382
383* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
384- add Patch100 for new RandR capplet. (fc)
385
386* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
387- new upstream release
388- dropped Patch8 (merged into upstream)
389
390* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
391- new upstream release
392- added Patch7 and Patch8 from Fedora
393  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
394  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
395  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
396  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
397  - Remove a nonfunctional button from the a11y preferences
398- added BuildRequires: gnome-settings-daemon, gnome-panel
399- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
400- removed Requires: xscreensaver
401
402* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
403- new upstream release based on Fedora
404- added BuildRequires: gnome-settings-daemon
405
406* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
407- new upstream release based on Fedora
408  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
409  - Fix the orca command in the default applications capplet (#351471)
410
411* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
412- add BuildReq: libgnomekbd-devel
413
414* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
415- rebuilt with evolution-data-server-devel-1.10.1
416
417* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
418- add BuildReq: evolution-data-server-devel
419
420* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
421- new upstream release
422- remove unneeded? patch10
423
424* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
425- added Patch10 to supress /dev/pmu warning messages on some ppc models
426
427* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
428- new upstream release
429
430* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
431- new upstream release
432
433* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
434- run gtk-update-icon-cache in %%post script.
435
436* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
437- new upstream release
438- drop Patch10,it is merged in upstream
439
440* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
441- add Patch10 for correct textdomain name in
442  default-applications-properties(Bug332833)
443- add Patch100 for change default-applications settings for vine
444
445* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
446- new upstream release
447
448* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
449- new upstream release
450
451* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
452- new upstream release
453
454* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
455- new upstream release
456- enable alsa support
457
458* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
459- new upstream release
460
461* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
462- fixed type in %%post script
463
464* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
465- clear the old defaults of xkb
466
467* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
468- remove bonobo-activation dependency
469
470* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
471- new upstream version
472
473* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
474- new upstream release
475- add Japanese summay to devel package
476
477* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
478- new upstream release
479
480* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
481- modify patch11 to use NeoVine theme instead of BeCool.
482
483* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
484- rebuild with new toolchain
485
486* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
487- new upstream release
488- remove obsolete ja.po
489
490* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
491- change required version of metacity to 2.4.34 on alpha
492
493* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
494- new upstream release
495
496* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
497- new upstream release
498
499* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
500- add more missing files and schemas...
501
502* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
503- add missing file in %{_libdir}/gnome-vfs-2.0/
504
505* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
506- new upstream release
507- this is experimental version
508- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
509
510* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
511- new upstream release
512
513* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
514- import patch6 (upstream paches) from rawhide package.
515
516* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
517- import patch1-5 (upstream paches) from rawhide package.
518
519* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
520- new upstream release
521
522* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
523- rebuild
524
525* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
526- new upstream release
527
528* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
529- new upstream release
530
531* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
532- new upstream release
533
534* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
535- change default gtk1 theme from Raleigh to BeCool.
536
537* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
538- add BuildRequires/Requires.
539- fixed kanjicode of specfile
540
541* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
542- remove bogus message in %%post scripts.
543
544* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
545- add patch10 to modify some desktop files
546- update ja.po
547
548* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
549- update ja.po
550
551* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
552- update ja.po
553
554* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
555- new upstream release
556
557* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
558- add devel package
559- add window-manager-settings files.
560
561* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
562- modify dependancies.
563
564* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
565- build for Vine Linux
566- new upstream release from gnome-2.1.4
567
568* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
569- Allow setting custom mime handlers
570
571* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
572- make desktop file symlinks absolute #71991
573- add po files from cvs.gnome.org
574
575* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
576- Fix up keyboard handling
577
578* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
579- Fixes for #68735
580
581* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
582- New version.  Fix up metacity theme locations
583
584* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
585- Switch the gtk1 theme along with the gtk2 theme
586- Add the ability to switch the window manager theme through the theme capplet
587- Add two more font options to the font property dialog
588- Add a bunch of missing unrefs of the result of gconf_client_get_default()
589
590* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
591- fix desktop files more
592- copy icons to /usr/share/pixmaps
593
594* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
595- munge the desktop files correctly
596- obsolete control-center-devel, #69168
597- replace gnomecc.desktop with a file from redhat-menus
598
599* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
600- Fix crasher bug in xftprefs patch
601
602* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
603- Change the default rendering style to be "Best Shapes", not "Best Contrast"
604
605* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
606- Add Xft / XSETTINGS support
607
608* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
609- fix %%post so schemas get installed
610 
611* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
612- 2.0.0
613- add new default editor schemas
614- fix find_lang
615
616* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
617- rebuild for new libraries
618- remove a no-longer-existing schemas file from post
619- use desktop-file-install
620
621* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
622- rebuild in different environment
623
624* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
625- rebuild with new dependent libs
626
627* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
628- rebuild in different environment
629
630* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
631- rebuild in different environment
632- build requires bonobo-activation
633
634* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
635- 1.99.10
636
637* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
638- 1.99.9
639
640* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
641- Move to GNOME 2 version
642
643* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
644- merge in translations
645
646* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
647- Make the theme selector write fontsets, not fonts (#62413)
648
649* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
650- really put screensaver capplet back (I think)
651
652* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
653- revert xscreensaver change
654
655* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
656- init "Scaled" radio button correctly #61913
657
658* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
659- change path to windowmaker config tool again, #61824
660
661* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
662- rather than keep patching and patching it, use xscreensaver's own
663  capplet
664
665* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
666- rebuild in Hampton
667
668* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
669- Rebuild package.
670
671* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
672- rebuilt against new openssl
673
674* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
675- automake14
676- don't run auto* again in ccsingle subdir, not sure why we did that
677
678* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
679- rebuild with new gnome-libs so that libcapplet has right cflags/libs
680- pixbufflags patch to make the rebuild work
681- compileflags patch to make control-center-single work
682
683* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
684- fix #52831 (UI properties in Programs menu)
685
686* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
687- Add po files from sources.redhat.com
688
689* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
690- set the _XROOTCOLOR_PIXEL property, should fix
691  bug #52141
692
693* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
694- Update translation.
695- Add CJK fontset patch
696
697* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
698- New control-center-single to handle exiting, #51665
699
700* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
701- remove .desktop file for gnomecc, so it won't appear
702  in panel menu, #49653
703
704* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
705- allow to build without depending on control-center-devel
706
707* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
708- Add BuildRequires
709
710* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
711- New version of control-center-single
712
713* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
714- Change default background to the same as the nautilus one
715
716* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
717- add hack to default to standalone control panels
718
719* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
720- Bump release + rebuild.
721
722* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
723- putting in tree for David
724
725* Tue May 22 2001 David Sainty <dsainty@redhat.com>
726- improve DPMS patch for the try case, and enable patch
727
728* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
729- add patch to use xscreensaver's DPMS stuff, require that version
730
731* Fri Apr 20 2001  <jrb@redhat.com>
732- New Version (1.4.0.1)
733
734* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
735- kick the mixer once on startup if we aren't running esd
736
737* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
738- translations
739
740* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
741- Rebuild for GTK+-1.2.9 include paths
742
743* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
744- langify
745- don't define and use "ver" at the top of the file
746- move changelog to sane location
747
748* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
749- Apply patch from bug #23782 to see how it works
750
751* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
752- Include fvwm2.desktop in WM's
753
754* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
755- Added Japanese patch.
756
757* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
758- Update release.
759
760* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
761- Again, fix problem with solid backgrounds in bg-properties capplet
762  (patch got lost somewhere)
763
764* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
765- Up Epoch and release
766
767* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
768- Handle unreadable desktop files without crashing
769
770* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
771- Fix problem with backgrounds bigger than screen.
772
773* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
774- Fix problem when ~/.gtkrc does not already exist.
775- Fix problem with solid backgrounds in bg-properties capplet
776
777* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
778- Sort of fix problem with people hitting OK while the
779  "Save Session" dialog is still up. (Session won't be saved,
780  but at least the selected entry will be correctly kept.)
781- Fix history list in background properties capplet
782- Fix problems with temporary files in theme-selector capplet
783
784* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
785- automatic rebuild
786
787* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
788- Require redhat-logos
789- Some spec file and FHS fixes
790- reposition embedded logo a bit
791
792* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
793- Add big change to use gdk-pixbuf for backgrounds and add
794  the ability to emboss the background with a logo
795
796* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
797- revert .so strip
798
799* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
800- strip .so lib
801- use configure macro
802
803* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
804- changed to work with 1.0.40
805
806* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
807- Added fixrevert bug to fix bug in theme selector.
808
809* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
810- updated RPM to use new control-center.
811
812* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
813- fixed sound-properties to only disable sound when run with --init-settings-..
814- removed debugging output from several capplets, fixed try behaviour of sm and
815  gnome-edit capplets
816- fixed bug in screensaver and background props
817- added new icons
818
819* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
820- added a patch to fix the close dialog
821- added a patch to limit the number of bg's in the history.
822
823* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
824- vesion 1.0.5
825- removed all patches >10 other then dontstartesd.
826
827* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
828- removed UI props till it works better
829
830* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
831- make sure we DONT inadvertantly start esd by calling esd_open_...
832
833* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
834- changed default bg color to '#356390'
835
836* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
837- prime file selector path for browse in background-props if
838  "/usr/share/pixmaps/backgrounds/" exists.
839- fix behavior of file selector when you delete/cancel/ok it
840
841* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
842- added patch to fix trying in theme selector
843- disabled crystal screensaver, it does evil things to preview in capplet
844
845* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
846- version 1.0.4, fixes problems with sndprops and theme props among
847  other things.
848
849* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
850- fix sound-properties capplet so Try/Revert doesnt come on unless user
851  changes something
852- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
853- strip binaries
854
855* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
856- version 1.0.3
857- added patch to make esd release after 30 sec of inactivity
858
859* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
860- version 1.0.2
861- turned off sound by default
862
863* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
864- version 1.0.1
865
866* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
867- version 0.99.8.1
868- added etc/CORBA/servers/* to file list
869
870* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
871- update to 0.99.8
872- added /usr/lib/cappletConf.sh
873
874* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
875- update to 0.99.5.1
876
877* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
878- update to 0.99.5
879
880* Mon Jan 20 1999 Michael Fulbright <drmike@redhat.com>
881- update to 0.99.3.1
882
883* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
884- update to 0.99.3
885- seems like patch for non-standard xscreensaver placement was already in
886  prestine sources(?)
887
888* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
889- updated to 0.99.1
890- temporary hack patch to get path to work to non-standard placement
891  of xscreensaver binaries in RH 5.2
892
893* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
894- Created for the new control-center branch
895
Note: See TracBrowser for help on using the repository browser.