source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 4933

Revision 4933, 30.2 KB checked in by Takemikaduchi, 13 years ago (diff)

NEW: latexila, latexmk, rubber
mono, NetworkManager: new upstream release
control-center: rebuild with NetworkManager-0.9

Line 
1%define pango_version 1.28.4
2%define gtk3_version 3.2.0
3%define gconf2_version 3.2.0
4%define gnome_desktop3_version 3.2.0
5%define libbonobo_version 2.32.0
6%define libgnomekbd_version 2.32.0
7%define gnome_vfs2_version 2.24.4
8%define desktop_file_utils_version 0.3
9%define startup_notification_version 0.7
10%define libxklavier_version 5.0
11%define gnome_doc_utils_version 0.20
12%define gnome_menus_version 2.30.0
13%define vine_menus_version 3.0
14%define metacity_version 2.30.3
15%define evolution_data_server_version 2.32.0
16%define libcanberra_version 0.9
17%define usermode_version 1.83
18%define libnotify_version 0.7.3
19%define nm_version 0.9.0
20
21Summary: GNOME Control Center.
22Summary(ja): GNOME コントロールセンター
23Name: control-center
24Version: 3.2.0
25Release: 2%{?_dist_release}
26License: GPLv2+ and GFDL+
27Group: User Interface/Desktops
28URL: http://www.gnome.org
29
30Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.2/gnome-control-center-%{version}.tar.xz
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: inagaki, daisuke, Takemikaduchi
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37
38Obsoletes: gnome, control-center-devel < 2.0
39Obsoletes: fontilus, themus
40
41Provides: gnome-volume-manager < 2.25
42Obsoletes: gnome-volume-manager < 2.25
43
44Requires: metacity >= %{metacity_version}
45Requires: usermode >= %{usermode_version}
46Requires: gnome-settings-daemon
47Requires: gnome-icon-theme
48Requires: gnome-desktop3 >= %{gnome_desktop_version}
49Requires: dbus-x11
50Requires: apg
51Requires(post,pre,preun): GConf2
52Requires(post,postun): desktop-file-utils shared-mime-info gtk3
53
54BuildRequires: gnome-common
55BuildRequires: pango-devel >= %{pango_version}
56BuildRequires: gtk3-devel >= %{gtk3_version}
57BuildRequires: GConf2-devel >= %{gconf2_version}
58BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
59BuildRequires: libbonobo-devel >= %{libbonobo_version}
60BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
61BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
62BuildRequires: startup-notification-devel >= %{startup_notification_version}
63BuildRequires: libxklavier-devel >= %{libxklavier_version}
64BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
65BuildRequires: gnome-panel-devel
66BuildRequires: metacity-devel >= %{metacity_version}
67BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
68BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
69BuildRequires: gnome-settings-daemon-devel
70BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
71BuildRequires: nautilus-devel
72BuildRequires: alsa-lib-devel
73BuildRequires: autoconf
74BuildRequires: gettext-devel
75BuildRequires: librsvg2-devel
76BuildRequires: libXScrnSaver-devel
77BuildRequires: libXxf86misc-devel
78BuildRequires: libSM-devel
79BuildRequires: unique3-devel
80BuildRequires: polkit-devel
81BuildRequires: libgtop2-devel
82BuildRequires: upower-devel
83BuildRequires: pulseaudio-libs-devel
84BuildRequires: cups-devel
85BuildRequires: cheese-devel
86BuildRequires: gstreamer-plugins-base-devel
87BuildRequires: gnome-online-accounts-devel
88BuildRequires: colord-devel
89BuildRequires: NetworkManager-gtk-devel >= %{nm_version}
90BuildRequires: libnotify-devel >= %{libnotify_version}
91
92%description
93GNOME (the GNU Network Object Model Environment) is an attractive and
94easy-to-use GUI desktop environment. The control-center package
95provides the GNOME Control Center utilities that allow you to setup
96and configure your system's GNOME environment (things like the desktop
97background and theme, the screensaver, the window manager, system
98sounds, and mouse behavior).
99
100If you install GNOME, you need to install control-center.
101
102%description -l ja
103GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
104GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
105環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
106す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
107ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
108
109%package devel
110Summary: Development files for GNOME Control Center
111Summary(ja): GNOME コントロールセンターの開発用ファイル
112Group: Development/Libraries
113Requires: %{name} = %{version}-%{release}
114
115%description devel
116Development tool for GNOME Control Center
117
118%descriotion -l ja devel
119GNOME コントロールセンターの開発用ファイルが含まれています。
120
121%prep
122%setup -q -n gnome-control-center-%{version}
123
124%build
125%configure --disable-static  \
126    --disable-scrollkeeper \
127    --disable-update-mimedb \
128    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
129
130# drop unneeded direct library deps with --as-needed
131# libtool doesn't make this easy, so we do it the hard way
132sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
133
134make %{?_smp_mflags}
135
136%install
137rm -rf $RPM_BUILD_ROOT
138
139export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
140make install DESTDIR=$RPM_BUILD_ROOT
141unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
142
143for i in apps_gnome_settings_daemon_default_editor.schemas              \
144            apps_gnome_settings_daemon_keybindings.schemas              \
145            apps_gnome_settings_daemon_screensaver.schemas              \
146            desktop_gnome_font_rendering.schemas ; do                   \
147            rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/$i ;      \
148done
149
150#desktop-file-install --vendor gnome --delete-original                   \
151#  --dir $RPM_BUILD_ROOT%{_datadir}/applications                                \
152#  --add-only-show-in GNOME                                              \
153#  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
154
155# install visual effect icons
156# install -m644 visual-effects/*.svg $RPM_BUILD_ROOT%{_datadir}/gnome-control-center/pixmaps/
157
158# we do want this
159mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
160
161# We don't want these
162rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
163rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
164
165# remove useless libtool archive files
166find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
167
168# don't package mime caches
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
170rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
171rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
172rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
173rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
174rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
175rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
176rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
177
178rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
179rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
180
181%find_lang gnome-control-center-2.0
182%find_lang gnome-control-center-2.0-timezones
183
184%clean
185rm -rf $RPM_BUILD_ROOT
186
187%post
188/sbin/ldconfig
189
190update-desktop-database %{_datadir}/applications >& /dev/null ||:
191update-mime-database %{_datadir}/mime > /dev/null
192touch --no-create %{_datadir}/icons/hicolor
193if [ -x /usr/bin/gtk-update-icon-cache ]; then
194  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
195fi
196
197%postun
198/sbin/ldconfig
199update-desktop-database %{_datadir}/applications >& /dev/null ||:
200update-mime-database %{_datadir}/mime > /dev/null
201touch --no-create %{_datadir}/icons/hicolor
202if [ -x /usr/bin/gtk-update-icon-cache ]; then
203  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
204fi
205
206%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
207%defattr(-, root, root)
208%doc AUTHORS COPYING ChangeLog NEWS README
209%dir %{_datadir}/gnome/wm-properties
210%dir %{_datadir}/gnome-control-center
211%{_datadir}/applications/*
212%{_datadir}/desktop-directories/*
213%{_datadir}/gnome/help/*
214%{_datadir}/gnome-control-center/datetime
215%{_datadir}/gnome-control-center/icons
216%{_datadir}/gnome-control-center/keybindings
217%{_datadir}/gnome-control-center/pixmaps
218%{_datadir}/gnome-control-center/sounds
219%{_datadir}/gnome-control-center/ui
220%{_datadir}/icons/*
221%{_datadir}/omf/control-center
222%{_datadir}/pixmaps/*
223%{_datadir}/sounds/*
224# list all binaries explicitly, so we notice if one goes missing
225%{_bindir}/gnome-control-center
226%{_bindir}/gnome-sound-applet
227%{_libdir}/*.so.*
228%{_libdir}/control-center-1/panels/*.so
229#{_libexecdir}/*
230%{_sysconfdir}/xdg/menus/gnomecc.menu
231%{_sysconfdir}/xdg/autostart/gnome-sound-applet.desktop
232
233%files devel
234%defattr(-, root, root)
235%{_datadir}/pkgconfig/*
236%{_libdir}/*.so
237
238
239%changelog
240* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
241- rebuild with NetworkManager-0.9
242- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
243
244* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
245- new upstream release
246
247* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
248- new upstream release
249
250* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
251- new upstream release
252- remove Patch0
253
254* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
255- new upstream release
256- add BuildRequires: libnotify-devel
257- add Patch0 (control-center-3.1.5-crash-layout.patch)
258
259* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
260- new upstream release
261- change BuildRequires: gtk3-devel instead of gtk2-devel
262- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
263- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
264- change BuildRequires: unique3-devel instead of unique-devel
265- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
266                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
267                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
268- add Requires: apg
269- drop all Patches
270- add Provides: and Obsoletes: gnome-volume-manager
271
272* Sun Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
273- update desktop-effect-integration patch
274  - fix freeze on changing metacity to compiz
275  - run compiz directly instead of compiz-gtk
276  - drop use of jockey-gtk
277- update ja.po
278
279* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
280- new upstream release
281
282* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
283- update translation.
284
285* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
286- update translation.
287
288* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
289- update Source21(gnome-control-center-2.32.0-vine.ja.po)
290
291* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
292- new upstream release
293- drop Patch22, Patch30, Patch52
294- fix %files
295
296* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
297- rebuilt with rpm-4.8.1 for pkg-config (too)
298
299* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
300- rebuild with rpm-4.8.1 for pkg-config file
301- add Requires: %{name}=%{version}-%{release}
302
303* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
304- rebuild with evolution-data-server-2.30.2
305
306* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
307- new upstream release
308
309* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
310- new upstream release
311- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
312- add BuildRequires: gnome-common, unique-devel
313
314* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
315- enable Patch101,110-112 and 500
316
317* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
318- new upstream release
319- disabled Patch101, 110-112 and 500
320
321* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
322- update notification-theme.patch
323  - use vine theme if NotificationTheme is not set in meta-theme.
324
325* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
326- add Patch510: use Sans for font-properties sample font.
327- add BR: librsvg2-devel, libXScrnSaver-devel
328- remove BR: esound
329
330* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
331- add Patch37: Don't rely on _BACKUP property for xkb initialization
332
333* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
334- renumber patch10 to patch1010
335  - do not check gdm fprint plugin
336- add Patch101: show aspect in drop down menu
337- add Patch110: modify gnome-mouse-properties to fit smaller screen
338- add Patch111: modify gnome-about-me to fit smaller screen
339- add Patch112: modify gnome-display-properties to fit smaller screen
340
341* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
342- update Patch100 to use compiz-gtk instead of compiz
343
344* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
345- update ja.po
346
347* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
348- import upstream patchs (10,22,3[0-6])
349
350* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
351- add nautilus-devel to BR: not Requires:
352
353* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
354- new upstream release
355- update ja.po
356- add BR: nautilus-devel
357
358* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
359- drop Patch20 which need new XInput API
360- update Patch23
361
362* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
363- add Patch20,22.23 from ubuntu
364  - patch20 to add touchpad configuration
365  - patch22 to add aspect setting in randr capplet
366  - patch23 to integrate desktop setting into appearance-properties
367
368* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
369- new upstream release
370
371* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
372- new upstream release
373
374* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
375- add gnome-typing-monitor to %%files
376
377* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
378- add Patch100 for new RandR capplet. (fc)
379
380* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
381- new upstream release
382- dropped Patch8 (merged into upstream)
383
384* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
385- new upstream release
386- added Patch7 and Patch8 from Fedora
387  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
388  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
389  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
390  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
391  - Remove a nonfunctional button from the a11y preferences
392- added BuildRequires: gnome-settings-daemon, gnome-panel
393- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
394- removed Requires: xscreensaver
395
396* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
397- new upstream release based on Fedora
398- added BuildRequires: gnome-settings-daemon
399
400* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
401- new upstream release based on Fedora
402  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
403  - Fix the orca command in the default applications capplet (#351471)
404
405* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
406- add BuildReq: libgnomekbd-devel
407
408* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
409- rebuilt with evolution-data-server-devel-1.10.1
410
411* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
412- add BuildReq: evolution-data-server-devel
413
414* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
415- new upstream release
416- remove unneeded? patch10
417
418* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
419- added Patch10 to supress /dev/pmu warning messages on some ppc models
420
421* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
422- new upstream release
423
424* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
425- new upstream release
426
427* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
428- run gtk-update-icon-cache in %%post script.
429
430* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
431- new upstream release
432- drop Patch10,it is merged in upstream
433
434* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
435- add Patch10 for correct textdomain name in
436  default-applications-properties(Bug332833)
437- add Patch100 for change default-applications settings for vine
438
439* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
440- new upstream release
441
442* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
443- new upstream release
444
445* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
446- new upstream release
447
448* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
449- new upstream release
450- enable alsa support
451
452* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
453- new upstream release
454
455* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
456- fixed type in %%post script
457
458* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
459- clear the old defaults of xkb
460
461* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
462- remove bonobo-activation dependency
463
464* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
465- new upstream version
466
467* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
468- new upstream release
469- add Japanese summay to devel package
470
471* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
472- new upstream release
473
474* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
475- modify patch11 to use NeoVine theme instead of BeCool.
476
477* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
478- rebuild with new toolchain
479
480* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
481- new upstream release
482- remove obsolete ja.po
483
484* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
485- change required version of metacity to 2.4.34 on alpha
486
487* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
488- new upstream release
489
490* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
491- new upstream release
492
493* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
494- add more missing files and schemas...
495
496* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
497- add missing file in %{_libdir}/gnome-vfs-2.0/
498
499* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
500- new upstream release
501- this is experimental version
502- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
503
504* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
505- new upstream release
506
507* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
508- import patch6 (upstream paches) from rawhide package.
509
510* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
511- import patch1-5 (upstream paches) from rawhide package.
512
513* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
514- new upstream release
515
516* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
517- rebuild
518
519* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
520- new upstream release
521
522* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
523- new upstream release
524
525* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
526- new upstream release
527
528* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
529- change default gtk1 theme from Raleigh to BeCool.
530
531* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
532- add BuildRequires/Requires.
533- fixed kanjicode of specfile
534
535* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
536- remove bogus message in %%post scripts.
537
538* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
539- add patch10 to modify some desktop files
540- update ja.po
541
542* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
543- update ja.po
544
545* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
546- update ja.po
547
548* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
549- new upstream release
550
551* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
552- add devel package
553- add window-manager-settings files.
554
555* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
556- modify dependancies.
557
558* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
559- build for Vine Linux
560- new upstream release from gnome-2.1.4
561
562* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
563- Allow setting custom mime handlers
564
565* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
566- make desktop file symlinks absolute #71991
567- add po files from cvs.gnome.org
568
569* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
570- Fix up keyboard handling
571
572* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
573- Fixes for #68735
574
575* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
576- New version.  Fix up metacity theme locations
577
578* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
579- Switch the gtk1 theme along with the gtk2 theme
580- Add the ability to switch the window manager theme through the theme capplet
581- Add two more font options to the font property dialog
582- Add a bunch of missing unrefs of the result of gconf_client_get_default()
583
584* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
585- fix desktop files more
586- copy icons to /usr/share/pixmaps
587
588* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
589- munge the desktop files correctly
590- obsolete control-center-devel, #69168
591- replace gnomecc.desktop with a file from redhat-menus
592
593* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
594- Fix crasher bug in xftprefs patch
595
596* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
597- Change the default rendering style to be "Best Shapes", not "Best Contrast"
598
599* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
600- Add Xft / XSETTINGS support
601
602* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
603- fix %%post so schemas get installed
604 
605* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
606- 2.0.0
607- add new default editor schemas
608- fix find_lang
609
610* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
611- rebuild for new libraries
612- remove a no-longer-existing schemas file from post
613- use desktop-file-install
614
615* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
616- rebuild in different environment
617
618* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
619- rebuild with new dependent libs
620
621* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
622- rebuild in different environment
623
624* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
625- rebuild in different environment
626- build requires bonobo-activation
627
628* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
629- 1.99.10
630
631* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
632- 1.99.9
633
634* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
635- Move to GNOME 2 version
636
637* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
638- merge in translations
639
640* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
641- Make the theme selector write fontsets, not fonts (#62413)
642
643* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
644- really put screensaver capplet back (I think)
645
646* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
647- revert xscreensaver change
648
649* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
650- init "Scaled" radio button correctly #61913
651
652* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
653- change path to windowmaker config tool again, #61824
654
655* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
656- rather than keep patching and patching it, use xscreensaver's own
657  capplet
658
659* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
660- rebuild in Hampton
661
662* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
663- Rebuild package.
664
665* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
666- rebuilt against new openssl
667
668* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
669- automake14
670- don't run auto* again in ccsingle subdir, not sure why we did that
671
672* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
673- rebuild with new gnome-libs so that libcapplet has right cflags/libs
674- pixbufflags patch to make the rebuild work
675- compileflags patch to make control-center-single work
676
677* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
678- fix #52831 (UI properties in Programs menu)
679
680* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
681- Add po files from sources.redhat.com
682
683* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
684- set the _XROOTCOLOR_PIXEL property, should fix
685  bug #52141
686
687* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
688- Update translation.
689- Add CJK fontset patch
690
691* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
692- New control-center-single to handle exiting, #51665
693
694* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
695- remove .desktop file for gnomecc, so it won't appear
696  in panel menu, #49653
697
698* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
699- allow to build without depending on control-center-devel
700
701* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
702- Add BuildRequires
703
704* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
705- New version of control-center-single
706
707* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
708- Change default background to the same as the nautilus one
709
710* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
711- add hack to default to standalone control panels
712
713* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
714- Bump release + rebuild.
715
716* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
717- putting in tree for David
718
719* Tue May 22 2001 David Sainty <dsainty@redhat.com>
720- improve DPMS patch for the try case, and enable patch
721
722* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
723- add patch to use xscreensaver's DPMS stuff, require that version
724
725* Fri Apr 20 2001  <jrb@redhat.com>
726- New Version (1.4.0.1)
727
728* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
729- kick the mixer once on startup if we aren't running esd
730
731* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
732- translations
733
734* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
735- Rebuild for GTK+-1.2.9 include paths
736
737* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
738- langify
739- don't define and use "ver" at the top of the file
740- move changelog to sane location
741
742* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
743- Apply patch from bug #23782 to see how it works
744
745* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
746- Include fvwm2.desktop in WM's
747
748* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
749- Added Japanese patch.
750
751* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
752- Update release.
753
754* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
755- Again, fix problem with solid backgrounds in bg-properties capplet
756  (patch got lost somewhere)
757
758* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
759- Up Epoch and release
760
761* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
762- Handle unreadable desktop files without crashing
763
764* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
765- Fix problem with backgrounds bigger than screen.
766
767* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
768- Fix problem when ~/.gtkrc does not already exist.
769- Fix problem with solid backgrounds in bg-properties capplet
770
771* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
772- Sort of fix problem with people hitting OK while the
773  "Save Session" dialog is still up. (Session won't be saved,
774  but at least the selected entry will be correctly kept.)
775- Fix history list in background properties capplet
776- Fix problems with temporary files in theme-selector capplet
777
778* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
779- automatic rebuild
780
781* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
782- Require redhat-logos
783- Some spec file and FHS fixes
784- reposition embedded logo a bit
785
786* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
787- Add big change to use gdk-pixbuf for backgrounds and add
788  the ability to emboss the background with a logo
789
790* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
791- revert .so strip
792
793* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
794- strip .so lib
795- use configure macro
796
797* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
798- changed to work with 1.0.40
799
800* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
801- Added fixrevert bug to fix bug in theme selector.
802
803* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
804- updated RPM to use new control-center.
805
806* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
807- fixed sound-properties to only disable sound when run with --init-settings-..
808- removed debugging output from several capplets, fixed try behaviour of sm and
809  gnome-edit capplets
810- fixed bug in screensaver and background props
811- added new icons
812
813* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
814- added a patch to fix the close dialog
815- added a patch to limit the number of bg's in the history.
816
817* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
818- vesion 1.0.5
819- removed all patches >10 other then dontstartesd.
820
821* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
822- removed UI props till it works better
823
824* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
825- make sure we DONT inadvertantly start esd by calling esd_open_...
826
827* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
828- changed default bg color to '#356390'
829
830* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
831- prime file selector path for browse in background-props if
832  "/usr/share/pixmaps/backgrounds/" exists.
833- fix behavior of file selector when you delete/cancel/ok it
834
835* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
836- added patch to fix trying in theme selector
837- disabled crystal screensaver, it does evil things to preview in capplet
838
839* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
840- version 1.0.4, fixes problems with sndprops and theme props among
841  other things.
842
843* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
844- fix sound-properties capplet so Try/Revert doesnt come on unless user
845  changes something
846- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
847- strip binaries
848
849* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
850- version 1.0.3
851- added patch to make esd release after 30 sec of inactivity
852
853* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
854- version 1.0.2
855- turned off sound by default
856
857* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
858- version 1.0.1
859
860* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
861- version 0.99.8.1
862- added etc/CORBA/servers/* to file list
863
864* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
865- update to 0.99.8
866- added /usr/lib/cappletConf.sh
867
868* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
869- update to 0.99.5.1
870
871* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
872- update to 0.99.5
873
874* Mon Jan 20 1999 Michael Fulbright <drmike@redhat.com>
875- update to 0.99.3.1
876
877* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
878- update to 0.99.3
879- seems like patch for non-standard xscreensaver placement was already in
880  prestine sources(?)
881
882* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
883- updated to 0.99.1
884- temporary hack patch to get path to work to non-standard placement
885  of xscreensaver binaries in RH 5.2
886
887* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
888- Created for the new control-center branch
889
Note: See TracBrowser for help on using the repository browser.