source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 4616

Revision 4616, 29.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define pango_version 1.28.4
2%define gtk3_version 3.0.0
3%define gconf2_version 2.32.2
4%define gnome_desktop3_version 3.0.0
5%define libbonobo_version 2.32.0
6%define libgnomekbd_version 2.32.0
7%define gnome_vfs2_version 2.24.4
8%define desktop_file_utils_version 0.3
9%define startup_notification_version 0.7
10%define libxklavier_version 5.0
11%define gnome_doc_utils_version 0.20
12%define gnome_menus_version 2.30.0
13%define vine_menus_version 3.0
14%define metacity_version 2.30.3
15%define evolution_data_server_version 2.32.0
16%define libcanberra_version 0.9
17%define usermode_version 1.83
18
19Summary: GNOME Control Center.
20Summary(ja): GNOME コントロールセンター
21Name: control-center
22Version: 3.1.4
23Release: 1%{?_dist_release}
24License: GPLv2+ and GFDL+
25Group: User Interface/Desktops
26URL: http://www.gnome.org
27
28Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.1/gnome-control-center-%{version}.tar.xz
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: inagaki, daisuke, Takemikaduchi
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36Obsoletes: gnome, control-center-devel < 2.0
37Obsoletes: fontilus, themus
38
39Provides: gnome-volume-manager < 2.25
40Obsoletes: gnome-volume-manager < 2.25
41
42Requires: metacity >= %{metacity_version}
43Requires: usermode >= %{usermode_version}
44Requires: gnome-settings-daemon
45Requires: gnome-icon-theme
46Requires: gnome-desktop3 >= %{gnome_desktop_version}
47Requires: dbus-x11
48Requires: apg
49Requires(post,pre,preun): GConf2
50Requires(post,postun): desktop-file-utils shared-mime-info gtk3
51
52BuildRequires: gnome-common
53BuildRequires: pango-devel >= %{pango_version}
54BuildRequires: gtk3-devel >= %{gtk3_version}
55BuildRequires: GConf2-devel >= %{gconf2_version}
56BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
57BuildRequires: libbonobo-devel >= %{libbonobo_version}
58BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
59BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
60BuildRequires: startup-notification-devel >= %{startup_notification_version}
61BuildRequires: libxklavier-devel >= %{libxklavier_version}
62BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
63BuildRequires: gnome-panel-devel
64BuildRequires: metacity-devel >= %{metacity_version}
65BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
66BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
67BuildRequires: gnome-settings-daemon-devel
68BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
69BuildRequires: nautilus-devel
70BuildRequires: alsa-lib-devel
71BuildRequires: autoconf
72BuildRequires: gettext-devel
73BuildRequires: librsvg2-devel
74BuildRequires: libXScrnSaver-devel
75BuildRequires: libXxf86misc-devel
76BuildRequires: libSM-devel
77BuildRequires: unique3-devel
78BuildRequires: polkit-devel
79BuildRequires: libgtop2-devel
80BuildRequires: upower-devel
81BuildRequires: pulseaudio-libs-devel
82BuildRequires: cups-devel
83BuildRequires: cheese-devel
84BuildRequires: gstreamer-plugins-base-devel
85BuildRequires: gnome-online-accounts-devel
86BuildRequires: colord-devel
87BuildRequires: NetworkManager-glib-devel
88
89%description
90GNOME (the GNU Network Object Model Environment) is an attractive and
91easy-to-use GUI desktop environment. The control-center package
92provides the GNOME Control Center utilities that allow you to setup
93and configure your system's GNOME environment (things like the desktop
94background and theme, the screensaver, the window manager, system
95sounds, and mouse behavior).
96
97If you install GNOME, you need to install control-center.
98
99%description -l ja
100GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
101GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
102環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
103す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
104ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
105
106%package devel
107Summary: Development files for GNOME Control Center
108Summary(ja): GNOME コントロールセンターの開発用ファイル
109Group: Development/Libraries
110Requires: %{name} = %{version}-%{release}
111
112%description devel
113Development tool for GNOME Control Center
114
115%descriotion -l ja devel
116GNOME コントロールセンターの開発用ファイルが含まれています。
117
118%prep
119%setup -q -n gnome-control-center-%{version}
120
121%build
122%configure --disable-static  \
123    --disable-scrollkeeper \
124    --disable-update-mimedb \
125    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
126
127# drop unneeded direct library deps with --as-needed
128# libtool doesn't make this easy, so we do it the hard way
129sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
130
131make %{?_smp_mflags}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135
136export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
137make install DESTDIR=$RPM_BUILD_ROOT
138unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
139
140for i in apps_gnome_settings_daemon_default_editor.schemas              \
141            apps_gnome_settings_daemon_keybindings.schemas              \
142            apps_gnome_settings_daemon_screensaver.schemas              \
143            desktop_gnome_font_rendering.schemas ; do                   \
144            rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/$i ;      \
145done
146
147#desktop-file-install --vendor gnome --delete-original                   \
148#  --dir $RPM_BUILD_ROOT%{_datadir}/applications                                \
149#  --add-only-show-in GNOME                                              \
150#  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
151
152# install visual effect icons
153# install -m644 visual-effects/*.svg $RPM_BUILD_ROOT%{_datadir}/gnome-control-center/pixmaps/
154
155# we do want this
156mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
157
158# We don't want these
159rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
160rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
161
162# remove useless libtool archive files
163find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
164
165# don't package mime caches
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
170rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
171rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
172rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
173rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
174
175rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
176rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
177
178%find_lang gnome-control-center-2.0
179%find_lang gnome-control-center-2.0-timezones
180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184%post
185/sbin/ldconfig
186
187update-desktop-database %{_datadir}/applications >& /dev/null ||:
188update-mime-database %{_datadir}/mime > /dev/null
189touch --no-create %{_datadir}/icons/hicolor
190if [ -x /usr/bin/gtk-update-icon-cache ]; then
191  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
192fi
193
194%postun
195/sbin/ldconfig
196update-desktop-database %{_datadir}/applications >& /dev/null ||:
197update-mime-database %{_datadir}/mime > /dev/null
198touch --no-create %{_datadir}/icons/hicolor
199if [ -x /usr/bin/gtk-update-icon-cache ]; then
200  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
201fi
202
203%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
204%defattr(-, root, root)
205%doc AUTHORS COPYING ChangeLog NEWS README
206%dir %{_datadir}/gnome/wm-properties
207%dir %{_datadir}/gnome-control-center
208%{_datadir}/applications/*
209%{_datadir}/desktop-directories/*
210%{_datadir}/gnome/help/*
211%{_datadir}/gnome-control-center/datetime
212%{_datadir}/gnome-control-center/icons
213%{_datadir}/gnome-control-center/keybindings
214%{_datadir}/gnome-control-center/pixmaps
215%{_datadir}/gnome-control-center/sounds
216%{_datadir}/gnome-control-center/ui
217%{_datadir}/icons/*
218%{_datadir}/omf/control-center
219%{_datadir}/pixmaps/*
220%{_datadir}/sounds/*
221# list all binaries explicitly, so we notice if one goes missing
222%{_bindir}/gnome-control-center
223%{_bindir}/gnome-sound-applet
224%{_libdir}/*.so.*
225%{_libdir}/control-center-1/panels/*.so
226#{_libexecdir}/*
227%{_sysconfdir}/xdg/menus/gnomecc.menu
228%{_sysconfdir}/xdg/autostart/gnome-sound-applet.desktop
229
230%files devel
231%defattr(-, root, root)
232%{_datadir}/pkgconfig/*
233%{_libdir}/*.so
234
235
236%changelog
237* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
238- new upstream release
239- change BuildRequires: gtk3-devel instead of gtk2-devel
240- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
241- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
242- change BuildRequires: unique3-devel instead of unique-devel
243- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
244                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
245                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
246- add Requires: apg
247- drop all Patches
248- add Provides: and Obsoletes: gnome-volume-manager
249
250* Sun Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
251- update desktop-effect-integration patch
252  - fix freeze on changing metacity to compiz
253  - run compiz directly instead of compiz-gtk
254  - drop use of jockey-gtk
255- update ja.po
256
257* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
258- new upstream release
259
260* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
261- update translation.
262
263* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
264- update translation.
265
266* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
267- update Source21(gnome-control-center-2.32.0-vine.ja.po)
268
269* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
270- new upstream release
271- drop Patch22, Patch30, Patch52
272- fix %files
273
274* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
275- rebuilt with rpm-4.8.1 for pkg-config (too)
276
277* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
278- rebuild with rpm-4.8.1 for pkg-config file
279- add Requires: %{name}=%{version}-%{release}
280
281* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
282- rebuild with evolution-data-server-2.30.2
283
284* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
285- new upstream release
286
287* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
288- new upstream release
289- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
290- add BuildRequires: gnome-common, unique-devel
291
292* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
293- enable Patch101,110-112 and 500
294
295* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
296- new upstream release
297- disabled Patch101, 110-112 and 500
298
299* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
300- update notification-theme.patch
301  - use vine theme if NotificationTheme is not set in meta-theme.
302
303* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
304- add Patch510: use Sans for font-properties sample font.
305- add BR: librsvg2-devel, libXScrnSaver-devel
306- remove BR: esound
307
308* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
309- add Patch37: Don't rely on _BACKUP property for xkb initialization
310
311* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
312- renumber patch10 to patch1010
313  - do not check gdm fprint plugin
314- add Patch101: show aspect in drop down menu
315- add Patch110: modify gnome-mouse-properties to fit smaller screen
316- add Patch111: modify gnome-about-me to fit smaller screen
317- add Patch112: modify gnome-display-properties to fit smaller screen
318
319* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
320- update Patch100 to use compiz-gtk instead of compiz
321
322* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
323- update ja.po
324
325* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
326- import upstream patchs (10,22,3[0-6])
327
328* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
329- add nautilus-devel to BR: not Requires:
330
331* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
332- new upstream release
333- update ja.po
334- add BR: nautilus-devel
335
336* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
337- drop Patch20 which need new XInput API
338- update Patch23
339
340* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
341- add Patch20,22.23 from ubuntu
342  - patch20 to add touchpad configuration
343  - patch22 to add aspect setting in randr capplet
344  - patch23 to integrate desktop setting into appearance-properties
345
346* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
347- new upstream release
348
349* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
350- new upstream release
351
352* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
353- add gnome-typing-monitor to %%files
354
355* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
356- add Patch100 for new RandR capplet. (fc)
357
358* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
359- new upstream release
360- dropped Patch8 (merged into upstream)
361
362* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
363- new upstream release
364- added Patch7 and Patch8 from Fedora
365  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
366  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
367  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
368  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
369  - Remove a nonfunctional button from the a11y preferences
370- added BuildRequires: gnome-settings-daemon, gnome-panel
371- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
372- removed Requires: xscreensaver
373
374* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
375- new upstream release based on Fedora
376- added BuildRequires: gnome-settings-daemon
377
378* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
379- new upstream release based on Fedora
380  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
381  - Fix the orca command in the default applications capplet (#351471)
382
383* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
384- add BuildReq: libgnomekbd-devel
385
386* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
387- rebuilt with evolution-data-server-devel-1.10.1
388
389* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
390- add BuildReq: evolution-data-server-devel
391
392* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
393- new upstream release
394- remove unneeded? patch10
395
396* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
397- added Patch10 to supress /dev/pmu warning messages on some ppc models
398
399* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
400- new upstream release
401
402* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
403- new upstream release
404
405* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
406- run gtk-update-icon-cache in %%post script.
407
408* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
409- new upstream release
410- drop Patch10,it is merged in upstream
411
412* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
413- add Patch10 for correct textdomain name in
414  default-applications-properties(Bug332833)
415- add Patch100 for change default-applications settings for vine
416
417* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
418- new upstream release
419
420* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
421- new upstream release
422
423* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
424- new upstream release
425
426* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
427- new upstream release
428- enable alsa support
429
430* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
431- new upstream release
432
433* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
434- fixed type in %%post script
435
436* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
437- clear the old defaults of xkb
438
439* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
440- remove bonobo-activation dependency
441
442* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
443- new upstream version
444
445* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
446- new upstream release
447- add Japanese summay to devel package
448
449* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
450- new upstream release
451
452* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
453- modify patch11 to use NeoVine theme instead of BeCool.
454
455* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
456- rebuild with new toolchain
457
458* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
459- new upstream release
460- remove obsolete ja.po
461
462* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
463- change required version of metacity to 2.4.34 on alpha
464
465* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
466- new upstream release
467
468* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
469- new upstream release
470
471* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
472- add more missing files and schemas...
473
474* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
475- add missing file in %{_libdir}/gnome-vfs-2.0/
476
477* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
478- new upstream release
479- this is experimental version
480- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
481
482* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
483- new upstream release
484
485* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
486- import patch6 (upstream paches) from rawhide package.
487
488* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
489- import patch1-5 (upstream paches) from rawhide package.
490
491* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
492- new upstream release
493
494* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
495- rebuild
496
497* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
498- new upstream release
499
500* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
501- new upstream release
502
503* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
504- new upstream release
505
506* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
507- change default gtk1 theme from Raleigh to BeCool.
508
509* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
510- add BuildRequires/Requires.
511- fixed kanjicode of specfile
512
513* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
514- remove bogus message in %%post scripts.
515
516* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
517- add patch10 to modify some desktop files
518- update ja.po
519
520* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
521- update ja.po
522
523* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
524- update ja.po
525
526* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
527- new upstream release
528
529* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
530- add devel package
531- add window-manager-settings files.
532
533* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
534- modify dependancies.
535
536* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
537- build for Vine Linux
538- new upstream release from gnome-2.1.4
539
540* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
541- Allow setting custom mime handlers
542
543* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
544- make desktop file symlinks absolute #71991
545- add po files from cvs.gnome.org
546
547* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
548- Fix up keyboard handling
549
550* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
551- Fixes for #68735
552
553* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
554- New version.  Fix up metacity theme locations
555
556* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
557- Switch the gtk1 theme along with the gtk2 theme
558- Add the ability to switch the window manager theme through the theme capplet
559- Add two more font options to the font property dialog
560- Add a bunch of missing unrefs of the result of gconf_client_get_default()
561
562* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
563- fix desktop files more
564- copy icons to /usr/share/pixmaps
565
566* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
567- munge the desktop files correctly
568- obsolete control-center-devel, #69168
569- replace gnomecc.desktop with a file from redhat-menus
570
571* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
572- Fix crasher bug in xftprefs patch
573
574* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
575- Change the default rendering style to be "Best Shapes", not "Best Contrast"
576
577* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
578- Add Xft / XSETTINGS support
579
580* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
581- fix %%post so schemas get installed
582 
583* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
584- 2.0.0
585- add new default editor schemas
586- fix find_lang
587
588* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
589- rebuild for new libraries
590- remove a no-longer-existing schemas file from post
591- use desktop-file-install
592
593* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
594- rebuild in different environment
595
596* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
597- rebuild with new dependent libs
598
599* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
600- rebuild in different environment
601
602* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
603- rebuild in different environment
604- build requires bonobo-activation
605
606* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
607- 1.99.10
608
609* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
610- 1.99.9
611
612* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
613- Move to GNOME 2 version
614
615* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
616- merge in translations
617
618* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
619- Make the theme selector write fontsets, not fonts (#62413)
620
621* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
622- really put screensaver capplet back (I think)
623
624* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
625- revert xscreensaver change
626
627* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
628- init "Scaled" radio button correctly #61913
629
630* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
631- change path to windowmaker config tool again, #61824
632
633* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
634- rather than keep patching and patching it, use xscreensaver's own
635  capplet
636
637* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
638- rebuild in Hampton
639
640* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
641- Rebuild package.
642
643* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
644- rebuilt against new openssl
645
646* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
647- automake14
648- don't run auto* again in ccsingle subdir, not sure why we did that
649
650* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
651- rebuild with new gnome-libs so that libcapplet has right cflags/libs
652- pixbufflags patch to make the rebuild work
653- compileflags patch to make control-center-single work
654
655* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
656- fix #52831 (UI properties in Programs menu)
657
658* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
659- Add po files from sources.redhat.com
660
661* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
662- set the _XROOTCOLOR_PIXEL property, should fix
663  bug #52141
664
665* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
666- Update translation.
667- Add CJK fontset patch
668
669* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
670- New control-center-single to handle exiting, #51665
671
672* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
673- remove .desktop file for gnomecc, so it won't appear
674  in panel menu, #49653
675
676* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
677- allow to build without depending on control-center-devel
678
679* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
680- Add BuildRequires
681
682* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
683- New version of control-center-single
684
685* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
686- Change default background to the same as the nautilus one
687
688* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
689- add hack to default to standalone control panels
690
691* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
692- Bump release + rebuild.
693
694* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
695- putting in tree for David
696
697* Tue May 22 2001 David Sainty <dsainty@redhat.com>
698- improve DPMS patch for the try case, and enable patch
699
700* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
701- add patch to use xscreensaver's DPMS stuff, require that version
702
703* Fri Apr 20 2001  <jrb@redhat.com>
704- New Version (1.4.0.1)
705
706* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
707- kick the mixer once on startup if we aren't running esd
708
709* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
710- translations
711
712* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
713- Rebuild for GTK+-1.2.9 include paths
714
715* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
716- langify
717- don't define and use "ver" at the top of the file
718- move changelog to sane location
719
720* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
721- Apply patch from bug #23782 to see how it works
722
723* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
724- Include fvwm2.desktop in WM's
725
726* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
727- Added Japanese patch.
728
729* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
730- Update release.
731
732* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
733- Again, fix problem with solid backgrounds in bg-properties capplet
734  (patch got lost somewhere)
735
736* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
737- Up Epoch and release
738
739* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
740- Handle unreadable desktop files without crashing
741
742* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
743- Fix problem with backgrounds bigger than screen.
744
745* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
746- Fix problem when ~/.gtkrc does not already exist.
747- Fix problem with solid backgrounds in bg-properties capplet
748
749* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
750- Sort of fix problem with people hitting OK while the
751  "Save Session" dialog is still up. (Session won't be saved,
752  but at least the selected entry will be correctly kept.)
753- Fix history list in background properties capplet
754- Fix problems with temporary files in theme-selector capplet
755
756* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
757- automatic rebuild
758
759* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
760- Require redhat-logos
761- Some spec file and FHS fixes
762- reposition embedded logo a bit
763
764* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
765- Add big change to use gdk-pixbuf for backgrounds and add
766  the ability to emboss the background with a logo
767
768* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
769- revert .so strip
770
771* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
772- strip .so lib
773- use configure macro
774
775* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
776- changed to work with 1.0.40
777
778* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
779- Added fixrevert bug to fix bug in theme selector.
780
781* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
782- updated RPM to use new control-center.
783
784* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
785- fixed sound-properties to only disable sound when run with --init-settings-..
786- removed debugging output from several capplets, fixed try behaviour of sm and
787  gnome-edit capplets
788- fixed bug in screensaver and background props
789- added new icons
790
791* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
792- added a patch to fix the close dialog
793- added a patch to limit the number of bg's in the history.
794
795* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
796- vesion 1.0.5
797- removed all patches >10 other then dontstartesd.
798
799* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
800- removed UI props till it works better
801
802* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
803- make sure we DONT inadvertantly start esd by calling esd_open_...
804
805* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
806- changed default bg color to '#356390'
807
808* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
809- prime file selector path for browse in background-props if
810  "/usr/share/pixmaps/backgrounds/" exists.
811- fix behavior of file selector when you delete/cancel/ok it
812
813* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
814- added patch to fix trying in theme selector
815- disabled crystal screensaver, it does evil things to preview in capplet
816
817* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
818- version 1.0.4, fixes problems with sndprops and theme props among
819  other things.
820
821* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
822- fix sound-properties capplet so Try/Revert doesnt come on unless user
823  changes something
824- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
825- strip binaries
826
827* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
828- version 1.0.3
829- added patch to make esd release after 30 sec of inactivity
830
831* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
832- version 1.0.2
833- turned off sound by default
834
835* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
836- version 1.0.1
837
838* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
839- version 0.99.8.1
840- added etc/CORBA/servers/* to file list
841
842* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
843- update to 0.99.8
844- added /usr/lib/cappletConf.sh
845
846* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
847- update to 0.99.5.1
848
849* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
850- update to 0.99.5
851
852* Mon Jan 20 1999 Michael Fulbright <drmike@redhat.com>
853- update to 0.99.3.1
854
855* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
856- update to 0.99.3
857- seems like patch for non-standard xscreensaver placement was already in
858  prestine sources(?)
859
860* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
861- updated to 0.99.1
862- temporary hack patch to get path to work to non-standard placement
863  of xscreensaver binaries in RH 5.2
864
865* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
866- Created for the new control-center branch
867
Note: See TracBrowser for help on using the repository browser.