source: projects/specs/trunk/c/control-center/control-center-vl.spec @ 9475

Revision 9475, 32.9 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1%define pango_version 1.36.3
2%define gtk3_version 3.16.0
3%define gnome_desktop3_version 3.16.0
4%define libgnomekbd_version 3.6.0
5%define desktop_file_utils_version 0.3
6%define startup_notification_version 0.7
7%define libxklavier_version 5.0
8%define gnome_doc_utils_version 0.20
9%define gnome_menus_version 3.8.0
10%define vine_menus_version 3.0
11%define evolution_data_server_version 3.16.0
12%define libcanberra_version 0.9
13%define usermode_version 1.83
14%define libnotify_version 0.7.3
15%define nm_version 0.9.8
16%define mm_version 0.7.0
17
18Summary: GNOME Control Center.
19Summary(ja): GNOME コントロールセンター
20Name: control-center
21Version: 3.16.0
22Release: 1%{?_dist_release}
23License: GPLv2+ and GFDL+
24Group: User Interface/Desktops
25URL: http://www.gnome.org
26
27Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-control-center/3.16/gnome-control-center-%{version}.tar.xz
28
29Patch1: control-center-3.8.1-gpermission.patch
30# patch for Vine
31Patch1000: control-center-3.14.2-datetime-vine.patch
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: inagaki, daisuke, Takemikaduchi
36
37BuildRoot: %{_tmppath}/%{name}-%{version}-root
38
39Obsoletes: gnome, control-center-devel < 2.0
40Obsoletes: fontilus, themus
41
42Provides: gnome-volume-manager < 2.25
43Obsoletes: gnome-volume-manager < 2.25
44
45Requires: usermode >= %{usermode_version}
46Requires: gnome-settings-daemon
47Requires: gnome-icon-theme
48Requires: gnome-desktop3 >= %{gnome_desktop_version}
49Requires: dbus-x11
50Requires: apg
51Requires(post,postun): desktop-file-utils shared-mime-info gtk3
52
53BuildRequires: gnome-common
54BuildRequires: pango-devel >= %{pango_version}
55BuildRequires: gtk3-devel >= %{gtk3_version}
56BuildRequires: gnome-desktop3-devel >= %{gnome_desktop3_version}
57BuildRequires: libgnomekbd-devel >= %{libgnomekbd_version}
58BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
59BuildRequires: startup-notification-devel >= %{startup_notification_version}
60BuildRequires: libxklavier-devel >= %{libxklavier_version}
61BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
62BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
63BuildRequires: evolution-data-server-devel >= %{evolution_data_server_version}
64BuildRequires: gnome-settings-daemon-devel
65BuildRequires: libcanberra-gtk3-devel >= %{libcanberra_version}
66BuildRequires: nautilus-devel
67BuildRequires: alsa-lib-devel
68BuildRequires: autoconf
69BuildRequires: gettext-devel
70BuildRequires: librsvg2-devel
71BuildRequires: libXScrnSaver-devel
72BuildRequires: libXxf86misc-devel
73BuildRequires: libSM-devel
74BuildRequires: unique3-devel
75BuildRequires: polkit-devel
76BuildRequires: libgtop2-devel
77BuildRequires: upower-devel
78BuildRequires: pulseaudio-libs-devel
79BuildRequires: cups-devel
80BuildRequires: cheese-devel
81BuildRequires: grilo-devel
82BuildRequires: gstreamer-plugins-base-devel
83BuildRequires: gnome-online-accounts-devel
84BuildRequires: colord-devel
85BuildRequires: colord-gtk-devel
86BuildRequires: libnm-gtk-devel >= %{nm_version}
87BuildRequires: NetworkManager-glib-devel >= %{nm_version}
88BuildRequires: ModemManager-glib-devel >= %{mm_version}
89BuildRequires: libnotify-devel >= %{libnotify_version}
90BuildRequires: libwacom-devel
91BuildRequires: libpwquality-devel
92BuildRequires: ibus-devel
93BuildRequires: accountsservice-devel
94BuildRequires: gnome-online-accounts-devel
95BuildRequires: libsmbclient-devel
96
97%description
98GNOME (the GNU Network Object Model Environment) is an attractive and
99easy-to-use GUI desktop environment. The control-center package
100provides the GNOME Control Center utilities that allow you to setup
101and configure your system's GNOME environment (things like the desktop
102background and theme, the screensaver, the window manager, system
103sounds, and mouse behavior).
104
105If you install GNOME, you need to install control-center.
106
107%description -l ja
108GNOME (the GNU Network Object Model Environment) は、魅力的で使いやすい
109GUI デスクトップ環境です。 control-center パッケージには、あなたの GNOME
110環境の設定に使う GNOME コントロールセンター・ユーティリティが含まれていま
111す。(これを使うと、デスクトップの壁紙や、テーマ、スクリーンセーバ、ウィン
112ドウマネージャ、サウンド、マウス、その他いろいろな設定を行えます。)
113
114%package devel
115Summary: Development files for GNOME Control Center
116Summary(ja): GNOME コントロールセンターの開発用ファイル
117Group: Development/Libraries
118Requires: %{name} = %{version}-%{release}
119
120%description devel
121Development tool for GNOME Control Center
122
123%descriotion -l ja devel
124GNOME コントロールセンターの開発用ファイルが含まれています。
125
126%prep
127%setup -q -n gnome-control-center-%{version}
128%patch1 -p1
129%patch1000 -p1 -b .vine
130
131%build
132autoreconf -if
133%configure --disable-static  \
134    --disable-update-mimedb \
135    --enable-ibus
136    CFLAGS="$RPM_OPT_FLAGS -Wno-error"
137
138# drop unneeded direct library deps with --as-needed
139# libtool doesn't make this easy, so we do it the hard way
140sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/    if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/      func_append compile_command " -Wl,-O1,--as-needed"\n      func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
141
142make %{?_smp_mflags}
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147make install DESTDIR=$RPM_BUILD_ROOT
148
149desktop-file-install --delete-original                  \
150  --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
151  --add-only-show-in GNOME                              \
152  $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
153
154# we do want this
155mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
156
157# We don't want these
158rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
159rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
160
161# remove useless libtool archive files
162find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
163
164# don't package mime caches
165rm -f $RPM_BUILD_ROOT%{_datadir}/mime/XMLnamespaces
166rm -f $RPM_BUILD_ROOT%{_datadir}/mime/aliases
167rm -f $RPM_BUILD_ROOT%{_datadir}/mime/application/x-gnome-theme-package.xml
168rm -f $RPM_BUILD_ROOT%{_datadir}/mime/globs
169rm -f $RPM_BUILD_ROOT%{_datadir}/mime/magic
170rm -f $RPM_BUILD_ROOT%{_datadir}/mime/subclasses
171rm -f $RPM_BUILD_ROOT%{_datadir}/mime/mime.cache
172rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
173
174rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/fdl
175rm -f $RPM_BUILD_ROOT%{_datadir}/gnome/lgpl
176
177%find_lang gnome-control-center-2.0
178%find_lang gnome-control-center-2.0-timezones
179
180%clean
181rm -rf $RPM_BUILD_ROOT
182
183%post
184/sbin/ldconfig
185
186update-desktop-database %{_datadir}/applications >& /dev/null ||:
187update-mime-database %{_datadir}/mime > /dev/null
188touch --no-create %{_datadir}/icons/hicolor
189if [ -x /usr/bin/gtk-update-icon-cache ]; then
190  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
191fi
192
193%postun
194/sbin/ldconfig
195update-desktop-database %{_datadir}/applications >& /dev/null ||:
196update-mime-database %{_datadir}/mime > /dev/null
197touch --no-create %{_datadir}/icons/hicolor
198if [ -x /usr/bin/gtk-update-icon-cache ]; then
199  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
200fi
201
202%files -f gnome-control-center-2.0.lang -f gnome-control-center-2.0-timezones.lang
203%defattr(-, root, root)
204%doc AUTHORS COPYING ChangeLog NEWS README
205%{_bindir}/gnome-control-center
206%{_libexecdir}/cc-remote-login-helper
207%{_libexecdir}/gnome-control-center-search-provider
208%dir %{_datadir}/gnome/wm-properties
209%dir %{_datadir}/gnome-control-center
210%{_datadir}/applications/*
211%{_datadir}/bash-completion/completions/gnome-control-center
212%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
213%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
214%{_datadir}/gnome-control-center/datetime
215%{_datadir}/gnome-control-center/icons
216%{_datadir}/gnome-control-center/keybindings
217%{_datadir}/gnome-control-center/pixmaps
218%{_datadir}/gnome-control-center/sounds
219%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
220%{_datadir}/icons/*
221%{_datadir}/pixmaps/*
222%{_datadir}/polkit-1/actions/org.gnome.controlcenter.datetime.policy
223%{_datadir}/polkit-1/actions/org.gnome.controlcenter.remote-login-helper.policy
224%{_datadir}/polkit-1/actions/org.gnome.controlcenter.user-accounts.policy
225%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
226%{_datadir}/sounds/*
227%{_mandir}/man1/gnome-control-center.1.gz
228
229%files devel
230%defattr(-, root, root)
231%{_datadir}/pkgconfig/*
232
233
234%changelog
235* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
236- new upstream release
237
238* Sun Nov 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-2
239- add Patch1000 (control-center-3.14.2-datetime-vine.patch)
240
241* Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
242- new upstream release
243
244* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
245- new upstream release
246
247* Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-3
248- rebuild with upower-0.99.1
249
250* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-2
251- rebuild with libgtop2-2.30.0
252
253* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
254- new upstream release
255
256* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
257- new upstream release
258- add BuildRequires: grilo-devel
259
260* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
261- new upstream release
262- remove Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
263
264* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
265- new upstream release
266- add BuildRequires: NetworkManager-glib-devel, ModemManager-glib-devel, libsmbclient-devel
267- add Patch0 (gnome-control-center-3.10.1-test-chooser-dialog.patch)
268
269* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4.1-1
270- new upstream release
271
272* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
273- new upstream release
274
275* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
276- new upstream release
277- remove Patch0 (control-center-3.8.1-git20130424.patch)
278
279* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-2
280- add Patch1 (control-center-3.8.1-gpermission.patch)
281
282* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
283- new upstream release
284- remove BuildRequires: gnome-panel-devel, metacity-devel
285- change BuildRequires: libnm-gtk-devel instead of NetworkManager-gtk-devel
286- add BuildRequires: colord-gtk-devel, accountsservice-devel, gnome-online-accounts-devel
287- add Patch0 (control-center-3.8.1-git20130424.patch)
288
289* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
290- new upstream release
291
292* Tue Oct 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
293- new upstream release
294
295* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
296- new upstream release
297
298* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
299- new upstream release
300- add BuildRequires: libpwquality-devel
301
302* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
303- new upstream release
304
305* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
306- new upstream release
307- remove BuildRequires: GConf2-devel, libbonobo-devel
308- add BuildRequires: libwacom-devel
309
310* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
311- new upstream release
312
313* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
314- new upstream release
315
316* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-2
317- rebuild with NetworkManager-0.9
318- change BuildRequires: NetworkManager-gtk-devel instead of NetworkManager-glib-devel
319
320* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
321- new upstream release
322
323* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
324- new upstream release
325
326* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
327- new upstream release
328- remove Patch0
329
330* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
331- new upstream release
332- add BuildRequires: libnotify-devel
333- add Patch0 (control-center-3.1.5-crash-layout.patch)
334
335* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
336- new upstream release
337- change BuildRequires: gtk3-devel instead of gtk2-devel
338- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
339- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
340- change BuildRequires: unique3-devel instead of unique-devel
341- add BuildRequires: libXxf86misc-devel, libSM-devel, polkit-devel, libgtop2-devel, upower-devel,
342                     pulseaudio-libs-devel, cups-devel, cheese-devel, gstreamer-plugins-base-devel,
343                     gnome-online-accounts-devel, colord-devel, NetworkManager-glib-devel
344- add Requires: apg
345- drop all Patches
346- add Provides: and Obsoletes: gnome-volume-manager
347
348* Mon Mar 14 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
349- update desktop-effect-integration patch
350  - fix freeze on changing metacity to compiz
351  - run compiz directly instead of compiz-gtk
352  - drop use of jockey-gtk
353- update ja.po
354
355* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
356- new upstream release
357
358* Sat Nov 06 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-4
359- update translation.
360
361* Fri Nov 05 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.32.0-3
362- update translation.
363
364* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
365- update Source21(gnome-control-center-2.32.0-vine.ja.po)
366
367* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
368- new upstream release
369- drop Patch22, Patch30, Patch52
370- fix %files
371
372* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-4
373- rebuilt with rpm-4.8.1 for pkg-config (too)
374
375* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
376- rebuild with rpm-4.8.1 for pkg-config file
377- add Requires: %{name}=%{version}-%{release}
378
379* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
380- rebuild with evolution-data-server-2.30.2
381
382* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
383- new upstream release
384
385* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
386- new upstream release
387- drop Patch3, Patch46, Patch50, Patch51, Patch53, Patch54, Patch112
388- add BuildRequires: gnome-common, unique-devel
389
390* Thu Dec 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-2
391- enable Patch101,110-112 and 500
392
393* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
394- new upstream release
395- disabled Patch101, 110-112 and 500
396
397* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-9
398- update notification-theme.patch
399  - use vine theme if NotificationTheme is not set in meta-theme.
400
401* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-8
402- add Patch510: use Sans for font-properties sample font.
403- add BR: librsvg2-devel, libXScrnSaver-devel
404- remove BR: esound
405
406* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-7
407- add Patch37: Don't rely on _BACKUP property for xkb initialization
408
409* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-6
410- renumber patch10 to patch1010
411  - do not check gdm fprint plugin
412- add Patch101: show aspect in drop down menu
413- add Patch110: modify gnome-mouse-properties to fit smaller screen
414- add Patch111: modify gnome-about-me to fit smaller screen
415- add Patch112: modify gnome-display-properties to fit smaller screen
416
417* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-5
418- update Patch100 to use compiz-gtk instead of compiz
419
420* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-4
421- update ja.po
422
423* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
424- import upstream patchs (10,22,3[0-6])
425
426* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
427- add nautilus-devel to BR: not Requires:
428
429* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
430- new upstream release
431- update ja.po
432- add BR: nautilus-devel
433
434* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-3
435- drop Patch20 which need new XInput API
436- update Patch23
437
438* Sat Oct 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
439- add Patch20,22.23 from ubuntu
440  - patch20 to add touchpad configuration
441  - patch22 to add aspect setting in randr capplet
442  - patch23 to integrate desktop setting into appearance-properties
443
444* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
445- new upstream release
446
447* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
448- new upstream release
449
450* Thu Jul 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-3
451- add gnome-typing-monitor to %%files
452
453* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
454- add Patch100 for new RandR capplet. (fc)
455
456* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2.1-1
457- new upstream release
458- dropped Patch8 (merged into upstream)
459
460* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
461- new upstream release
462- added Patch7 and Patch8 from Fedora
463  * Mon Mar 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
464  - Fix warnings in the keybindings capplet when in non-UTF-8 locale
465  - Fix Esc/Backspace being bindable when CapsLock is on (#427123)
466  * Tue Apr  8 2008 Matthias Clasen <mclasen@redhat.com> - 2.22.1-2
467  - Remove a nonfunctional button from the a11y preferences
468- added BuildRequires: gnome-settings-daemon, gnome-panel
469- added Requires: gnome-icon-theme, gnome-desktop, dbus-x11
470- removed Requires: xscreensaver
471
472* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
473- new upstream release based on Fedora
474- added BuildRequires: gnome-settings-daemon
475
476* Tue Jan  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
477- new upstream release based on Fedora
478  * Wed Oct 24 2007  Matthias Clasen <mclasen@redhat.com> - 2.20.1-5
479  - Fix the orca command in the default applications capplet (#351471)
480
481* Sat Jul 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl4
482- add BuildReq: libgnomekbd-devel
483
484* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl3
485- rebuilt with evolution-data-server-devel-1.10.1
486
487* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0-0vl2
488- add BuildReq: evolution-data-server-devel
489
490* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
491- new upstream release
492- remove unneeded? patch10
493
494* Sun Oct 22 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.2-0vl2
495- added Patch10 to supress /dev/pmu warning messages on some ppc models
496
497* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
498- new upstream release
499
500* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
501- new upstream release
502
503* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
504- run gtk-update-icon-cache in %%post script.
505
506* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
507- new upstream release
508- drop Patch10,it is merged in upstream
509
510* Sat Mar 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl2
511- add Patch10 for correct textdomain name in
512  default-applications-properties(Bug332833)
513- add Patch100 for change default-applications settings for vine
514
515* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
516- new upstream release
517
518* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
519- new upstream release
520
521* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
522- new upstream release
523
524* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
525- new upstream release
526- enable alsa support
527
528* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
529- new upstream release
530
531* Thu Mar 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl4
532- fixed type in %%post script
533
534* Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl3
535- clear the old defaults of xkb
536
537* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
538- remove bonobo-activation dependency
539
540* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
541- new upstream version
542
543* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
544- new upstream release
545- add Japanese summay to devel package
546
547* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
548- new upstream release
549
550* Sat Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
551- modify patch11 to use NeoVine theme instead of BeCool.
552
553* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl2
554- rebuild with new toolchain
555
556* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
557- new upstream release
558- remove obsolete ja.po
559
560* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 2.3.6-0vl2
561- change required version of metacity to 2.4.34 on alpha
562
563* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
564- new upstream release
565
566* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
567- new upstream release
568
569* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl3
570- add more missing files and schemas...
571
572* Sun May 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
573- add missing file in %{_libdir}/gnome-vfs-2.0/
574
575* Sat May 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl1
576- new upstream release
577- this is experimental version
578- remove sr@Latn locale from desktop files to build with desktop-file-utils-0.3
579
580* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
581- new upstream release
582
583* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl3
584- import patch6 (upstream paches) from rawhide package.
585
586* Tue Feb 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl2
587- import patch1-5 (upstream paches) from rawhide package.
588
589* Sun Feb 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
590- new upstream release
591
592* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
593- rebuild
594
595* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
596- new upstream release
597
598* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
599- new upstream release
600
601* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
602- new upstream release
603
604* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl7
605- change default gtk1 theme from Raleigh to BeCool.
606
607* Wed Jan  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl6
608- add BuildRequires/Requires.
609- fixed kanjicode of specfile
610
611* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl5
612- remove bogus message in %%post scripts.
613
614* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl4
615- add patch10 to modify some desktop files
616- update ja.po
617
618* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
619- update ja.po
620
621* Sun Dec 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
622- update ja.po
623
624* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
625- new upstream release
626
627* Sun Dec 22 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl3
628- add devel package
629- add window-manager-settings files.
630
631* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl2
632- modify dependancies.
633
634* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
635- build for Vine Linux
636- new upstream release from gnome-2.1.4
637
638* Thu Sep  5 2002 Jonathan Blandford <jrb@redhat.com>
639- Allow setting custom mime handlers
640
641* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
642- make desktop file symlinks absolute #71991
643- add po files from cvs.gnome.org
644
645* Fri Aug 23 2002 Jonathan Blandford <jrb@redhat.com>
646- Fix up keyboard handling
647
648* Wed Aug 21 2002 Jonathan Blandford <jrb@redhat.com>
649- Fixes for #68735
650
651* Wed Aug  7 2002 Jonathan Blandford <jrb@redhat.com>
652- New version.  Fix up metacity theme locations
653
654* Wed Jul 24 2002 Owen Taylor <otaylor@redhat.com>
655- Switch the gtk1 theme along with the gtk2 theme
656- Add the ability to switch the window manager theme through the theme capplet
657- Add two more font options to the font property dialog
658- Add a bunch of missing unrefs of the result of gconf_client_get_default()
659
660* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
661- fix desktop files more
662- copy icons to /usr/share/pixmaps
663
664* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
665- munge the desktop files correctly
666- obsolete control-center-devel, #69168
667- replace gnomecc.desktop with a file from redhat-menus
668
669* Tue Jul 23 2002 Owen Taylor <otaylor@redhat.com>
670- Fix crasher bug in xftprefs patch
671
672* Tue Jul 16 2002 Owen Taylor <otaylor@redhat.com>
673- Change the default rendering style to be "Best Shapes", not "Best Contrast"
674
675* Tue Jul  9 2002 Owen Taylor <otaylor@redhat.com>
676- Add Xft / XSETTINGS support
677
678* Fri Jun 28 2002 Bill Nottingham <notting@redhat.com> 2.0.0-2
679- fix %%post so schemas get installed
680 
681* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
682- 2.0.0
683- add new default editor schemas
684- fix find_lang
685
686* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
687- rebuild for new libraries
688- remove a no-longer-existing schemas file from post
689- use desktop-file-install
690
691* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
692- rebuild in different environment
693
694* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
695- rebuild with new dependent libs
696
697* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
698- rebuild in different environment
699
700* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
701- rebuild in different environment
702- build requires bonobo-activation
703
704* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
705- 1.99.10
706
707* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
708- 1.99.9
709
710* Wed Apr 17 2002 Havoc Pennington <hp@redhat.com>
711- Move to GNOME 2 version
712
713* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
714- merge in translations
715
716* Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
717- Make the theme selector write fontsets, not fonts (#62413)
718
719* Mon Apr  1 2002 Havoc Pennington <hp@redhat.com>
720- really put screensaver capplet back (I think)
721
722* Wed Mar 27 2002 Bill Nottingham <notting@redhat.com>
723- revert xscreensaver change
724
725* Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
726- init "Scaled" radio button correctly #61913
727
728* Mon Mar 25 2002 Havoc Pennington <hp@redhat.com>
729- change path to windowmaker config tool again, #61824
730
731* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com>
732- rather than keep patching and patching it, use xscreensaver's own
733  capplet
734
735* Wed Feb 27 2002 Havoc Pennington <hp@redhat.com>
736- rebuild in Hampton
737
738* Wed Jan 30 2002 Jonathan Blandford <jrb@redhat.com>
739- Rebuild package.
740
741* Thu Jan 24 2002 Tim Powers <timp@redhat.com>
742- rebuilt against new openssl
743
744* Fri Jan 18 2002 Havoc Pennington <hp@redhat.com>
745- automake14
746- don't run auto* again in ccsingle subdir, not sure why we did that
747
748* Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
749- rebuild with new gnome-libs so that libcapplet has right cflags/libs
750- pixbufflags patch to make the rebuild work
751- compileflags patch to make control-center-single work
752
753* Wed Aug 29 2001 Havoc Pennington <hp@redhat.com>
754- fix #52831 (UI properties in Programs menu)
755
756* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
757- Add po files from sources.redhat.com
758
759* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
760- set the _XROOTCOLOR_PIXEL property, should fix
761  bug #52141
762
763* Wed Aug 22 2001 Yukihiro Nakai <ynakai@redhat.com>
764- Update translation.
765- Add CJK fontset patch
766
767* Thu Aug 16 2001 Jonathan Blandford <jrb@redhat.com>
768- New control-center-single to handle exiting, #51665
769
770* Wed Aug 01 2001 Havoc Pennington <hp@redhat.com>
771- remove .desktop file for gnomecc, so it won't appear
772  in panel menu, #49653
773
774* Mon Jul 30 2001 Jonathan Blandford <jrb@redhat.com>
775- allow to build without depending on control-center-devel
776
777* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
778- Add BuildRequires
779
780* Mon Jul 16 2001 Jonathan Blandford <jrb@redhat.com>
781- New version of control-center-single
782
783* Thu Jul 12 2001 Alexander Larsson <alexl@redhat.com>
784- Change default background to the same as the nautilus one
785
786* Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
787- add hack to default to standalone control panels
788
789* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
790- Bump release + rebuild.
791
792* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
793- putting in tree for David
794
795* Tue May 22 2001 David Sainty <dsainty@redhat.com>
796- improve DPMS patch for the try case, and enable patch
797
798* Wed May  2 2001 Bill Nottingham <notting@redhat.com>
799- add patch to use xscreensaver's DPMS stuff, require that version
800
801* Fri Apr 20 2001  <jrb@redhat.com>
802- New Version (1.4.0.1)
803
804* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
805- kick the mixer once on startup if we aren't running esd
806
807* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
808- translations
809
810* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
811- Rebuild for GTK+-1.2.9 include paths
812
813* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
814- langify
815- don't define and use "ver" at the top of the file
816- move changelog to sane location
817
818* Thu Feb 08 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-4
819- Apply patch from bug #23782 to see how it works
820
821* Fri Feb 02 2001 Elliot Lee <sopwith@redhat.com> 1.2.2-3
822- Include fvwm2.desktop in WM's
823
824* Sat Jan 27 2001 Akira TAGOH <tagoh@redhat.com>
825- Added Japanese patch.
826
827* Mon Dec 04 2000 Jonathan Blandford <jrb@redhat.com>
828- Update release.
829
830* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
831- Again, fix problem with solid backgrounds in bg-properties capplet
832  (patch got lost somewhere)
833
834* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
835- Up Epoch and release
836
837* Thu Aug 10 2000 Owen Taylor <otaylor@redhat.com>
838- Handle unreadable desktop files without crashing
839
840* Mon Aug 07 2000 Owen Taylor <otaylor@redhat.com>
841- Fix problem with backgrounds bigger than screen.
842
843* Tue Aug 01 2000 Owen Taylor <otaylor@redhat.com>
844- Fix problem when ~/.gtkrc does not already exist.
845- Fix problem with solid backgrounds in bg-properties capplet
846
847* Tue Jul 18 2000 Owen Taylor <otaylor@redhat.com>
848- Sort of fix problem with people hitting OK while the
849  "Save Session" dialog is still up. (Session won't be saved,
850  but at least the selected entry will be correctly kept.)
851- Fix history list in background properties capplet
852- Fix problems with temporary files in theme-selector capplet
853
854* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
855- automatic rebuild
856
857* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
858- Require redhat-logos
859- Some spec file and FHS fixes
860- reposition embedded logo a bit
861
862* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
863- Add big change to use gdk-pixbuf for backgrounds and add
864  the ability to emboss the background with a logo
865
866* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
867- revert .so strip
868
869* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
870- strip .so lib
871- use configure macro
872
873* Mon Sep 20 1999 Jonathan Blandford <jrb@redhat.com>
874- changed to work with 1.0.40
875
876* Fri Sep 17 1999 Jonathan Blandford <jrb@redhat.com>
877- Added fixrevert bug to fix bug in theme selector.
878
879* Sun Jun 13 1999 Jonathan Blandford <jrb@redhat.com>
880- updated RPM to use new control-center.
881
882* Wed Apr 07 1999 Michael Fulbright <drmike@redhat.com>
883- fixed sound-properties to only disable sound when run with --init-settings-..
884- removed debugging output from several capplets, fixed try behaviour of sm and
885  gnome-edit capplets
886- fixed bug in screensaver and background props
887- added new icons
888
889* Mon Apr 05 1999 Jonathan Blandford <jrb@redhat.com>
890- added a patch to fix the close dialog
891- added a patch to limit the number of bg's in the history.
892
893* Fri Apr 02 1999 Jonathan Blandford <jrb@redhat.com>
894- vesion 1.0.5
895- removed all patches >10 other then dontstartesd.
896
897* Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
898- removed UI props till it works better
899
900* Wed Mar 31 1999 Michael Fulbright <drmike@redhat.com>
901- make sure we DONT inadvertantly start esd by calling esd_open_...
902
903* Tue Mar 30 1999 Michael Fulbright <drmike@redhat.com>
904- changed default bg color to '#356390'
905
906* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
907- prime file selector path for browse in background-props if
908  "/usr/share/pixmaps/backgrounds/" exists.
909- fix behavior of file selector when you delete/cancel/ok it
910
911* Wed Mar 24 1999 Michael Fulbright <drmike@redhat.com>
912- added patch to fix trying in theme selector
913- disabled crystal screensaver, it does evil things to preview in capplet
914
915* Mon Mar 22 1999 Michael Fulbright <drmike@redhat.com>
916- version 1.0.4, fixes problems with sndprops and theme props among
917  other things.
918
919* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
920- fix sound-properties capplet so Try/Revert doesnt come on unless user
921  changes something
922- fixed theme-selector to not leave processes behind on Linux 2.2 kernels
923- strip binaries
924
925* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
926- version 1.0.3
927- added patch to make esd release after 30 sec of inactivity
928
929* Wed Mar 10 1999 Michael Fulbright <drmike@redhat.com>
930- version 1.0.2
931- turned off sound by default
932
933* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
934- version 1.0.1
935
936* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
937- version 0.99.8.1
938- added etc/CORBA/servers/* to file list
939
940* Fri Feb 12 1999 Michael Fulbright <drmike@redhat.com>
941- update to 0.99.8
942- added /usr/lib/cappletConf.sh
943
944* Mon Feb 08 1999 The Rasterman <raster@redhat.com>
945- update to 0.99.5.1
946
947* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
948- update to 0.99.5
949
950* Wed Jan 20 1999 Michael Fulbright <drmike@redhat.com>
951- update to 0.99.3.1
952
953* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
954- update to 0.99.3
955- seems like patch for non-standard xscreensaver placement was already in
956  prestine sources(?)
957
958* Wed Jan 06 1999 Jonathan Blandford <jrb@redhat.com>
959- updated to 0.99.1
960- temporary hack patch to get path to work to non-standard placement
961  of xscreensaver binaries in RH 5.2
962
963* Wed Dec 16 1998 Jonathan Blandford <jrb@redhat.com>
964- Created for the new control-center branch
965
Note: See TracBrowser for help on using the repository browser.